Subject: [nmrg] Planning the next NMRG meetings for 2015

From: Lisandro Zambenedetti Granville <[email-masked]>
Date: Thu, 23 Oct 2014 17:17:13 +0200

Dear NMRG subscribers

Back in 2011, we run a poll on this list to collect your feedback  in regard to topics that NMRG could focus on. At that point, the use of autonomic computing for network management revealed to be an often mentioned topic. From that point and on, we organized some meetings on autonomics for management that ultimately resulted in some I-D proposals, a BoF in the last IETF meeting, and the ANIMA initiative.

We’ve also been running a series of successful workshops “on the usages of NetFlow/IPFIX in Network management”, the last one being held in Berlim during IETF 87. A next workshop is planned for the NMRG meeting in the upcoming IETF 93 in Prague. Some other topic-specific meetings have been also organized, such as “lossy and low power networks management” (27th NMRG meeting during IETF 81 in Quebec), "Management Aspects of Emerging Networking Paradigms” (29th NMRG meeting during IETF 86 in Orlando), and the “1st Workshop on Large Scale Network Measurements” (31st NMRG meeting during CNSM 2013 in Zurich).

In order to bring more transparency and planning for the upcoming meeting in 2015 (thanks Juergen Schoenwaelder for comments on this regard in the list), we would like to share with you our initial thoughts, re-run the poll we mentioned in the beginning of this message, and collect your feedback for the NMRG next steps. We would like to organize in 2015 four NMRG meeting: 3 meetings during IETFs, in addition to an interim meeting together with IM or CNSM 2015, if the conference calendar allows that. As such, the upcoming meetings would be, in principle:

NMRG meeting during IETF 92, Dallas, Mar. 2015
- Topic: TBD

NMRG meeting during IETF 93, Prague, Jul. 2015
- Topic: Together with the Flamingo FP7 project, we scheduled another edition of the flow-based measurement workshop. Since the last workshop in this series happened in Berlim Aug. 2013, we believe Jul. 2015 would be a good moment for another issue.

NMRG meeting during IETF 94, Yokohama, Nov. 2015
- Topic: TBD

NMRG (interim) meeting, occasionally together with IM 2015 (May 2015, Ottawa) or CNSM 2015 (possibly Oct./Nov. 2015, TBD)
- Topic: TBD

NMRG meetings don’t need to have specific topics. The 35th meeting in Rio will not be centered on a single topic (call for contributions will be distributed in the next message). Still, having a set of main topics would certainly guide better the work developed under the NMRG belt. As mentioned above, we would like to hear the feedback of NMRG subscribers on topics that you believe should be addressed. As a reference and starting point for another poll, please observe below the list of topics (arbitrary order) considered back in 2011.

a) Management of the Internet of Things
b) Autonomics management / network learning
c) Network-wide safe configuration
d) Energy monitoring and management
e) Network flow measurement and analysis
f) Large-scale network-wide measurements
g) Management of virtual machines and clouds

Considering the above, we would like to ask you the following questions:

1) For the interim meeting, what seems more adequate for your personal calendar, i.e., IM or CNSM? We’ll try to accommodate the 2015 interim meeting in a moment that more people could potentially attend.

2) Would you include additional topics to the list above? Which ones? Some “modern” topics may be already covered with a slight different phrasing. For example, management of NFV would fall under item g) above or require a specific topic. 

3) Do you have interest in any of these topics? If so, in which order?

We’ll appreciate if you could reply these questions. That would give us important information for the next steps of NMRG.

Best regards,

Olivier and Lisandro
NMRG Co-Chairs

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Thu, 23 Oct 2014 16:52:45 +0000

Hi Lisandro,

to your first question, I think having an NMRG meeting in conjunction with IM would make sense, as it is widely attended by NMRG's target audience and has larger participation than CNSM.  On your topics, (e) and (f) seem closely related (measurements).  Perhaps consider combining them and calling out a topic more generally on Service Assurance instead (of which measurements are of course one aspect...).

Cheers
--- Alex

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Lisandro Zambenedetti Granville
Sent: Thursday, October 23, 2014 8:17 AM
To: [email-masked]
Subject: [nmrg] Planning the next NMRG meetings for 2015

Dear NMRG subscribers

Best regards,

Olivier and Lisandro
NMRG Co-Chairs

_______________________________________________
nmrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmrg

---

From: <[email-masked]>
Date: Fri, 24 Oct 2014 07:50:39 +0000

Dear Lisandro (and others)

What I miss in the IRTF are security management issues. As far as I know, there is a Crypto RG, but crypto is just one part of the puzzle. I'm not aware of other WGs on security, but please correct me if I'm wrong.

Nice topics that, in my opinion, would fit well in a Network (operations and) Management RG are:
- how well is BCP38 (IP spoofing) implemented?
- how much worse is the amplification of DNSSEC? (We will present a paper on that at next IMC)
- what is the behavior of botnets / DGAs?
- what privacy sensitive data is leaked from various protocols, without users awareness?

I can make this list much longer. The key is that I propose to shift our focus more from "the deign of management technologies" to the "analysis of operational problems". 

Regarding location, I propose to focus (next to IETF) rather on IM/NOMS instead of CNSM. In addition, we could meet with organizations more coupled to the operational aspects, such as RIPE (many of us might be interested in atlas) and TERENA (TNC).

Bye

Aiko

> On 23 okt. 2014, at 17:18, "Lisandro Zambenedetti Granville" <[email-masked]> wrote:
> 
> Dear NMRG subscribers
> 
> Back in 2011, we run a poll on this list to collect your feedback  in regard to topics that NMRG could focus on. At that point, the use of autonomic computing for network management revealed to be an often mentioned topic. >From that point and on, we organized some meetings on autonomics for management that ultimately resulted in some I-D proposals, a BoF in the last IETF meeting, and the ANIMA initiative.
>

---

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Sat, 25 Oct 2014 10:55:46 +0000

Hello,

I would like to see the list extended to the following topics:

o) information/content networks management 

o) move beyond spatio-temporal analysis of traffic flows and consider structure and semantic analysis of information flows

o) cooperative/agent-based management 

More generally, it seems advisable to keep a more technology-independent approach, for instance instead of targeting "NFV" or similar, focus on function placement problems, functional-abstraction and network-function driven management.

Concerning meeting venues: my preference goes to keep balance between number of meetings organized during IETF (2) and conferences (2), thus both IM and CNSM but it could be also valuable to consider instead a conference which has a more specific scope (related to the topic of the NMRG meeting).

Thanks,
-dimitri.

> Sent: Thursday, October 23, 2014 5:17 PM
> To: [email-masked]
> Back in 2011, we run a poll on this list to collect your feedback  in
> regard to topics that NMRG could focus on. At that point, the use of
> autonomic computing for network management revealed to be an often
> mentioned topic. From that point and on, we organized some meetings on
> autonomics for management that ultimately resulted in some I-D proposals,
> a BoF in the last IETF meeting, and the ANIMA initiative.
> 
> We’ve also been running a series of successful workshops “on the usages of
> NetFlow/IPFIX in Network management”, the last one being held in Berlim
> during IETF 87. A next workshop is planned for the NMRG meeting in the
> upcoming IETF 93 in Prague. Some other topic-specific meetings have been
> also organized, such as “lossy and low power networks management” (27th
> NMRG meeting during IETF 81 in Quebec), "Management Aspects of Emerging
> Networking Paradigms” (29th NMRG meeting during IETF 86 in Orlando), and
> the “1st Workshop on Large Scale Network Measurements” (31st NMRG meeting
> during CNSM 2013 in Zurich).
> 
> In order to bring more transparency and planning for the upcoming meeting
> in 2015 (thanks Juergen Schoenwaelder for comments on this regard in the
> list), we would like to share with you our initial thoughts, re-run the
> poll we mentioned in the beginning of this message, and collect your
> feedback for the NMRG next steps. We would like to organize in 2015 four
> NMRG meeting: 3 meetings during IETFs, in addition to an interim meeting
> together with IM or CNSM 2015, if the conference calendar allows that. As
> such, the upcoming meetings would be, in principle:
> 
> - Topic: Together with the Flamingo FP7 project, we scheduled another
> edition of the flow-based measurement workshop. Since the last workshop in
> this series happened in Berlim Aug. 2013, we believe Jul. 2015 would be a
> good moment for another issue.
> 
> NMRG (interim) meeting, occasionally together with IM 2015 (May 2015,
> Ottawa) or CNSM 2015 (possibly Oct./Nov. 2015, TBD)
> - Topic: TBD
> 
> NMRG meetings don’t need to have specific topics. The 35th meeting in Rio
> will not be centered on a single topic (call for contributions will be
> distributed in the next message). Still, having a set of main topics would
> certainly guide better the work developed under the NMRG belt. As
> mentioned above, we would like to hear the feedback of NMRG subscribers on
> topics that you believe should be addressed. As a reference and starting
> point for another poll, please observe below the list of topics (arbitrary
> order) considered back in 2011.
> 
> 1) For the interim meeting, what seems more adequate for your personal
> calendar, i.e., IM or CNSM? We’ll try to accommodate the 2015 interim
> meeting in a moment that more people could potentially attend.
> 
> 2) Would you include additional topics to the list above? Which ones? Some
> “modern” topics may be already covered with a slight different phrasing.
> For example, management of NFV would fall under item g) above or require a
> specific topic.
> 
> We’ll appreciate if you could reply these questions. That would give us
> important information for the next steps of NMRG.
> 
> Best regards,
> 
> Olivier and Lisandro
> NMRG Co-Chairs
>

---

From: Kostas Pentikousis <[email-masked]>
Date: Tue, 28 Oct 2014 17:12:20 +0100

Hi Lisandro, all,

| -----Ursprüngliche Nachricht-----
| Von: Papadimitriou, Dimitri (Dimitri)
| [mailto:[email-masked]]
| Gesendet: Samstag, 25. Oktober 2014 12:56
| An: Lisandro Zambenedetti Granville; [email-masked]
| Betreff: Re: [nmrg] Planning the next NMRG meetings for 2015
| 
| Hello,
| 
| I would like to see the list extended to the following topics:
| 
| o) information/content networks management

I'd like to second Dimitri on this one.

Back in IETF 86 (https://trac.tools.ietf.org/group/irtf/trac/wiki/NetworkManagementResearchGroupAg&LgOrlando) we presented an earlier version of draft-corujo-icn-mgmt (https://datatracker.ietf.org/doc/draft-corujo-icn-mgmt/). Although the draft has been further developed since then, more work is foreseen and we would be happy to have NMRG members review and contribute.

There are two aspects that folks may be interested in this direction. First, management of an information-centric network. There was earlier work in FP7 4WARD, but I'm sure others have done work in this direction since then. Second, it's very interesting to see how ICN can be used to manage networks. The best paper winner of SIGCOMM ICN 2014, by Arumaithurai et al. entitled "Exploiting ICN for Flexible Management in Software-Defined Networks" would be an excellent example of this latter category. draft-corujo-icn-mgmt discusses to some degree both aspects, but I'm sure there's lots of space for other drafts in NMRG in this area.

<snip>
| More generally, it seems advisable to keep a more technology-
| independent approach, for instance instead of targeting "NFV" or
| similar, focus on function placement problems, functional-abstraction
| and network-function driven management.

Second this too, although some NFV-management specific drafts could be done in NMRG or in close cooperation with the proposed NFVRG.

Regarding the meetings: What worked well in ICNRG for some time now was to schedule a full day meeting and work on RG drafts together (or in split groups) during the IETF week (e.g. on Sunday). This could be seen as a particular form of a design team (without the protocol development) and can help reach consensus on comprehensive high-quality RG drafts.

Best regards,

Kostas