Subject: Re: [nmrg] Activities in 2016: your feedback is precious !

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Sat, 2 Jan 2016 19:31:15 +0000

Laurent:

Concerning the statement “the topic of management of/using ICN was not covered”  included in the report, I would like to bring the following clarification:

The initial suggestion was to start a topic focused on network operations driven by information flows (instead of packet flows) thus not tied to a specific implementation of the forwarding plane. Related points include what does it imply at the management and operational level to monitor information flows ? is it limited to adaptation of current packet monitoring techniques or does this functional enhancement change monitoring practices. I think this topic could still be included as part of the workplan for 2016 if there is sufficient interest.

Another topic that could be considered relates to the discussion point that partitioning in distinct autonomous systems leads de-facto to the absence of common realization(s) whereas many “planes” (being autonomic or monitoring or others) aim at crossing –or even breaking- boundaries between such partitions; it would be of interest to investigate what can be commonly achieved if selfish behavior is the main characteristic of Internet environments.

Thanks,
-dimitri.

From: nmrg [mailto:[email-masked]] On Behalf Of Laurent Ciavaglia
Sent: Thursday, December 24, 2015 12:13 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [nmrg] Activities in 2016: your feedback is precious !

Dear NMRG,

In order to organize the group activities for 2016, we solicit your feedback on the following items:

1. 2015 activity report
   A short report on the NMRG activities for 2015 is available on the RG wiki page: https://trac.tools.ietf.org/group/irtf/trac/wiki/NetworkManagementResearchGroupReport2015
   Please send us your feedback, things we might have missed, etc.

2. Meetings in 2016
   Below is a list of possible meetings for NMRG:
   .IETF 95, Buenos Aires, April 2016, Topic: TBD
   .NOMS 2016, Istanbul, April 2016, Topic: TBD
   .IETF 96, Berlin, July 2016, Topic: TBD
   .IETF 97, Seoul, November 2016, Topic: TBD

   We plan to hold a minimum of 3 NMRG meetings in 2016 (2 colocated with IETF meetings, and 1 with a conference) ; including possibly joint meetings with other IRTF RGs (e.g. ICN, SDN, NFV, T2T, NML...) and/or relevant IETF WGs.
   As suggested last year, we will also investigate if/how NMRG could meet with organizations more coupled to operational aspects, such as RIPE, NANOG...
   Again, your views and help are most welcome to shape the most appropriate and attractive meetings.
   The actual list of meetings will depend on the topics interest/priority/support and may evolve during the year. We will advertise as early as possible.

3. Topics of interest
   We solicit your ideas and suggestions for the topics of interest.
   The feedback received last year is summarized at the end of the email.
   Our objective is twofold:
   1) to vitalize NMRG with strategic, timely and important topics; and
   2) to raise the level of activity/impact/visibility of NMRG, including determining a plan of tangible outcome (e.g. IDs, papers...)

Thanks and best regards,
Lisandro and Laurent
NMRG co-chairs.

---
Previous topics of interest and suggestions expressed:
- Management of the Internet of Things
- Autonomics management / network learning
- Network-wide safe configuration
- Energy monitoring and management
- Network flow measurement and analysis
- Large-scale network-wide measurements
- Management of virtual machines and clouds
- Service Assurance
- Security management issues
- Shift our focus more from "the design of management technologies" to the "analysis of operational problems".
    . how well is BCP38 (IP spoofing) implemented?
    . how much worse is the amplification of DNSSEC? (We will present a paper on that at next IMC)
    . what is the behavior of botnets / DGAs?
    . what privacy sensitive data is leaked from various protocols, without users awareness?
- Information/content networks management
- Move beyond spatio-temporal analysis of traffic flows and consider structure and semantic analysis of information flows
- Cooperative/agent-based management
- Keep more technology-independent approach, for instance instead of targeting "NFV" or similar, focus on function placement problems, functional-abstraction and network-function driven management.
- Management of an information-centric network
- How ICN can be used to manage networks
- NFV-management specific drafts could be done in NMRG or in close cooperation with the proposed NFVRG.
- Schedule a full day meeting and work on RG drafts together (or in split groups) during the IETF week (e.g. on Sunday).

---

From: Laurent Ciavaglia <[email-masked]>
Date: Tue, 12 Jan 2016 10:09:42 +0100

Hello and Happy New Year to you all !

*** Gentle reminder ***

Please provide your feedback on the below poll to drive the NMRG 
activities in 2016 and beyond.

Thanks,
Lisandro and Laurent.

-------- Forwarded Message --------
Subject: 	Activities in 2016: your feedback is precious !
Date: 	Thu, 24 Dec 2015 12:13:18 +0100
From: 	Laurent Ciavaglia <[email-masked]>
Organization: 	Alcatel-Lucent Bell Labs France
To: 	[email-masked] <[email-masked]>
CC: 	Lisandro Zambenedetti Granville <[email-masked]>, Laurent 
Ciavaglia <[email-masked]>

Dear NMRG,

In order to organize the group activities for 2016, we solicit your 
feedback on the following items:

*1. 2015 activity report*
    A short report on the NMRG activities for 2015 is available on the 
RG wiki page: 
https://trac.tools.ietf.org/group/irtf/trac/wiki/NetworkManagementResearchGroupReport2015
    Please send us your feedback, things we might have missed, etc.

*2. **Meetings in 2016*

    We plan to hold a minimum of 3 NMRG meetings in 2016 (2 colocated 
with IETF meetings, and 1 with a conference) ; including possibly joint 
meetings with other IRTF RGs (e.g. ICN, SDN, NFV, T2T, NML...) and/or 
relevant IETF WGs.
    As suggested last year, we will also investigate if/how NMRG could 
meet with organizations more coupled to operational aspects, such as 
RIPE, NANOG...
    Again, your views and help are most welcome to shape the most 
appropriate and attractive meetings.
    The actual list of meetings will depend on the topics 
interest/priority/support and may evolve during the year. We will 
advertise as early as possible.

*3. **T**opics of interest*
    We solicit your ideas and suggestions for the topics of interest.
    The feedback received last year is summarized at the end of the email.
    Our objective is twofold:
    1) to vitalize NMRG with strategic, timely and important topics; and
    2) to raise the level of activity/impact/visibility of NMRG, 
including determining a plan of tangible outcome (e.g. IDs, papers...)

Thanks and best regards,
Lisandro and Laurent
NMRG co-chairs.

---
_Previous topics of interest and suggestions expressed:_
- Management of the Internet of Things
- Autonomics management / network learning
- Network-wide safe configuration
- Energy monitoring and management
- Network flow measurement and analysis
- Large-scale network-wide measurements
- Management of virtual machines and clouds
- Service Assurance
- Security management issues
- Shift our focus more from "the design of management technologies" to 
the "analysis of operational problems".
     . how well is BCP38 (IP spoofing) implemented?
     . how much worse is the amplification of DNSSEC? (We will present a 
paper on that at next IMC)
     . what is the behavior of botnets / DGAs?
     . what privacy sensitive data is leaked from various protocols, 
without users awareness?
- Information/content networks management
- Move beyond spatio-temporal analysis of traffic flows and consider 
structure and semantic analysis of information flows
- Cooperative/agent-based management
- Keep more technology-independent approach, for instance instead of 
targeting "NFV" or similar, focus on function placement problems, 
functional-abstraction and network-function driven management.
- Management of an information-centric network
- How ICN can be used to manage networks
- NFV-management specific drafts could be done in NMRG or in close 
cooperation with the proposed NFVRG.
- Schedule a full day meeting and work on RG drafts together (or in 
split groups) during the IETF week (e.g. on Sunday).

-- 

Bien cordialement, Best regards,

*Laurent Ciavaglia*

Bell Labs | Nokia

phone: +33 160 402 636

email: [email-masked] <mailto:[email-masked]>

linkedin: laurentciavaglia <http://fr.linkedin.com/in/laurentciavaglia/>

address: Route de Villejust | 91620 Nozay | France

---

From: Jérôme François <[email-masked]>
Date: Mon, 25 Jan 2016 15:25:21 +0100

Dear Laurent,
> with IETF meetings, and 1 with a conference) ; including possibly
> joint meetings with other IRTF RGs (e.g. ICN, SDN, NFV, T2T, NML...)
> and/or relevant IETF WGs.
Good plan.
> including determining a plan of tangible outcome (e.g. IDs, papers...)
Regarding topic, here are some suggestion:
- As suggested in your second item, there is an overlap between our
activities and other RG. So, SDN, NFV and ICN are good topics but those
are probably have to be addressed jointly with other RGs.
- Do we continue the series on flow-based measurement ? In my opinion it
is very attractive and has been successful and thus should continue,
maybe with no restriction on the type of measurements (flow-based and
others).
- Security
- network management and data analytics. This covers two topics: using
data-analytics for network management and rethinking network management
to support data-analytics, which is more original in my opinion.
- network management in the context of encrypted traffic.

Best regards,
jerome