Subject: [nmrg] In-Band Synchronization for Distributed SDN Control Planes | acm sigcomm

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Feb 2016 13:01:05 +1300

This paper is quite interesting. It suggests a rather different approach
than RFC 7575 and 7576 and the IETF work being done in Anima.

http://www.sigcomm.org/node/3886

Regards
   Brian Carpenter

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 18 Feb 2016 09:41:04 +0100

So the different approach is that the paper suggests some sort
of central control to make sure that distributed functions are
well coordinated. That as opposed to supposedly complete autonomous
distributed systems?

Or are you hinting at some other aspect of this?

I want to be sure I understand it correctly.

Thanks,
Bert

On 18/02/16 01:01, Brian E Carpenter wrote:
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 19 Feb 2016 07:53:27 +1300

On 18/02/2016 21:41, Bert Wijnen (IETF) wrote:
> well coordinated. 

Well, central controllers are one of the negative aspects of SDN,
so I was mainly reacting to their strong preference for signaling
in the data plane. Also of course they are talking about transactional
memory, but we never discussed in NMRG whether autonomic mechanisms
need transactional integrity. Most distributed designs on the Internet
these days seem to use a RESTful approach.

    Brian

> That as opposed to supposedly complete autonomous
> distributed systems?
>