Subject: Re: [nmrg] NMRG at IETF103

From: Jéferson Campos Nobre <[email-masked]>
Date: Mon, 5 Nov 2018 04:22:31 +0700

Dear NMRG.
Just to add up in the discussion brought by Laurent, I have some ideas
on the evolution of NMRG.
By the way, I don't claim to have "solutions", just suggestions on
this evolution.
Here they are:

- More young students/researchers
As Laurent wrote, NMRG is turning 20 years old. Thus, it is necessary
to bring "new blood" to the RG.
I believe that a initiative that can make young students/researchers
more involved in NMRG is to have hands-on activities such as
hackathons.
Thus, we could do that regarding NMRG related documents.

- Collaboration and cooperation
Several NMRG documents came from other WGs/RGs due to several reasons
(for example, works outside charters, group goes defunct, etc).
Maybe this is because the main idea of network management is really
broad. In any case, we can actively promote cooperation and
integration among different WGs/RGs to elaborate on that.
Besides, we could increase joint activities among other Network
Management technical committees and standardization bodies.

- Identification of emerging technical areas
In the same sense that Autonomics was identified and integrated to
NMRG, we could facilitate an entry into emerging technical areas.
This could be done, for example, through meetings centered in a
restrict area as we have done (autonomics, measurement-based NM).
In addition, this can be done in cooperation with different WGs/RGs.

I know that some of the suggestions are already being done, but we can
always move forward.

Best.
Jéferson

----------------------------------------------------On Mon, Oct 29,
2018 at 4:03 AM Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
<[email-masked]> wrote:
>
> Hello,
>
> To clarify: the discussion on the RG evolution is a process that will take some time e.g. until IETF 104/105.
>
> IETF 103 is just a starting point and I also would like to have the discussion to occur on the list to capture things with text and allow anyone to contribute (those attending and not the IETF meetings).
>
> Best regards, Laurent.
>
> From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> Sent: Saturday, October 27, 2018 9:25:10 PM
> To: nmrg@irtf..org
> Subject: NMRG at IETF103
>
> *** Apparently this message didn’t reach the intended mailing list on Thursday, October 25th ***
>
> Dear NMRG,
>
> Some updates on the way forward for the RG, and our upcoming meeting at IETF103/Bangkok.
>
> -The co-chair selection is still going on and we plan to conclude soon.
>
> -NMRG is turning 20 years old in March 2019 (yes, really!).
>  Seems like a good opportunity to reflect on the field of network management and how to approach the challenges of a new era.
> I’m thus starting a process to collect ideas, views and proposals to augment and complement the NMRG research agenda.
>  This may also result in a more or less profound rewrite of the charter.
>
> -For IETF 103, NMRG will meet on Wednesday, November 7h 11:20-12:20.
> As the session is short we will cover:
> Progress on current research agenda items.Discussion on the “re-chartering”.
> I will publish a draft agenda soon after this email.
>
> Thank you and looking forward to your prospective ideas for the future of our research group!
>
> Best regards, Laurent.
>
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Mon, 5 Nov 2018 04:51:06 +0000

I agree with the points proposed by the email below. 
For the first one, besides inviting young researchers to join IRTF meeting, another option is having workshops in local universities similar to the one we've done in Montreal, more flexible and easier for young researchers with limited budgets.
In addition to the 3rd one, I believe as an RG should not only cooperate to WGs/RGs in IETF/IRTF, but also a broader  horizon even with other SDOs / open source consortia /academic conferences, e.g., in autonomics area, the target may be ETSI ENI, LX Acumos, SIGCOMM NetAI...

My two cents.

Cheers,
Will

> -----Original Message-----
> From: nmrg [mailto:[email-masked]] On Behalf Of Jéferson Campos
> Nobre
> Sent: Monday, November 05, 2018 5:23 AM
> To: [email-masked]; Laurent Ciavaglia <[email-masked]>
> Subject: Re: [nmrg] NMRG at IETF103
> 
> Dear NMRG.
> Just to add up in the discussion brought by Laurent, I have some ideas on the
> evolution of NMRG.
> By the way, I don't claim to have "solutions", just suggestions on this
> evolution.
> Here they are:
> 
> As Laurent wrote, NMRG is turning 20 years old. Thus, it is necessary to bring
> "new blood" to the RG.
> I believe that a initiative that can make young students/researchers more
> involved in NMRG is to have hands-on activities such as hackathons.
> Maybe this is because the main idea of network management is really broad.
> In any case, we can actively promote cooperation and integration among
> different WGs/RGs to elaborate on that.
> - Identification of emerging technical areas In the same sense that
> Autonomics was identified and integrated to NMRG, we could facilitate an
> entry into emerging technical areas.
> This could be done, for example, through meetings centered in a restrict area
> as we have done (autonomics, measurement-based NM).
> > IETF 103 is just a starting point and I also would like to have the discussion
> to occur on the list to capture things with text and allow anyone to
> contribute (those attending and not the IETF meetings).
> >
> > Best regards, Laurent.
> >
> >  Seems like a good opportunity to reflect on the field of network
> management and how to approach the challenges of a new era.
> > I’m thus starting a process to collect ideas, views and proposals to
> augment and complement the NMRG research agenda.

---

From: Alexander Clemm <[email-masked]>
Date: Mon, 5 Nov 2018 05:56:39 +0000

Hi all, 

to add to Jef and Laurent, regarding bringing in "new blood" in terms of attracting young researchers:  As a young researcher, I would ask myself the question why I should even engage in IRTF when there are plenty of research communities in IEEE, IFIP, ACM, which offer the additional benefit of building a record of peer-referenced publication (which NMRG does not - and as an additional hurdle, the typical cycle to bring something from individual draft to an RFC takes longer than many PhD students can afford).  So, where does NMRG fit into that larger research landscape?  

For this reasons, I think it would be good to include something in the NMRG charter that points out what is unique about IRTF (and, by extension, NMRG) and why young researchers want to engage here.  In my view, this is the link to IETF - i.e., the abililty to have your research affect possible future direction of standardization.  That is, for research that involves interoperability between systems, and that will ultimately require standardization at a later stage if it is to have real-world impact, NMRG is a great place to go to.  It would be good to have a statement like that in the charter.  

In terms of research agenda for NMRG, I do think the intent-theme is clearly one of the top items that should be on the agenda (and that can clearly impact future IETF agenda), although I think we should have a few more themes on there as well (as the scope of NMRG is larger).  

Cheers
--- Alex  

> Sent: Monday, November 05, 2018 4:23 AM
> By the way, I don't claim to have "solutions", just suggestions on this evolution.
> Here they are:
> 
> Maybe this is because the main idea of network management is really broad. In
> any case, we can actively promote cooperation and integration among different
> WGs/RGs to elaborate on that.
> Besides, we could increase joint activities among other Network Management
> technical committees and standardization bodies.
> 
> - Identification of emerging technical areas In the same sense that Autonomics
> was identified and integrated to NMRG, we could facilitate an entry into
> emerging technical areas.
> This could be done, for example, through meetings centered in a restrict area as
> we have done (autonomics, measurement-based NM).
> I know that some of the suggestions are already being done, but we can always
> move forward.
> 
> Best.
> Jéferson
> 
> 
> 
> 
> > IETF 103 is just a starting point and I also would like to have the discussion to
> occur on the list to capture things with text and allow anyone to contribute
> (those attending and not the IETF meetings).
> >
> > Best regards, Laurent.
> >
> >  Seems like a good opportunity to reflect on the field of network management
> and how to approach the challenges of a new era.

---

From: Jérôme François <[email-masked]>
Date: Mon, 5 Nov 2018 12:18:54 +0100

Hi all,

1) Many presentations given by researchers in NMRG were following publications in
peer-reviewd conferences. So as Alex highlighted, NMRG offers the possibility for
these work ro reach the IETF public and so also to have a potential on industry
standard that is more difficult to have in an academia conf. Important to take
into account is the new habit for standards, open-source is today the fastest way
to have impact. It is not specific to NMRG but supporting also the development of
open-source tools related to NMRG should be considerd and aligned with the remark
of Jef regarding Hackathon.

2) Having more "accessible" workshop in unversities is good as well. But consider
that it will be hard to justify for a youg researcher or student to do a trip
abroad for a one day meeting. It will be better to colocate our events. We did in
the past and should continue with some conferences as IM or NOMS. We can also
think targeting some summer schools to attract young researchers as earlier as
possible.

3) Regarding topics, I agree with IBN. We also have a lot of discussions regarding
machine learning/intelligent-defined/knowledge-defined networking. I think there
is actualy a good match between this and IBN but also others such as self-driving
networks.

Cheers,
jerome

On 05/11/2018 06:56, Alexander Clemm wrote:
> also

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 5 Nov 2018 12:42:48 +0100

On Mon, Nov 05, 2018 at 12:18:54PM +0100, Jérôme François wrote:
> 
> 1) Many presentations given by researchers in NMRG were following
> publications in peer-reviewd conferences. So as Alex highlighted,
> NMRG offers the possibility for these work ro reach the IETF public
> and so also to have a potential on industry standard that is more
> difficult to have in an academia conf. Important to take into
> account is the new habit for standards, open-source is today the
> fastest way to have impact. It is not specific to NMRG but
> supporting also the development of open-source tools related to NMRG
> should be considerd and aligned with the remark of Jef regarding
> Hackathon.

Back in the 80s and 90s, Internet standard development was often
closely tied to open source activities. So I am not sure this is "a
new habit for standards".

[Sorry, but I could not resist to make this comment.]

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Jérôme François <[email-masked]>
Date: Mon, 5 Nov 2018 13:46:51 +0100

> new habit for standards".
Yes, what I mean is that open-source can be considered as standardization per se
without being closely tied to be some "regular" standardization process.

jerome

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 5 Nov 2018 14:16:52 +0100

On Mon, Nov 05, 2018 at 01:46:51PM +0100, Jérôme François wrote:
> 
> Yes, what I mean is that open-source can be considered as
> standardization per se without being closely tied to be some
> "regular" standardization process.
>

I do not share this view. There are many open source projects that
compete and which are not interoperable. The purpose of a standard is
interoperability (and the success of standards should IMHO be judged
on the amount of interoperability they enabled.)

/js

---

From: Jérôme François <[email-masked]>
Date: Mon, 5 Nov 2018 14:42:30 +0100

This just reflects some discussions I have with young and "less young" researchers
that prefer to go for open-source exclusively to make their proposal de facto
adopted rather than going through months or years of standardization.

So, improving cooperation with open source communites is important.

jerome

---

From: "Natale, Bob" <[email-masked]>
Date: Mon, 5 Nov 2018 14:53:03 +0000

Hi Juergen,

Apologies for shining the apple (or whatever the correct metaphor should be) on your prescription below, but I'd say that the success of a standard should be judged on the amount of interoperability _delivered_ in deployed products/solutions over the set of target implementers.

Beyond nit-picking, the point I would like to emphasize is that aiming and managing standards development to such an outcome (usually) involves (sometimes difficult) trade-offs and balances along the way. (And you have always done a masterful job at that task.)

Long-time lurker,
BobN

-----Original Message-----
From: nmrg <[email-masked]> On Behalf Of Juergen Schoenwaelder
Sent: Monday, November 5, 2018 8:17 AM
To: Jérôme François <[email-masked]>
Cc: [email-masked]
Subject: Re: [nmrg] NMRG at IETF103

On Mon, Nov 05, 2018 at 01:46:51PM +0100, Jérôme François wrote:
> standardization per se without being closely tied to be some "regular" 
> standardization process.
>

I do not share this view. There are many open source projects that compete and which are not interoperable. The purpose of a standard is interoperability (and the success of standards should IMHO be judged on the amount of interoperability they enabled.)

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 5 Nov 2018 15:58:55 +0100

Which is perfectly fine, you do not start with standardization, you
may end with standardization in situations where interoperability
between multiple implementations is adding value.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 5 Nov 2018 16:15:32 +0100

> Apologies for shining the apple (or whatever the correct metaphor should be) on your prescription below, but I'd say that the success of a standard should be judged on the amount of interoperabilit…

Yep, this is what I meant.

/js

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Mon, 5 Nov 2018 16:06:47 +0000

Interesting discussion!
The relationship of NMRG (and IRTF to a larger extent) to standards is surely a point of discussion.

	How to compose with the current IRTF statement that RG are not meant to do standardization?

-Laurent.

> Sent: Monday, November 5, 2018 16:16
> To: Natale, Bob <[email-masked]>
> Cc: [email-masked]
> > Apologies for shining the apple (or whatever the correct metaphor should
> be) on your prescription below, but I'd say that the success of a standard
> should be judged on the amount of interoperability _delivered_ in deployed
> products/solutions over the set of target implementers.
> >
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 5 Nov 2018 17:18:43 +0100

> meant to do standardization?

The NMRG has been a place to stimulate interaction between researchers
(that are sometimes detached from operational and technology reality)
and network operators or technology developers (that are sometimes
detached from the research state of the art). The challenge is to run
something like this successfully since the interaction must provide
value to a rather inhomogenous groups of people.

Trying out different formats is likely worth it I think. If we take
dialogue between people with different backgrounds as a value
proposition, then of course meetings (colocated with whatever events)
where only some groups participate are of limited value.

/js

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Mon, 5 Nov 2018 23:40:47 +0100

Those were the days ;-)

Bert