Subject: [nmrg] FW: New Version Notification for draft-li-nmrg-intent-classification-00.txt

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Wed, 24 Apr 2019 02:23:51 +0000

Hi,

I just did some small modifications and submit this draft as -nmrg, which replaced the old draft-li version.

As we presented during last NMRG meeting, there are several shared principles between SDOs:
  -intent should be declarative, using and depending on as few deployment details as possible and focusing on what and not how
  -intent should provide an easy-to-use interface, and use terminology and concepts familiar to its target audience
  -intent should be vendor-independent and portable across platforms
  -the intent framework should be able to detect and resolve conflicts between multiple intents

This document goal is to discuss and propose how to classify intents, so that  can be a good foundation for future discussion related to intent in IETF scope.

In the draft we've listed Intent Classification based on :
-Solutions, Users and their Purpose
-When to Activate
-Lifecycle Management Requirements
-Granularity

Slides we presented: 
https://datatracker.ietf.org/meeting/104/materials/slides-104-nmrg-sessb-intent-classification-00
                                 
Your comments and contributions are welcome!

Regards, / 致礼! 
Will LIU  / 刘树成

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, April 23, 2019 8:41 PM
To: Liushucheng (Will Liu) <[email-masked]>; John Strassner <[email-masked]>; Olga Havel <[email-masked]>; Xuweiping (David) <[email-masked]>; Ying Cheng <[email-masked]>; Liushucheng (Will Liu) <[email-masked]>; Chen Li <[email-masked]>
Subject: New Version Notification for draft-li-nmrg-intent-classification-00.txt

A new version of I-D, draft-li-nmrg-intent-classification-00.txt
has been successfully submitted by Will (Shucheng) Liu and posted to the IETF repository.

Name:		draft-li-nmrg-intent-classification
Revision:	00
Title:		Intent Classification
Document date:	2019-04-22
Group:		Individual Submission
Pages:		13
URL:            https://www.ietf.org/internet-drafts/draft-li-nmrg-intent-classification-00.txt
Status:         https://datatracker.ietf.org/doc/draft-li-nmrg-intent-classification/
Htmlized:       https://tools.ietf.org/html/draft-li-nmrg-intent-classification-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-li-nmrg-intent-classification

Abstract:
   RFC 7575 defines Intent as an abstract high-level policy used to
   operate the network. Intent management system includes an interface
   for users to input requests and an engine to translate the intents
   into the network configuration and manage their lifecycle. Up to
   now, there is no commonly agreed definition, interface or model of
   intent.

   This document discusses what intent means to different stakeholders,
   describes different ways to classify intent, and an associated
   taxonomy of this classification. This is a foundation for discussion
   intent related topics.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 24 Apr 2019 07:29:08 +0200

How does this document relate to draft-clemm-nmrg-dist-intent-01? Are
the authors of these two documents going to collaborate to produce a
common document?

/js

On Wed, Apr 24, 2019 at 02:23:51AM +0000, Liushucheng (Will Liu) wrote:
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Thu, 25 Apr 2019 08:34:15 +0000

Hi Juergen,

Thanks for the question.  IMHO, the two draft are complementary. 

draft-clemm-nmrg-dist-intent-01 is a good start to clearify the concept of intent and relationship between intent and policy. 

The abstract of draft-clemm-nmrg-dist-intent-01:
Intent and Intent-Based Networking are taking the industry by storm. At the same time, those terms are used loosely and often inconsistently, in many cases overlapping with other concepts such as "policy". This document is therefore intended to clarify the concept of "Intent" and how it relates to other concepts. The goal is to contribute towards a common and shared understanding of terms and concepts which can then be used as foundation to guide further definition of valid research and engineering problems and their solutions.

draft-li-nmrg-intent-classification-00 is a summary of the categorization of intent and can be the a good baseline to refer to when we discuss the scope of intent. E.g., we could easily refer to this draft to describe which kinds of intent we are working firstly in NMRG and which are not covered here or being worked in other SDOs.

I've been discussing with Alex about the next step of the two drafts and we can discuss this in today online meeting. 

Regards, / 致礼! 
Will LIU  / 刘树成

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, April 24, 2019 1:29 PM
To: Liushucheng (Will Liu) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [nmrg] FW: New Version Notification for draft-li-nmrg-intent-classification-00.txt

How does this document relate to draft-clemm-nmrg-dist-intent-01? Are the authors of these two documents going to collaborate to produce a common document?

/js

On Wed, Apr 24, 2019 at 02:23:51AM +0000, Liushucheng (Will Liu) wrote:
> To: Liushucheng (Will Liu) <[email-masked]>; John Strassner 
> <[email-masked]>; Olga Havel <[email-masked]>; 
> Xuweiping (David) <[email-masked]>; Ying Cheng 
> <[email-masked]>; Liushucheng (Will Liu) 
> <[email-masked]>; Chen Li <[email-masked]>
> Subject: New Version Notification for 
> draft-li-nmrg-intent-classification-00.txt
> 
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 25 Apr 2019 10:38:31 +0200

I prefer that the NMRG produces a single document.

/js