Subject: [nmrg] NMRG Virtual Meeting May 2019 - Minutes

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 24 May 2019 15:47:54 +0000

Dear all,

Please find below and at: https://datatracker.ietf.org/meeting/interim-2019-nmrg-05/materials/minutes-interim-2019-nmrg-05-201905231700
or here if you prefer the Etherpad version: https://etherpad.tools.ietf.org/p/nmrg-virtual-20190523
the minutes of our virtual meeting held on May 23th, 2019.

Summary of main action points:

  1.  Dean to formalize a problem statement on "residual configurations" and see relevance to add this item to the work plan.
  2.  Creation of a team tasked to document the Network AI Challenge framework.
  3.  Chairs: propose refined work plan and milestones for approval

We will soon send a doodle poll for the next meeting in June/July.
Thanks to all the participants, to Jéferson for the minutes, and looking forward to the next virtual/physical meetings.
Best regards, Laurent.

---
NMRG Virtual Meeting May 2019
Thursday 23-05-2019 17:00-19-00 CEST

Participants (12):

     Laurent Ciavaglia (co-chair, Nokia), Jérôme François (co-chair, INRIA), Jeferson Nobre (secretary, UFRGS), Dean Bogdanovic (Volta Networks), Jeff Tantsura (Apstra), Egemen Cetinkaya (Verizon); Julien Maisonneuve (Nokia), Sabine Randriamasy (Nokia), Luis Contreras (Telefonica), Vishnu Ram (Technical Consultant, ITU-T ML5G FG), Shagufta Henna (TSSG), Alex Clemm (Huawei)

Useful links:
* Agenda: https://datatracker.ietf.org/doc/agenda-interim-2019-nmrg-05-nmrg-01/
* Materials: https://datatracker.ietf.org/meeting/interim-2019-nmrg-05/session/nmrg
* Webex: https://ietf.webex.com/ietf/j.php?MTID=m3749c133247f0efd650133795d261af1
* Etherpad: https://etherpad.tools.ietf.org/p/nmrg-virtual-20190523

Agenda:
05min. - Short introduction of new co-chair: Jérôme.

05min. - Status of the WG, next meetings, etc.

60min. - Status progress on Intent Based Networking topic

    IBN some challenges and research directions

    Work plan refinement

20min. - Network AI Challenge project

    Interest expressed from Vishnu Ram (ITU-T ML5G FG)

    Draft framework, Jérôme & Laurent

15min. - Modus Operandi for virtual meetings

    What is working well and not

    Dedicated meeting per topic? Alternate meetings per time zone

    Input: more proactive, only presentations or something more/different

    Output: minutes and actions, need more?

    How to follow-up between meetings? I-D updates, central place for work plan, progress and issue tracking, back-end / front-end

xxmin. - Any other business?

Meeting notes:

 - Agenda bashing
 - Jérôme presentation
****************************************************
IBN some challenges and research directions

Dean: In respect to intent from existing systems, there is configuration in the system... Old rules that are still in the systems and are not relevant anymore.
Need some sort of "garbage collector"

Jeff: what is the single source of truth? What the delta of the intent state and the operational state?
The brown field is a complex topic.
There are known frameworks for ACL (references?)

Dean: Single source of truth is the configuration files which are written by humans, but which becomes lost because people leave the organization. Hard problem as seen by people from the operational side.

Jeff: API for users to express the intent...

Laurent: from legacy point of view, it is needed a path to enable the interopetation in order to perform intent extraction from the CLI. It is necessary more data to analyse it.

Jeff: I don't see how to do this fully automatic (intent extraction?).

Jeff: It is needed to reach consensus in distributed systems (refer to slide 10) about the intent state across the system,
Cannot rely on a centralized entity, so have to degin/evaluate a system based on consensus with distributed entities and see the cost ratio (performance vs. complexity).
Stateless and central entity, could be path for lots or research.

Jeff: Planning changes through intent, how it is done? Telemetry framework being proposed by the IETF, it could be some colaboration.
abstracting the view from telemetry and linking to the intent deployment.

Dean: updates on intent, how they would work?
Jeff:?
Laurent: it depends how dependencies on intent would be formulated.
Dean: Intent as an atomic action avoids the dependecies problem.
Laurent: there will be relationships among intents, this could be included in the workplan.

******************
- IBN Work Plan
Jeff: terminology first.
Dean: garbage colection routine, potentially added to the work plan?
Laurent: formalize the problem and see from there.

**************************
- Network AI Challenge

Vishnu: Uses cases, we have analyzed several use cases considering 5G e future networks.
Vishnu: ITU Focus group on this topic.
Vishnu: We want to participate in the defintions of any of this aspects.

Laurent: form a team to define/document the Network AI challenge.

Jéferson: how do you think that we should pursue that? as a draft?

Laurent: no specific recommendation on form, could be draft, doc, slides
Eventually, if useful to document challenge framework as an I-D to be re-usable.

Dean: would rather see a challenge linking IBN and autonomic networking, incl. ANIMA. more realistic, indutry expectations.
Jeff: I could be interested if it is not too general (AI challenge)
Laurent: Jérôme  would be involved (lead co-chair on the project).
Vishnu ok to be part of the team.

- Virtual meetings
Laurent: wnat to know areas of improvement, what we can do to have efficient/useful meeting. propose issue/topic for more in-depth discussion during the meeting.
Jeff: some level of project management would be great
Jéferson: forming teams maybe would be helpul to track advances
Alex: Meetings are fine
Laurent: careful no to slide to some traditional project management and to no create 'groups within the group" with the design teams.
But if this is what the RG is aksing we will implement that.
Laurent: Virutal meetings specific for IBN?
Dean: ?

---

From: Jérôme François <[email-masked]>
Date: Mon, 27 May 2019 18:36:29 +0200

Dear all,

Just some comments I unfortunately was not able during meeting due to my audio 
connection problems:
- IBN: there were discussions on how to translate high level intents from CLI/API 
but it would be interested to consider the reverse way as well. For example, in 
case the resolution cannot find any solution that solves the problem but found a 
sub-optimal solution, it would then need to translate backward direction in the 
same "user language" (to confirm or decline for example)
- Network AI challenge: the goal is not to have a broad "Network AI" challenge but 
something specific to a use case. The current title serves for our discussion 
until we precisely define its scope.

best regards
jerome

On 24/05/2019 17:47, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) wrote:
>
> Dear all,
>
> Please find below and at: 
> https://datatracker.ietf.org/meeting/interim-2019-nmrg-05/materials/minutes-interim-2019-nmrg-05-201905231700
>
> or here if you prefer the Etherpad version: 
> https://etherpad.tools.ietf.org/p/nmrg-virtual-20190523
>
> the minutes of our virtual meeting held on May 23^th , 2019.
>
> *_Summary of main action points:_*
>
>  1. Dean to formalize a problem statement on "residual configurations" and see
>     relevance to add this item to the work plan.
> Laurent Ciavaglia (co-chair, Nokia), Jérôme François (co-chair, INRIA), Jeferson 
> Nobre (secretary, UFRGS), Dean Bogdanovic (Volta Networks), Jeff Tantsura 
> (Apstra), Egemen Cetinkaya (Verizon); Julien Maisonneuve (Nokia), Sabine 
> Randriamasy (Nokia), Luis Contreras (Telefonica), Vishnu Ram (Technical 
> Consultant, ITU-T ML5G FG), Shagufta Henna (TSSG), Alex Clemm (Huawei)
>
> Useful links:
>
> How to follow-up between meetings? I-D updates, central place for work plan, 
> progress and issue tracking, back-end / front-end
>
> Dean: In respect to intent from existing systems, there is configuration in the 
> system... Old rules that are still in the systems and are not relevant anymore.
>
> Dean: Single source of truth is the configuration files which are written by 
> humans, but which becomes lost because people leave the organization. Hard 
> problem as seen by people from the operational side.
>
> Laurent: from legacy point of view, it is needed a path to enable the 
> interopetation in order to perform intent extraction from the CLI. It is 
> necessary more data to analyse it.
>
> Jeff: It is needed to reach consensus in distributed systems (refer to slide 10) 
> about the intent state across the system,
>
> Cannot rely on a centralized entity, so have to degin/evaluate a system based on 
> consensus with distributed entities and see the cost ratio (performance vs. 
> complexity).
>
> Jeff: Planning changes through intent, how it is done? Telemetry framework being 
> proposed by the IETF, it could be some colaboration.
>
> Dean: would rather see a challenge linking IBN and autonomic networking, incl. 
> ANIMA. more realistic, indutry expectations.
>
> Laurent: wnat to know areas of improvement, what we can do to have 
> efficient/useful meeting. propose issue/topic for more in-depth discussion 
> during the meeting.
>
> Laurent: careful no to slide to some traditional project management and to no 
> create 'groups within the group" with the design teams.
>