Subject: Re: [nmrg] FW: New Version Notification for draft-li-nmrg-intent-classification-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Sat, 4 May 2019 16:03:17 +1200

Hi,

I appreciate this document as background for what is otherwise quite a confusing discussion.

There is one statement that gives me a bit of difficulty, however:

>    Management personnel, such as network Administrators, have complete
>    knowledge of the underlying network.  However, they may not
>    understand the details of the applications and services of Customers
>    and End-Users.

The second sentence is certainly true. However, especially if autonomic networking is a success, I am not sure about the first sentence. As networks get more and more complex, and especially when virtual networks or slices are created dynamically and automatically, the administrators will *not* have complete knowledge of the underlying network. In fact, the intent itself may be the reason for this: the network is configured as a result of the intent, and the human administrators will then be unaware of the details. (They are presumably aware of the physical structure of the network, and the devices installed, but that is only part of the story.)

Regards
   Brian Carpenter

On 24-Apr-19 14:23, Liushucheng (Will Liu) wrote:
> Hi,
> 
> I just did some small modifications and submit this draft as -nmrg, which replaced the old draft-li version.
> 
> As we presented during last NMRG meeting, there are several shared principles between SDOs:
>   -intent should be declarative, using and depending on as few deployment details as possible and focusing on what and not how
>   -intent should provide an easy-to-use interface, and use terminology and concepts familiar to its target audience
>   -intent should be vendor-independent and portable across platforms
>   -the intent framework should be able to detect and resolve conflicts between multiple intents
> 
> This document goal is to discuss and propose how to classify intents, so that  can be a good foundation for future discussion related to intent in IETF scope.
> 
> In the draft we've listed Intent Classification based on :
> -Solutions, Users and their Purpose
> -When to Activate
> -Lifecycle Management Requirements
> -Granularity
> 
> Slides we presented: 
> https://datatracker.ietf.org/meeting/104/materials/slides-104-nmrg-sessb-intent-classification-00
>                                  
> Your comments and contributions are welcome!
> 
> Regards, / 致礼! 
> Will LIU  / 刘树成
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, April 23, 2019 8:41 PM
> To: Liushucheng (Will Liu) <[email-masked]>; John Strassner <[email-masked]>; Olga Havel <[email-masked]>; Xuweiping (David) <[email-masked]>; Ying Cheng <[email-masked]>; Liushucheng (Will Liu) <[email-masked]>; Chen Li <[email-masked]>
> Subject: New Version Notification for draft-li-nmrg-intent-classification-00.txt
> 
> 
> A new version of I-D, draft-li-nmrg-intent-classification-00.txt
> has been successfully submitted by Will (Shucheng) Liu and posted to the IETF repository.
> 
> Name:		draft-li-nmrg-intent-classification
> Revision:	00
> Title:		Intent Classification
> Document date:	2019-04-22
> Group:		Individual Submission
> Pages:		13
> URL:            https://www.ietf.org/internet-drafts/draft-li-nmrg-intent-classification-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-li-nmrg-intent-classification/
> Htmlized:       https://tools.ietf.org/html/draft-li-nmrg-intent-classification-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-li-nmrg-intent-classification
> 
> 
> Abstract:
>    RFC 7575 defines Intent as an abstract high-level policy used to
>    operate the network. Intent management system includes an interface
>    for users to input requests and an engine to translate the intents
>    into the network configuration and manage their lifecycle. Up to
>    now, there is no commonly agreed definition, interface or model of
>    intent.
> 
>    This document discusses what intent means to different stakeholders,
>    describes different ways to classify intent, and an associated
>    taxonomy of this classification. This is a foundation for discussion
>    intent related topics.
> 
>                                                                                   
> 
> 
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg
>

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Wed, 8 May 2019 09:46:21 +0000

Hi Brian,

Thanks for your comments. I agree that the first sentence is not accurate and the rest of your comments. 

The main role of the first sentence is to lead to the second one. :)
We will modify it in next version to: Management personnel, such as network administrators, may have the knowledge of the underlying network.  
Is that OK?

Regards, / 致礼! 
Will LIU  / 刘树成

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Saturday, May 04, 2019 12:03 PM
To: Liushucheng (Will Liu) <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [nmrg] FW: New Version Notification for draft-li-nmrg-intent-classification-00.txt

Hi,

Regards
   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 9 May 2019 08:13:45 +1200

> We will modify it in next version to: Management personnel, such as network administrators, may have the knowledge of the underlying network.  

Yes, I think so. I hope we can soon have some concrete examples of intent, because for a long time the discussion has been very abstract.

Regards
    Brian

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Thu, 9 May 2019 03:10:00 +0000

Thanks for the comments. Let's try to write some examples in next version. Also, welcome your contribution.  :)

Regards, / 致礼! 
Will LIU  / 刘树成

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Thursday, May 09, 2019 4:14 AM
To: Liushucheng (Will Liu) <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [nmrg] FW: New Version Notification for draft-li-nmrg-intent-classification-00.txt

Regards
    Brian

> Subject: Re: [nmrg] FW: New Version Notification for 
> draft-li-nmrg-intent-classification-00.txt
> 
> Hi,
> 
> The second sentence is certainly true. However, especially if 
> autonomic networking is a success, I am not sure about the first 
> sentence. As networks get more and more complex, and especially when 
> virtual networks or slices are created dynamically and automatically, 
> the administrators will *not* have complete knowledge of the 
> underlying network. In fact, the intent itself may be the reason for 
> this: the network is configured as a result of the intent, and the 
> human administrators will then be unaware of the details. (They are 
> presumably aware of the physical structure of the network, and the 
> devices installed, but that is only part of the story.)
> 
> Regards
>    Brian Carpenter
> 
>> To: Liushucheng (Will Liu) <[email-masked]>; John Strassner 
>> <[email-masked]>; Olga Havel <[email-masked]>; 
>> Xuweiping (David) <[email-masked]>; Ying Cheng 
>> <[email-masked]>; Liushucheng (Will Liu) 
>> <[email-masked]>; Chen Li <[email-masked]>
>> Subject: New Version Notification for 
>> draft-li-nmrg-intent-classification-00.txt
>>
>>