Subject: [nmrg] NMRG activities at IETF 105 / Montreal / July 2019

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 7 May 2019 11:06:32 +0000

Dear NMRG,

In order to plan the various possible NMRG meetings at IETF 105, we would like to get your inputs on the following options, ideally before Wednesday, May 22nd 2019, AoE:

- Topics for discussion during the IETF 105 meeting ("regular" NMRG session(s))
  We plan to allocate time for discussion on intent based networking and the research group re-chartering.
  We could have time for other topics based on expressed needs, such as follow-up on the AI for Network Management discussion in IETF 104/Prague/March 2019. Presentations on other topics are also welcome.

- Use of unstructured time to progress on work of the NMRG ("informal" NMRG session(s). outcome could eventually be reported in the regular session if timing allows)
  IETF 105 schedule will allow for unstructured time during mornings and evenings of the IETF week.
  To maximize the efficiency of such unstructured time, we advise to organize in advance and call for specific items to be discussed and inform participants accordingly.

- Side meeting in the form of a dedicated workshop/meeting as done at IETF 102/Montreal/July 2018 ("interim" NMRG meeting).
  Last year we've organized a 1-day workshop on intent based networking together with the ETS Montreal, on the Friday.
  We could repeat a similar experiment based on expressed needs.
  The topic could be again intent based networking or another one.
  We can try to accommodate another day to the extent possible. However it seems Friday would again be the best option wrt. to other planning constraint of the week.

Please note that Applied Networking Research Workshop (ANRW) will be taking place on the Monday of IETF 105, and no other IRTF sessions will be scheduled on that day.

Thank you, best regards,
Laurent.

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Wed, 22 May 2019 16:34:47 +0000

Inline.

From: nmrg [mailto:[email-masked]] On Behalf Of Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Tuesday, May 7, 2019 7:07 PM
To: [email-masked]
Subject: [nmrg] NMRG activities at IETF 105 / Montreal / July 2019

Dear NMRG,

[Will] From the Montreal IETF agenda, it seems Thursday afternoon will be free. So, maybe another a good choice.

Regards, / 致礼!
Will LIU  / 刘树成

Thank you, best regards,
Laurent.

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 22 May 2019 20:25:12 +0000

Hi Will,
Thanks for your suggestion.
I'm not sure the current agenda for IETF 105 is accurate.
The information I have on the schedule of the meeting week is that the unstructured time will be distributed on the mornings and evenings (1 hour per day).

Best regards, Laurent.
________________________________
From: Liushucheng (Will Liu) <[email-masked]>
Sent: Wednesday, May 22, 2019 6:34:47 PM
To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay); [email-masked]
Subject: RE: NMRG activities at IETF 105 / Montreal / July 2019

Inline.

Dear NMRG,

Regards, / 致礼!
Will LIU  / 刘树成

Thank you, best regards,
Laurent.

---

From: "Dean Bogdanovic" <[email-masked]>
Date: Wed, 22 May 2019 16:37:48 -0400

Laurent,

For informal part, I would like to see if there is any current research work in network efficiencies (or should we say inefficiencies). I’ve heard recently that current networks are aprox 60% efficient, which leaves lot of space for improvement. I can see how network management is contributing to that (by managing networks as collection of devices and building services from bottom up, instead of managing network as collection of resources that consume resources and capabilities of the network), but don’t have better data on where the inefficiencies are. If any person on the list has more data on that and has interest, I would be interested to participate in the work.

Dean

> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 22 May 2019 15:45:35 -0700

Dean,

It this a good topic for discussions and research.
A common way to optimize is to define the end state of the system (network, a not device) and go back from there. The discrepancy between intended and operational states provides some good hints about eventual optimizations.

Cheers,
Jeff

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 23 May 2019 00:53:28 +0200

> For informal part, I would like to see if there is any current research work in network efficiencies (or should we say inefficiencies). I’ve heard recently that current networks are aprox 60% effic…

The question is too vague. What is the definition of "efficient"?
Where did you hear that networks are aprox 60% efficient?  And what
kind of network do you mean? There are significant differences between
lets say backbone networks and different types of access networks. And
do we talk about 'costs' for providing network services?  If so,
operational costs vs. investment costs vs. costs for things like
licenses (5G frequency auctions come to mind). Or do we talk about
'energy efficiency', i.e., CO2 footprints?

A blanket statement like 'networks are aprox 60% efficient' really
means nothing. This is far from an tangible research question.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: "Dean Bogdanovic" <[email-masked]>
Date: Fri, 24 May 2019 08:25:48 -0400

> means nothing. This is far from an tangible research question.

Yes, I agree with you, as wasn’t too clear about my interest. My main interest is in configuration efficiency. From talking to network operators they have config entries for which they don’t know why are there, sometimes entered with specific reason, but that reason expired, but the config was left. Also, the config is entered in too many devices, although it is not needed in each one of them to to enable the correct execution of network service.

Dean