Subject: [nmrg] NMRG Interim meeting aka IBN workshop - Friday July 26th - ETS Montreal

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 16 Jul 2019 09:20:58 +0000

Hello,

Details for the NMRG Interim meeting aka IBN workshop - Friday July 26th - ETS Montreal are available at: https://datatracker.ietf.org/doc/agenda-interim-2019-nmrg-07-nmrg-01/02/
and copied below for your convenience.

@Participants:
 . Please come prepared, read the drafts, think about intent examples, validation scenarios - for a fruitful meeting. This will not be presentation-focused !
. if you have specific topic for discussion and/or presentation, please inform the chairs.

The chairs would like to thank ETS Montreal, and particularly Mohamed-Faten Zhani, for hosting us (again) in such good conditions!

Looking forward to meet you at IETF 105 and at the workshop.
Thank you, best regards, Jérôme and Laurent.
---

NMRG 55th meeting
Interim meeting, ETS Montreal, Canada
Friday 26-07-2019 09:30-16:30 EDT

* RG Chair:
   Laurent Ciavaglia <[email-masked]>
   Jéröme François <[email-masked]>

* Meeting Location:
  ÉTS Montreal
  1100 Notre-Dame St W, Montreal, QC H3C 1K3, Canada
  Map: https://goo.gl/maps/kGDP9wCVBJahaALVA
  4th Floor
  Department of Software and IT Engineering
  Room A4458 (the room is inside the department)
  How to access: From ETS entrance, take the elevators that are next to the Cafeteria. Go to 4th floor and go to the department of Software and IT Engineering.

* Registration:
  Participation is free, registration is appreciated: https://doodle.com/poll/vwysqkq4h34w6c5f

* Remote participation:
  https://ietf.webex.com/ietf/j.php?MTID=m81b3d749f415e5456d8161b1db4eedba

* Useful links:
   Agenda and Materials: https://datatracker.ietf.org/meeting/interim-2019-nmrg-07/session/nmrg
   Etherpad: https://etherpad.tools.ietf.org/p/nmrg-interim-20190726

* Agenda:
  ** The meeting will focus on Intent Based Networking (IBN) and on making progress on the current work items, tentatively covering:
     - Concepts definition and terminology
     - Intent examples and validation scenarios, use cases
     - Architecture: requirements, principles, properties, functions/services, enablers, theory of operations, interworking/integration with other frameworks, human-network interface...

  ** Pleased come prepared:
     - Read the active Internet Drafts
       https://datatracker.ietf.org/doc/draft-clemm-nmrg-dist-intent/
         https://datatracker.ietf.org/doc/draft-li-nmrg-intent-classification/
         https://datatracker.ietf.org/doc/draft-sun-nmrg-intent-framework/

     - Think about examples of intents and how to validate them (on a scenario, on a logical flow, who are the actors/roles involved...)

  ** Schedule:
      9h30-10h   Welcome and coffee
       10h-12h    Morning session
       12h-13h    Lunch break
      13h-14h30 Afternoon session I
      14h30-15h Coffee break
      15h-16h30 Afternoon session II

  ** Agenda items: (to be announced)
     1. Introduction, Chairs
     2. ...
     3. ...
     4. ...
     5. ...

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 25 Jul 2019 05:21:00 +0000

Hello NMRG,

For our workshop on Friday, I would like to share and stress one aspect I would like us to investigate and exercise. This is the aspect of intent examples.

I would invite each of the participants to think and propose one or more examples of intents.
We will then run through a set of questions and "tests" to see if/how far we can go with the proposed intent examples: are some "parts" missing, incomplete, too approximative? Are the functions we are thinking of in the architecture enough to transform the proposed intents to the required level of output (e.g. configurations), are we missing some functionality to achieve the process or some capabilities to make the functionality complete, etc
Also, what are the commonalities and differences we could identify between the different intent examples proposed, how does it help on the work of intent classification, is it consistent or points to aspects we have overlooked?
Who are the actors/roles involved e.g. expressing intent, validating intent, mapping/translating/rendering, etc.
These examples could be linked to simple use cases or technologies to help us better grasp the exercise and help us validate the approach.

I strongly believe this will help us to move forward in the several activities we are engaging on intent based networking: terminology, classification, architecture, validation scenarios, human-network interface...

As starting point, after some search and thinking  I could come up with the following proposal/basis, for discussion:
Intents are composed of: a functional and an operational part. The functional part consist in the expression of the business goal, the expected outcome. The operation part captures the performance parameters such as network/compute/memory, time, space/topology ; security ; availability, etc. Units, metrics and value/value ranges may also be specified.
I don't know if cost or cost vs. x,y,z ratio should be considered in the intent expression.
We can also consider aspect of logic and operators, semantics... but we have to set some scope also first not to get lost in the complexity.

I think getting towards such "structures" could help us defining guidelines how to write intents and systems to parse them without imposing a single format or language.

I'm also deeply convinced that the intent "expression/refinement" process should edge towards continuous, iterative and interactive process rather than one shot intent expression.

We can also try to characterize different categories of intent (and use the corresponding draft as a support): business intents: end-users and operators: both have business intents for the system under study but have/are in different businesses.

Food for thoughts.
Best regards, Laurent.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Tuesday, July 16, 2019 11:21
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: NMRG Interim meeting aka IBN workshop - Friday July 26th - ETS Montreal

Hello,

@Participants:

NMRG 55th meeting

* RG Chair:
   Laurent Ciavaglia <[email-masked]<mailto:[email-masked]>>
   Jéröme François <[email-masked]<mailto:[email-masked]>>

* Meeting Location:
  ÉTS Montreal

* Registration:

* Remote participation:

* Useful links:

* Agenda:

  ** Schedule:

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 26 Jul 2019 04:21:32 +0000

Updated agenda here: https://datatracker.ietf.org/doc/agenda-interim-2019-nmrg-07-nmrg-01/03/
and here:

***
Agenda:
         9h30-10h - Welcome and coffee

         10h-12h - Morning session
         . Introduction, Workshop Chairs (Faten and Laurent) ~5 min.
         . FlexNGIA: A Flexible Internet Architecture for the Next-Generation Tactile Internet, Mohamed-Faten Zhani ~25 min.
         . Working on intent examples

         12h-13h - Lunch break

         13h-14h30 - Afternoon session I
         . A word from Patrick Cardinal, Head of Department of Software and IT Engineering ~5min.
         . Intent examples (continued)
         . Architecture discussion

         14h30-15h - Coffee break

         15h-16h30 - Afternoon session II
         . Architecture discussion (continued)
         . Meeting conclusions, Chairs and participants

***
Don't forget to come prepared (intent examples, read the drafts) and bring your brain 😉

See you tomorrow, Laurent.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>
Sent: Thursday, July 25, 2019 07:21
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: NMRG Interim meeting aka IBN workshop - Friday July 26th - ETS Montreal

Hello NMRG,

I strongly believe this will help us to move forward in the several activities we are engaging on intent based networking: terminology, classification, architecture, validation scenarios, human-network interface…

As starting point, after some search and thinking  I could come up with the following proposal/basis, for discussion:
Intents are composed of: a functional and an operational part. The functional part consist in the expression of the business goal, the expected outcome. The operation part captures the performance parameters such as network/compute/memory, time, space/topology ; security ; availability, etc. Units, metrics and value/value ranges may also be specified.
I don't know if cost or cost vs. x,y,z ratio should be considered in the intent expression.
We can also consider aspect of logic and operators, semantics… but we have to set some scope also first not to get lost in the complexity.

Food for thoughts.
Best regards, Laurent.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Tuesday, July 16, 2019 11:21
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: NMRG Interim meeting aka IBN workshop - Friday July 26th - ETS Montreal

Hello,

@Participants:
 . Please come prepared, read the drafts, think about intent examples, validation scenarios – for a fruitful meeting. This will not be presentation-focused !
. if you have specific topic for discussion and/or presentation, please inform the chairs.

NMRG 55th meeting

* RG Chair:

* Meeting Location:
  ÉTS Montreal

* Registration:

* Remote participation:

* Useful links:

* Agenda:

  ** Schedule: