Subject: [nmrg] Follow-up Network AI Challenge

From: Jérôme François <[email-masked]>
Date: Thu, 10 Oct 2019 13:49:21 +0200

Dear all,

Here are the minutes of the last telco on AI challenge:

- discussion on the different work-items and some addings (publication of the 
cahllenge to conferences, possibilities to have two phase with a final stage in a 
conference/hackhathon, use of kaggle)
- presentation of potential use cases to develop for the challenge: routing, 
traffic analysis, intent intepretation
- need a platform to perform the challenge (pure data-based validation as kaggle 
vs validating with running experiment in network simulator/emulator)

- General Comments:
-- need to check how other communities propose challenge and what are the outcomes
-- open question: what will be the outcome of the challenge? only a ranking of 
algorithm? What could be useful for NMRG activities then?
-- IBN - AI challenge: can be at the different stage of the IBN pipeline, need to 
understand the requirements of each stage

To follow the activity (with more details about use cases and discussions): 
https://pad.inria.fr/p/g.D1sMHS8qEcwsc2iq$np_TuYkekVkbtLyVZYr_netaichallenge

To continue:
- we are looking for volunteers to investigate the feasability and the potential 
outcomes of some uses (either those proposed or other ones). So please raise your 
hand if you're interested.
- to setup a follow-up telco you fill out the following doodle: 
https://doodle.com/poll/34ecz66ptmugec86

Best regards
jerome

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Fri, 11 Oct 2019 06:34:17 +0000

Hi Jerome,

Very detailed and useful info. Thanks for the efforts!
Sorry that due to time conflict I missed the meeting. My comments below inline.

Regards, | 致礼!
Will LIU   | 刘树成

From: nmrg [mailto:[email-masked]] On Behalf Of Jér?me Fran?ois
Sent: Thursday, October 10, 2019 7:49 PM
To: [email-masked]
Subject: [nmrg] Follow-up Network AI Challenge

Dear all,

- discussion on the different work-items and some addings (publication of the cahllenge to conferences, possibilities to have two phase with a final stage in a conference/hackhathon, use of kaggle)
[Will] Given the status of this work. I prefer one single work-items to describe the gap analysis and challenging.

- presentation of potential use cases to develop for the challenge: routing, traffic analysis, intent interpretation
[Will] Agree. Use cases specific to IETF/IRTF aspects will be critical to trigger the work here, especially those that attached to some IETF existing work such as YANG, SR, and intent as well.

- need a platform to perform the challenge (pure data-based validation as kaggle vs validating with running experiment in network simulator/emulator)
[Will] This might be bit difficult currently for standalone platform for IETF/IRTF, we may try to cooperate with some of existing work in industry, such as LN acumos.

- General Comments:
-- need to check how other communities propose challenge and what are the outcomes
-- open question: what will be the outcome of the challenge? only a ranking of algorithm? What could be useful for NMRG activities then?
-- IBN - AI challenge: can be at the different stage of the IBN pipeline, need to understand the requirements of each stage
[Will] AI and IBN are related, but the overlapping is not a must. AI may be even wider than IBN, which could help most of the policy and decision in IETF scope.

To follow the activity (with more details about use cases and discussions): https://pad.inria.fr/p/g.D1sMHS8qEcwsc2iq$np_TuYkekVkbtLyVZYr_netaichallenge

To continue:
- we are looking for volunteers to investigate the feasability and the potential outcomes of some uses (either those proposed or other ones). So please raise your hand if you're interested.
- to setup a follow-up telco you fill out the following doodle:  https://doodle.com/poll/34ecz66ptmugec86

Best regards
jerome

---

From: Abdelkader Lahmadi <[email-masked]>
Date: Fri, 11 Oct 2019 18:05:11 +0200

Hi all,
I can help for the AI-based routing use case.
Best,
> On 10 Oct 2019, at 13:49, Jérôme François <[email-masked]> wrote:
> 
> Dear all,
> 
> - presentation of potential use cases to develop for the challenge: routing, traffic analysis, intent intepretation
> To follow the activity (with more details about use cases and discussions): https://pad.inria.fr/p/g.D1sMHS8qEcwsc2iq$np_TuYkekVkbtLyVZYr_netaichallenge <https://pad.inria.fr/p/g.D1sMHS8qEcwsc2iq$np_TuYkekVkbtLyVZYr_netaichallenge>
> 
> To continue:
> - to setup a follow-up telco you fill out the following doodle:  https://doodle.com/poll/34ecz66ptmugec86 <https://doodle.com/poll/34ecz66ptmugec86>
> 
> Best regards
> jerome
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

---

From: Jérôme François <[email-masked]>
Date: Wed, 16 Oct 2019 13:29:40 +0200

Hi,

Just a small reminder about the doodle for the network AI next telco if you are 
interested to contribute with any ideas and comments:
https://doodle.com/poll/34ecz66ptmugec86

best
jerome

On 10/10/2019 13:49, Jérôme François wrote:
> cahllenge to conferences, possibilities to have two phase with a final stage in 
> a conference/hackhathon, use of kaggle)
> -- IBN - AI challenge: can be at the different stage of the IBN pipeline, need 
> to understand the requirements of each stage
>
> outcomes of some uses (either those proposed or other ones). So please raise 
> your hand if you're interested.