Subject: [nmrg] New Version Notification for draft-li-nmrg-intent-classification-02.txt

From: Olga Havel <[email-masked]>
Date: Mon, 18 Nov 2019 14:22:36 +0000

Hi,

We've just uploaded 02 version of intent classification draft (https://www.ietf.org/internet-drafts/draft-li-nmrg-intent-classification-02.txt) according to the comments in the list and offline discussions.

Updates from previous version from July:
1.                   Addressed Brain's comments about "Adding solid use cases". Addressed by adding use cases in section 3.2.
2.                   Addressed Diego's comments about "Provide a framework for further intent evolution".  Addressed by adding a new draft: draft-sun-nmrg-intent-framework-00
3.                   Addressed Laurent's comments "Suggest to use parameter/classification table to do classification". Addressed by adding the whole Section 5 with classification tables for Carrier, DC and Enterprise.
4.                   Addressed comments from Ericsson "Classify based on granularity is not accurate, may change granularity to abstraction of service description". Addressed by changing Section 4.2 from Granularity Section to Feedback Section and adding column Abstraction to the classification table.
5.                   Chapters 5 and 6 became 6 and 7, as a result of adding new chapter 5
6.                   Section 7: Added explanation about AI related content
7.                   Moved the sections of Policy Continuum and AI after the section for Intent Classification Table
8.                   Updated contributors
9.                   Fixed document format and typos

Your comments and contributions are welcome!.

Best Regards,
Olga

---

From: 孙雪媛 <[email-masked]>
Date: Thu, 21 Nov 2019 15:56:30 +0800

Hi Olga,
I noticed that the draft has been added intent classification table in section five. Is there a consideration for adding  the correspondence between the content of the section five  and the description of the intention translation of AI in section seven? I think this would make the draft more complete. 

Best Regards,
Xueyuan SUN

Xueyuan Sun
China Telecom Strategy and Innovation Research Institute
Email：[email-masked]
Tel: +86-10-50902887
Mobile: +86-17316269362

==============================
孙雪媛
中国电信战略与创新研究院 
Tel：010-50902887/ 17316269362
Email：[email-masked]
 
From: Olga Havel
Date: 2019-11-18 22:22
To: [email-masked]
CC: [email-masked]
Subject: [nmrg] New Version Notification for draft-li-nmrg-intent-classification-02.txt
Hi,
 
We’ve just uploaded 02 version of intent classification draft (https://www.ietf.org/internet-drafts/draft-li-nmrg-intent-classification-02.txt) according to the comments in the list and offline discussions. 
 
Updates from previous version from July:
1.                   Addressed Brain’s comments about “Adding solid use cases”. Addressed by adding use cases in section 3.2.
2.                   Addressed Diego’s comments about “Provide a framework for further intent evolution”.  Addressed by adding a new draft: draft-sun-nmrg-intent-framework-00
3.                   Addressed Laurent’s comments “Suggest to use parameter/classification table to do classification”. Addressed by adding the whole Section 5 with classification tables for Carrier, DC and Enterprise. 
4.                   Addressed comments from Ericsson “Classify based on granularity is not accurate, may change granularity to abstraction of service description”. Addressed by changing Section 4.2 from Granularity Section to Feedback Section and adding column Abstraction to the classification table.
5.                   Chapters 5 and 6 became 6 and 7, as a result of adding new chapter 5 
6.                   Section 7: Added explanation about AI related content
7.                   Moved the sections of Policy Continuum and AI after the section for Intent Classification Table
8.                   Updated contributors
9.                   Fixed document format and typos

Best Regards,
Olga

---

From: Olga Havel <[email-masked]>
Date: Thu, 21 Nov 2019 13:33:54 +0000

Hi Xueyuan Sun,

Thank you very much for your comments.

This current table was for classification of user intents, independent of how they are implemented  (ML/AI used or not during intent translation/closed-loop/security). But it is a great suggestion to add more info to Chapter 5 that would link with Section 7. In that case I would suggest that we move Section 5 after Section 7. The following are some things that come to my mind, please let me know what you think about them.

1.       We can add new categories / sub-categories to the existing tables:

a)      Related to the first part of Section 7. Add category mentioned in regards to intent: goal intent versus policy intent.

b)      Related to the second part of Section 7. Add category for how intents are realized in regards to ML/AI techniques: AI used in realization (YES/NO): AI for security, AI for intent translation, AI for adaptive adjustment

c)       Related to the third part of Section 7. Add a new category or sub-category (maybe to abstraction category– technical with feedback (human) / non-technical (human) / machine) that specifically mentions resulting actions determine by AI control modules

d)      Related to the forth part of Section 7. Do we utilize ML/AI to classify intents, maybe we can add new sub-category to lifecycle (intent discovery – automatic intent classification via AI), which would mean that intent categories would be determined / recommended by AI.

e)      Related to Intent Translation definition in Section 7? Please let me know what category you would suggest if you want to relate it just to intent translation?  Please suggest if you think your suggestion has not be covered by 1a) to 1d).

2.       Another option is that instead of adding some categories / sub-categories in the existing tables, we add a section 5.4 that would focuses on the classification based on adoption of different AI/ML approaches / techniques in
different stages of intent implementation on the network. I believe this approach may bring the most value. We could include 1a) to 1e) and we do not need to split between different solutions and intent users, as classification would be more focused on how intents are implemented in regards to adoption of AI/ML, independent of solutions, intent users and intent types.

Best Regards,
Olga

From: 孙雪媛 [mailto:[email-masked]]
Sent: Thursday 21 November 2019 07:57
To: Olga Havel <[email-masked]>; [email-masked]; Liushucheng (Will Liu) <[email-masked]>
Cc: [email-masked]
Subject: Re: [nmrg] New Version Notification for draft-li-nmrg-intent-classification-02.txt

Hi Olga,

Best Regards,
Xueyuan SUN

________________________________
Xueyuan Sun
China Telecom Strategy and Innovation Research Institute
Email：[email-masked]<mailto:[email-masked]>
Tel: +86-10-50902887
Mobile: +86-17316269362

==============================
孙雪媛
中国电信战略与创新研究院
Tel：010-50902887/ 17316269362
Email：[email-masked]<mailto:[email-masked]>

From: Olga Havel<mailto:[email-masked]>
Date: 2019-11-18 22:22
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Subject: [nmrg] New Version Notification for draft-li-nmrg-intent-classification-02.txt

Hi,

Best Regards,
Olga