Subject: Re: [nmrg] Call for contributions - NMRG Session 1 at IETF 106 / Singapore / November 2019

From: Benoit Claise <[email-masked]>
Date: Tue, 12 Nov 2019 12:03:05 +0100

Jérôme, Laurent,

During the NMRG interim meeting end of July in Montreal, I explained 
verbally what I believe is the way (to attempt) to solve the 
intent-based networking.

In the end, I finally I wrote those two drafts below. I would like to 
request a slot to present them, if the agenda time permits:

     - draft-claise-opsawg-service-assurance-architecture-00
     - draft-claise-opsawg-service-assurance-yang-01

The first document describes the architecture for Service Assurance for 
Intent-based Networking (SAIN). This architecture aims at assuring that 
service instances are correctly running. As services rely on multiple 
sub-services by the underlying network devices, getting the assurance of 
a healthy service is only possible with a holistic view of network 
devices. This architecture not only helps to correlate the service 
degradation with the network root cause but also the impacted services 
impacted when a network component fails or degrades.

This second document complements the architecture by providing open 
interfaces between components, meaning YANG modules.

FYI, this architecture has been validated by a proof of concept.

In the mean time, NMRG, your feedback is welcome.

Regards, Benoit

> Dear all,
>
> We will have two NMRG sessions in IETF 106 planned as below (subject 
> to changes):
>
> - Session 1: Thursday 2019/11/21 10:00 - 12:00 (local time)
> - Session 2: Friday 2019/11/22 12:20 – 13:50 (local time)
>
> Session 1 will focus on the Intent-based Networking topic with:
> 1) Quick report on October interim meeting on practical aspects of 
> IBN, and follow-ups
> 2) Status and progress of active I-Ds
> 3) Technical presentations and discussion on
> - Architecture/functionality
> - Use cases and validation scenarios
> - Techniques
>
> For point 3), we invite presentations on various, AI and non-AI based, 
> techniques addressing the IBN challenges and problems of IBN.
> We are interested in learning which techniques are useful and 
> applicable, their benefits, limits and drawbacks, including 
> quantitative and qualitative comparison/evaluation between different 
> techniques or approaches.
> The diagrams in presentations [1], [2] and [3] can help as support to 
> identify specific functional components or phases with challenges and 
> issues to solve.
>
> Please reply to chairs with your proposals by Thursday, October 31st 
> 2019.
>
> Best regards
> Jérôme & Laurent
> NMRG chairs
>
> ---
> [1]: 
> https://datatracker.ietf.org/meeting/interim-2019-nmrg-05/materials/slides-interim-2019-nmrg-05-sessa-intent-driven-networks-some-challenges-and-research-directions
> [2]: 
> https://datatracker.ietf.org/meeting/interim-2019-nmrg-08/materials/slides-interim-2019-nmrg-08-sessa-towards-an-intent-lifecycle
> [3]: 
> https://datatracker.ietf.org/meeting/105/materials/slides-105-nmrg-update-on-ibn-concepts-lifecycle-and-functionality-00.pdf 
>
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 12 Nov 2019 14:55:56 +0000

Hi Benoît, all,

Thanks Benoît for sharing the links and the proposal towards the NMRG.
We can re-arrange the agenda of session 1 to give you a (10min?) slot, but time will be limited (the agenda was already quite packed).

Please give us a title for your presentation.

Best regards, Laurent.

> -----Original Message-----
> From: Benoit Claise <[email-masked]>
> Sent: Tuesday, November 12, 2019 12:03
> To: Jérôme François <[email-masked]>; [email-masked]
> Cc: [email-masked]; Jean Quilbeuf -X (jquilbeu - LIANEO at Cisco)
> <[email-masked]>
> Subject: Re: [nmrg] Call for contributions - NMRG Session 1 at IETF 106 /
> Singapore / November 2019
> 
> Jérôme, Laurent,
> 
> > https://datatracker.ietf.org/meeting/interim-2019-nmrg-
> 05/materials/slides-interim-2019-nmrg-05-sessa-intent-driven-networks-
> some-challenges-and-research-directions
> > [2]:
> > https://datatracker.ietf.org/meeting/interim-2019-nmrg-
> 08/materials/slides-interim-2019-nmrg-08-sessa-towards-an-intent-lifecycle
> > [3]:
> > https://datatracker.ietf.org/meeting/105/materials/slides-105-nmrg-
> update-on-ibn-concepts-lifecycle-and-functionality-00.pdf
> >

---

From: Benoit Claise <[email-masked]>
Date: Tue, 12 Nov 2019 20:03:01 +0100

Hi Laurent,
> We can re-arrange the agenda of session 1 to give you a (10min?) slot, but time will be limited (the agenda was already quite packed).
Perfect.
> Please give us a title for your presentation.
Service Assurance for Intent-based Networking Architecture

Thanks and regards, B.*
*