Subject: Re: [nmrg] New Version Notification for draft-li-nmrg-intent-classification-02.txt

From: Olga Havel <[email-masked]>
Date: Thu, 28 Nov 2019 16:51:50 +0000

Hi,
As some of you remember, we asked during the Singapore meeting for adoption of draft-li-nmrg-intent-classification-02 as an RG draft. After voting, all of those who read it agreed that the draft is very useful. You also mentioned that we need to potentially address some additional review comments. Could everyone who has any comments please share them with us. Laurent, Jerome, could you please share your comments as well? Also, please let us know what comments you think must be addressed in for v2 to be adopted, versus what comments we can address in v3, currently planned for March/April.
Best Regards,
Olga

From: Olga Havel
Sent: Monday 18 November 2019 14:23
To: [email-masked]' <[email-masked]>
Cc: [email-masked]' <[email-masked]>
Subject: New Version Notification for draft-li-nmrg-intent-classification-02.txt

Hi,

We've just uploaded 02 version of intent classification draft (https://www.ietf.org/internet-drafts/draft-li-nmrg-intent-classification-02.txt) according to the comments in the list and offline discussions.

Updates from previous version from July:
1.                   Addressed Brain's comments about "Adding solid use cases". Addressed by adding use cases in section 3.2.
2.                   Addressed Diego's comments about "Provide a framework for further intent evolution".  Addressed by adding a new draft: draft-sun-nmrg-intent-framework-00
3.                   Addressed Laurent's comments "Suggest to use parameter/classification table to do classification". Addressed by adding the whole Section 5 with classification tables for Carrier, DC and Enterprise.
4.                   Addressed comments from Ericsson "Classify based on granularity is not accurate, may change granularity to abstraction of service description". Addressed by changing Section 4.2 from Granularity Section to Feedback Section and adding column Abstraction to the classification table.
5.                   Chapters 5 and 6 became 6 and 7, as a result of adding new chapter 5
6.                   Section 7: Added explanation about AI related content
7.                   Moved the sections of Policy Continuum and AI after the section for Intent Classification Table
8.                   Updated contributors
9.                   Fixed document format and typos

Your comments and contributions are welcome!.

Best Regards,
Olga

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Thu, 28 Nov 2019 17:24:08 +0000

So how does this interact with draft-clemm-nmrg-dist-intent-03?

I personally find the big tables confusing and not very helpful to
understand the concepts. But perhaps my problem is not classification
of intent but looking for a good and concise definition of what is
intent, what is not intent, how intent relates to prior art on
(declarative) policy languages (or is intent just a new name?)  In
that direction, I find draft-clemm-nmrg-dist-intent-03 clearer and
more useful.

/js

> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Olga Havel <[email-masked]>
Date: Thu, 28 Nov 2019 18:27:56 +0000

Hi Jürgen,

Thank you very much for your comments. As draft-clemm-nmrg-dist-intent-03 addressed the differences between the policy, intent and service models, we did not address the same. This draft is about intent classification but we could add definition here, thank you for your suggestion. Initially we wanted to communicate that intent may be different thing for different users in different solutions. But we said in our presentation that the next steps for v3 is: 'Work with community to derive unified intent definition that encompasses all intent types for all solutions and intent users.'

We added tables based on Laurent's comments (this was the addition from the v1) , and the goal was to include in some tabular form the text that was in the document. Laurent suggested to use the table to position the PoCs / tools, identifying what intent types / categories they address.

Maybe we can together agree the definition of intent that could be used in NMRG and we can add it to our draft. What about the following as just a starting point for discussion in the group:

Intents are objectives of the network users, expressed in the form suitable for different user types. Intents represent what the users require from a network and not how these objectives are resolved, realized, configured and assured on the network. 

Any comments are welcome, would be great to start discussion. 

Best Regards,
Olga

-----Original Message-----
From: Schönwälder, Jürgen [mailto:[email-masked]] 
Sent: Thursday 28 November 2019 17:24
To: Olga Havel <[email-masked]>
Cc: [email-masked]; [email-masked]; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]
Subject: Re: [nmrg] New Version Notification for draft-li-nmrg-intent-classification-02.txt

I personally find the big tables confusing and not very helpful to understand the concepts. But perhaps my problem is not classification of intent but looking for a good and concise definition of what is intent, what is not intent, how intent relates to prior art on
(declarative) policy languages (or is intent just a new name?)  In that direction, I find draft-clemm-nmrg-dist-intent-03 clearer and more useful.

/js

On Thu, Nov 28, 2019 at 04:51:50PM +0000, Olga Havel wrote:
> Cc: [email-masked]' 
> <[email-masked]>
> Subject: New Version Notification for 
> draft-li-nmrg-intent-classification-02.txt
> 
> 
> Hi,
> 
>

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Fri, 29 Nov 2019 12:06:24 +0000

> Any comments are welcome, would be great to start discussion. 

I believe draft-clemm-nmrg-dist-intent should define the terminology
and concepts and not the classification draft. I do not support the
adoption of the classification draft until we adopt the other draft
and have agreement that draft-clemm-nmrg-dist-intent will be the one
defining terminology and concepts. Having multiple definitions in
different drafts can't be our goal.

/js