Subject: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02

From: Jérôme François <[email-masked]>
Date: Wed, 4 Dec 2019 18:24:44 +0100

Dear all,

We recently received an RG adoption request for 
draft-li-nmrg-intent-classification-02 
(https://www.ietf.org/id/draft-li-nmrg-intent-classification-02.txt)

Please let us know if you support the work becoming a RG document or if you think 
it should not be adopted. In all cases, provide detailed comments to support your 
opinion and send them on the mailing list.

This call for adoption is open for two weeks and ends up on 19 December 2019.

The procedure for RG document adoption and important criteria are detailed here: 
https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Wed, 4 Dec 2019 21:24:51 +0000

I am still not sure what the value of this document is. What is the
insight that these big tables deliver? How do they help doing
ultimately better work in the IETF?

I am sure I will get some answer quickly from the authors but what I
am saying is that I prefer to see the value of this document very
clearly explained in the document before adopting it. Note that I also
expect that this document would align with the other document defining
intent concepts and terminology. Perhaps this is more intended like a
survey paper but then it has gone a bit in the wrong direction since a
decent survey would explain how intent is defined and used in concrete
projects (hint: lots of concrete descriptions and references) and then
you would classify things. But right now, we have big tables with
empty cells or cells with text that seems to come from rather unknown
sources.

For the above reasons, I do not support adoption at this point in
time.

/js

On Wed, Dec 04, 2019 at 06:24:44PM +0100, Jérôme François wrote:
> Please let us know if you support the work becoming a RG document or if you
> think it should not be adopted. In all cases, provide detailed comments to
> support your opinion and send them on the mailing list.
> 
> The procedure for RG document adoption and important criteria are detailed
> here: https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU
> 
> Best regards
> NMRG chairs
> Laurent & Jérôme
> 
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 4 Dec 2019 13:32:18 -0800

+1 Juergen

Cheers,
Jeff

---

From: "Natale, Bob" <[email-masked]>
Date: Thu, 5 Dec 2019 06:57:31 +0000

I would like to add that the extremely brief section on the Policy Continuum in the draft seems superfluous in light of its brevity and consequent over-simplification. (If John Strassner feels otherwise, then please ignore my comments here!)

While the existing text is a reasonable facsimile of early descriptions of the Policy Continuum, as thought developed the concept matured: E.g., "The Policy Continuum - Policy authoring and conflict analysis" (2008), http://brendanjennings.net/papers/2008_COMCOM_SDavy_et_al_published.pdf, esp. sec. 2.1.4, but most of the rest of the paper is essential to a useful level of understanding. 

Alas, at some point the Policy Continuum concept seems to have fallen relatively dormant. Regardless, wrt the discussion topic at hand, I believe that several points must be considered:

- Non-person entity "actors" as policy authors will be essential to translation of policy expressions in the Intent-based operating model.
- It is (and always has been) the translation of policies across levels. The translation activity is what makes the model a continuum as opposed to (only) a set of interworking differentiated layers.
- Applying Intent-based policy expression adds a distinct dimension to operation of the Policy Continuum ... this new dimension is compatible with existing common understanding of the Policy Continuum but introduces additional translations at some layers.

So, I think it's necessary to cover the Policy Continuum (by whatever name might be preferable today, if that term is out of vogue) in an explanation of Intent-based policy implementation. I am not sure it belongs in a document defining Intent classification. And it almost certainly does not fit into this particular draft in its present form. I do see the connection you are presumably making with your Intent User and Intent Type breakouts and the Policy Continuum but (to coin a phrase?) it's "too little too early" to add any real value.

FWIW (from a lurker),
BobN

-----Original Message-----
From: nmrg <[email-masked]> On Behalf Of Schönwälder, Jürgen
Sent: Wednesday, December 4, 2019 4:25 PM
To: Jérôme François <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [EXT] Re: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02

I am still not sure what the value of this document is. What is the insight that these big tables deliver? How do they help doing ultimately better work in the IETF?

I am sure I will get some answer quickly from the authors but what I am saying is that I prefer to see the value of this document very clearly explained in the document before adopting it. Note that I also expect that this document would align with the other document defining intent concepts and terminology. Perhaps this is more intended like a survey paper but then it has gone a bit in the wrong direction since a decent survey would explain how intent is defined and used in concrete projects (hint: lots of concrete descriptions and references) and then you would classify things. But right now, we have big tables with empty cells or cells with text that seems to come from rather unknown sources.

For the above reasons, I do not support adoption at this point in time.

/js

On Wed, Dec 04, 2019 at 06:24:44PM +0100, Jérôme François wrote:
> Please let us know if you support the work becoming a RG document or 
> if you think it should not be adopted. In all cases, provide detailed 
> comments to support your opinion and send them on the mailing list.
> 
> here:

---

From: "Branislav Meandzija" <[email-masked]>
Date: Thu, 5 Dec 2019 10:14:55 -0800

While I have followed some of the various discussions here over the past
decades, I am not sure whether my 2 cents on this subject  is appropriate or
not. However, I have done quite a bit of research, system design and
implementation  synonymous with  "intent" intent over this period of time
and feel compelled to comment.  

My perspective is that intent is application/domain specific and can only be
abstracted from a knowledgebase specific to that application/domain. This
abstraction should be formal and not fluff. 

As such, I feel this document just further muddies the waters with
unnecessary and arbitrary new definitions and  I would not promote it
further.

Branislav

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Natale, Bob
Sent: Wednesday, December 4, 2019 10:58 PM
To: Jérôme François <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [nmrg] [EXT] Re: Adoption call for
Importance: Low

I would like to add that the extremely brief section on the Policy Continuum
in the draft seems superfluous in light of its brevity and consequent
over-simplification. (If John Strassner feels otherwise, then please ignore
my comments here!)

While the existing text is a reasonable facsimile of early descriptions of
the Policy Continuum, as thought developed the concept matured: E.g., "The
Policy Continuum - Policy authoring and conflict analysis" (2008),
http://brendanjennings.net/papers/2008_COMCOM_SDavy_et_al_published.pdf,
esp. sec. 2.1.4, but most of the rest of the paper is essential to a useful
level of understanding. 

Alas, at some point the Policy Continuum concept seems to have fallen
relatively dormant. Regardless, wrt the discussion topic at hand, I believe
that several points must be considered:

- Non-person entity "actors" as policy authors will be essential to
translation of policy expressions in the Intent-based operating model.
- It is (and always has been) the translation of policies across levels. The
translation activity is what makes the model a continuum as opposed to
(only) a set of interworking differentiated layers.
- Applying Intent-based policy expression adds a distinct dimension to
operation of the Policy Continuum ... this new dimension is compatible with
existing common understanding of the Policy Continuum but introduces
additional translations at some layers.

So, I think it's necessary to cover the Policy Continuum (by whatever name
might be preferable today, if that term is out of vogue) in an explanation
of Intent-based policy implementation. I am not sure it belongs in a
document defining Intent classification. And it almost certainly does not
fit into this particular draft in its present form. I do see the connection
you are presumably making with your Intent User and Intent Type breakouts
and the Policy Continuum but (to coin a phrase?) it's "too little too early"
to add any real value.

FWIW (from a lurker),
BobN

-----Original Message-----
From: nmrg <[email-masked]> On Behalf Of Schönwälder, Jürgen
Sent: Wednesday, December 4, 2019 4:25 PM
To: Jérôme François <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [EXT] Re: [nmrg] Adoption call for

I am still not sure what the value of this document is. What is the insight
that these big tables deliver? How do they help doing ultimately better work
in the IETF?

I am sure I will get some answer quickly from the authors but what I am
saying is that I prefer to see the value of this document very clearly
explained in the document before adopting it. Note that I also expect that
this document would align with the other document defining intent concepts
and terminology. Perhaps this is more intended like a survey paper but then
it has gone a bit in the wrong direction since a decent survey would explain
how intent is defined and used in concrete projects (hint: lots of concrete
descriptions and references) and then you would classify things. But right
now, we have big tables with empty cells or cells with text that seems to
come from rather unknown sources.

/js

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Fri, 6 Dec 2019 09:55:44 +0000

After received so many comments and addressed them with recent updates (see our summary in slides Olga presented), as co-author, I support this draft being adopted.

Regards, 	|   致礼! 
Will LIU  	|   刘树成

> From: nmrg [mailto:[email-masked]] On Behalf Of Jér?me Fran?ois
> Sent: Thursday, December 5, 2019 1:25 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02
> 
> Dear all,
> 
> Please let us know if you support the work becoming a RG document or if
> you think it should not be adopted. In all cases, provide detailed comments
> to support your opinion and send them on the mailing list.
>

---

From: Olga Havel <[email-masked]>
Date: Fri, 6 Dec 2019 11:50:34 +0000

As a co-author, I support this draft being adopted

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Liushucheng (Will Liu)
Sent: Friday 6 December 2019 09:56
To: Jérôme François <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02

Regards, 	|   致礼! 
Will LIU  	|   刘树成

---

From: Giuseppe Fioccola <[email-masked]>
Date: Fri, 6 Dec 2019 12:03:53 +0000

Hi All,
I also support this draft being adopted.
Regards,

Giuseppe

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Jérôme François
Sent: Wednesday, December 4, 2019 6:25 PM
To: [email-masked]
Cc: [email-masked]
Subject: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02

Dear all,

Please let us know if you support the work becoming a RG document or if you think it should not be adopted. In all cases, provide detailed comments to support your opinion and send them on the mailing list.

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Jéferson Campos Nobre <[email-masked]>
Date: Fri, 6 Dec 2019 09:33:35 -0300

As a co-author, I support this draft being adopted.
Thanks.
Best.
Jeferson

---

From: Olga Havel <[email-masked]>
Date: Fri, 6 Dec 2019 12:44:06 +0000

Hi,

We agreed the 2 drafts with chairs at the previous meetings. We did not have any review comments about the 2 drafts overlapping during the previous reviews or meetings, it seemed to be clear. But it may be because of some things discussed at meetings have not been documented in the drafts, so we need to address this - either in this version or version 03. And I believe this may be applicable to both drafts.

This draft is about classification of intents based on different users of the network, from their perspective. This draft tries to answer what intent types are needed for different users of the network, and it takes the approach of first identifying solutions, intent users and intent types and categories of intents that these users may need. This is from the abstract:

"This document discusses what intent means to different stakeholders,  describes different ways to classify intent, and an associated  taxonomy of this classification. This is a foundation for discussion of intent related topics."

Also:
"Therefore, it is important to start a discussion in the industry about what intent is for different solutions and intent users. It is also imperative to try to propose some intent categories / classifications that could be understood by a wider audience. This would help us define intent interfaces, DSLs and models."

In regards to the tables, I already mentioned in the previous email on 28/11/2019, we added them as chairs considered them to be more useful than text for classification purposes and I do agree fully. This was the main Laurent's comment about the previous version of the draft. They can be used for different purposes by the group, for example:
- PoCs/ Demos /Research may fill in the empty cells to identify what their scope is
- Some future drafts (e.g. intent model/DSL/API) may fill in the empty cells to identify their scope or priorities
- discuss if some things should be considered intents or not (e.g.  strategy intents, different opinions) and agree to remove them
- identify some new intent types/ categories currently not identified
- ensure that whatever intent definition is agreed (in draft-clemm-nmrg-dist-intent-03) is comprehensive enough to address all solutions and users of network and intent types they require from the network to support (draft-li-nmrg-intent-classification-02).

I agree completely that we should be fully aligned and I propose that the further alignment could be done after we adopt both drafts. We are talking here about versions 02/03, so we obviously need more work on either. It would be better to use the latest versions for further alignment, as there were lots of changes done and we addressed lots of comments from the community.

Best Regards,
Olga

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Schönwälder, Jürgen
Sent: Wednesday 4 December 2019 21:25
To: Jérôme François <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02

/js

---

From: Olga Havel <[email-masked]>
Date: Fri, 6 Dec 2019 13:22:06 +0000

Hi BobN,

Thank you very much for your comments, I absolutely agree with you about it all. But I do think that we need to have additional drafts to address some of the comments you have and that maybe not all of them are in the scope of this draft. The scope of this draft is intent classification - from the perspective of different solutions and intent users, where intent user is any human interacting with the network (existing network and future autonomous network). I think this draft should be foundation for discussion of intent related topics and other drafts that would be coming - intent engine architecture (including translation, layering) and intent DSLs.

- Policy Continuum.  I agree but we intentionally reduced it in order to focus this draft on intent classification from the solution and user perspective, for both technical & non-technical user, without need to understand the black box and layering. This draft is the starting point to continue working on formal definitions (intents, APIs, DSLs) & architecture. I do believe we need to start working on additional drafts that would address other aspects and the work on Policy Continuum will be the core input in these drafts. 

- Translation of policies, intent-based policy expression, operation of Policy Continuum
[Olga] This draft did not look at translation, intent DSLs / models / APIs and is focused on identifying solutions, users and intent types. I think your comments are very valuable and it is definitely something we have to focus in other drafts that would look at intent architecture and intent models / DSLs.  There is already some work started on the architecture draft.

I do believe the value of this draft and the adoption of version 02 will be continued discussion and hopefully final agreement in the group about how to classify intents, but starting from business / intent user - what is needed by different solutions & different intent users in those solutions. I do not think version 02 means that we agreed about all categories and classification, it means we are continuing discussion. 

Best Regards,
Olga

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Natale, Bob
Sent: Thursday 5 December 2019 06:58
To: Jérôme François <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [nmrg] [EXT] Re: Adoption call for draft-li-nmrg-intent-classification-02
Importance: Low

FWIW (from a lurker),
BobN

-----Original Message-----
From: nmrg <[email-masked]> On Behalf Of Schönwälder, Jürgen
Sent: Wednesday, December 4, 2019 4:25 PM
To: Jérôme François <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [EXT] Re: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02

/js

---

From: "SUN Xueyuan" <[email-masked]>
Date: Mon, 9 Dec 2019 09:35:22 +0800

As a contributor, I support this draft being adopted.

Best Regards,
Xueyuan SUN

Xueyuan Sun
China Telecom Strategy and Innovation Research Institute
Email：[email-masked]
Tel: +86-10-50902887
Mobile: +86-17316269362

孙雪媛
中国电信战略与创新研究院 战略与规划研究所
网络规划中心
Tel：010-50902887/ 17316269362
Email：[email-masked]
 
From: Jérôme François
Date: 2019-12-05 01:24
To: [email-masked]
CC: [email-masked]

 

Best regards
NMRG chairs
Laurent & Jérôme

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 9 Dec 2019 10:32:06 +0800

+1 support ：）

Sun Qiong from China Telecom

From: SUN Xueyuan
Date: 2019-12-09 09:35
To: Jérôme François; [email-masked]
CC: [email-masked]
Subject: Re: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02
As a contributor, I support this draft being adopted.

Best Regards,
Xueyuan SUN

Xueyuan Sun

孙雪媛
中国电信战略与创新研究院 战略与规划研究所
网络规划中心
 
From: Jérôme François
Date: 2019-12-05 01:24
To: [email-masked]
CC: [email-masked]

 

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Jérôme François <[email-masked]>
Date: Mon, 16 Dec 2019 11:27:10 +0100

Dear all,

Speaking as an individual.

It is clearly valuable to have some concrete examples of intents from different 
perspectives. It will help the global understanding of IBN but I have the same 
concerns as others expressed in the mailing list. It is unclear what are the 
criteria of classification and why those criteria have been selected and how much 
representative they are.
As an intent definition can come from different perspectives (technical or 
business for instance), a unique methodology for classification should be proposed 
to integrate all of them. It will be a good value for such a document. Using then 
examples to validate the classification methodology should be more documented with 
references in my opinion.

Best regards
jerome

---

From: Olga Havel <[email-masked]>
Date: Tue, 17 Dec 2019 10:12:09 +0000

Hi Jerome,

Thank you very much for your comments. I think my reply to Laurent also applies here, as your comment is similar. I do believe that we should agree the overall methodology for the group that would drive not just intent classification, but also intent and IBN system definition, intent architecture, etc. Nevertheless, in the meantime I would like to understand what change in our draft would be sufficient at this stage to approve the draft. Would adding a 'Classification Methodology' section at the beginning of the draft and moving tables to the addendum be sufficient change to address your comments?

Best Regards,
Olga  

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Jérôme François
Sent: Monday 16 December 2019 10:27
To: [email-masked]
Cc: [email-masked]
Subject: Re: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02

Dear all,

It is clearly valuable to have some concrete examples of intents from different perspectives. It will help the global understanding of IBN but I have the same concerns as others expressed in the mailing list. It is unclear what are the criteria of classification and why those criteria have been selected and how much representative they are.
As an intent definition can come from different perspectives (technical or business for instance), a unique methodology for classification should be proposed to integrate all of them. It will be a good value for such a document. Using then examples to validate the classification methodology should be more documented with references in my opinion.

Best regards
jerome

---

From: Jérôme François <[email-masked]>
Date: Fri, 20 Dec 2019 15:41:36 +0100

Dear all,

The RG chairs thank all the participants who replied and provided comments to the 
call for adoption for draft-li-nmrg-intent-classification-02.

Based on the discussion and feedback received during the IETF 106 meeting in 
Singapore and by email, a general interest for the document has been expressed.

However, based on the several technical comments and issues raised, it appears 
that the document needs to be improved to meet the defined adoption criteria.

In particular:
- Purpose / scope of the draft: the purpose, and so the end value of the draft for 
the group and IBN community, has to be refined. Its content must support further 
research in a durable manner and must go beyond a directory of use cases of IBN.
- Scientific quality and impact: the produced classification should be the result 
of a more rigorous method, to be defined in the document. Such methodology should 
define the criteria/attributes allowing to capture the different cases, validation 
of the methodology with concrete/existing IBN systems and referencing those when 
possible.

Therefore, authors are highly encouraged to take these remarks into account for 
revising their document to fulfill all criteria for adoption and possibly request 
a new call.
To do so, we expect the authors and participants to continue the discussion 
started through the mailing list to align the future revision with the group 
expectations. A dedicated slot in the next virtual meeting (planned for end of 
January) will be allocated to check the status of the draft and discussion.

Best regards
NMRG chairs
Laurent & Jérôme