Subject: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03

From: Jérôme François <[email-masked]>
Date: Wed, 4 Dec 2019 18:27:11 +0100

Dear all,

We recently received an RG adoption request for draft-clemm-nmrg-dist-intent-03 
(https://www.ietf.org/id/draft-clemm-nmrg-dist-intent-03.txt)

Please let us know if you support the work becoming a RG document or if you think 
it should not be adopted. In all cases, provide detailed comments to support your 
opinion and send them on the mailing list.

This call for adoption is open for two weeks and ends up on 19 December 2019.

The procedure for RG document adoption and important criteria are detailed here: 
https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 4 Dec 2019 12:47:51 -0800

Support as co-author

Cheers,
Jeff
On Dec 4, 2019, 9:28 AM -0800, Jérôme François <[email-masked]>, wrote:
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Wed, 4 Dec 2019 21:14:50 +0000

I support adoption.

/js

On Wed, Dec 04, 2019 at 06:27:11PM +0100, Jérôme François wrote:
> Please let us know if you support the work becoming a RG document or if you
> think it should not be adopted. In all cases, provide detailed comments to
> support your opinion and send them on the mailing list.
> 
> The procedure for RG document adoption and important criteria are detailed
> here: https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU
> 
> Best regards
> NMRG chairs
> Laurent & Jérôme
> 
> 

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Alexander Clemm <[email-masked]>
Date: Wed, 4 Dec 2019 22:42:17 +0000

+1.  Support as co-author.
I think the document is framed well enough and has been sufficiently discussed to warrant adoption.
--- Alex

From: nmrg <[email-masked]> On Behalf Of Jeff Tantsura
Sent: Wednesday, December 04, 2019 12:48 PM
To: [email-masked]; Jérôme François <[email-masked]>
Cc: [email-masked]
Subject: Re: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03

Support as co-author

Cheers,
Jeff
On Dec 4, 2019, 9:28 AM -0800, Jérôme François <[email-masked]<mailto:[email-masked]>>, wrote:

Dear all,

Best regards
NMRG chairs
Laurent & Jérôme

_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 5 Dec 2019 14:28:07 +0000

Hello,

I'm co-author of the document, and supports its adoption as RG document.

As RG participant, I think the document helps to provide clarity in the field of intent-based networking and brings in useful definitions.

As expressed at IETF 106, some updates are planned to further improve the document quality and completeness.

Best regards, Laurent.

From: Alexander Clemm <[email-masked]>
Sent: Wednesday, December 4, 2019 23:42
To: Jeff Tantsura <[email-masked]>; [email-masked]; Jérôme François <[email-masked]>
Cc: [email-masked]
Subject: RE: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03

From: nmrg <[email-masked]<mailto:[email-masked]>> On Behalf Of Jeff Tantsura
Sent: Wednesday, December 04, 2019 12:48 PM
To: [email-masked]<mailto:[email-masked]>; Jérôme François <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03

Support as co-author

Cheers,
Jeff

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Thu, 5 Dec 2019 11:35:31 -0300

As an RG observer, I find the document useful and contributes with a
comprehensive introduction of concepts on IBN, a very much needed
milestone for the community.

Therefore, +1 support on RG adoption

On Thu, Dec 5, 2019 at 11:28 AM Ciavaglia, Laurent (Nokia -

---

From: "Galis, Alex" <[email-masked]>
Date: Thu, 5 Dec 2019 14:50:24 +0000

Hi All

+ 1 support on the RG adoption.

Best Regards
Alex

> On 5 Dec 2019, at 14:35, Christian Esteve Rothenberg <[email-masked]> wrote:
>

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Fri, 6 Dec 2019 12:38:20 +0900

Dear all,

I'm adding myself to support the adoption of this RG document.

Regards,
Pedro

-- 
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory
Network System Research Institute
National Institute of Information and Communications Technology (NICT)
4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 6 Dec 2019 06:04:15 +0100

+1 (support)

-- 
---
[email-masked]

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Fri, 6 Dec 2019 05:56:49 +0000

I support the adoption of the draft for the NMRG WG. 

Thanks
Mouli

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Fri, 6 Dec 2019 10:16:20 +0000

As a contributor, I also support this draft being adopted.

Regards, 	|   致礼! 
Will LIU  	|   刘树成

> -----Original Message-----
> From: nmrg [mailto:[email-masked]] On Behalf Of Jér?me Fran?ois
> Sent: Thursday, December 5, 2019 1:27 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03
> 
> Dear all,
> 
> Please let us know if you support the work becoming a RG document or if
> you think it should not be adopted. In all cases, provide detailed comments
> to support your opinion and send them on the mailing list.
>

---

From: Olga Havel <[email-masked]>
Date: Fri, 6 Dec 2019 11:48:29 +0000

I support this draft being adopted

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Liushucheng (Will Liu)
Sent: Friday 6 December 2019 10:16
To: Jérôme François <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03

Regards, 	|   致礼! 
Will LIU  	|   刘树成

> Please let us know if you support the work becoming a RG document or 
> if you think it should not be adopted. In all cases, provide detailed 
> comments to support your opinion and send them on the mailing list.
>

---

From: Giuseppe Fioccola <[email-masked]>
Date: Fri, 6 Dec 2019 11:52:18 +0000

Hi All,
I have read the draft and I support its adoption. 
Regards,

Giuseppe

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Jérôme François
Sent: Wednesday, December 4, 2019 6:27 PM
To: [email-masked]
Cc: [email-masked]
Subject: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03

Dear all,

Please let us know if you support the work becoming a RG document or if you think it should not be adopted. In all cases, provide detailed comments to support your opinion and send them on the mailing list.

Best regards
NMRG chairs
Laurent & Jérôme

---

From: festor <[email-masked]>
Date: Fri, 6 Dec 2019 13:35:43 +0100

Same status as Christian,

I have followed the evolution of the document from the outside. While it still needs some typo/writing checks, the content is sound, solid and useful for the community. So it deserves to be moved forward. +1 on my side as well.

Best Regards

/Olivier Festor
TELECOM Nancy

On 5 Dec 2019, at 15:35, Christian Esteve Rothenberg <[email-masked]> wrote:

Hello,

Best regards, Laurent.

--- Alex

Support as co-author

Cheers,

Jeff

Dear all,

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Flavio Esposito <[email-masked]>
Date: Fri, 6 Dec 2019 13:17:52 +0000

Thanks to the authors for putting this together. +1 from me!

-Flavio Esposito

--
Assistant Professor
Computer Science Department

& School of Engineering
Saint Louis University

Office: (314)-977-2434<tel:%28314%29-977-2434>
McDonnell Douglas Hall 2015

http://www.cs.slu.edu/~esposito/

________________________________
From: nmrg <[email-masked]> on behalf of festor <[email-masked]>
Sent: Friday, December 6, 2019 6:35 AM
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>
Subject: [External] Re: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03

Best Regards

/Olivier Festor
TELECOM Nancy

Hello,

Best regards, Laurent.

--- Alex

Support as co-author

Cheers,

Jeff

Dear all,

We recently received an RG adoption request for draft-clemm-nmrg-dist-intent-03
(https://www.ietf.org/id/draft-clemm-nmrg-dist-intent-03.txt<https://urldefense.com/v3/__https://www.ietf.org/id/draft-clemm-nmrg-dist-intent-03.txt__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0Jk4M6-NmQ$>)

The procedure for RG document adoption and important criteria are detailed here:
https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU<https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmMQavnYA$>

Best regards
NMRG chairs
Laurent & Jérôme

_______________________________________________
nmrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmrg<https://urldefense.com/v3/__https://www.irtf.org/mailman/listinfo/nmrg__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmkkD-6ew$>

_______________________________________________
nmrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmrg<https://urldefense.com/v3/__https://www.irtf.org/mailman/listinfo/nmrg__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmkkD-6ew$>

_______________________________________________
nmrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmrg<https://urldefense.com/v3/__https://www.irtf.org/mailman/listinfo/nmrg__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmkkD-6ew$>

_______________________________________________
nmrg mailing list
[email-masked]
https://urldefense.com/v3/__https://www.irtf.org/mailman/listinfo/nmrg__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmkkD-6ew$

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 12 Dec 2019 15:19:20 +0000

+1 support on RG adoption

This doc is a solid basis for a thorough collection of Intent Based Networking framework properties and features. Once consolidated, it can be very useful  to position and assess other IBN frameworks.

Sabine Randriamasy

From: Flavio Esposito <[email-masked]>
Sent: Friday, December 06, 2019 2:18 PM
To: [email-masked]; [email-masked]
Subject: Re: [nmrg] [External] Re: Adoption call for draft-clemm-nmrg-dist-intent-03

-Flavio Esposito

& School of Engineering
Saint Louis University

________________________________
From: nmrg <[email-masked]<mailto:[email-masked]>> on behalf of festor <[email-masked]<mailto:[email-masked]>>
Sent: Friday, December 6, 2019 6:35 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>
Subject: [External] Re: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03

Best Regards

/Olivier Festor
TELECOM Nancy

On 5 Dec 2019, at 15:35, Christian Esteve Rothenberg <[email-masked]<mailto:[email-masked]>> wrote:

On Thu, Dec 5, 2019 at 11:28 AM Ciavaglia, Laurent (Nokia -
FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Best regards, Laurent.

From: Alexander Clemm <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, December 4, 2019 23:42
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Jérôme François <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [nmrg] Adoption call for draft-clemm-nmrg-dist-intent-03

--- Alex

Support as co-author

Cheers,

Jeff

Dear all,

We recently received an RG adoption request for draft-clemm-nmrg-dist-intent-03
(https://www.ietf.org/id/draft-clemm-nmrg-dist-intent-03.txt<https://urldefense.com/v3/__https:/www.ietf.org/id/draft-clemm-nmrg-dist-intent-03.txt__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0Jk4M6-NmQ$>)

The procedure for RG document adoption and important criteria are detailed here:
https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmMQavnYA$>

Best regards
NMRG chairs
Laurent & Jérôme

_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg<https://urldefense.com/v3/__https:/www.irtf.org/mailman/listinfo/nmrg__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmkkD-6ew$>

_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg<https://urldefense.com/v3/__https:/www.irtf.org/mailman/listinfo/nmrg__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmkkD-6ew$>

_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg<https://urldefense.com/v3/__https:/www.irtf.org/mailman/listinfo/nmrg__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmkkD-6ew$>

_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.com/v3/__https://www.irtf.org/mailman/listinfo/nmrg__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmkkD-6ew$<https://urldefense.com/v3/__https:/www.irtf.org/mailman/listinfo/nmrg__;!!K543PA!Yz4x-ija0ZaaP8J19IAfRg_U9YVV3xv3MeBeEymp_r1_ZGZgelOI0G3TLgbM0JmkkD-6ew$>

---

From: Jérôme François <[email-masked]>
Date: Mon, 16 Dec 2019 10:56:21 +0100

Dear all,

Speaking as an individual.

The document already offers a good support to understand the IBN concepts and how 
they relate to other ones.
So I support the adoption of the draft but would like to hear from authors a more 
concrete working plan for the following items:

1) Principles - abstractions: a lot of potential other principles to be 
investigated in future revisions. What will be your plan here. Are some of these 
principles already identified to be documented (some priority) or are they open 
questions for the community? Note that explainability is already in item 5. I 
recommend not to use "how to?" for principles.
2) Lifecycle: different lifecycles are proposed in the draft. I understand from 
discussions it is hard/impossible to have a unique lifecycle for IBN. However, 
will it be possible to identify one or a few of "generic lifecycles" with minimal 
functions? Or should it be possible to identify a core sets of "atomic" functions 
and a secondary sets? In my opinion, in the two lifecycles proposed, there are 
some clear similarities in their description (plan  ~ decompose ? render ~ 
communicate ?) and so some convergence might de done.

Below are other comments on specific items:
- "Ideally, it should not even be orchestrated or broken down by a higher-level, 
centralized system, but by the network devices themselves" -> so it supposes that 
ideally it should be decentralized. Why an IBN system should be decentralized. I 
think from a conceptual point of view, there is no reason for that.
- "this interpretation opens a slippery slope of how to clearly distinguish 
"intent" from other higher-layer abstractions": good to plan to investigate that 
in further revisions but would like to understand how you plan to address this, in 
particular to see if you plan to modify the intent concepts/definition to make it 
quite unique or evaluate how much they are close/far from other propositions.
- Section 4.2.2: "it is present today..." -> but reference is from 2007, maybe 
complete with a more recent one.
- Section 4.2.3 - difference with service models: in my understanding, you 
decouple here, the model itself from the orchestrator but we could think the same 
between "intent expression" and "intent realization"
- Lifecycle: refer to figure in text (hard to map each function into figure, no 
1-to-1 mapping)

Best regards
jerome