Subject: Re: [nmrg] [EXT] Re: Adoption call for draft-li-nmrg-intent-classification-02

From: "El Khatib, Yehia (elkhatib)" <[email-masked]>
Date: Thu, 5 Dec 2019 18:39:03 +0000

Hello all,

Long time listener, first time caller!  I feel compelled to chip in as someone who's worked on intents for a few years now.

The definitions in the draft are not entirely helpful in terms of clarifying the difference between intents and policies, which is the main point of confusion I observed from working and publishing** in this area. To me, an intent is for an application (that 'intends' to do something) whereas a policy is for an operator (a policy of how to run things). An intent cannot be everything for everyone, as this will not be feasible to work with. 

As such, the way an intent is defined needs to enable the application developer to indicate their:  (1) preference; (2) priorities; and (3) ways the network can help. I fail to see how these could be specified using this draft.

Just my 2 cents and glad to finally make contact with the group. __

** See papers:
http://www.lancaster.ac.uk/~elkhatib/papers/elkhatib2017idn.pdf
http://www.lancaster.ac.uk/~elkhatib/papers/elhabbash2018mediation.pdf 

/yehia

-- 
Dr. Yehia Elkhatib
PhD Admissions Officer  &  Distributed Systems Group Lead 
School of Computing & Communications
Lancaster University, LA1 4WA, UK
y.elkhatib /then add/ lancaster.ac.uk
http://www.lancaster.ac.uk/~elkhatib

On 06/12/2019, 7:15 am, "nmrg on behalf of Branislav Meandzija" <[email-masked] on behalf of [email-masked]> wrote:

    This email originated from outside of the University. Do not click links or open attachments unless you recognise the sender and know the content is safe.
    
    While I have followed some of the various discussions here over the past
    decades, I am not sure whether my 2 cents on this subject  is appropriate or
    not. However, I have done quite a bit of research, system design and
    implementation  synonymous with  "intent" intent over this period of time
    and feel compelled to comment.
    
    My perspective is that intent is application/domain specific and can only be
    abstracted from a knowledgebase specific to that application/domain. This
    abstraction should be formal and not fluff.
    
    As such, I feel this document just further muddies the waters with
    unnecessary and arbitrary new definitions and  I would not promote it
    further.
    
    Branislav
    
    -----Original Message-----
    From: nmrg [mailto:[email-masked]] On Behalf Of Natale, Bob
    Sent: Wednesday, December 4, 2019 10:58 PM
    To: Jérôme François <[email-masked]>
    Cc: [email-masked]; [email-masked]
    Subject: Re: [nmrg] [EXT] Re: Adoption call for
    draft-li-nmrg-intent-classification-02
    Importance: Low
    
    I would like to add that the extremely brief section on the Policy Continuum
    in the draft seems superfluous in light of its brevity and consequent
    over-simplification. (If John Strassner feels otherwise, then please ignore
    my comments here!)
    
    While the existing text is a reasonable facsimile of early descriptions of
    the Policy Continuum, as thought developed the concept matured: E.g., "The
    Policy Continuum - Policy authoring and conflict analysis" (2008),
    https://eur02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fbrendanjennings.net%2Fpapers%2F2008_COMCOM_SDavy_et_al_published.pdf&amp;data=02%7C01%7Cy.elkhatib%40lancaster.ac.uk%7Cf4cb25180e5e4f4bb8ce08d779af12a3%7C9c9bcd11977a4e9ca9a0bc734090164a%7C1%7C1%7C637111665168487059&amp;sdata=zjSiVlt1Ej1ZH%2FNiBBehVQG281%2FzFrwQTJ3ZDtSi5BQ%3D&amp;reserved=0,
    esp. sec. 2.1.4, but most of the rest of the paper is essential to a useful
    level of understanding.
    
    Alas, at some point the Policy Continuum concept seems to have fallen
    relatively dormant. Regardless, wrt the discussion topic at hand, I believe
    that several points must be considered:
    
    - Non-person entity "actors" as policy authors will be essential to
    translation of policy expressions in the Intent-based operating model.
    - It is (and always has been) the translation of policies across levels. The
    translation activity is what makes the model a continuum as opposed to
    (only) a set of interworking differentiated layers.
    - Applying Intent-based policy expression adds a distinct dimension to
    operation of the Policy Continuum ... this new dimension is compatible with
    existing common understanding of the Policy Continuum but introduces
    additional translations at some layers.
    
    So, I think it's necessary to cover the Policy Continuum (by whatever name
    might be preferable today, if that term is out of vogue) in an explanation
    of Intent-based policy implementation. I am not sure it belongs in a
    document defining Intent classification. And it almost certainly does not
    fit into this particular draft in its present form. I do see the connection
    you are presumably making with your Intent User and Intent Type breakouts
    and the Policy Continuum but (to coin a phrase?) it's "too little too early"
    to add any real value.
    
    FWIW (from a lurker),
    BobN
    
    -----Original Message-----
    From: nmrg <[email-masked]> On Behalf Of Schönwälder, Jürgen
    Sent: Wednesday, December 4, 2019 4:25 PM
    To: Jérôme François <[email-masked]>
    Cc: [email-masked]; [email-masked]
    Subject: [EXT] Re: [nmrg] Adoption call for
    draft-li-nmrg-intent-classification-02
    
    I am still not sure what the value of this document is. What is the insight
    that these big tables deliver? How do they help doing ultimately better work
    in the IETF?
    
    I am sure I will get some answer quickly from the authors but what I am
    saying is that I prefer to see the value of this document very clearly
    explained in the document before adopting it. Note that I also expect that
    this document would align with the other document defining intent concepts
    and terminology. Perhaps this is more intended like a survey paper but then
    it has gone a bit in the wrong direction since a decent survey would explain
    how intent is defined and used in concrete projects (hint: lots of concrete
    descriptions and references) and then you would classify things. But right
    now, we have big tables with empty cells or cells with text that seems to
    come from rather unknown sources.
    
    For the above reasons, I do not support adoption at this point in time.
    
    /js
    
    On Wed, Dec 04, 2019 at 06:24:44PM +0100, Jérôme François wrote:
    > Dear all,
    >
    > We recently received an RG adoption request for
    > draft-li-nmrg-intent-classification-02
    > (https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-li-nmrg-intent-classification-02.txt&amp;data=02%7C01%7Cy.elkhatib%40lancaster.ac.uk%7Cf4cb25180e5e4f4bb8ce08d779af12a3%7C9c9bcd11977a4e9ca9a0bc734090164a%7C1%7C1%7C637111665168487059&amp;sdata=M%2FTst5mAOIjFeR1iFSukkcRTaOchtVh9ewwBRVbky4M%3D&amp;reserved=0)
    >
    > Please let us know if you support the work becoming a RG document or
    > if you think it should not be adopted. In all cases, provide detailed
    > comments to support your opinion and send them on the mailing list.
    >
    > This call for adoption is open for two weeks and ends up on 19 December
    2019.
    >
    > The procedure for RG document adoption and important criteria are
    > detailed
    > here:
    > https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fnmrg%2FCVEyLUvfxJk1Ud5WdM9Y5LGvQmU&amp;data=02%7C01%7Cy.elkhatib%40lancaster.ac.uk%7Cf4cb25180e5e4f4bb8ce08d779af12a3%7C9c9bcd11977a4e9ca9a0bc734090164a%7C1%7C1%7C637111665168497055&amp;sdata=7rhDdw7Y5XcdL1Af1MxnlfrF3wjQknNKZpSWIU%2FYcIU%3D&amp;reserved=0
    >
    > Best regards
    > NMRG chairs
    > Laurent & Jérôme
    >
    > _______________________________________________
    > nmrg mailing list
    > [email-masked]
    > https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=02%7C01%7Cy.elkhatib%40lancaster.ac.uk%7Cf4cb25180e5e4f4bb8ce08d779af12a3%7C9c9bcd11977a4e9ca9a0bc734090164a%7C1%7C1%7C637111665168497055&amp;sdata=lUFZxPcdaugC8U%2BAWiLnm9DQxVJlQGdhM6CNmwMF84E%3D&amp;reserved=0
    
    --
    Juergen Schoenwaelder           Jacobs University Bremen gGmbH
    Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
    Fax:   +49 421 200 3103         <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.jacobs-university.de%2F&amp;data=02%7C01%7Cy.elkhatib%40lancaster.ac.uk%7Cf4cb25180e5e4f4bb8ce08d779af12a3%7C9c9bcd11977a4e9ca9a0bc734090164a%7C1%7C1%7C637111665168497055&amp;sdata=tMNXSBE2hRvkwWK676Zb%2FzUROEGDRRMrjEBUQJF48Vc%3D&amp;reserved=0>
    
    _______________________________________________
    nmrg mailing list
    [email-masked]
    https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=02%7C01%7Cy.elkhatib%40lancaster.ac.uk%7Cf4cb25180e5e4f4bb8ce08d779af12a3%7C9c9bcd11977a4e9ca9a0bc734090164a%7C1%7C1%7C637111665168497055&amp;sdata=lUFZxPcdaugC8U%2BAWiLnm9DQxVJlQGdhM6CNmwMF84E%3D&amp;reserved=0
    
    _______________________________________________
    nmrg mailing list
    [email-masked]
    https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=02%7C01%7Cy.elkhatib%40lancaster.ac.uk%7Cf4cb25180e5e4f4bb8ce08d779af12a3%7C9c9bcd11977a4e9ca9a0bc734090164a%7C1%7C1%7C637111665168497055&amp;sdata=lUFZxPcdaugC8U%2BAWiLnm9DQxVJlQGdhM6CNmwMF84E%3D&amp;reserved=0

    _______________________________________________
    nmrg mailing list
    [email-masked]
    https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=02%7C01%7Cy.elkhatib%40lancaster.ac.uk%7Cf4cb25180e5e4f4bb8ce08d779af12a3%7C9c9bcd11977a4e9ca9a0bc734090164a%7C1%7C1%7C637111665168497055&amp;sdata=lUFZxPcdaugC8U%2BAWiLnm9DQxVJlQGdhM6CNmwMF84E%3D&amp;reserved=0

---

From: Olga Havel <[email-masked]>
Date: Fri, 6 Dec 2019 11:47:43 +0000

Hi Yehia,

Thanks you very much for your comments and it is great that you made contact with the group. Thanks you very much for sharing your papers, .

The draft deals with different types of intents based on different solutions and different users of the network (intent users), and its scope is intents for both current and future networks. And application developer is one of the users we identified. There are some that would agree with you that intents are only for applications, and policies for operators and administrators. But there are others who are talking about
- intents of administrators and operators in regards to operating network and network services
- intents of end-users in regards to self-service

Therefore, we tried to capture all these, fully aware that it is a superset and that different stakeholders may only find subsets relevant in their research, applications and solutions. Also, some of the operator and administrator intents may disappear with autonomous networking. But currently, these are still requirements we get from the industry and we added intent types and categories for any human interaction, as any interaction should be driven by intent of the human user (app developers for applications, operators, administrators, subscribers, end-users).

I absolutely agree with you that there is confusion between policies and intents. But we wanted this draft to propose some categories of intents that could be understood by the wider audience and driven by intent user requirements, and not only targeted to those that are familiar with policy continuum, imperative/goal/declarative policies. Also, draft draft-clemm-nmrg-dist-intent-03 addresses the difference between policies, services and intents. draft-clemm-nmrg-dist-intent-03  can also be used for intent definition and our draft can be used for classification only. We do, nevertheless propose to include policies into strategy intents. In the future versions, strategy intents can only include policies as models, workflows & scripts may disappear in autonomous networks. But currently we do sometimes have models, workflows, scripts as parts of these strategy intents, that either operators/administrators or DevOps need to create during the design-time. Examples : NS and VNF descriptors, service/resource templates/definitions, models, DevOps scripts, policies.

In regards to preferences, priorities and ways the network can help, I agree intent should be able to formulate all or some of them. Do you think this belongs to the classification draft or should we leave it when we start defining interfaces, DSLs and models and how we formulate network intents?

Best Regards,
Olga

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of El Khatib, Yehia (elkhatib)
Sent: Thursday 5 December 2019 18:39
To: [email-masked]
Cc: [email-masked]
Subject: Re: [nmrg] [EXT] Re: Adoption call for draft-li-nmrg-intent-classification-02

Hello all,

** See papers:

/yehia

--
Dr. Yehia Elkhatib
PhD Admissions Officer  &  Distributed Systems Group Lead School of Computing & Communications Lancaster University, LA1 4WA, UK y.elkhatib /then add/ lancaster.ac.uk http://www.lancaster.ac.uk/~elkhatib

    

    
    Branislav
    
    -----Original Message-----
    From: nmrg [mailto:[email-masked]] On Behalf Of Natale, Bob
    Sent: Wednesday, December 4, 2019 10:58 PM
    To: Jérôme François <[email-masked]>
    Cc: [email-masked]; [email-masked]
    Subject: Re: [nmrg] [EXT] Re: Adoption call for
    draft-li-nmrg-intent-classification-02
    Importance: Low

    

    
    FWIW (from a lurker),
    BobN
    
    -----Original Message-----
    From: nmrg <[email-masked]> On Behalf Of Schönwälder, Jürgen
    Sent: Wednesday, December 4, 2019 4:25 PM
    To: Jérôme François <[email-masked]>
    Cc: [email-masked]; [email-masked]
    Subject: [EXT] Re: [nmrg] Adoption call for
    draft-li-nmrg-intent-classification-02

    
    
    /js
    
    2019.

    

_______________________________________________
nmrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmrg