Subject: Re: [nmrg] Comments welcome on revised NMRG charter

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 4 Dec 2019 16:49:33 +0000

Dear NMRG,

This is a gentle reminder to share your comments on the proposed revised charter.

We plan on finalizing the process in the coming weeks, so don't wait to voice out your opinion.

Thank you, best regards,
Jérôme & Laurent.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>
Sent: Wednesday, November 20, 2019 10:17
To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]
Cc: [email-masked]; irtf-chair ([email-masked]) <[email-masked]>
Subject: RE: Comments welcome on revised NMRG charter

Hello,

In addition to the previous email, a few additional links for your convenience:

  *   Version -01 of NMRG charter: https://docs.google.com/document/d/1e84-M4DEDi-LCXjLG0Wf0JhbPXVcIPm2hnFFIQPrkro/edit?usp=sharing
  *   Comparison between version -01 and -02: https://docs.google.com/document/d/19xidbplhn5gPr41QdeXBTh2WLhoA9kbhNieZiSh0Uyk/edit?usp=sharing

Also, to clarify:

  *   The intent of the charter revision is not a complete overhaul but more to capture more recent activities the RG has engaged into and reflect that in an update of the original charter together with a work plan.
You can see in the comparison, that the first part (original charter) has not been changed.

Thank you.
Best regards, Laurent.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, November 20, 2019 06:46
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Comments welcome on revised NMRG charter

Hi NMRG,

Jérôme and I have been working on a new version of the NMRG charter to capture better the current shape and activity of the RG.

We'd like to receive comments from the community. This is on the agenda of the session on Friday.

https://docs.google.com/document/d/14eHQALG95VHE5N-YIAwH6vriKFG2WvI8d63TtugZLgU/edit?usp=sharing

Thank you.
Best regards, Jérôme & Laurent.

---

From: Alexander Clemm <[email-masked]>
Date: Wed, 4 Dec 2019 22:39:32 +0000

Hello all,

I think the charter proposal looks fine overall.

One nit re: "The initial focus of the NMRG will be on higher-layer management services that interface with the current Internet management framework."  NMRG has a long tradition, so perhaps it is better to not call it "The initial focus", but to state "The current focus", or perhaps (not ideal) "the initial focus of the current NMRG cycle".

Likewise the statement "The NMRG will investigate in priority three related topics".  This suggests that the listed topics are in priority order, which I don't think is correct - they are simply all topics of priority.  Perhaps rephrase to "The NMRG will prioritize investigation of three related topics", or similar?

There is one typo: "One one hand" (should be "On one hand").

Some more minor comments FWIW (feel free to ignore):

- Third bullet item under IBN "categorize the different forms of intents and define what constitutes a "well-formed" intent; describe how an intent can be expressed and what can be expressed using an intent with means such as information models, grammars, and languages."  I think that arguably the categorization could be covered under terminology; perhaps this bullet should simply focus on the second aspect (how to express intent), which is a more open-ended problem to which several solutions may be put forward.

Since no milestones are listed, is the Milestones section still needed?  (I assume they will be defined as working group documents get adopted.)

Cheers
--- Alex

From: nmrg <[email-masked]> On Behalf Of Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Wednesday, November 20, 2019 1:17 AM
To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]
Cc: [email-masked]; irtf-chair ([email-masked]) <[email-masked]>
Subject: Re: [nmrg] Comments welcome on revised NMRG charter

Hello,

  *   Version -01 of NMRG charter: https://docs.google.com/document/d/1e84-M4DEDi-LCXjLG0Wf0JhbPXVcIPm2hnFFIQPrkro/edit?usp=sharing<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F1e84-M4DEDi-LCXjLG0Wf0JhbPXVcIPm2hnFFIQPrkro%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547674184&sdata=e85hgUuBg71bWNaQUL5iNwVPWrSQYuMx%2B%2BW26KP8TVM%3D&reserved=0>
  *   Comparison between version -01 and -02: https://docs.google.com/document/d/19xidbplhn5gPr41QdeXBTh2WLhoA9kbhNieZiSh0Uyk/edit?usp=sharing<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F19xidbplhn5gPr41QdeXBTh2WLhoA9kbhNieZiSh0Uyk%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547684192&sdata=U%2BZkwEydIcU26n7GNnMQfwcCMnbr40058ChrQEXPQXs%3D&reserved=0>

Also, to clarify:

Thank you.
Best regards, Laurent.

Hi NMRG,

https://docs.google.com/document/d/14eHQALG95VHE5N-YIAwH6vriKFG2WvI8d63TtugZLgU/edit?usp=sharing<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F14eHQALG95VHE5N-YIAwH6vriKFG2WvI8d63TtugZLgU%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547694199&sdata=LfR1fw5Q4IshxAbHRn%2F5M5AZXge6kzsL%2BFlLpbI7%2F%2B8%3D&reserved=0>

Thank you.

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 4 Dec 2019 22:53:25 +0000

Thank you Alex for the feedback on the charter. We will incorporate your comments.

As for the milestones:
You are right, milestones have not been defined yet. This is not an omission, rather an open/pending point.
To my knowledge it is neither a common nor established practice to define milestones for RG (HRPC has one). But the possibility exists.
With milestones, we (NMRG chairs) wanted to express a general planning of the research activities, in particular for the IBN work plan.
Tis was also part of an initial discussion with Colin (IRTF Chair). Given the items listed in the work plan and the pace at which the RG is progressing, we currently think it is "challenging" to define milestones in a meaningful way, and not a posteriori.
This is a point we will discuss with Colin on the updates of the revised charter.

Best regards, Laurent.

From: Alexander Clemm <[email-masked]>
Sent: Wednesday, December 4, 2019 23:40
To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]
Cc: [email-masked]; irtf-chair ([email-masked]) <[email-masked]>
Subject: RE: Comments welcome on revised NMRG charter

Hello all,

Cheers
--- Alex

From: nmrg <[email-masked]<mailto:[email-masked]>> On Behalf Of Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Wednesday, November 20, 2019 1:17 AM
To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; irtf-chair ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nmrg] Comments welcome on revised NMRG charter

Hello,

Also, to clarify:

Thank you.
Best regards, Laurent.

Hi NMRG,

Thank you.

---

From: Vishnu Ram OV <[email-masked]>
Date: Thu, 5 Dec 2019 12:53:31 +0530

Hello All,

Thanks for asking feedback. I support the charter.
I can also say (from my personal experience) that some of the work items
are quite interesting to ITU FG ML5G that I work with.

Comments -
if the group sees sufficient interest, we can add the AI challenge, that we
discussed separately, as one of the possible work items under network
artificial intelligence topics?

Thanks,
Vishnu
whatsapp: +91 9844178052
Skype: vishnubright_1
WeChat: Vishnu-Ram-OV
FB Messenger: Vishnu.Ram.OV
https://www.researchgate.net/profile/Vishnu_Ov/projects
<https://join.skype.com/invite/MFYtZ9DwJKd8>

On Thu, Dec 5, 2019 at 4:23 AM Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
<[email-masked]> wrote:

> To my knowledge it is neither a common nor established practice to define
> milestones for RG (HRPC has one). But the possibility exists.
>
> With milestones, we (NMRG chairs) wanted to express a general planning of
> the research activities, in particular for the IBN work plan.
>
> Tis was also part of an initial discussion with Colin (IRTF Chair). Given
> the items listed in the work plan and the pace at which the RG is
> progressing, we currently think it is "challenging" to define milestones in
> a meaningful way, and not a posteriori.
>
> *From:* Alexander Clemm <[email-masked]>
> *Sent:* Wednesday, December 4, 2019 23:40
> *To:* Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <
> [email-masked]>; [email-masked]
> *Cc:* [email-masked]; irtf-chair ([email-masked]) <
> [email-masked]>
> *Subject:* RE: Comments welcome on revised NMRG charter
>
>
>
> Hello all,
>
>
>
> One nit re: “The initial focus of the NMRG will be on higher-layer
> management services that interface with the current Internet management
> framework.”  NMRG has a long tradition, so perhaps it is better to not
> call it “The initial focus”, but to state “The current focus”, or perhaps
> (not ideal) “the initial focus of the current NMRG cycle”.
>
>
>
> Likewise the statement “The NMRG will investigate in priority three
> related topics”.  This suggests that the listed topics are in priority
> order, which I don’t think is correct – they are simply all topics of
> priority.  Perhaps rephrase to “The NMRG will prioritize investigation of
> three related topics”, or similar?
>
>
>
> There is one typo: “One one hand” (should be “On one hand”).
>
>
>
> - Third bullet item under IBN “categorize the different forms of intents
> and define what constitutes a “well-formed” intent; describe how an intent
> can be expressed and what can be expressed using an intent with means such
> as information models, grammars, and languages.”  I think that arguably
> the categorization could be covered under terminology; perhaps this bullet
> should simply focus on the second aspect (how to express intent), which is
> a more open-ended problem to which several solutions may be put forward.
>
>
>
> Since no milestones are listed, is the Milestones section still needed?
> (I assume they will be defined as working group documents get adopted.)
>
>
>
> Cheers
>
> --- Alex
>
>
>
> *From:* nmrg <[email-masked]> *On Behalf Of *Ciavaglia, Laurent
> (Nokia - FR/Paris-Saclay)
> *Sent:* Wednesday, November 20, 2019 1:17 AM
> *To:* Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <
> [email-masked]>; [email-masked]
> *Cc:* [email-masked]; irtf-chair ([email-masked]) <
> [email-masked]>
> *Subject:* Re: [nmrg] Comments welcome on revised NMRG charter
>
>
>
> Hello,
>
>
>
>    - Version -01 of NMRG charter:
>    https://docs.google.com/document/d/1e84-M4DEDi-LCXjLG0Wf0JhbPXVcIPm2hnFFIQPrkro/edit?usp=sharing
>    <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F1e84-M4DEDi-LCXjLG0Wf0JhbPXVcIPm2hnFFIQPrkro%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547674184&sdata=e85hgUuBg71bWNaQUL5iNwVPWrSQYuMx%2B%2BW26KP8TVM%3D&reserved=0>
>    - Comparison between version -01 and -02:
>    https://docs.google.com/document/d/19xidbplhn5gPr41QdeXBTh2WLhoA9kbhNieZiSh0Uyk/edit?usp=sharing
>    <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F19xidbplhn5gPr41QdeXBTh2WLhoA9kbhNieZiSh0Uyk%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547684192&sdata=U%2BZkwEydIcU26n7GNnMQfwcCMnbr40058ChrQEXPQXs%3D&reserved=0>
>
>
>
> Also, to clarify:
>
>    - The intent of the charter revision is not a complete overhaul but
>    more to capture more recent activities the RG has engaged into and reflect
>    that in an update of the original charter together with a work plan.
>
> *From:* Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <
> [email-masked]>
> *Sent:* Wednesday, November 20, 2019 06:46
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Comments welcome on revised NMRG charter
>
>
>
> Hi NMRG,
>
>
>
> Jérôme and I have been working on a new version of the NMRG charter to
> capture better the current shape and activity of the RG.
>
>
>
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F14eHQALG95VHE5N-YIAwH6vriKFG2WvI8d63TtugZLgU%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547694199&sdata=LfR1fw5Q4IshxAbHRn%2F5M5AZXge6kzsL%2BFlLpbI7%2F%2B8%3D&reserved=0>
>
>
>
> Thank you.
>
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg
>

---

From: Yong-Geun Hong <[email-masked]>
Date: Thu, 5 Dec 2019 18:05:26 +0900

Dears.

Thanks for your efforts to update the NMRG charter.
I think the proposed charter looks good and I support it.

I would like to emphasize the network artificial intelligence topic and it
is very welcome to find the topic is included in the revised charter.
I have been involved in the discussion of network artificial intelligence
from NMLRG(Network Machine Learning Research Group) and
IDNET(Intelligent Defined Network) from 2015. From that, we have spend lots
of time and effort to progress the topic but it is not easy to make a
progress.
Currently, I believe that the NMRG is an outstanding place to develop the
network artificial intelligence topic and we can identify many interest of
the topics
from participants in IETF meetings.

To efficiently develop the network artificial intelligence topic in the
NMRG, it is better to have more specific and practical goals such as
priority of candidate items
and scheduling of each item.

Best regards.

Yong-Geun.

On Thu, Dec 5, 2019 at 4:24 PM Vishnu Ram OV <[email-masked]> wrote:

> if the group sees sufficient interest, we can add the AI challenge, that
> we discussed separately, as one of the possible work items under network
> On Thu, Dec 5, 2019 at 4:23 AM Ciavaglia, Laurent (Nokia -
> FR/Paris-Saclay) <[email-masked]> wrote:
>

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 12 Dec 2019 18:29:11 +0000

Hello all,

Thank you for this charter update. I focused on the IBN aspects and the proposal is clear and covers well the challenges and aimed results. One question: does the RG want to position the work wrt IETF work? that is, how NMRG work on IBN and IETF may related to each other? or is it too soon?

Please find below a couple of suggestions and nits. Some of the nits have already been mentioned in other feedbacks.

Thanks,
Sabine
---------------------------------------------------
SUGGESTIONS
---------------------------------------------------

- Section - Research Activities (2017-2022)
-- para 2
Sentence "In this area, ... for the users": MAYBE drop "for the users". Sentence will be lighter.

After this sentence: MAYBE add "Abstracted user requests, known as Intents, protect infrastructure information confidentiality while hiding its complexity."

- Section - Work plan

(WI stands for "work item")

* the expression "Intent" is omnipresent in presentations and so is the question "what is an intent?". Since it is a key IBN feature, before WI3 on categorizing Intents, the text of WI2 may append: "in particular, characterize an Intent and its differences with a usual (service) request".

* draft on IBN Concepts and Overview has a section 5 on "Principles" and other text that call for given properties that characterize an IBN framework. So maybe the work "properties" could be added in WI 4, near "requirements".

---------------------------------------------------
NITS
---------------------------------------------------

- section - Research Activities (2017-2022)
-- para 2
OLD: where the human users remain “in the loop” and is progressively assisted
NEW: where the human users remain “in the loop” and **are** progressively assisted

OLD: One one hand
NEW: **On** one hand

OLD: alleviates the need user to
NEW: alleviates the need **for the** user to

OLD require
NEW require*s*

OLD as little as possible human involvement
NEW MAYBE: as little human involvement as possible

OLD re-examine deeply
NEW deeply re-examine

From: Yong-Geun Hong <[email-masked]>
Sent: Thursday, December 05, 2019 10:05 AM
To: Vishnu Ram OV <[email-masked]>
Cc: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]; [email-masked]; irtf-chair ([email-masked]) <[email-masked]>
Subject: Re: [nmrg] Comments welcome on revised NMRG charter

 Dears.

I would like to emphasize the network artificial intelligence topic and it is very welcome to find the topic is included in the revised charter.
I have been involved in the discussion of network artificial intelligence from NMLRG(Network Machine Learning Research Group) and
IDNET(Intelligent Defined Network) from 2015. From that, we have spend lots of time and effort to progress the topic but it is not easy to make a progress.
Currently, I believe that the NMRG is an outstanding place to develop the network artificial intelligence topic and we can identify many interest of the topics
from participants in IETF meetings.

To efficiently develop the network artificial intelligence topic in the NMRG, it is better to have more specific and practical goals such as priority of candidate items
and scheduling of each item.

Best regards.

Yong-Geun.

On Thu, Dec 5, 2019 at 4:24 PM Vishnu Ram OV <[email-masked]<mailto:[email-masked]>> wrote:
Hello All,

Thanks for asking feedback. I support the charter.
I can also say (from my personal experience) that some of the work items are quite interesting to ITU FG ML5G that I work with.

Comments -
if the group sees sufficient interest, we can add the AI challenge, that we discussed separately, as one of the possible work items under network artificial intelligence topics?

Thanks,
Vishnu
whatsapp: +91 9844178052
Skype: vishnubright_1
WeChat: Vishnu-Ram-OV

On Thu, Dec 5, 2019 at 4:23 AM Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>> wrote:
Thank you Alex for the feedback on the charter. We will incorporate your comments.

As for the milestones:

Best regards, Laurent.

From: Alexander Clemm <[email-masked]<mailto:[email-masked]>>

Hello all,

One nit re: “The initial focus of the NMRG will be on higher-layer management services that interface with the current Internet management framework.”  NMRG has a long tradition, so perhaps it is better to not call it “The initial focus”, but to state “The current focus”, or perhaps (not ideal) “the initial focus of the current NMRG cycle”.

Likewise the statement “The NMRG will investigate in priority three related topics”.  This suggests that the listed topics are in priority order, which I don’t think is correct – they are simply all topics of priority.  Perhaps rephrase to “The NMRG will prioritize investigation of three related topics”, or similar?

- Third bullet item under IBN “categorize the different forms of intents and define what constitutes a “well-formed” intent; describe how an intent can be expressed and what can be expressed using an intent with means such as information models, grammars, and languages.”  I think that arguably the categorization could be covered under terminology; perhaps this bullet should simply focus on the second aspect (how to express intent), which is a more open-ended problem to which several solutions may be put forward.

Cheers
--- Alex

Hello,

Also, to clarify:

Thank you.
Best regards, Laurent.

Hi NMRG,

Thank you.
Best regards, Jérôme & Laurent.
_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg
_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg