Subject: [nmrg] Fw: Fw: Adoption call for draft-li-nmrg-intent-classification-02

From: "Chongfeng Xie" <[email-masked]>
Date: Tue, 10 Dec 2019 20:52:26 +0800

Hi, all,
I support the adoption of this work as a RG document.  Although Internet driven network has been an hot topic, but the concept of Intent itselft is a little abstract,different people have different understanding and expectation.  This document provides several dimensions to classify intents，which will make intent more specific and easy to implement in different scenarios. 
Thanks
Chongfeng 

From: Jérôme François
Date: 2019-12-05 01:24
To: [email-masked]
CC: [email-masked]
Subject: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02
Dear all,
 
We recently received an RG adoption request for 
draft-li-nmrg-intent-classification-02 
(https://www.ietf.org/id/draft-li-nmrg-intent-classification-02.txt)
 
Please let us know if you support the work becoming a RG document or if you think 
it should not be adopted. In all cases, provide detailed comments to support your 
opinion and send them on the mailing list.
 
This call for adoption is open for two weeks and ends up on 19 December 2019.
 
The procedure for RG document adoption and important criteria are detailed here: 
https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU
 
Best regards
NMRG chairs
Laurent & Jérôme
 
_______________________________________________
nmrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmrg

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 10 Dec 2019 14:40:04 +0000

Hello,

Speaking as an individual.

I think the work initiated with the document is useful.

As part of the criteria for adopting an individual document as a RG document, I'm looking for the scientific rigor and potential value/impact.
What I see missing in the current document is a more rigorous approach (methodology, criteria definition) to the classification work. Currently I see it more as a bottom-up exercise listing different intent user/application examples and trying to produce a classification out of it. I think this is a first step but not sufficient (cf. methodology).
An issue with the current content, as I understand it, is that it will be challenging to keep a consistent classification over time, or how sure (methodology again) are we that the current classification is robust enough and representative of the problem/solution space.

The work would gain a lot by considering (and documenting) a methodological approach and populating the classification based on it, instead of (only) from examples.

Concerning the addition of the tables: I suggested the creation of such table(s) in a specific context: mapping of the demos presented at the NMRG56 meeting in Roma, and with a specific purpose: exercise the classification (can the different demos aspects (actors, intents) map easily to the classification (or not, and derive conclusion from the exercise); a second purpose was to use the classification as a common tool to present the information of the demos, with the goal to have this published in the IBN resource hub, maintaining description of the various IBN demos and tools. If table(s) are to be kept in the draft, maybe worth to consider only selected examples and put them as annex.

Best regards, Laurent.

From: Chongfeng Xie <[email-masked]>
Sent: Tuesday, December 10, 2019 13:52
To: nmrg <[email-masked]>
Cc: nmrg-chairs <[email-masked]>
Subject: Fw: Fw: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02

Hi, all,

From: Jérôme François<mailto:[email-masked]>
Date: 2019-12-05 01:24
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Subject: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02
Dear all,

Best regards
NMRG chairs
Laurent & Jérôme

_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg

---

From: Olga Havel <[email-masked]>
Date: Tue, 10 Dec 2019 19:24:41 +0000

Hi Laurent,

Thanks for your comments. Would something like this be better format to communicate our proposed taxonomy?

But we can also use UML or knowledge graphs as well, the problem is IETF format.

In regards to methodology, I do believe we approached it top down (business driven, solutions, users, some requirements) in proposing the taxonomy. I do agree that having agreed methodology would be very useful. But I think it is not for taxonomy only. We should have overall business driven methodology that will drive intent & IBN system definition, taxonomy, ontologies & architecture. In fact, I do believe that work item 1 may be more suitable placeholder for methodology. And describe how other work items and drafts fit into this methodology. This would drive work item 2 (intent definition and IBN system definition is in), work item 3 (taxonomy and ontologies), work item 4 (architecture), etc.

And I would suggest that we ensure that all other drafts are aligned and iteratively updated. For intent classification draft, we can add this alignment as the highest priority for future work on 03 version.

Best Regards,
Olga

From: nmrg [mailto:[email-masked]] On Behalf Of Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Tuesday 10 December 2019 14:40
To: nmrg <[email-masked]>
Cc: nmrg-chairs <[email-masked]>
Subject: Re: [nmrg] Fw: Adoption call for draft-li-nmrg-intent-classification-02

Hello,

Best regards, Laurent.

From: Chongfeng Xie <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, December 10, 2019 13:52
To: nmrg <[email-masked]<mailto:[email-masked]>>
Cc: nmrg-chairs <[email-masked]<mailto:[email-masked]>>
Subject: Fw: Fw: [nmrg] Adoption call for draft-li-nmrg-intent-classification-02

Hi, all,

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Tue, 10 Dec 2019 19:38:41 +0000

> But we can also use UML or knowledge graphs as well, the problem is IETF format.

Turn it by 90 degrees and you can easily write this down in ASCII.  Or
make the 2nd layer boxes simply section titles. The format is seldom
the problem.

My problems are terms like "Solution" or "Carrier Solutions" or
"Enterprise" - these are extremly bendable terms. Why do we need
SD-WAN but not SD-LAN? It seems all arbitrary. Things would be
different for me if you can point to concrete intent technology for
each and every item in there. Then we get into the direction of a
survey plus classification and things start to get useful. If we only
brainstrom classifiction terms together, I see little value in this
exercise. If you pull together information from concrete intent
implementation and you identify and extract common features or design
pattern, then this adds value. But yes, this is more work than
brainstorming some terms together.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Olga Havel <[email-masked]>
Date: Wed, 11 Dec 2019 10:15:43 +0000

Hi Jurgen,

Thank you very much for your comments. In regards to solutions, they are the starting points to identify users and different intent types we need to analyse and support. These are the existing solutions from the industry, our proposal is based on information from China Telecom, Huawei and others. The goal was to start from business, from existing solutions provided in the industry where we believe intent driven approach is required (independent of any current implementations, if they are intent driven or not). If some solutions, intent users or intent types are missed, please let us know and we should add them. Or if you think any of those mentioned do not require intent driven approach, please let us know. Your comments would be really welcome.

In regards to starting from intent technologies, it seems you are proposing bottom up methodology, starting from what is available today. That is alternative approach, but in that case we are classifying the baseline and not the target. Our preferred approach was to start classification from the target and not baseline and then position baseline (PoCs/Demos/Products/Applications). 

Best Regards,
Olga

-----Original Message-----
From: Schönwälder, Jürgen [mailto:[email-masked]] 
Sent: Tuesday 10 December 2019 19:39
To: Olga Havel <[email-masked]>
Cc: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; nmrg <[email-masked]>; nmrg-chairs <[email-masked]>
Subject: Re: [nmrg] Fw: Adoption call for draft-li-nmrg-intent-classification-02

> But we can also use UML or knowledge graphs as well, the problem is IETF format.

Turn it by 90 degrees and you can easily write this down in ASCII.  Or make the 2nd layer boxes simply section titles. The format is seldom the problem.

My problems are terms like "Solution" or "Carrier Solutions" or "Enterprise" - these are extremly bendable terms. Why do we need SD-WAN but not SD-LAN? It seems all arbitrary. Things would be different for me if you can point to concrete intent technology for each and every item in there. Then we get into the direction of a survey plus classification and things start to get useful. If we only brainstrom classifiction terms together, I see little value in this exercise. If you pull together information from concrete intent implementation and you identify and extract common features or design pattern, then this adds value. But yes, this is more work than brainstorming some terms together.

/js

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Wed, 11 Dec 2019 14:00:31 +0000

In research, I am used to references to sources.

/js