Subject: Re: [nmrg] Comments welcome on revised NMRG charter

From: Olga Havel <[email-masked]>
Date: Fri, 17 Jan 2020 14:46:57 +0000

Hi Laurent,

I am sorry I will not be able to join the NMRG meetings. I am in China at the moment - it will be middle of the night here. I have some meetings on Tuesday morning to attend, so I will need to have some sleep :). Sorry for that, I will try to align with you in regards to the classification draft comments outside of the meeting as you kindly suggested.

I know I sent my initial charter questions/comments to the chairs only, but probably should have sent them to the nmrg mailing list in the first place. Therefore, I am sending them now.

I do agree with Alex that intent classification/taxonomy should be split from how to express intents. One is the user perspective of what types / categories of intents we have and could hopefully be referred to/used by different SDOs who may want to propose different DSLs/models/grammars/APIs. How intents are formed, expressed and informations models/grammars/languages may be better suited as part of our future architecture. I think  information models/APIs are part of information/data architecture and not classification/taxonomy? Architecture of the intent engine should not just contain components/internal decomposition, it should certainly include external view and APIs and definitely include information architecture.

I suggest that the goal for the third work item is: 'Provide the way to classify intents into different types and categories based on requirements of different intent users'. I suggest we can also add "and add examples for each type/category" and we can do that for the next version while we address all other comments for our draft. I also suggest that we move the rest (how intents are formed/grammar/information models/APIs/DSLs) to the architecture work item.

Best Regards,
Olga

From: nmrg [mailto:[email-masked]] On Behalf Of Alexander Clemm
Sent: Wednesday 4 December 2019 22:40
To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]
Cc: [email-masked]; irtf-chair ([email-masked]) <[email-masked]>
Subject: Re: [nmrg] Comments welcome on revised NMRG charter

Hello all,

I think the charter proposal looks fine overall.

One nit re: "The initial focus of the NMRG will be on higher-layer management services that interface with the current Internet management framework."  NMRG has a long tradition, so perhaps it is better to not call it "The initial focus", but to state "The current focus", or perhaps (not ideal) "the initial focus of the current NMRG cycle".

Likewise the statement "The NMRG will investigate in priority three related topics".  This suggests that the listed topics are in priority order, which I don't think is correct - they are simply all topics of priority.  Perhaps rephrase to "The NMRG will prioritize investigation of three related topics", or similar?

There is one typo: "One one hand" (should be "On one hand").

Some more minor comments FWIW (feel free to ignore):

- Third bullet item under IBN "categorize the different forms of intents and define what constitutes a "well-formed" intent; describe how an intent can be expressed and what can be expressed using an intent with means such as information models, grammars, and languages."  I think that arguably the categorization could be covered under terminology; perhaps this bullet should simply focus on the second aspect (how to express intent), which is a more open-ended problem to which several solutions may be put forward.

Since no milestones are listed, is the Milestones section still needed?  (I assume they will be defined as working group documents get adopted.)

Cheers
--- Alex

From: nmrg <[email-masked]<mailto:[email-masked]>> On Behalf Of Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Wednesday, November 20, 2019 1:17 AM
To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; irtf-chair ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nmrg] Comments welcome on revised NMRG charter

Hello,

In addition to the previous email, a few additional links for your convenience:

  *   Version -01 of NMRG charter: https://docs.google.com/document/d/1e84-M4DEDi-LCXjLG0Wf0JhbPXVcIPm2hnFFIQPrkro/edit?usp=sharing<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F1e84-M4DEDi-LCXjLG0Wf0JhbPXVcIPm2hnFFIQPrkro%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547674184&sdata=e85hgUuBg71bWNaQUL5iNwVPWrSQYuMx%2B%2BW26KP8TVM%3D&reserved=0>
  *   Comparison between version -01 and -02: https://docs.google.com/document/d/19xidbplhn5gPr41QdeXBTh2WLhoA9kbhNieZiSh0Uyk/edit?usp=sharing<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F19xidbplhn5gPr41QdeXBTh2WLhoA9kbhNieZiSh0Uyk%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547684192&sdata=U%2BZkwEydIcU26n7GNnMQfwcCMnbr40058ChrQEXPQXs%3D&reserved=0>

Also, to clarify:

  *   The intent of the charter revision is not a complete overhaul but more to capture more recent activities the RG has engaged into and reflect that in an update of the original charter together with a work plan.
You can see in the comparison, that the first part (original charter) has not been changed.

Thank you.
Best regards, Laurent.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, November 20, 2019 06:46
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Comments welcome on revised NMRG charter

Hi NMRG,

Jérôme and I have been working on a new version of the NMRG charter to capture better the current shape and activity of the RG.

We'd like to receive comments from the community. This is on the agenda of the session on Friday.

https://docs.google.com/document/d/14eHQALG95VHE5N-YIAwH6vriKFG2WvI8d63TtugZLgU/edit?usp=sharing<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F14eHQALG95VHE5N-YIAwH6vriKFG2WvI8d63TtugZLgU%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547694199&sdata=LfR1fw5Q4IshxAbHRn%2F5M5AZXge6kzsL%2BFlLpbI7%2F%2B8%3D&reserved=0>

Thank you.
Best regards, Jérôme & Laurent.

---

From: 孙雪媛 <[email-masked]>
Date: Sun, 19 Jan 2020 14:56:50 +0800

Dear all,
I support Olga’s suggestion here.The two parts of the architecture and classification should be clearly divided and coordinated.
1)   Arch draft may include  “How intents are formed, expressed and information models/grammars/languages” . We will discuss about this further later.
2)   Classification draft may add examples for category.

Best Regards,
SUN Xueyuan

孙雪媛   SUN Xueyuan
中国电信战略与创新研究院 China Telecom Research Institute
Tel：010-50902887/ 17316269362
Email：[email-masked]
 
From: Olga Havel
Date: 2020-01-17 22:46
To: Alexander Clemm; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay); [email-masked]
CC: [email-masked]; irtf-chair \([email-masked]\)
Subject: Re: [nmrg] Comments welcome on revised NMRG charter
Hi Laurent,
 
I am sorry I will not be able to join the NMRG meetings. I am in China at the moment - it will be middle of the night here. I have some meetings on Tuesday morning to attend, so I will need to have some sleep J. Sorry for that, I will try to align with you in regards to the classification draft comments outside of the meeting as you kindly suggested.

 
I suggest that the goal for the third work item is: ‘Provide the way to classify intents into different types and categories based on requirements of different intent users’. I suggest we can also add “and add examples for each type/category” and we can do that for the next version while we address all other comments for our draft. I also suggest that we move the rest (how intents are formed/grammar/information models/APIs/DSLs) to the architecture work item.
 
Best Regards,
Olga

Hello all,

One nit re: “The initial focus of the NMRG will be on higher-layer management services that interface with the current Internet management framework.”  NMRG has a long tradition, so perhaps it is better to not call it “The initial focus”, but to state “The current focus”, or perhaps (not ideal) “the initial focus of the current NMRG cycle”.  
 
Likewise the statement “The NMRG will investigate in priority three related topics”.  This suggests that the listed topics are in priority order, which I don’t think is correct – they are simply all topics of priority.  Perhaps rephrase to “The NMRG will prioritize investigation of three related topics”, or similar?  
 
There is one typo: “One one hand” (should be “On one hand”).  
 
Some more minor comments FWIW (feel free to ignore):
- Third bullet item under IBN “categorize the different forms of intents and define what constitutes a “well-formed” intent; describe how an intent can be expressed and what can be expressed using an intent with means such as information models, grammars, and languages.”  I think that arguably the categorization could be covered under terminology; perhaps this bullet should simply focus on the second aspect (how to express intent), which is a more open-ended problem to which several solutions may be put forward.  

Cheers
--- Alex
 
From: nmrg <[email-masked]> On Behalf Of Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
 
Hello,
 
In addition to the previous email, a few additional links for your convenience:
Version -01 of NMRG charter: https://docs.google.com/document/d/1e84-M4DEDi-LCXjLG0Wf0JhbPXVcIPm2hnFFIQPrkro/edit?usp=sharing
Comparison between version -01 and -02: https://docs.google.com/document/d/19xidbplhn5gPr41QdeXBTh2WLhoA9kbhNieZiSh0Uyk/edit?usp=sharing
 
Also, to clarify: 
The intent of the charter revision is not a complete overhaul but more to capture more recent activities the RG has engaged into and reflect that in an update of the original charter together with a work plan.
You can see in the comparison, that the first part (original charter) has not been changed.
 
Thank you.
Best regards, Laurent.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]> 
Sent: Wednesday, November 20, 2019 06:46
To: [email-masked]
Cc: [email-masked]
Subject: Comments welcome on revised NMRG charter
 
Hi NMRG,

 
https://docs..google.com/document/d/14eHQALG95VHE5N-YIAwH6vriKFG2WvI8d63TtugZLgU/edit?usp=sharing
 
Thank you.

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Mon, 20 Jan 2020 08:42:30 +0000

Hello everyone,

I'd like to clarify that there is not a 1-to-1 mapping between work items and outputs; i.e. there is not necessarily one type of outputs (e.g. not only I-D), there is not necessarily one document per work item, and output may cover (partly) more than one work item.

On the below thread, I think the text of the charter is flexible and open enough to allow the different outputs to be produced; and I would like to keep the discussion on drafts (draft-li-nmrg-intent-classification-02) separate from the charter discussion.

I think the adoption call for draft-li-nmrg-intent-classification-02 has been useful to understand further development and scope of the outputs, and how it can address the charter work item(s).

For the architecture discussion and work, we are encouraging participants to provide their views and inputs; and this is on the agenda of today's virtual meeting.

Best regards, Laurent.

From: 孙雪媛 <[email-masked]>
Sent: Sunday, January 19, 2020 07:57
To: Olga Havel <[email-masked]>; Alexander Clemm <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]
Cc: [email-masked]; irtf-chair ([email-masked]) <[email-masked]>
Subject: Re: Re: [nmrg] Comments welcome on revised NMRG charter

Dear all,

Best Regards,
SUN Xueyuan

________________________________
孙雪媛   SUN Xueyuan
中国电信战略与创新研究院 China Telecom Research Institute
Tel：010-50902887/ 17316269362
Email：[email-masked]<mailto:[email-masked]>

From: Olga Havel<mailto:[email-masked]>
Date: 2020-01-17 22:46
To: Alexander Clemm<mailto:[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>; irtf-chair \([email-masked]\)<mailto:[email-masked]>
Subject: Re: [nmrg] Comments welcome on revised NMRG charter
Hi Laurent,

I am sorry I will not be able to join the NMRG meetings. I am in China at the moment - it will be middle of the night here. I have some meetings on Tuesday morning to attend, so I will need to have some sleep ☺. Sorry for that, I will try to align with you in regards to the classification draft comments outside of the meeting as you kindly suggested.

Best Regards,
Olga

Hello all,

Cheers
--- Alex

Hello,

Also, to clarify:

Thank you.
Best regards, Laurent.

Hi NMRG,

https://docs..google.com/document/d/14eHQALG95VHE5N-YIAwH6vriKFG2WvI8d63TtugZLgU/edit?usp=sharing<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F14eHQALG95VHE5N-YIAwH6vriKFG2WvI8d63TtugZLgU%2Fedit%3Fusp%3Dsharing&data=02%7C01%7Calex%40futurewei.com%7C33241176de274246eed408d76d9a78d1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637098382547694199&sdata=LfR1fw5Q4IshxAbHRn%2F5M5AZXge6kzsL%2BFlLpbI7%2F%2B8%3D&reserved=0>

Thank you.