Subject: [nmrg] Introduction Updated in draft-li-intent-classification

From: Olga Havel <[email-masked]>
Date: Wed, 26 Feb 2020 16:22:07 +0000

Hi Jürgen, Jérôme, Laurent,

Attached is the new introduction to the draft that hopefully clarifies the purpose of this document, the reasons for classification (therefore tables) and methodology and links to draft-clemm-nmrg-dist-intent. Could you please verify that it is aligned with your comments? If so, we can close the comments 1, 2 and 4 and proceed with addressing other comments by updating other section and adding methodology section.

Any volunteers to contribute and/or review the methodology section prior to sharing it on the group?

Best Regards,
Olga

1. Introduction
The vision of intent-driven networks has attracted a lot of attention, as it promises to simplify the management of networks by human operators by simply specifying what should happen on the network, without giving any instructions on how to do it. This promise led many telecom companies to begin adopting this new paradigm, and many SDOs to propose various intent variants.

All SDOs, such as IETF [ANIMA], ONF [ONF], ONOS [ONOS], have proposed intents as a declarative interface for defining a set of network operations to execute.

As such, IETF [ANIMA] defines intent as a declarative policy and focuses on providing a more complete definition of it, a tentative format, and a life-cycle. Within ONF [ONOS] intent is represented as a list of CLI commands that allows users to pass low-level details on the network, such as flows, or host addresses. ONF through its Boulder and Aspen projects focuses on NBI semantics and intent models.

As it can be observed, each of these SDOs came up with their own way of specifying an intent, and with their own understanding of what an Intent is in terms of the level of abstraction, intended users or scenarios. However, all intent approaches proposed by SDOs share the same following features:
              - It must be declarative in nature, meaning that a user specifies the goal on the network without specifying how to achieve that goal.
              - It must be vendor agnostic, in the sense that it abstracts the network capabilities, or the network infrastructure from the user, and it can be ported across different platforms.
              - It must provide an easy-to-use interface, which simplifies the users' interaction with the intent system through the usage of familiar terminology or concepts.
              - It should be able to detect and resolve intent conflicts.

Currently, work is underway on unifying a common understanding of intent concepts and terminology.  IRTF / NMRG [CLEMM] is currently leading these efforts by defining intent as higher-level declarative policy that operates at the level of network and services it provides, and by capturing the differences between intent, policy and service. However, even with proposed intent concepts and terminology, and agreement on common intent characteristics, an intent may still be viewed in different ways by different stakeholders for different use cases and solutions.

Thus, the goal of this document is to bring clarity to what an intent represents for different stakeholders, by means of classification on various dimensions, such as solutions, intent users, intent types, intent scope, network scope. This classification would ensure a common understanding across all participants and can be used to identify the scope and priorities of individual projects, PoCs, research projects, open-source projects, models, DSLs and APIs.

This is achieved by proposing initial classification tables and the methodology used for generating them. This methodology can be used to update the tables by adding or removing different dimensions, solutions, users, intent types, intent scopes, network scopes in order to cater for future scenarios, applications or domains. The tables could be filled in and shared with the community to communicate the scope and priorities of different projects and intent DSLs.

This draft together with [CLEMM] aims to become the foundation for future intent-related topic discussions where all participants have the same common understanding.

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 26 Feb 2020 13:13:19 -0800

Hi Olga,

In the [CLEMM] we have clearly differentiated intent and policies.
Policies, while provide degree of abstraction are still imperative in their nature, a policy could be a result of intent rendering, but calling intent a policy (even declarative) is quite incorrect.
Hope this helps

Cheers,
Jeff
On Feb 26, 2020, 8:24 AM -0800, Olga Havel <[email-masked]>, wrote:
> Introduction
>               - It must provide an easy-to-use interface, which simplifies the users’ interaction with the intent system through the usage of familiar terminology or concepts.

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Thu, 27 Feb 2020 11:40:27 +0000

If you look into the academic network management research literate,
which has quite some history, then policies were not really limited to
imperative policies. This is why older people struggle to understand
what intent is.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Olga Havel <[email-masked]>
Date: Thu, 27 Feb 2020 11:41:20 +0000

Dear Jeff,

Thank you very much for the comment. Is your comment about [CLEMM] or the  classification draft? We do not want to propose intent definition in our draft, we just want to refer to some suitable definition from your draft.

Independent of either drafts, I do fully agree with you that it may be better to improve the definition and do not mention declarative policy if we can find better term. My preference would be to use definition that does not have either policy or rule as both may imply imperative for some stakeholders. I did share my initial proposal on the group during the draft review, hoping to get some feedback:
‘Intents are objectives of the network users, expressed in the form suitable for different user types. Intents represent what the user requires from the network and not how these objectives are resolved, realized, configured and assured on the network’.

In the meantime, we agreed that your draft would be used for definition and that our draft should focus on classification. We are now just addressing comments about missing references to [CLEMM] in regards to intent definition and differences between policy / service / intent.

Therefore, the introduction just referred to your draft and we used what is defined in the section 4.2.3 where you are describing the differences between services, policies and intents and defining what intent is:

       “Intent is a higher-level declarative policy that operates at the

      level of a network and services it provides, not individual

      devices.  It is used to define outcomes and high-level operational

      goals, without the need to enumerate specific events, conditions,

      and actions.  Which algorithm or rules to apply can be

      automatically "learned/derived from intent" by the intent system.

      In the context of autonomic networking, ideally, intent is

      rendered by the network itself; also the dissemination of intent

      across the network and any required coordination between nodes is

      resolved by the network itself without the need for outside

      systems.”

Is your suggestion that we should instead use definition  from ’Definitions and Acronyms’ section:

      Intent: An abstracted, declarative and vendor agnostic set of

      rules used to provide full lifecycle (Design/Build/Deploy/

      Validate) to a network and services it provides

Is the ‘ declarative set of rules’ more acceptable than ‘declarative policy’? Especially where set of rules for some is very often considered just a part of a policy that contains classifier and action (e.g. https://gbp.readthedocs.io/en/latest/usage.html). We thought that using declarative policy is higher level abstraction and more suitable then set of rules, where actions may imply. Therefore we referred to 4.2.3 definition and not the other one.

But, I would appreciate guidelines from [CLEMM] authors. We want to refer to what the current definition is and focus on classification.  I think going forward we in NMRG can jointly continue to improve the definition in new versions of [CLEMM].

Best Regards,

Olga

From: Jeff Tantsura [mailto:[email-masked]]
Sent: Wednesday 26 February 2020 21:13
To: Schönwälder, Jürgen <[email-masked]>; Jérôme François <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; Olga Havel <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Introduction Updated in draft-li-intent-classification

Hi Olga,

Cheers,
Jeff
On Feb 26, 2020, 8:24 AM -0800, Olga Havel <[email-masked]<mailto:[email-masked]>>, wrote:

Best Regards,
Olga

Introduction

---

From: Olga Havel <[email-masked]>
Date: Thu, 27 Feb 2020 13:15:11 +0000

Dear Jürgen,

In regards to older versus younger people, I think users of our intent driven/based networks will be very diverse in terms of age, intelligence, technical depth. So I think we need to propose both definition and classification that is understood by majority in our industry, including academia - but not only by academia. How we parse those intents, how we formally define them below simple intent user interface, how we deliver those intents, what algorithms we use, what techniques we use, how we implement intents in the network , how we use ML/AI to self-correct and self-optimize - that can be hidden and understood by experts/academia only, or even by academia only for specific algorithms/maths.

The purpose of intents is to hide complexity and technical depth from network users. Intent Users are network planners/designers, operators, DevOp engineers, end-users. I hope I do understand personally what declarative policy is, despite my age. (I felt much better about your comment although it was not directed to me - after I checked your CV ☺) And I think definition of policy in Wikipedia is aligned – statement of intent. But unfortunately we have history with ECAs. And maybe difference what first comes to someone’s mind, depending if you are software / network engineer or academic.

I do agree with Jeff that defining intents via declarative policies may bring some questions. In any case, I think declarative policy is better than set of rules, which is in the formal definition in the draft. Is ‘user objective’ or ‘user goal’ or ‘user requirements’ better term than declarative policy for wider audience?  But I will leave this to [CLEMM] and I will comment again during the next review.

For now, Alex, Laurent, Jeff, … please let me know what definition to use when referring to the draft.

Best Regards,

Olga

-----Original Message-----
From: Schönwälder, Jürgen [mailto:[email-masked]]
Sent: Thursday 27 February 2020 11:40
To: Jeff Tantsura <[email-masked]>
Cc: Jérôme François <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; Olga Havel <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Introduction Updated in draft-li-intent-classification

If you look into the academic network management research literate, which has quite some history, then policies were not really limited to imperative policies. This is why older people struggle to understand what intent is.

/js

--

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 27 Feb 2020 13:48:10 +0000

Dear Olga, all,

We will fix the inconsistency between sections 3 and 4.2.3.

The definition of intent is a work in progress and the views shared are useful inputs.

My individual view is we should not over-simplify nor over-complexify the definition.
The goal would be to develop a clear and comprehensive definition based on rigorous analysis and references (as pointed out there are multiple definitions from different sources).

There is an inherent challenge in understanding the various definitions (motivated by different goals, technical contexts, users, etc.) and come with the NMRG view on the intent definition.

I think this is also why we named [CLEMM] draft "concepts and definitions" because there are inter-related parts and concepts which cannot be captured in a single definition that will suit everyone.

-Laurent.

From: Olga Havel <[email-masked]>
Sent: Thursday, February 27, 2020 12:41
To: Jeff Tantsura <[email-masked]>; Schönwälder, Jürgen <[email-masked]>; Jérôme François <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Introduction Updated in draft-li-intent-classification

Dear Jeff,

      systems.”

Best Regards,

Olga

From: Jeff Tantsura [mailto:[email-masked]]
Sent: Wednesday 26 February 2020 21:13
To: Schönwälder, Jürgen <[email-masked]<mailto:[email-masked]>>; Jérôme François <[email-masked]<mailto:[email-masked]>>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>; Olga Havel <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Introduction Updated in draft-li-intent-classification

Hi Olga,

Cheers,
Jeff

Best Regards,
Olga

Introduction

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Thu, 27 Feb 2020 15:42:41 +0000

Dear Olga,

if someone says "declarative policy is nowadays also called intent", I
am fine. If someone says "declarative policy is not policy anymore
since now we have the term intent", then I have a problem because the
distinction between declarative policy and non-declarative policy
predates the popularity of the term intent.  The network management
research community has a rather long history of policy based
management and I think we should not ignore this. For those who
like to know more, here is a place to start:

https://link.springer.com/article/10.1007/s10922-007-9083-8

Sometimes the distinction between declarative and non-declarative is
fuzzy since one way to implement declarative policies is to translate
them into non-declarative policy rules.

/js

---

From: Olga Havel <[email-masked]>
Date: Thu, 27 Feb 2020 16:47:11 +0000

Hi,

Thanks Jeff and Jürgen for the discussion. Thanks Jürgen for sharing the link, it does give a great historical perspective (and also brings some good and bad memories).

In regards to the classification draft, I suggest for now to keep the following statement in our Introduction, based on the current content of [CLEMM]:
"IRTF / NMRG [CLEMM] is currently leading these efforts by defining intent as higher-level declarative policy that operates at the level of network and services it provides, and by capturing the differences between intent, policy and service. "

Jeff, I suggest you bring your comment to other authors of your draft and that we address them and some of my and Jürgen's suggestions during the review of the next Intent Concepts and Definition version - Laurent is that OK? We should have a requirement to keep the drafts aligned, so we will change classification draft if there are any changes in the concepts / definitions draft. 

In regards to classification draft, I would like if Jürgen, Jérôme, Laurent let me know if I can close their comments 1, 2 and 4 so we can move to the other comments. I think we must address the comments about the purpose and value of the draft first and get agreement before proceeding. Otherwise, please let me know what you would like to change or believe is missing in the introduction.

Best Regards,
Olga

-----Original Message-----
From: Schönwälder, Jürgen [mailto:[email-masked]] 
Sent: Thursday 27 February 2020 15:43
To: Olga Havel <[email-masked]>
Cc: Jeff Tantsura <[email-masked]>; Jérôme François <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Introduction Updated in draft-li-intent-classification

Dear Olga,

if someone says "declarative policy is nowadays also called intent", I am fine. If someone says "declarative policy is not policy anymore since now we have the term intent", then I have a problem because the distinction between declarative policy and non-declarative policy predates the popularity of the term intent.  The network management research community has a rather long history of policy based management and I think we should not ignore this. For those who like to know more, here is a place to start:

Sometimes the distinction between declarative and non-declarative is fuzzy since one way to implement declarative policies is to translate them into non-declarative policy rules.

/js

On Thu, Feb 27, 2020 at 01:15:11PM +0000, Olga Havel wrote:
> From: Schönwälder, Jürgen 
> [mailto:[email-masked]]
> Cc: Jérôme François <[email-masked]>; Ciavaglia, Laurent 
> (Nokia - FR/Paris-Saclay) <[email-masked]>; Olga Havel 
> <[email-masked]>; [email-masked]; 
> [email-masked]; 
> [email-masked]

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 27 Feb 2020 16:54:15 +0000

In-line below.

> Sent: Thursday, February 27, 2020 17:47
> To: Schönwälder, Jürgen <[email-masked]>
> Cc: Jeff Tantsura <[email-masked]>; Jérôme François
> <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> <[email-masked]>; [email-masked]; draft-li-nmrg-intent-
> [email-masked]; [email-masked]
> Thanks Jeff and Jürgen for the discussion. Thanks Jürgen for sharing the
> link, it does give a great historical perspective (and also brings some
> good and bad memories).
> 
> In regards to the classification draft, I suggest for now to keep the
> following statement in our Introduction, based on the current content of
> [CLEMM]:
> "IRTF / NMRG [CLEMM] is currently leading these efforts by defining intent
> as higher-level declarative policy that operates at the level of network
> and services it provides, and by capturing the differences between intent,
> policy and service. "
> 
> Jeff, I suggest you bring your comment to other authors of your draft and
> that we address them and some of my and Jürgen's suggestions during the
> review of the next Intent Concepts and Definition version - Laurent is
> that OK? We should have a requirement to keep the drafts aligned, so we
> will change classification draft if there are any changes in the concepts
> / definitions draft.

LC: Yes. And aligned with my previous reply.

> 
> In regards to classification draft, I would like if Jürgen, Jérôme,
> Laurent let me know if I can close their comments 1, 2 and 4 so we can
> move to the other comments. I think we must address the comments about the
> purpose and value of the draft first and get agreement before proceeding.
> Otherwise, please let me know what you would like to change or believe is
> missing in the introduction.

LC: I will come back to you. Need some time to read carefully and reply.

> Cc: Jeff Tantsura <[email-masked]>; Jérôme François
> <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> <[email-masked]>; [email-masked]; draft-li-nmrg-intent-
> [email-masked]; [email-masked]
> if someone says "declarative policy is nowadays also called intent", I am
> fine. If someone says "declarative policy is not policy anymore since now
> we have the term intent", then I have a problem because the distinction
> between declarative policy and non-declarative policy predates the
> popularity of the term intent.  The network management research community
> has a rather long history of policy based management and I think we should
> not ignore this. For those who like to know more, here is a place to
> start:
> 
> Sometimes the distinction between declarative and non-declarative is fuzzy
> since one way to implement declarative policies is to translate them into
> non-declarative policy rules.
> 
> /js
> 
> > In regards to older versus younger people, I think users of our intent
> driven/based networks will be very diverse in terms of age, intelligence,
> technical depth. So I think we need to propose both definition and
> classification that is understood by majority in our industry, including
> academia - but not only by academia. How we parse those intents, how we
> formally define them below simple intent user interface, how we deliver
> those intents, what algorithms we use, what techniques we use, how we
> implement intents in the network , how we use ML/AI to self-correct and
> self-optimize - that can be hidden and understood by experts/academia
> only, or even by academia only for specific algorithms/maths.
> >
> >
> >
> > The purpose of intents is to hide complexity and technical depth from
> network users. Intent Users are network planners/designers, operators,
> DevOp engineers, end-users. I hope I do understand personally what
> declarative policy is, despite my age. (I felt much better about your
> comment although it was not directed to me - after I checked your CV ☺)
> And I think definition of policy in Wikipedia is aligned – statement of
> intent. But unfortunately we have history with ECAs. And maybe difference
> what first comes to someone’s mind, depending if you are software /
> network engineer or academic.
> >
> >
> >
> > I do agree with Jeff that defining intents via declarative policies may
> bring some questions. In any case, I think declarative policy is better
> than set of rules, which is in the formal definition in the draft. Is
> ‘user objective’ or ‘user goal’ or ‘user requirements’ better term than
> declarative policy for wider audience?  But I will leave this to [CLEMM]
> and I will comment again during the next review.
> >
> >
> >
> imperative policies. This is why older people struggle to understand what
> intent is.
> >
> >
> >
> > /js
> >
> >
> >
> > > Policies, while provide degree of abstraction are still imperative in
> their nature, a policy could be a result of intent rendering, but calling
> intent a policy (even declarative) is quite incorrect.
> >
> > > Hope this helps
> >
> > >
> >
> > > Cheers,
> >
> > > Jeff
> >
> > > On Feb 26, 2020, 8:24 AM -0800, Olga Havel
> <[email-masked]<mailto:[email-masked]>>, wrote:
> >
> > > > Attached is the new introduction to the draft that hopefully
> clarifies the purpose of this document, the reasons for classification
> (therefore tables) and methodology and links to draft-clemm-nmrg-dist-
> intent. Could you please verify that it is aligned with your comments? If
> so, we can close the comments 1, 2 and 4 and proceed with addressing other
> comments by updating other section and adding methodology section.
> >
> > > >
> >
> >
> > > >
> >
> > > > The vision of intent-driven networks has attracted a lot of
> attention, as it promises to simplify the management of networks by human
> operators by simply specifying what should happen on the network, without
> giving any instructions on how to do it. This promise led many telecom
> companies to begin adopting this new paradigm, and many SDOs to propose
> various intent variants.
> >
> > > >
> >
> > > > All SDOs, such as IETF [ANIMA], ONF [ONF], ONOS [ONOS], have
> proposed intents as a declarative interface for defining a set of network
> operations to execute.
> >
> > > >
> >
> > > > As such, IETF [ANIMA] defines intent as a declarative policy and
> focuses on providing a more complete definition of it, a tentative format,
> and a life-cycle. Within ONF [ONOS] intent is represented as a list of CLI
> commands that allows users to pass low-level details on the network, such
> as flows, or host addresses. ONF through its Boulder and Aspen projects
> focuses on NBI semantics and intent models.
> >
> > > >
> >
> > > > As it can be observed, each of these SDOs came up with their own way
> of specifying an intent, and with their own understanding of what an
> Intent is in terms of the level of abstraction, intended users or
> scenarios. However, all intent approaches proposed by SDOs share the same
> following features:
> >
> > > >               - It must be declarative in nature, meaning that a
> user specifies the goal on the network without specifying how to achieve
> that goal.
> >
> > > >               - It must be vendor agnostic, in the sense that it
> abstracts the network capabilities, or the network infrastructure from the
> user, and it can be ported across different platforms.
> >
> > > >               - It must provide an easy-to-use interface, which
> simplifies the users’ interaction with the intent system through the usage
> of familiar terminology or concepts.
> >
> > > > Currently, work is underway on unifying a common understanding of
> intent concepts and terminology.  IRTF / NMRG [CLEMM] is currently leading
> these efforts by defining intent as higher-level declarative policy that
> operates at the level of network and services it provides, and by
> capturing the differences between intent, policy and service. However,
> even with proposed intent concepts and terminology, and agreement on
> common intent characteristics, an intent may still be viewed in different
> ways by different stakeholders for different use cases and solutions.
> >
> > > >
> >
> > > > Thus, the goal of this document is to bring clarity to what an
> intent represents for different stakeholders, by means of classification
> on various dimensions, such as solutions, intent users, intent types,
> intent scope, network scope. This classification would ensure a common
> understanding across all participants and can be used to identify the
> scope and priorities of individual projects, PoCs, research projects,
> open-source projects, models, DSLs and APIs.
> >
> > > >
> >
> > > > This is achieved by proposing initial classification tables and the
> methodology used for generating them. This methodology can be used to
> update the tables by adding or removing different dimensions, solutions,
> users, intent types, intent scopes, network scopes in order to cater for
> future scenarios, applications or domains. The tables could be filled in
> and shared with the community to communicate the scope and priorities of
> different projects and intent DSLs.
> >
> > > >
> >
> > > > This draft together with [CLEMM] aims to become the foundation for
> future intent-related topic discussions where all participants have the
> same common understanding.
> >
> > > >
> >
> > > >
> >
> > > >
> >
> > > >
> >
> > > >
> >
> >
> >
> > --
> >

---

From: Olga Havel <[email-masked]>
Date: Thu, 27 Feb 2020 16:56:18 +0000

Dear Laurent,

I agree and I do not want that to slow down the progress of our draft updates. We would like to focus on improving the classification draft in order to get it approved.

Best Regards,
Olga

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) [mailto:[email-masked]]
Sent: Thursday 27 February 2020 13:48
To: Olga Havel <[email-masked]>; Jeff Tantsura <[email-masked]>; Schönwälder, Jürgen <[email-masked]>; Jérôme François <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Introduction Updated in draft-li-intent-classification

Dear Olga, all,

-Laurent.

From: Olga Havel <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, February 27, 2020 12:41
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Schönwälder, Jürgen <[email-masked]<mailto:[email-masked]>>; Jérôme François <[email-masked]<mailto:[email-masked]>>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: Introduction Updated in draft-li-intent-classification

Dear Jeff,

      systems.”

Best Regards,

Olga

Hi Olga,

Cheers,
Jeff

Best Regards,
Olga

Introduction

---

From: "Branislav Meandzija" <[email-masked]>
Date: Thu, 27 Feb 2020 09:41:20 -0800

A couple of comments  providing  different interpretation of the terms used  (in-line with my previous comments):
	- Intent and policy can be specified declaratively or non-declaratively. 
	- Non-declaratively specified intent may be easier to understand .e.g. re-send 3 times and if not-successful e-mail the administrator, and ....
	- Intent is not policy. 
	- A policy is an unambiguous  specification of a well-defined aspect of a system function. 
	-  Intent is  a jargon (incomplete and contextually deduced)  description of desired functioning of a system.

Branislav

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Olga Havel
Sent: Thursday, February 27, 2020 8:47 AM
To: Schönwälder, Jürgen <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nmrg] Introduction Updated in draft-li-intent-classification

Hi,

Best Regards,
Olga

-----Original Message-----
From: Schönwälder, Jürgen [mailto:[email-masked]]
Sent: Thursday 27 February 2020 15:43
To: Olga Havel <[email-masked]>
Cc: Jeff Tantsura <[email-masked]>; Jérôme François <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Introduction Updated in draft-li-intent-classification

Dear Olga,

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>
_______________________________________________
nmrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmrg

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Thu, 27 Feb 2020 18:45:16 +0000

> 	- Intent is not policy.

And the difference is?

/js

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Thu, 27 Feb 2020 19:03:16 +0000

See inline...

> All SDOs, such as IETF [ANIMA], ONF [ONF], ONOS [ONOS], have proposed intents as a declarative interface for defining a set of network operations to execute.

Is ONOS and SDO? Or did you mean ONF?

[...]

> Thus, the goal of this document is to bring clarity to what an intent represents for different stakeholders, by means of classification on various dimensions, such as solutions, intent users, inten…

Nit: Acronyms should be expanded to avoid guessing.

> This is achieved by proposing initial classification tables and the methodology used for generating them. This methodology can be used to update the tables by adding or removing different dimension…

So the goal is to propose classification tables (that can be extended)
but not to fill them? Then I believe the proposed tables are of rather
limited value.

> This draft together with [CLEMM] aims to become the foundation for future intent-related topic discussions where all participants have the same common understanding.

Instead of some 'abstract' classification tables, I would rather have
a decent overview of the different intent 'solutions' out there in the
industry followed by an analysis of commonalities and differences.
This would be a valuable document to have that can also pave the way
to much better discussions in the future.

I have a fundamental problem with this document that can't be fixed by
wordsmithing the introduction. This being a RG, there is no need to
find agreement on the value of a document so you can just ignore the
fact that I find this document not very helpful (and remove my name
of the Acknowledgments).

/js

---

From: Olga Havel <[email-masked]>
Date: Thu, 27 Feb 2020 19:06:11 +0000

Hi Branislave,

Thank you very much for your comment. Do you have any suggestions how do we move from intent being a jargon to something that has agreed definition and classification in our RG? 
What other term would you use to communicate the user objectives/requirements to the network? 

We will need formal definition, but it was outside of the scope of this draft. Would you be interested in contributing into the methodology section of the classification draft? We can expand the methodology to describe the process of how we formally define intent as well?

Best Regards,
Olga

-----Original Message-----
From: Branislav Meandzija [mailto:[email-masked]] 
Sent: Thursday 27 February 2020 17:41
To: Olga Havel <[email-masked]>; 'Schönwälder, Jürgen' <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [nmrg] Introduction Updated in draft-li-intent-classification

Branislav

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Olga Havel
Sent: Thursday, February 27, 2020 8:47 AM
To: Schönwälder, Jürgen <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nmrg] Introduction Updated in draft-li-intent-classification

Hi,

Best Regards,
Olga

-----Original Message-----
From: Schönwälder, Jürgen [mailto:[email-masked]]
Sent: Thursday 27 February 2020 15:43
To: Olga Havel <[email-masked]>
Cc: Jeff Tantsura <[email-masked]>; Jérôme François <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Introduction Updated in draft-li-intent-classification

Dear Olga,

/js

---

From: "Natale, Bob" <[email-masked]>
Date: Thu, 27 Feb 2020 19:25:19 +0000

I would distinguish intent-based declarative policy statements form action-based declarative policy statements.

   - The latter were sometimes characterized as Event / Condition / Action (ECA) policy statements.

   - The former can be characterized as Goal / Constraint / Metric (GCM) policy statements.

It's the "reversal" from "Action" to "Goal" that really makes the difference.

Very rushed (meeting hell) ... I realize it takes some hermeneutics to fill in the blanks ... from a lurker and FWIW, YMMV, and many other disclaimers.

BobN

-----Original Message-----
From: nmrg <[email-masked]> On Behalf Of Olga Havel
Sent: Thursday, February 27, 2020 2:06 PM
To: Branislav Meandzija <[email-masked]>; 'Schönwälder, Jürgen' <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [EXT] Re: [nmrg] Introduction Updated in draft-li-intent-classification

Hi Branislave,

Best Regards,
Olga

-----Original Message-----
From: Branislav Meandzija [mailto:[email-masked]]
Sent: Thursday 27 February 2020 17:41
To: Olga Havel <[email-masked]>; 'Schönwälder, Jürgen' <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [nmrg] Introduction Updated in draft-li-intent-classification

Branislav

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Olga Havel
Sent: Thursday, February 27, 2020 8:47 AM
To: Schönwälder, Jürgen <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nmrg] Introduction Updated in draft-li-intent-classification

Hi,

Best Regards,
Olga

-----Original Message-----
From: Schönwälder, Jürgen [mailto:[email-masked]]
Sent: Thursday 27 February 2020 15:43
To: Olga Havel <[email-masked]>
Cc: Jeff Tantsura <[email-masked]>; Jérôme François <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Introduction Updated in draft-li-intent-classification

Dear Olga,

/js

---

From: "Branislav Meandzija" <[email-masked]>
Date: Thu, 27 Feb 2020 11:36:14 -0800

Hi Olga,

This would be too time-intensive for me right now. Thanks for the invite.

I think at this point in time Juergen's  statement:

" Instead of some 'abstract' classification tables, I would rather have a decent overview of the different intent 'solutions' out there in the industry followed by an analysis of commonalities and differences.
This would be a valuable document to have that can also pave the way to much better discussions in the future."

Is the best way forward.

Branislav

-----Original Message-----
From: Olga Havel [mailto:[email-masked]] 
Sent: Thursday, February 27, 2020 11:06 AM
To: Branislav Meandzija <[email-masked]>; 'Schönwälder, Jürgen' <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [nmrg] Introduction Updated in draft-li-intent-classification

Hi Branislave,

Best Regards,
Olga

-----Original Message-----
From: Branislav Meandzija [mailto:[email-masked]]
Sent: Thursday 27 February 2020 17:41
To: Olga Havel <[email-masked]>; 'Schönwälder, Jürgen' <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [nmrg] Introduction Updated in draft-li-intent-classification

Branislav

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Olga Havel
Sent: Thursday, February 27, 2020 8:47 AM
To: Schönwälder, Jürgen <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nmrg] Introduction Updated in draft-li-intent-classification

Hi,

Best Regards,
Olga

-----Original Message-----
From: Schönwälder, Jürgen [mailto:[email-masked]]
Sent: Thursday 27 February 2020 15:43
To: Olga Havel <[email-masked]>
Cc: Jeff Tantsura <[email-masked]>; Jérôme François <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Introduction Updated in draft-li-intent-classification

Dear Olga,

/js