Subject: [nmrg] Minutes of Feb. meeting

From: Jérôme François <[email-masked]>
Date: Wed, 4 Mar 2020 20:14:02 +0100

Dear all,

The minutes of our last virtual meeting (28/02/2020) are available at:
https://datatracker.ietf.org/doc/minutes-interim-2020-nmrg-02-202002281300/
https://etherpad.tools.ietf.org/p/nmrg-virtual-20200228

As announced the meeting has been fully recorded:
https://ietf.webex.com/recordingservice/sites/ietf/recording/playback/66d69d9d440e4b8b9148ec929dd51e35

Best regards
jerome

---

From: Olga Havel <[email-masked]>
Date: Thu, 5 Mar 2020 10:08:02 +0000

Hi Jérôme,

Attached are the slides. Could you and Laurent  please send me your comments about the attached table and the attached introduction. Although we are proceeding with other comments and would engage with you in regards to Methodology , I would want to ensure first that we are in agreement in regards to the purpose of the draft described in the shared introduction. It is important that you share with us your comments if you think this introduction is different from the original agreement about the purpose of the classification draft.

1. Introduction
The vision of intent-driven networks has attracted a lot of attention, as it promises to simplify the management of networks by human operators by simply specifying what should happen on the network, without giving any instructions on how to do it. This promise led many telecom companies to begin adopting this new paradigm, and many SDOs to propose various intent variants.

All SDOs, such as IETF [ANIMA], ONF [ONF], ONOS [ONOS], have proposed intents as a declarative interface for defining a set of network operations to execute.

As such, IETF [ANIMA] defines intent as a declarative policy and focuses on providing a more complete definition of it, a tentative format, and a life-cycle. Within ONF [ONOS] intent is represented as a list of CLI commands that allows users to pass low-level details on the network, such as flows, or host addresses. ONF through its Boulder and Aspen projects focuses on NBI semantics and intent models.

As it can be observed, each of these SDOs came up with their own way of specifying an intent, and with their own understanding of what an Intent is in terms of the level of abstraction, intended users or scenarios. However, all intent approaches proposed by SDOs share the same following features:
              - It must be declarative in nature, meaning that a user specifies the goal on the network without specifying how to achieve that goal.
              - It must be vendor agnostic, in the sense that it abstracts the network capabilities, or the network infrastructure from the user, and it can be ported across different platforms.
              - It must provide an easy-to-use interface, which simplifies the users' interaction with the intent system through the usage of familiar terminology or concepts.
              - It should be able to detect and resolve intent conflicts.

Currently, work is underway on unifying a common understanding of intent concepts and terminology.  IRTF / NMRG [CLEMM] is currently leading these efforts by defining intent as higher-level declarative policy that operates at the level of network and services it provides, and by capturing the differences between intent, policy and service. However, even with proposed intent concepts and terminology, and agreement on common intent characteristics, an intent may still be viewed in different ways by different stakeholders for different use cases and solutions.

Thus, the goal of this document is to bring clarity to what an intent represents for different stakeholders, by means of classification on various dimensions, such as solutions, intent users, intent types, intent scope, network scope. This classification would ensure a common understanding across all participants and can be used to identify the scope and priorities of individual projects, PoCs, research projects, open-source projects, models, DSLs and APIs.

This is achieved by proposing initial classification tables and the methodology used for generating them. This methodology can be used to update the tables by adding or removing different dimensions, solutions, users, intent types, intent scopes, network scopes in order to cater for future scenarios, applications or domains. The tables could be filled in and shared with the community to communicate the scope and priorities of different projects and intent DSLs.

This draft together with [CLEMM] aims to become the foundation for future intent-related topic discussions where all participants have the same common understanding.

Best Regards,
Olga

From: Jérôme François [mailto:[email-masked]]
Sent: Wednesday 4 March 2020 19:16
To: Olga Havel <[email-masked]>
Cc: [email-masked]
Subject: Fwd: [nmrg] Minutes of Feb. meeting

Hi Olga,

Can you send me the slides you presented last week ?

Thanks
jerome

-------- Message transféré --------
Sujet :

[nmrg] Minutes of Feb. meeting

Date :

Wed, 4 Mar 2020 20:14:02 +0100

De :

Jérôme François <[email-masked]><mailto:[email-masked]>

Pour :

[email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>

Copie à :

[email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>

Dear all,

Best regards
jerome

_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg