Subject: [nmrg] Discussion on IBN Architecture

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Mon, 18 May 2020 10:14:20 +0000

Dear NMRG,

We'd like to trigger a discussion on *IBN Architecture*, as part of the RG work plan, and in preparation of the upcoming NMRG virtual meeting on 29-05-2020.

The work item #4 of our IBN work plan stipulates:
" Design and specify a common architectural framework comprising requirements, functions and
techniques to realize an archetypal IBN system; describe the lifecycle and theory of operations.

Goal: determine the elementary functional blocks of an IBN system, their interactions, inputs and
outputs; propose different techniques applicable for the different functions."

We've had some presentations and discussion in past meetings, and also a couple of individual I-Ds related to the topic.

In order to foster progress on the work item, we propose a set of questions and considerations.
We invite you to provide your opinion, comments and feedback on them (or new ones).

Considerations for Intent-Based Management Architecture(s)

  *   Define the problem statement, design goals and challenges, principles and requirements
  *   Focus on intent-* specific aspects, not yet another holistic management framework
  *   Aim for simplicity, flexibility, extensibility and integrability
  *   Consider Service Based Architecture approach and principles
  *   What should be the scope and system boundaries? What should be the lower boundary of an IBN architecture (what should it configure)? What typical user types should be considered?
  *   Should we consider use-case specific IBN architectures or try to have more generic/common architecture ? (what is the right tradeoff or how to find it?)
  *   How IBN co-exists with legacy management systems and emerging management/automation technologies and frameworks?
  *   Should we consider, investigate and document interoperability between different intent-based systems?
  *   How should the NMRG proposition differ from others? (positioning)

Best regards, Jérôme & Laurent.

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 26 May 2020 16:27:26 +0000

Hello everyone,

This is a gentle reminder: IBN architecture is on the agenda of our virtual meeting on Friday 25-05-2020. It would be nice to get (written) feedback on the questions, or be prepared to give your opinion during the meeting.

Thank you.
Jérôme & Laurent.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Monday, May 18, 2020 12:14
To: [email-masked]
Cc: [email-masked]' <[email-masked]>
Subject: Discussion on IBN Architecture

Dear NMRG,

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 26 May 2020 16:29:07 +0000

Correct date for the meeting is Friday 29-05-2020 😉

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>
Sent: Tuesday, May 26, 2020 18:27
To: [email-masked]
Cc: [email-masked]
Subject: RE: Discussion on IBN Architecture

Hello everyone,

Thank you.
Jérôme & Laurent.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Monday, May 18, 2020 12:14
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]' <[email-masked]<mailto:[email-masked]>>
Subject: Discussion on IBN Architecture

Dear NMRG,