Subject: [nmrg] [NMRG] review of draft-li-nmrg-intent-classification-03.txt

From: "Bezahaf, Mehdi" <[email-masked]>
Date: Thu, 14 May 2020 17:05:14 +0000

Dear all,

I hope this email finds you all safe and sound. Please find below my review of the last version of Draft-li-nmrg-intent-classification-03.txt.

     *   Lifecycle or life-cycle, keep it consistent
     *   Add NBI, API, VNF, PNF, AI and GBP to the acronym section
     *   In section 3.1

        *   The authors mentioned that "Intent is very often just a synonym for policy". I am sure that the authors meant that for the wider audience confusing intent and policy. Probably need to link this sentence with the one just before it.
     *   Section 3.2
        *   It is a bit confusing because the authors are talking about intent solutions and they present as an example carrier networks, DC networks, and Enterprise networks, which for me are more as situations, scenarios or contexts than a solution
        *   Does the table cover all the possibilities or just some examples (if it is the case, it needs to be clear in the text)?
        *   I don't agree. I guess if we pick the scenario (carrier networks for example) and a user (network operator), you will probably have different intent types depending on the use-case. What I mean is that just the user and the context does not describe or define the intent type
        *   Section 3.1 and 3.2 are related. If you can pick the actor, the context, and the use case, you can have a clear definition of your intent!
     *   Section 3.3
        *   The title of this section is "current problems and requirements". I wouldn't say 'problems' as it is defined in this section but more as possible improvement or intent benefits! I guess there are still some technical people that they want/need to use APIs/CLI to fix/access/interact with the system on specific issues!

     *   Section 5.1

        *   The figure in this section is a bit confusing! Does the classification process follow this order (R1-U1, R2-U2,.....)? I think this picture can be deleted!
     *   Section 5.2
        *   In section 4.2, three different intent user types were defined (customers, App dev, and Management). However, in section 5.2, the authors mentioned other intent user types such as Network or service operator, Enterprise administrator, cloud administrator, underlay network administrator. There is a difference between intent user and intent user type.
     *   Section 5.3.1
        *   In the first table, the authors duplicated some entries twice (probably by mistake).
        *   In section 3.4, the authors define a list of intent types that should be supported but in section 5.3.1, 5.4.1, and 5.5.1 new intent types are defined such as "strategy intent".
     *   Section 6
        *   I don't see the point of having this section (at least as it is) in this document. What I mean, is that I cannot see how AI will impact the classification!
        *   I don't agree with the authors when they support that intent determined by AI-based will have a format closer to machine language structures than natural language structures to avoid misconception. One way to do it is to have multiple exchanges between the user (human) and the system (the first loop) to be sure about the user request and that the AI-based agent gets the user's intention.

Best Regards,
Mehdi

Mehdi Bezahaf, PhD
Senior Research Associate
D31, InfoLab21
School of Computing & Communications
Lancaster University
+44 (0) 1524 510384

---

From: "El Khatib, Yehia (elkhatib)" <[email-masked]>
Date: Fri, 15 May 2020 12:42:40 +0000

Hi all,

This version of the draft is better than the last. I think it brings more clarity about the different ways intents could be used, which also helps to define who the users of intents are. Some suggestions:

- Like Mehdi mentioned, the bit in §3.1 about “Intent is very often just a synonym for policy” comes off as being confirmative of that stance, although the draft argues otherwise. And the rest of the paragraph repeats the same 2 points again. Perhaps just better wording here would help. Suggested alternative:

   An intent is mistaken by many to be just a synonym for policy.
   While it is easier for those familiar with different standards to
   understand what service, CFS, RFS, resource, policy continuum, ECA
   policy, declarative policy, abstract policy or intent policy is, it
   may be more difficult for the wider audience. Furthermore, those
   familiar with policies understand the difference between a business,
   intent, declarative, imperative and ECA policy.

- There is a number of examples spread throughout the draft, but none of them go into any detail so would leave some readers a little lost. I think the draft would benefit from having at least one case study explained in a little more detail. I’ve used some examples in my papers, e.g. : section III in
https://yelkhatib.github.io/papers/elkhatib2017idn.pdf

An alternative would be to just expand a little more whenever each of these examples is thrown in, such as “Request high priority queueing for traffic of class A”. The expansion would be a couple of sentences on how this would be manifested in an operational sense without being tech-specific.

- The draft mentioned that an intent-driven network (IDN) “should be able to detect and resolve intent conflicts”, but not how or whose responsibility this would be. This is probably beyond the scope of this draft, but it’s not ideal to leave that requirement there and never comment on its feasibility or responsibility. Even a brief comment would be better than nothing at all.

- I assume that the intent scopes in §4.3 are expandable and are context-specific?

Best,
Yehia

--
Dr. Yehia Elkhatib
Distributed Systems Group Lead  &  Director of PhD Admissions
School of Computing & Communications
Lancaster University, LA1 4WA, UK
y.elkhatib /then add/ lancaster.ac.uk
https://yelkhatib.github.io

From: nmrg <[email-masked]> on behalf of "Bezahaf, Mehdi" <[email-masked]>
Date: Thursday, 14 May 2020 at 9:46 pm
To: "[email-masked]" <[email-masked]>
Subject: [External] [nmrg] [NMRG] review of draft-li-nmrg-intent-classification-03.txt

This email originated outside the University. Check before clicking links or attachments.
Dear all,

     *   Section 3.2

     *   Section 3.3

        *   The title of this section is "current problems and requirements".. I wouldn't say 'problems' as it is defined in this section but more as possible improvement or intent benefits! I guess there are still some technical people that they want/need to use APIs/CLI to fix/access/interact with the system on specific issues!

     *   Section 5.1

        *   The figure in this section is a bit confusing! Does the classification process follow this order (R1-U1, R2-U2,…..)? I think this picture can be deleted!

     *   Section 5.2

        *   In section 4.2, three different intent user types were defined (customers, App dev, and Management). However, in section 5.2, the authors mentioned other intent user types such as Network or service operator, Enterprise administrator, cloud administrator, underlay network administrator. There is a difference between intent user and intent user type..

     *   Section 5.3.1

     *   Section 6

Best Regards,
Mehdi

Mehdi Bezahaf, PhD

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 27 May 2020 09:51:27 +0800

Dear Yehia,
 
Thank you very much for your comments. Thanks for your opinion that this version of the draft is much better and brings more clarity. Please see the replies below. We propose to address in the next version of the document those comments with reply “Added to the list of updates for the next version”. For others, we added some clarification – please let us know if you need additional clarification.
 
Best Regards,
Chen

李  晨  Li Chen
中国电信战略与创新研究院 战略与规划研究所 网络规划中心
电话：010-50902891/18910853955
邮箱：[email-masked]/[email-masked]
只为成功找方法，不为失败找借口
==============================
Chen  Li
Network Evolution and Planning Center
Network Technology & Planning Department
Email：[email-masked] /[email-masked]
Tel: +86-10-50902891
Mobile: +86-18910853955

From: nmrg [mailto:[email-masked]] On Behalf Of El Khatib, Yehia (elkhatib)
Sent: Friday 15 May 2020 13:43
To: [email-masked]
Subject: Re: [nmrg] [External] [NMRG] review of draft-li-nmrg-intent-classification-03.txt
 
Hi all,

 
Added to the list of updates for the next version –
Thank you for your suggestion on improving the wording. We will update in the next version to further clarify that for the wider audience intents are sometimes confused with policies. 

Added to the list of updates for the next version –
The examples presented in tables 5.3.1, 5.4.1 and 5.5.1 have been added based on the previous draft comments received. The purpose of these intents is to provide actual examples of intent from the perspective of a user for different solutions, intent user types, and intent types. We agreed that the Use Cases, Intent Formal Definition (DSL) the operational aspects (such as how these intents are decomposed) behind these intents are outside of the scope of this draft and would be addressed by other drafts (Use Cases, Intent DSL, Intent Architecture). But your suggestion to add some expansions is welcome and we will add some clarification in the next draft version.
Thanks for sharing the link, it is excellent reference and should be used when the RG start working on use cases and formal definition and architecture. 

Added to the list of updates for the next version -
We agreed that addressing in detail intent conflict resolution is outside the scope of this draft. 
We will update this sentence in the next version of the draft, to explain that a new intent issued by an intent user, can be in conflict with the already existing intents, and that once the system identifies such a conflict, an option is to report back to the user to refine its intent.
 
- I assume that the intent scopes in §4.3 are expandable and are context-specific?
Yes, the intent scopes are expendable through the methodology presented in section 5.1.

Best,
Yehia

 

Lifecycle or life-cycle, keep it consistent
Add NBI, API, VNF, PNF, AI and GBP to the acronym section
In section 3.1
The authors mentioned that "Intent is very often just a synonym for policy". I am sure that the authors meant that for the wider audience confusing intent and policy. Probably need to link this sentence with the one just before it.
Section 3.2
It is a bit confusing because the authors are talking about intent solutions and they present as an example carrier networks, DC networks, and Enterprise networks, which for me are more as situations, scenarios or contexts than a solution
Does the table cover all the possibilities or just some examples (if it is the case, it needs to be clear in the text)?
I don't agree. I guess if we pick the scenario (carrier networks for example) and a user (network operator), you will probably have different intent types depending on the use-case. What I mean is that just the user and the context does not describe or define the intent type
Section 3.1 and 3.2 are related. If you can pick the actor, the context, and the use case, you can have a clear definition of your intent!
Section 3.3
The title of this section is "current problems and requirements".. I wouldn't say 'problems' as it is defined in this section but more as possible improvement or intent benefits! I guess there are still some technical people that they want/need to use APIs/CLI to fix/access/interact with the system on specific issues!
 
Section 5.1
The figure in this section is a bit confusing! Does the classification process follow this order (R1-U1, R2-U2,…..)? I think this picture can be deleted!
Section 5.2
In section 4.2, three different intent user types were defined (customers, App dev, and Management). However, in section 5.2, the authors mentioned other intent user types such as Network or service operator, Enterprise administrator, cloud administrator, underlay network administrator. There is a difference between intent user and intent user type..
Section 5.3.1
In the first table, the authors duplicated some entries twice (probably by mistake).
In section 3.4, the authors define a list of intent types that should be supported but in section 5.3.1, 5.4.1, and 5.5.1 new intent types are defined such as "strategy intent".
Section 6
I don't see the point of having this section (at least as it is) in this document. What I mean, is that I cannot see how AI will impact the classification! 
I don't agree with the authors when they support that intent determined by AI-based will have a format closer to machine language structures than natural language structures to avoid misconception. One way to do it is to have multiple exchanges between the user (human) and the system (the first loop) to be sure about the user request and that the AI-based agent gets the user's intention.

Best Regards,
Mehdi

Mehdi Bezahaf, PhD