Subject: [nmrg] Discussion on IBN (virtual) Hackathon

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Mon, 18 May 2020 10:19:15 +0000

Dear NMRG,

We mentioned a few times the intention to participate in the IETF Hackathon to further develop the practical side of the IBN activity.

The work items #5 and #6 of our IBN work plan stipulates respectively:
#5 " Define appropriate validation scenarios and use cases describing concrete examples of intent
expressions and functions.
Goal: assess the quality and completeness of specifications and evaluate intent-based systems
functionalities in experimental settings."

#6 "Develop implementations and proof of concepts.
Goal: demonstrate the feasibility of the proposed framework and its functions; detect potential
design flaws, and provide a basis for interoperability evaluations."

As a starting point of this activity, the NMRG held a dedicated interim meeting on IBN demos and tools in October 2019, in Roma.
The main outcome of the meeting is documented in a report available at: https://datatracker.ietf.org/meeting/interim-2019-nmrg-10/materials/slides-interim-2019-nmrg-10-sessa-report-nof-nmrg-demo-session

Several actions and future directions were identified, such as:
- Creation of a code repository including tools/demos description and installation/use guides.
- Definition of an IBN tool data sheet and commitment of the meeting participants to provide documented tool data sheets for their demos. Additional tools and proof of concepts have already been identified.
- Proposition of the Mapping table and population based on the available use cases and demos.
- Maintenance and updates to the Overall IBN tools view .
- Creation of an IBN Resource Hub to gather scientific publications, standards and industry documentation, and pointers to projects, events and useful resources on IBN.
- Follow-up interactions and further joint development or interconnection between tools presented at the meeting and new ones.
The NMRG was also planning to participate in the IETF 108 Hackathon to be held in July 2020 in Madrid on the topic of intent based networking. IETF108 will be an on-line meeting, however, we'd like to keep IETF 108 as a general milestone to define our work on IBN implementation.

In order to plan the future steps and mode of operation of the activity, we'd like to collect the views, opinion, comments and feedback from the research group.
In particular, we'd like to know more on:
- What are the objectives we/you want to achieve with such an activity (hackathon, implementation)?
- Do you think NMRG should first work on documents (drafts) to set definition and propositions (e.g. architecture) for IBN.
- How should it be organized and developed? e.g. virtual hackathon, virtual teams (off-line collaboration)
- Who is willing to take part in the activity?, to do what? (e.g. develop demos, tools, etc. ; provide support (SDK, IDE, testbeds, etc.) ; test, evaluate, lead/animate, etc.
- How much resources do you think you could allocate to this activity in the next 12 months (in number of days, engineers, students...)
- We are planning to organize dedicated calls with interested parties, to start with. Do you think it's a good idea? What else could be proposed?
- What kind of outcomes do you expect (short/mid/long term): simple prototype / demo, reference tool/framework...

Best regards, Jérôme & Laurent.

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 26 May 2020 16:32:23 +0000

Hello,

This is a gentle reminder: the IBN use cases and implementation/virtual hackathon are on the agenda of our upcoming meeting (29-05-2020).
It would be nice to hear from you on the questions listed at the bottom of the message.

From: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
Sent: Monday, May 18, 2020 12:19
To: [email-masked]
Cc: [email-masked]
Subject: Discussion on IBN (virtual) Hackathon

Dear NMRG,