Subject: [nmrg] Adoption call for draft-li-nmrg-intent-classification-03

From: Jérôme François <[email-masked]>
Date: Mon, 1 Jun 2020 09:18:47 +0200

Dear all,

We recently received an RG adoption request for 
draft-li-nmrg-intent-classification-03 
(https://www.ietf.org/id/draft-li-nmrg-intent-classification-03.txt)

Please let us know if you support the work becoming a RG document or if you think 
it should not be adopted. In all cases, provide detailed comments to support your 
opinion and send them on the mailing list.

This call for adoption is open for two weeks and ends up on 15 June 2020.

The procedure for RG document adoption and important criteria are detailed here: 
https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Pedro Andres Aranda Gutierrez <[email-masked]>
Date: Mon, 1 Jun 2020 10:25:34 +0200

Dear all,

I'm reading through the introduction and I still have doubts... Just a
couple of linguistic quirks that may make the document clearer:

[Page 4]

"All SDOs, such as IETF [ANIMA], ONF [ONF], ONOS [ONOS], have
   proposed intents as a declarative interface for defining a set of
   network operations to execute."

IMvHO, ONOS is _NOT_ an SDO, it's just an implementation of an SDN
framework.

[Page 5]
"Thus, the goal of this document is to bring clarity to what an
   intent represents for different stakeholders,..."

The goal of this document is to clarify what intent represents for
different stakeholders.

And put the rest in a sentence and you classify in/on different (not
various) dimensions.

"This classification would ensure a common
   understanding across all participants and it can be used to identify"

would/could or will/can

   "This is achieved by proposing initial classification tables and the
   methodology used for generating them."

Wkat is more important? The tables or the methodology. I guess the latter,
right?

"This draft together with [CLEMM] aims"

Together with CLEMM, this draft aims...

Best regards,

On Mon, 1 Jun 2020 at 09:19, Jérôme François <[email-masked]>
wrote:

> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg
>

-- 
Fragen sind nicht da um beantwortet zu werden,
Fragen sind da um gestellet zu werden
Georg Kreisler

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 3 Jun 2020 08:53:17 +0800

Dear Pedro,
 
Thank you very much for your comments and suggestions. Please see the replies below. We propose to address all of your comments as you suggested in the next version of the document. Please let us know if you need any additional clarification.
 
Best Regards,
Chen

李  晨  Li Chen
中国电信战略与创新研究院 战略与规划研究所 网络规划中心
电话：010-50902891/18910853955
邮箱：[email-masked]/[email-masked]
只为成功找方法，不为失败找借口
==============================
Chen  Li
Network Evolution and Planning Center
Network Technology & Planning Department
Email：[email-masked] /[email-masked]
Tel: +86-10-50902891
Mobile: +86-18910853955
==============================
 
From: nmrg [mailto:[email-masked]] On Behalf Of Pedro Andres Aranda Gutierrez
Sent: Monday 1 June 2020 09:26
To: Jérôme François <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [nmrg] Adoption call for draft-li-nmrg-intent-classification-03
 
Dear all, 
 
I'm reading through the introduction and I still have doubts... Just a couple of linguistic quirks that may make the document clearer:
 
[Page 4]

IMvHO, ONOS is _NOT_ an SDO, it's just an implementation of an SDN framework.

Added to the list of updates for the next version. We will say “All SDOs and open source projects, such as …”

[Page 5]

Added to the list of updates for the next version. We will update based on your suggestion.

And put the rest in a sentence and you classify in/on different (not various) dimensions.

Added to the list of updates for the next version. We will update the sentence as you suggested and make it more readable.

would/could or will/can

Added to the list of updates for the next version. We will review the document with focus on the usage of would/could and will/can and update as needed.

Wkat is more important? The tables or the methodology. I guess the latter, right?
Added to the list of updates for the next version. We will change the order.

Together with CLEMM, this draft aims...
Added to the list of updates for the next version. We will update the sentence as you suggested.
Best regards,
 
On Mon, 1 Jun 2020 at 09:19, Jérôme François <[email-masked]> wrote:
Dear all,

Best regards
NMRG chairs
Laurent & Jérôme

---

From: 孙雪媛 <[email-masked]>
Date: Wed, 3 Jun 2020 09:51:53 +0800

Dear all,
As a co-contributor, I support the adoption of this draft. Classification is an important part of the intent network. The research on this topic is very meaningful as well. The draft has been discussed online and offline many times, and I think it is mature as a RG document. In the next, I will continue to follow up the research and discussion on the topic of intent classification.

Best Regards,
Sun Xueyuan

孙雪媛   SUN Xueyuan
中国电信研究院 China Telecom Research Institute
Tel：010-50902887/ 17316269362
Email：[email-masked]
 
From: Jérôme François
Date: 2020-06-01 15:18
To: [email-masked]
CC: [email-masked]
Subject: [nmrg] Adoption call for draft-li-nmrg-intent-classification-03
Dear all,

 

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Giuseppe Fioccola <[email-masked]>
Date: Wed, 3 Jun 2020 10:04:38 +0000

Dear All,
I have read the draft and I support its adoption as a RG document.

Regards,

Giuseppe

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Jérôme François
Sent: Monday, June 1, 2020 9:19 AM
To: [email-masked]
Cc: [email-masked]
Subject: [nmrg] Adoption call for draft-li-nmrg-intent-classification-03

Dear all,

Please let us know if you support the work becoming a RG document or if you think it should not be adopted. In all cases, provide detailed comments to support your opinion and send them on the mailing list.

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Alexander Clemm <[email-masked]>
Date: Wed, 3 Jun 2020 19:30:37 +0000

Hi,

I support adoption of this draft.

I do have a few comments for consideration as the draft continues to evolve and am looking forward to further RG discussions:  
- The expectation is that this will be referencing / coordinating with draft-irtf-nmrg-ibn-concepts-definitions to avoid potential overlap.  
- I am not sure I understand the purpose of the intent Classification Tables.  As those tables feature quite prominently in the draft, that purpose and how they are supposed to be used needs to be clarified more clearly. 
- There should be discussion if and how the classification might be extended or adjusted going forward - which aspects of the classification are "closed" and which ones are "open-ended".  For example, technologies subjected to intent might evolve, new areas of concern (e.g. privacy, compliance) might arise etc.  
- The intent scope currently concerns operations as a whole, concerning what would be addressed e.g. by an OSS.  There should be a discussion whether lower-level intent, such as intent for a given flow, should be included (or whether that would even qualify as intent).  Perhaps the answer is that it should be excluded, but if so it would be good to do so after clear deliberation.  

Thanks
--- Alex

> From: nmrg <[email-masked]> On Behalf Of Jérôme François
> Sent: Monday, June 01, 2020 12:19 AM
> To: [email-masked]
> Cc: [email-masked]
> (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww
> .ietf.org%2Fid%2Fdraft-li-nmrg-intent-classification-
> 03.txt&amp;data=02%7C01%7Calex%40futurewei.com%7C094ce241c8694bac
> 556d08d805fc0efa%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637
> 265927443721368&amp;sdata=f2S776Ohe8ALFdaCAwmHyVK%2FqKKQreBe14
> c9%2F8aaXCU%3D&amp;reserved=0)
> 
> Please let us know if you support the work becoming a RG document or if you
> think it should not be adopted. In all cases, provide detailed comments to
> support your opinion and send them on the mailing list.
> 
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailar
> chive.ietf.org%2Farch%2Fmsg%2Fnmrg%2FCVEyLUvfxJk1Ud5WdM9Y5LGvQmU
> &amp;data=02%7C01%7Calex%40futurewei.com%7C094ce241c8694bac556d0
> 8d805fc0efa%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C63726592
> 7443731365&amp;sdata=nyOW1APSnLiFiBfvR4np07gk8jHGcBmkB9aa2xyNi7g
> %3D&amp;reserved=0
> 
> Best regards
> NMRG chairs
> Laurent & Jérôme
> 
> 
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.i
> rtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=02%7C01%7Calex%40futur
> ewei.com%7C094ce241c8694bac556d08d805fc0efa%7C0fee8ff2a3b240189c75
> 3a1d5591fedc%7C1%7C0%7C637265927443731365&amp;sdata=PnAiBZcqk%2
> B1iKTU6Kaf9CXaXA24TnZIg2WKfjut%2BVgk%3D&amp;reserved=0

---

From: Adriana Olariu <[email-masked]>
Date: Thu, 4 Jun 2020 08:22:34 +0000

Dear all,

As co-author, I support the draft  adoption as RG document.

All the comments have been addressed, bringing the document to a mature phase for becoming an RG document.

Kind regards,
Adriana

-----Original Message-----
From: nmrg [mailto:[email-masked]] On Behalf Of Jér?me Fran?ois
Sent: Monday 1 June 2020 08:19
To: [email-masked]
Cc: [email-masked]
Subject: [nmrg] Adoption call for draft-li-nmrg-intent-classification-03

Dear all,

Best regards
NMRG chairs
Laurent & Jérôme

---

From: Pedro Andres Aranda Gutierrez <[email-masked]>
Date: Thu, 4 Jun 2020 10:30:14 +0200

Hi

in addition to my comments, I'm in favour of adopting this document as a
way to further refine it.

Best regards,
Pedro A. Aranda

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 18 Jun 2020 16:17:00 +0000

Dear all, 

I have read the draft and do support its adoption as an RG document. 
It provides room to end up with a comprehensive and evolutive classification.  
Best regards,
Sabine

---

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 22 Jun 2020 11:40:26 +0000

As co-author, I support the adoption.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

    >Please let us know if you support the work becoming a RG document or if
    >you think it should not be adopted. In all cases, provide detailed
    >comments to support your opinion and send them on the mailing list.
    >
    >The procedure for RG document adoption and important criteria are
    >detailed
    >here:

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 22 Jun 2020 11:41:41 +0000

And let me note (I was too quick in pressing "Send") that I have not reacted before because the original message (and the replies to it) did not reach me, as far as I can tel...

Dr Diego R. Lopez
Telefonica I+D

On 22/06/2020, 13:40, "Diego R. Lopez" <[email-masked]> wrote:

    Be goode,

    Dr Diego R. Lopez
    Telefonica I+D