Subject: [nmrg] Poll for NMRG IETF 108 Hackathon - Demo session(s) + additional important information

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 17 Jul 2020 17:52:23 +0000

Dear NMRG,

IETF 108 Hackathon is next week (Monday 20-07 to Friday 24-07).

NMRG will participate to the hackathon with a number of projects; see bottom of the page at https://trac.ietf.org/trac/ietf/meeting/wiki/108hackathon

IETF 108 Hackathon Opening and Closing sessions
There will be global opening and closing sessions for the hackathon on:

  *   Monday, July 20
     *   07:00 PDT / 10:00 EDT / 14:00 UTC - Hackathon kickoff ​Meetecho link<https://meetings.conf.meetecho.com/ietf108/?group=hackathon>

  *   Friday, July 24
     *   07:00 PDT / 10:00 EDT / 14:00 UTC - Hackathon closing ​Meetecho link<https://meetings.conf.meetecho.com/ietf108/?group=hackathon&item=2>

NMRG IETF 108 Hackathon Demo sessions
For the NMRG projects, we plan to hold "Demo + Discussion sessions" during the week where projects will be showcased and discussed.
In order to define the slots, please answer the doodle poll: https://doodle.com/poll/pqu8tnssn4edf3gn
Depending on the number of projects and availability we may organize one or more demo sessions. Demo sessions would typically last between 1 to 3 hours (depending if single or multiple projects are showcased).

NMRG IETF 108 Hackathon Slack Workspace
In parallel to the demo sessions, Davide and Walter have configured an NMRG workspace for the IETF 108 hackathon; here's the link to join: https://join.slack.com/t/nmrghackathon/shared_invite/zt-fo3xzvbq-_9BwwMGt7Xgzn_LTz0Y6IA
The workspace will typically be used for (asynchronous) interactions between projects participants.

NMRG GitHub
The NMRG GitHub is available at: https://github.com/irtf-nmrg

IETF 108 and IETF 108 Hackathon tools
IETF 108 and the IETF 108 Hackathon will be fully on-line events.
A set of tools are made available:

    Meetecho will be the main conferencing platform for the IETF 108 and IETF 108 Hackathon   Online meeting.
    You are encouraged to review the IETF 108 participant guide, which has links to the sessions and further details:
    https://www.ietf.org/how/meetings/108/session-participant-guide/

    Also, Gather.town <https://gather.town> will be available as a platform for social interaction during the IETF 108 meeting week. Details are being finalized and will be shared ahead of the meeting. In the meantime, a test session has been set up at:
    https://gather.town/IWtOGrHFbPX6dPSE/ietftest
    with the password: Test108!

Best regards,
Jérôme and Laurent

---

From: Walter Cerroni <[email-masked]>
Date: Tue, 21 Jul 2020 11:02:07 +0200

Dear NMRG Members,

one of the NMRG projects that will take place at the IETF 108 Hackathon (which started yesterday) will be about "A Multi-Level Approach to Intent-Based Networking (IBN)". For your reference, please find attached the slides we presented at the NMRG preparation meeting on July 10th.

The Hackathon session dedicated to this project is scheduled for tomorrow, Wednesday July 22. Here are the details:

Hackathon session: A Multi-Level Approach to IBN
Date and time: Wednesday, July 22 from 2pm to 6pm CEST (12:00-16:00 UTC)
Link to web conference: https://ietf.webex.com/meet/nmrg
Link to NMRG Hackathon Slack Workspace: ​https://join.slack.com/t/nmrghackathon/shared_invite/zt-fo3xzvbq-_9BwwMGt7Xgzn_LTz0Y6IA

Anyone interested is very welcome to attend the session. We will start with a short presentation introducing concepts and tools, then we will show a demo of our implementation of the multi-level intent in an NFV environment. After that, we welcome any kind of interaction with the audience: comments, questions, suggestions, ideas for contributions, possible hands-on work on any extension/improvements to be carried out during the Hackathon week and even after that (there is still a lot to do).

Please find below the Chairs message with relevant information on how to joint the whole IETF 108 Hackathon event. The schedule of other IETF 108 Hackathon sessions is available here:

https://trac.ietf.org/trac/ietf/meeting/wiki/108hackathon/teamschedule

We look forward to meeting you tomorrow at the online Hackathon session.

Best regards,

Walter, Barbara, Davide, Molka

On 7/17/20 7:52 PM, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) wrote:
> *IETF 108 Hackathon Opening and Closing sessions*
> 
>       o 07:00 PDT / 10:00 EDT / 14:00 UTC - Hackathon kickoff ​Meetecho link <https://meetings.conf.meetecho.com/ietf108/?group=hackathon> 
> 
>   * Friday, July 24
>       o 07:00 PDT / 10:00 EDT / 14:00 UTC - Hackathon closing ​Meetecho link <https://meetings.conf.meetecho.com/ietf108/?group=hackathon&item=2> 
> 
> *NMRG IETF 108 Hackathon Demo sessions*
> 
> *NMRG IETF 108 Hackathon Slack Workspace*
> 
> *NMRG GitHub*
> *IETF 108 and IETF 108 Hackathon tools*
> 
> *    Meetecho*will be the main conferencing platform for the IETF 108 and IETF 108 Hackathon   Online meeting.
> 
>      Also, *Gather.town* <https://gather.town> will be available as a platform for social interaction during the IETF 108 meeting week. Details are being finalized and will be shared ahead of the meeting. In the meantime, a test session has been set up at:
> 
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg
>

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 22 Jul 2020 10:30:43 +0000

Dear all,

Gentle reminder: the "hackathon" session for the project "A Multi-Level Approach to Intent-Based Networking (IBN)" will start at 2pm CEST today.
Details on content and how to connect are provided below.

Best regards, 
-Laurent

> -----Original Message-----
> From: Walter Cerroni <[email-masked]>
> Sent: Tuesday, July 21, 2020 11:02
> To: [email-masked]
> Cc: [email-masked]; Barbara Martini <[email-masked]>;
> Davide Borsatti <[email-masked]>; Molka Gharbaoui
> <[email-masked]>
> Subject: NMRG IETF 108 Hackathon session on multi-level IBN
> 
> Dear NMRG Members,
> 
> one of the NMRG projects that will take place at the IETF 108 Hackathon
> (which started yesterday) will be about "A Multi-Level Approach to Intent-
> Based Networking (IBN)". For your reference, please find attached the
> slides we presented at the NMRG preparation meeting on July 10th.
> 
> Link to NMRG Hackathon Slack Workspace: 
> https://join.slack.com/t/nmrghackathon/shared_invite/zt-fo3xzvbq-
> _9BwwMGt7Xgzn_LTz0Y6IA
> 
> Anyone interested is very welcome to attend the session. We will start
> with a short presentation introducing concepts and tools, then we will
> show a demo of our implementation of the multi-level intent in an NFV
> environment. After that, we welcome any kind of interaction with the
> audience: comments, questions, suggestions, ideas for contributions,
> possible hands-on work on any extension/improvements to be carried out
> during the Hackathon week and even after that (there is still a lot to
> do).
> 
> Please find below the Chairs message with relevant information on how to
> joint the whole IETF 108 Hackathon event. The schedule of other IETF 108
> Hackathon sessions is available here:
> 
> > NMRG will participate to the hackathon with a number of projects; see
> bottom of the page at
> https://trac.ietf.org/trac/ietf/meeting/wiki/108hackathon
> >
> >       o 07:00 PDT / 10:00 EDT / 14:00 UTC - Hackathon kickoff ​Meetecho
> link <https://meetings.conf.meetecho.com/ietf108/?group=hackathon>
> >
> >   * Friday, July 24
> >       o 07:00 PDT / 10:00 EDT / 14:00 UTC - Hackathon closing ​Meetecho
> link <https://meetings.conf.meetecho.com/ietf108/?group=hackathon&item=2>
> >
> > For the NMRG projects, we plan to hold "Demo + Discussion sessions"
> during the week where projects will be showcased and discussed.
> >
> > Depending on the number of projects and availability we may organize one
> or more demo sessions. Demo sessions would typically last between 1 to 3
> hours (depending if single or multiple projects are showcased).
> >
> > In parallel to the demo sessions, Davide and Walter have configured an
> NMRG workspace for the IETF 108 hackathon; here's the link to join:
> https://join.slack.com/t/nmrghackathon/shared_invite/zt-fo3xzvbq-
> _9BwwMGt7Xgzn_LTz0Y6IA
> >
> >      You are encouraged to review the IETF 108 participant guide, which
> has links to the sessions and further details:
> >
> >      Also, *Gather.town* <https://gather.town> will be available as a
> platform for social interaction during the IETF 108 meeting week. Details
> are being finalized and will be shared ahead of the meeting. In the
> meantime, a test session has been set up at:
> >

---

From: Walter Cerroni <[email-masked]>
Date: Fri, 24 Jul 2020 17:14:13 +0200

Dear all,

the IETF 108 Hackathon week is closing. We had a very stimulating discussion after the IBN demo session on Wednesday, and I would like to thank all the people that took part in the online meeting.

If you missed it, the video recording of our session is available here:

https://bit.ly/nmrg108hackathon

Please find attached a few slides that I just presented as a wrap-up at the Hackathon closing session.

Best regards,

Walter

-- 
-----------------------------
        Walter  Cerroni
DEI -- Universita' di Bologna
-----------------------------
    Via dell’Università, 50
   47522 Cesena (FC) - ITALY
-----------------------------
email [email-masked]
-----------------------------
Tel. Cesena   +39 0547 339209
Tel. Bologna  +39 051 2093089
-----------------------------