Subject: [nmrg] Updates of draft-irtf-nmrg-ibn-intent-classification-01 - Alex

From: Olga Havel <[email-masked]>
Date: Tue, 20 Oct 2020 16:43:43 +0000

Hi Alex,

We are addressing some of your comments now and want to ensure that they would be addressed to your satisfaction. Please let me know if you have any comments or suggestions:

Alex's comments:
1. The expectation is that this will be referencing / coordinating with draft-irtf-nmrg-ibn-concepts-definitions to avoid potential overlap.
<Olga> We already added reference, but will add the latest version of the document and mention that we will stay aligned.
-  [CLEMM] is currently leading these efforts by defining intent as higher-level declarative policy that operates at the level of network and services it provides, and by capturing the differences between intent, policy and service.
- Together with [CLEMM], this draft aims to become the foundation for future intent-related topic discussions where all participants have the same common understanding.
- Concerning this, [CLEMM] draft brings clarification with relation to what an intent is and how it differentiates from policies and services.
I suggest we also add specific statement that we will keep the versions of this draft aligned with [CLEMM].  
 
2. I am not sure I understand the purpose of the intent Classification Tables.  As those tables feature quite prominently in the draft, that purpose and how they are supposed to be used needs to be clarified more clearly. 
<Olga> Our plan was to add the section with an example, section 6.6 "Intent Classification Example", would that be OK? I already suggested to take " A Multi-Level Approach to IBN, W. Cerroni" at one of the previous meetings, we will contact Walter to add his example. 

3. There should be discussion if and how the classification might be extended or adjusted going forward - which aspects of the classification are "closed" and which ones are "open-ended".  For example, technologies subjected to intent might evolve, new areas of concern (e.g. privacy, compliance) might arise etc.  
<Olga> Please see the section 6.1. The draft proposed that the methodology can be used to update existing classification by adding or removing different solutions, users, categories in order to cater for future scenarios, applications or domains. We do not see any aspects being closed, we can extend any. The taxonomy and tables presented are the example of our current classification, that will evolve. We will add more text in 6.1 to make it clearer. 

4. The intent scope currently concerns operations as a whole, concerning what would be addressed e.g. by an OSS.  There should be a discussion whether lower-level intent, such as intent for a given flow, should be included (or whether that would even qualify as intent).  Perhaps the answer is that it should be excluded, but if so it would be good to do so after clear deliberation.  

<Olga> Are you referring to the section 5.5? We added technical intents as we often see that operators and administrators do consider them as their intents as well as some technical PoCs and Demos. Hopefully, the target would be that all intents are of higher level of abstraction. We can state that we do not consider lower-level intents to qualify as intents (based on the definition in your draft), but we kept this classification to identify any PoCs/Demos/Use Cases that still either require or implement lower level of abstraction.

Best Regards,
Olga

---

From: Alexander Clemm <[email-masked]>
Date: Thu, 22 Oct 2020 19:24:35 +0000

Hi Olga,

Quick replies inline, <ALEX>

--- Alex

-----Original Message-----
From: Olga Havel <[email-masked]> 
Sent: Tuesday, October 20, 2020 9:44 AM
To: Alexander Clemm <[email-masked]>; Jérôme François <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Updates of draft-irtf-nmrg-ibn-intent-classification-01 - Alex

Hi Alex,

Alex's comments:
 
<ALEX> Sure </ALEX>

<ALEX> An example is always good.  However, I think it would be good to add some explanatory text at the beginning of the section (currently section 5) that explains this.  Right now, it is a bit "we want to classify things because we can" and it will be good to more clearly explain the purpose of those tables.   For the example, it would be good if you cannot only show how you would classify a given intent, but that also shows why the classification is relevant here, e.g. how it would be used.   
</ALEX>

<ALEX> I don't see a section 6.1, do you mean 5.1?  As mentioned, I think it would be good to call this out somewhere - I think it may be important enough to add a short subsection somewhere to make it explicit.  </ALEX>

<ALEX> Ok.  I think if you add the explanations of extensibility and put the hooks in place by which to extend this, it becomes a lesser issue anyhow.   
BR
--- Alex
</ALEX>

Best Regards,
Olga