Subject: [nmrg] RG Last Call for draft-irtf-nmrg-ibn-concepts-definitions

From: Jérôme François <[email-masked]>
Date: Tue, 6 Oct 2020 23:59:20 +0200

Dear all,

As expressed during NMRG September interim meeting, authors of draft "Intent-Based Networking - Concepts and Definitions" would like to publish it as informational RFC and so enter in the publication process*:
https://datatracker.ietf.org/doc/draft-irtf-nmrg-ibn-concepts-definitions/

This process starts by the review of the document by the group. So, please provide feedback on the technical and editorial quality of the document by*October 21st *
Best regards,
Jérôme and Laurent
NMRG chairs

*https://trac.ietf.org/trac/irtf/wiki/IRTF-RFCs

---

From: Jérôme François <[email-masked]>
Date: Wed, 21 Oct 2020 13:45:47 +0200

Dear all,

Just a kind reminder that we entered into the last call for the Intent-Based 
Networking - Concepts and Definitions" draft:

To progress on RFC publictation, describing the level of support for publication 
is necessary*. So, your feedback (negative and positive) is also necessary on both 
technical and editorial quality of the document.  It does not need to be long, in 
particular if you think the document is ready for IRSG review, but we need to know 
your opinion.

In order to let you enough time to read and review the document, we decided to 
extend the deadline to Oct 28.

Best regards,
Jérôme and Laurent
NMRG chairs

---

From: Alexander Clemm <[email-masked]>
Date: Wed, 21 Oct 2020 17:19:51 +0000

Responding as an author:  I think the draft is ready.  NMRG had quite a few discussions on this over the past couple of years.  The draft is quite stable at this point and IMHO reflects the consensus of the community.   
--- Alex

-----Original Message-----
From: nmrg <[email-masked]> On Behalf Of Jérôme François
Sent: Wednesday, October 21, 2020 4:46 AM
To: [email-masked]
Cc: [email-masked]
Subject: [nmrg] [NMRG] Reminder: RG Last Call for draft-irtf-nmrg-ibn-concepts-definitions

Dear all,

Just a kind reminder that we entered into the last call for the Intent-Based Networking - Concepts and Definitions" draft:

https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-irtf-nmrg-ibn-concepts-definitions%2F&amp;data=04%7C01%7Calex%40futurewei.com%7C44b3e1e490fe4c0d0ea208d875b704c8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637388776214881382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=NiTUt9oNraAVweJog8hAyWqWF69xJsPlcIAVyMCCB0A%3D&amp;reserved=0

To progress on RFC publictation, describing the level of support for publication is necessary*. So, your feedback (negative and positive) is also necessary on both technical and editorial quality of the document.  It does not need to be long, in particular if you think the document is ready for IRSG review, but we need to know your opinion.

In order to let you enough time to read and review the document, we decided to extend the deadline to Oct 28.

Best regards,
Jérôme and Laurent
NMRG chairs

*https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Firtf%2Fwiki%2FIRTF-RFCs&amp;data=04%7C01%7Calex%40futurewei.com%7C44b3e1e490fe4c0d0ea208d875b704c8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637388776214881382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=iityaODMc2PcbvmYNjdt9%2FnRNsiMc07OkN7Mf4o0za8%3D&amp;reserved=0

_______________________________________________
nmrg mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=04%7C01%7Calex%40futurewei.com%7C44b3e1e490fe4c0d0ea208d875b704c8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637388776214881382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=59%2F9ZEz1v78%2Fmb6LOY7%2BFXwDCkKhs%2BFuE4P8bNvJiJw%3D&amp;reserved=0

---

From: Haoyu Song <[email-masked]>
Date: Wed, 21 Oct 2020 18:11:04 +0000

I think the draft is ready for IRSG review. We have referenced the terms and concepts in our own drafts and believe they are solid and useful. 

Haoyu  

-----Original Message-----
From: nmrg <[email-masked]> On Behalf Of Jérôme François
Sent: Wednesday, October 21, 2020 4:46 AM
To: [email-masked]
Cc: [email-masked]
Subject: [nmrg] [NMRG] Reminder: RG Last Call for draft-irtf-nmrg-ibn-concepts-definitions

Dear all,

https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-irtf-nmrg-ibn-concepts-definitions%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C3f10b14deadb4ef5e9e108d875b714c7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637388776488702970%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=o%2BFkSGNJyWpqsJjXVPpxo2XR8Fo1jdT4isyGlyS3Ad8%3D&amp;reserved=0

Best regards,
Jérôme and Laurent
NMRG chairs

*https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Firtf%2Fwiki%2FIRTF-RFCs&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C3f10b14deadb4ef5e9e108d875b714c7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637388776488702970%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=Cqc5d%2Bnvrp6V2eqb56VJUKHQSPnKZuY4ZwR4walnqP8%3D&amp;reserved=0

_______________________________________________
nmrg mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C3f10b14deadb4ef5e9e108d875b714c7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637388776488702970%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=0ptqwIYodRakMolFmPDCb%2BPrq7BvVgsZQImlDax1YAE%3D&amp;reserved=0

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 21 Oct 2020 13:07:05 -0700

Dear RG,

Responding as an author and implementor - I believe the draft is ready for the further progress, we have addressed all outstanding comments and the content is stable.
The draft  provides a good foundation for the further work on IBN that will happen in IRTF and IETF.

Cheers,
Jeff
On Oct 21, 2020, 4:46 AM -0700, Jérôme François <[email-masked]>, wrote:
> https://www.irtf.org/mailman/listinfo/nmrg

---

From: Jéferson Campos Nobre <[email-masked]>
Date: Thu, 22 Oct 2020 00:15:47 -0300

Hi.
As an NMRG participant, I think this I-D is ready for IRSG review.
Thanks.
Cheers.

----------------------------------------------------
Prof. Dr. Jéferson Campos Nobre
Instituto de Informática
Programa de Pós-Graduação em Computação
Universidade Federal do Rio Grande do Sul
http://www.inf.ufrgs.br/~jcnobre
----------------------------------------------------

On Wed, Oct 21, 2020 at 5:07 PM Jeff Tantsura <[email-masked]>
wrote:

> Dear RG,
>
> Responding as an author and implementor - I believe the draft is ready for
> the further progress, we have addressed all outstanding comments and the
> content is stable.

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 22 Oct 2020 07:56:27 +0000

Hi all,

From my perspective the draft is ready for IRSG review.

Thanks

Best regards

Luis

De: nmrg <[email-masked]> En nombre de Jéferson Campos Nobre
Enviado el: jueves, 22 de octubre de 2020 5:16
Para: [email-masked]
CC: [email-masked]
Asunto: Re: [nmrg] [NMRG] Reminder: RG Last Call for draft-irtf-nmrg-ibn-concepts-definitions

Hi.

On Wed, Oct 21, 2020 at 5:07 PM Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:
Dear RG,

Cheers,
Jeff
On Oct 21, 2020, 4:46 AM -0700, Jérôme François <[email-masked]<mailto:[email-masked]>>, wrote:

Dear all,

Best regards,
Jérôme and Laurent
NMRG chairs

_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 23 Oct 2020 10:49:33 +0000

Hello,

Some of my colleagues reviewed the draft.
Their comments are attached.

Best regards, 
Laurent

> From: Jérôme François <[email-masked]>
> Sent: Wednesday, October 21, 2020 13:46
> To: [email-masked]
> Cc: [email-masked]
> Subject: [NMRG] Reminder: RG Last Call for draft-irtf-nmrg-ibn-concepts-
> definitions
> 
> Dear all,
>

---

From: marinos <[email-masked]>
Date: Mon, 26 Oct 2020 22:55:34 +0000

Dear All,

I also believe the draft is in a good state for IRSG review.

Regards,
-Marinos

On Thu, 22 Oct 2020 at 08:56, LUIS MIGUEL CONTRERAS MURILLO <
[email-masked]> wrote:

> *De:* nmrg <[email-masked]> *En nombre de *Jéferson Campos Nobre
> *Enviado el:* jueves, 22 de octubre de 2020 5:16
> *Para:* [email-masked]
> *CC:* [email-masked]
> *Asunto:* Re: [nmrg] [NMRG] Reminder: RG Last Call for
> draft-irtf-nmrg-ibn-concepts-definitions
>
>
>
> Hi.
>
> ------------------------------
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição

---

From: Jérôme François <[email-masked]>
Date: Tue, 27 Oct 2020 08:45:03 +0100

Dear all,

Below, the review done by a colleague in CC, Rémi Badonnel (University of Lorraine).

"Very interesting and instructive draft on intent-based management. Some minor 
comments:
-In addition to the examples, would it make sense to provide some 
counter-examples, of what is not an intent (if possible, beyond the notion of 
policies)?
-I fully agree that explainability is an important IBN function, in particular 
from a legal/ethical viewpoint.
-"Policy-based management can be considered an imperative management paradigm": 
some policy based-management systems (such as cfEngine) seem to use a declarative 
style to specify their policies (but with a low/technical-level granularity), how 
shall we position them in comparison to intent-based management?"

Best,
jerome

Le 21/10/2020 à 13:45, Jérôme François a écrit :
> is necessary*. So, your feedback (negative and positive) is also necessary on 
> both technical and editorial quality of the document.  It does not need to be 
> long, in particular if you think the document is ready for IRSG review, but we 
> need to know your opinion.
>

---

From: Jérôme François <[email-masked]>
Date: Tue, 27 Oct 2020 08:53:43 +0100

Dear all,

Attached are some comments to the drafts (CREF references in the text).
The draft is in a very good shape. My remarks mostly concern the style/typos 
except the one about life-cycle. I think this might not be clear for an external 
reader to see  the mapping of the IBN functionalities to the lifecycle (should 
maybe be explicit)

Best,
jerome

---

From: Olga Havel <[email-masked]>
Date: Tue, 27 Oct 2020 09:20:43 +0000

Hi,
I agree that the draft is ready for IRSG review.
Best regards,
Olga

From: nmrg [mailto:[email-masked]] On Behalf Of marinos
Sent: Monday 26 October 2020 22:56
To: [email-masked]
Cc: [email-masked]
Subject: Re: [nmrg] [NMRG] Reminder: RG Last Call for draft-irtf-nmrg-ibn-concepts-definitions

Dear All,

Regards,
-Marinos

On Thu, 22 Oct 2020 at 08:56, LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Thanks

Best regards

Luis

De: nmrg <[email-masked]<mailto:[email-masked]>> En nombre de Jéferson Campos Nobre
Enviado el: jueves, 22 de octubre de 2020 5:16
Para: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Asunto: Re: [nmrg] [NMRG] Reminder: RG Last Call for draft-irtf-nmrg-ibn-concepts-definitions

Hi.

Cheers,
Jeff

Best regards,
Jérôme and Laurent
NMRG chairs

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 28 Oct 2020 18:43:46 +0800

Hi all ,
I think the draft is ready for IRSG review. 

BR,
Chen

李  晨  Li Chen
中国电信研究院 战略与规划研究所 网络规划中心
电话：010-50902891/18910853955
邮箱：[email-masked]/[email-masked]
只为成功找方法，不为失败找借口
==============================
Chen  Li
Network Evolution and Planning Center
Network Technology & Planning Department
Email：[email-masked] /[email-masked]
Tel: +86-10-50902891
Mobile: +86-18910853955
 
From: Jérôme François
Date: 2020-10-21 19:45
To: [email-masked]
CC: [email-masked]

 

Best regards,
Jérôme and Laurent
NMRG chairs

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 28 Oct 2020 17:36:47 +0000

Hello,

Please find a review from Molka and Barbara.

Best regards,
Laurent

From: Jérôme François <[email-masked]>
Sent: Tuesday, October 6, 2020 23:59
To: [email-masked]
Cc: [email-masked]
Subject: RG Last Call for draft-irtf-nmrg-ibn-concepts-definitions

Dear all,

This process starts by the review of the document by the group. So, please provide feedback on the technical and editorial quality of the document by October 21st

Best regards,

Jérôme and Laurent

NMRG chairs

* https://trac.ietf.org/trac/irtf/wiki/IRTF-RFCs

---

From: Walter Cerroni <[email-masked]>
Date: Wed, 28 Oct 2020 18:52:43 +0100

Hi,

responding as an NMRG participant.

I found this I-D very interesting and definitely useful to shed some light on the concepts of intent and related system functionality. I especially liked the discussion about the distinction between intent, policy, and service models, which are very often confused and misinterpreted. Also, the proposed definition of IBN functionality and intent life-cycle were very useful in the context of my own research activity on IBN.

Here's a couple of minor suggestions for improvement:

Section 1, p. 3: The sentence starting with "Adaptability to changes at scale is a fundamental property of a well-designed IBN system,..." seems to assume that the general concepts of "IBN system" and "intent" are already known to the reader. But those very same concepts are introduced later on in the draft. Maybe that sentence could be rephrased and made more general, not mentioning IBN and intents yet.

Section 4.1, p. 6: The sentence starting at the bottom of the page mentions that "In an autonomic network, intent should be rendered by the network itself..." Is that true only for autonomic networks? How about other types of networks? Previously it was mentioned that "...the concept of 'Intent' is not limited to autonomic networks, but applies to any network." To be consistent, the sentence at the end of page 6 should be complemented with something related to non-autonomic networks, or just made more general.

Section 4.2.2, p.11: At some point the PBM acronym is used, which was never defined before. Maybe the authors intended to use PBNM instead.

In conclusion, I support this I-D and consider it ready for IRSG review, pending the minor changes suggested above.

Best regards,

Walter

-- 
-----------------------------
        Walter  Cerroni
DEI -- Universita' di Bologna
-----------------------------
    Via dell’Università, 50
   47522 Cesena (FC) - ITALY
-----------------------------
email [email-masked]
-----------------------------
Tel. Cesena   +39 0547 339209
Tel. Bologna  +39 051 2093089
-----------------------------