Subject: [nmrg] [NMRG] research challenges in AI for NM - Next meeting

From: Jérôme François <[email-masked]>
Date: Tue, 8 Dec 2020 22:48:42 +0100

Dear all,

The next meeting regarding the AI document will be Dec 15 at 14:00 (UTC+1)

Tentative agenda:
- review comments received regarding scope
- discuss the method on how to identify the righ challenge sets (and so verify the 
oens we already described): I was suggesting to list properties of NM problems and 
AI technique properties) -> if anyone has good references on theses aspects, 
please share it.

Any other suggestion ?

A datatracker entry will be created for this meeting. Webex details below.

Best regards
jerome

https://ietf.webex.com/ietf/j.php?MTID=m7d9057e767719e6fcd1b7d1f05975e0f
Tuesday, 15 Dec, 2020 14:00 | 1 hour | (UTC+01:00) Brussels, Copenhagen, Madrid, Paris
Meeting number: 178 859 5216
Password: cEP6WaMNu33
432c93cde3704433833ae5836e94a06f

Join by video system
Dial [email-masked]
You can also dial 173.243.2.68 and enter your meeting number.

Join by phone
1-650-479-3208 Call-in toll number (US/Canada)
Access code: 178 859 5216

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 9 Dec 2020 09:38:44 +0000

Hi Jérôme,

Looking forward to the meeting next week to progress on the document.

Regarding your question on how to rightly define the challenges:
	- An important thing to clarify early is to avoid confusion between a challenge and a use case.
	A rough distinction would be that a challenge exists at the NM domain level and applies across multiple/all use cases. A use case may illustrate several challenges, or facets of challenges in a particular context.
	I think that we could utilize use cases to fuel our analysis and reflections but also that we should strive to extract commonalities, patterns among the use cases. Such commonalities could hint to more systemic challenges, or help in their identification, understanding and definition.
	I agree with the approach to analyze the characteristics of NM problems or activities (based on a "taxonomy", e.g. FCAPS) and analyze the characteristics of AI techniques; however we should be careful not to prescribe or imply which AI technique(s) should be used to address which NM problem(s).
	- Another aspect that could help to properly describe (the scope of the) challenges is to define what/how we aim to describe them, e.g. a description, motivations for, considerations of the challenge followed by research questions or directions. This would be in line with the existing guidelines for challenge description.
	- Sources to identify and define the right set of challenges could be diverse: SotA review, technical documentation (e.g. from standards, open source...), but also I think we should not neglect our own domain knowledge and capacity of analysis (e.g. by asking ourselves questions such as: "Is the list of challenges comprehensive?" "Are there gaps or additional areas to consider?" "Are we covering the most important aspects of AI-based NM?", etc.)

Best regards, 
Laurent

> -----Original Message-----
> From: Jérôme François <[email-masked]>
> Sent: Tuesday, December 8, 2020 22:49
> To: [email-masked]
> Cc: [email-masked]
> Subject: [NMRG] research challenges in AI for NM - Next meeting
> 
> Dear all,
>

---

From: Roberto Riggio <[email-masked]>
Date: Wed, 9 Dec 2020 19:25:12 +0100

Hi,

I will not be able to participate in that call because I have a keynote in
parallel but I wanted to provide my two cents to the discussion. Another
dimension we could take into consideration is the split between AIML
challenges (interpretability, computational complexity, ease of use, ...)
and NM challenges (stability, convergence, security, etc.) and put the use
cases at the crossing between both of them, for example, a use case on
routing could be at the intersection between interpretability (because a
network administrator may want to know why a route was chosen) and
stability (to avoid flip flop effects). Of course a use case could be in
multiple cells of the matrix so we could have one matrix for each use case.

R.

On Wed, 9 Dec 2020 at 10:38, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <
[email-masked]> wrote:

>         A rough distinction would be that a challenge exists at the NM
> domain level and applies across multiple/all use cases. A use case may
> illustrate several challenges, or facets of challenges in a particular
> context.
>         I think that we could utilize use cases to fuel our analysis and
> reflections but also that we should strive to extract commonalities,
> patterns among the use cases. Such commonalities could hint to more
> systemic challenges, or help in their identification, understanding and
> definition.
>         I agree with the approach to analyze the characteristics of NM
> problems or activities (based on a "taxonomy", e.g. FCAPS) and analyze the
> characteristics of AI techniques; however we should be careful not to
> prescribe or imply which AI technique(s) should be used to address which NM
> problem(s).
>         - Another aspect that could help to properly describe (the scope
> of the) challenges is to define what/how we aim to describe them, e.g. a
> description, motivations for, considerations of the challenge followed by
> research questions or directions. This would be in line with the existing
> guidelines for challenge description.
>         - Sources to identify and define the right set of challenges could
> be diverse: SotA review, technical documentation (e.g. from standards, open
> source...), but also I think we should not neglect our own domain knowledge
> and capacity of analysis (e.g. by asking ourselves questions such as: "Is
> the list of challenges comprehensive?" "Are there gaps or additional areas
> to consider?" "Are we covering the most important aspects of AI-based NM?",
> etc.)
>
> Best regards,
> Laurent
>
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg
>