Subject: [OAUTH-WG] Draft -02 submitted

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 6 May 2010 12:58:02 -0700

The new draft should show up shortly. The changes are:

- Scope parameter (space-delimited for now)
- JSON response format for tokens
- Removed URI query restriction on redirection URI when using 'state'

I am thinking of moving all the flows up section up (no more splitting them into three categories in the sections). This will make the document less nested, but also will solve the issue of the assertion flow not always being an autonomous flow, etc. Let me know if you have strong objections as I am likely to submit a -03 tomorrow with just that change (to make diffs easier limit major format changes to their own drafts).

EHL

---

From: Robert Sayre <[email-masked]>
Date: Thu, 6 May 2010 16:04:22 -0400

On Thu, May 6, 2010 at 3:58 PM, Eran Hammer-Lahav <[email-masked]> wrote:
>
> I am likely to submit a -03 tomorrow

There are some broken JSON examples that should be fixed tomorrow as well:

     {"error"="incorrect_client_credentials"}

-- 

Robert Sayre

"I would have written a shorter letter, but I did not have the time."

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 6 May 2010 13:07:18 -0700

Ugh. I forgot to save the doc before I rendered. It is already fixed in my local copy. I'll include that in the next refresh.

EHL

> -----Original Message-----
> From: Robert Sayre [mailto:[email-masked]]
> Sent: Thursday, May 06, 2010 1:04 PM
> To: Eran Hammer-Lahav
> Cc: OAuth WG ([email-masked])
> Subject: Re: [OAUTH-WG] Draft -02 submitted
>