Subject: [OAUTH-WG] application/x-www-form-urlencoded Counterproposal

From: Mike Moore <[email-masked]>
Date: Fri, 7 May 2010 09:05:52 -0600

I propose alter the spec so that the token responses are encoded with
application/x-www-form-urlencoded, matching OAuth 1.0. I also propose moving
the JSON and XML support for these responses to an extension.

I haven't heard an argument that convinces me that JSON adds anything over
application/x-www-form-urlencoded. It seems to be a preference and as such
can be accommodated as an extension. Thoughts?

---

From: Yaron Goland <[email-masked]>
Date: Fri, 7 May 2010 16:49:38 +0000

+1

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mike Moore
Sent: Friday, May 07, 2010 8:06 AM
To: OAuth WG
Subject: [OAUTH-WG] application/x-www-form-urlencoded Counterproposal

I propose alter the spec so that the token responses are encoded with application/x-www-form-urlencoded, matching OAuth 1.0. I also propose moving the JSON and XML support for these responses to an extension.

I haven't heard an argument that convinces me that JSON adds anything over application/x-www-form-urlencoded. It seems to be a preference and as such can be accommodated as an extension. Thoughts?