Subject: [OAUTH-WG] I-D Action:draft-ietf-oauth-v2-05.txt

From: [email-masked]
Date: Thu, 13 May 2010 12:15:07 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Open Authentication Protocol Working Group of the IETF.

	Title           : The OAuth 2.0 Protocol
	Author(s)       : E. Hammer-Lahav, et al.
	Filename        : draft-ietf-oauth-v2-05.txt
	Pages           : 55
	Date            : 2010-05-13

This specification describes the OAuth 2.0 protocol.  OAuth provides
a method for making authenticated HTTP requests using a token - an
identifier used to denote an access grant with specific scope,
duration, and other attributes.  Tokens are issued to third-party
clients by an authorization server with the approval of the resource
owner.  OAuth defines multiple flows for obtaining a token to support
a wide range of client types and user experience.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 13 May 2010 12:27:48 -0700

Changes:

   o  Corrected device example.
   o  Added client credentials parameters to the assertion flow as OPTIONAL.
   o  Added the ability to send client credentials using an HTTP authentication scheme.
   o  Initial text for the "WWW-Authenticate" header (also added scope support).
   o  Changed authorization endpoint to end-user endpoint.
   o  In the device flow, changed the "user_uri" parameter to "verification_uri" to avoid confusion with the end-user endpoint.
   o  Added "format" request parameter and support for XML and form-encoded responses.

This will be the last draft update before our meeting next week to allow everyone time to read it and prepare.

EHL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of [email-masked]
> Sent: Thursday, May 13, 2010 12:15 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [OAUTH-WG] I-D Action:draft-ietf-oauth-v2-05.txt
> 
> This specification describes the OAuth 2.0 protocol.  OAuth provides a
> method for making authenticated HTTP requests using a token - an identifier
> used to denote an access grant with specific scope, duration, and other
> attributes.  Tokens are issued to third-party clients by an authorization server
> with the approval of the resource owner.  OAuth defines multiple flows for
> obtaining a token to support a wide range of client types and user
> experience.
> 
> implementation to automatically retrieve the ASCII version of the Internet-
> Draft.

---

From: Prateek Mishra <[email-masked]>
Date: Mon, 17 May 2010 10:07:43 -0400

Where is the meeting and at what time?

[quote]
> This will be the last draft update before our meeting next week to allow everyone time to read it and prepare.
[\quote]