Subject: Re: [OAUTH-WG] OAuth session at IETF-79

From: Eliot Lear <[email-masked]>
Date: Fri, 15 Oct 2010 13:22:49 +0200

On 10/15/10 1:13 PM, [email-masked] wrote:
> What is the alternative from your point of view?
>
Continued use of the mailing list, as long as we think that's working.

Eliot

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 15 Oct 2010 14:40:11 +0300

Hi Torsten, 

there is no problem with skipping a meeting. This is done in other working groups as well. 

Ciao
Hannes

On Oct 15, 2010, at 2:22 PM, Eliot Lear wrote:

> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: [email-masked]
Date: Fri, 15 Oct 2010 11:13:08 +0000

Regards,
Torsten.
------Originalnachricht------
Von: Eliot Lear
An:[email-masked]
Cc:Lodderstedt, Torsten
Cc:[email-masked]
Betreff: Re: [OAUTH-WG] OAuth session at IETF-79
Gesendet: 15. Okt. 2010 13:10

 I agree with Hannes' approach.  What happened in Maastricht was that we
ended up with  bifurcated discussions- in the room and on the list. 
That didn't seem very productive.

Gesendet mit BlackBerry® Webmail von Telekom Deutschland

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Fri, 15 Oct 2010 15:11:29 +0300

Hi Torsten,

We have to figure out what the most efficient way is to get our work
done. 

With the Prague IETF we will see again whether there is a need for
face-to-face meeting. We had phone conference calls earlier this year as
well. That's another option to make progress in addition to the usage of
the mailing list.  

Attending the IETF meetings is useful to get a better understanding of
the big picture and that's why I go there.  However, I understand that
others have travel restrictions. Meetings outside the US, like this one,
are obviously more expensive for those who are based in the US. 
 
Ciao
Hannes

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of ext [email-masked]
> Sent: Friday, October 15, 2010 2:13 PM
> To: Eliot Lear; [email-masked]
> Cc: [email-masked]
> Subject: Re: [OAUTH-WG] OAuth session at IETF-79
> 
> Gesendet mit BlackBerry(r) Webmail von Telekom Deutschland

---

From: David Recordon <[email-masked]>
Date: Fri, 15 Oct 2010 10:52:07 -0700

Hey Hannes, I'd like to at least explain my reasoning behind not planning to
go to the China meeting because it really isn't restrictions around travel.
This is likely inpolitic to say, but it's because of how much of a waste of
my time the LA meeting was. The LA meeting contained numerous people who
weren't – and still aren't – engaged in this working group who felt that
they should argue with us repeatedly around how what we were doing was wrong
and already solved by Kerberos. That trip was only two days, but China will
easily be a week. So for me it is about what is the best use of my time, not
just how much it costs.

I'd love to have another face to face meeting between people working
actively on deploying OAuth 2.0. I hope that IIW in a few weeks will provide
a venue for some of that. But if it's in Europe then I'll go to Europe. For
me it is about who is (and isn't) going to be there rather than where the
meeting is physically located.

--David

On Fri, Oct 15, 2010 at 5:11 AM, Tschofenig, Hannes (NSN - FI/Espoo) <
[email-masked]> wrote:

> > An:[email-masked]<[email-masked]>
> > Cc:Lodderstedt, Torsten
> > Cc:[email-masked] <[email-masked]>

---

From: Torsten Lodderstedt <[email-masked]>
Date: Sat, 16 Oct 2010 11:47:21 +0200

Am 15.10.2010 19:52, schrieb David Recordon:
> Hey Hannes, I'd like to at least explain my reasoning behind not 
> planning to go to the China meeting because it really isn't 
> restrictions around travel. This is likely inpolitic to say, but it's 
> because of how much of a waste of my time the LA meeting was. The LA 
> meeting contained numerous people who weren't – and still aren't – 
> engaged in this working group who felt that they should argue with 
> us repeatedly around how what we were doing was wrong and already 
> solved by Kerberos. That trip was only two days, but China will easily 
> be a week. So for me it is about what is the best use of my time, not 
> just how much it costs.
>
> actively on deploying OAuth 2.0. I hope that IIW in a few weeks will 
> provide a venue for some of that. But if it's in Europe then I'll go 
> to Europe. For me it is about who is (and isn't) going to be there 
> rather than where the meeting is physically located.

I fully agree with you. Unfortunately, I had assumed to meet the WG 
people at IETF meetings and it's to late for me to arrange for a travel 
to IIW (mainly du to administrative proccess).

regards,
Torsten.
>
> --David
>
>
> On Fri, Oct 15, 2010 at 5:11 AM, Tschofenig, Hannes (NSN - FI/Espoo) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi Torsten,
>
>     > From: [email-masked] <mailto:[email-masked]>
>     [mailto:[email-masked] <mailto:[email-masked]>]
>     <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     > Cc: [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     > Cc:Lodderstedt, Torsten
>     > Cc:[email-masked] <mailto:[email-masked]>
>     > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 24 Oct 2010 19:11:17 +0300

Hi David, 

I believe that there is lot of other work in the IETF with relevance to OAuth. For example, at this IETF meeting the topics of interest are: 

* Web related working groups in the APPS area.
* Security area, including the recently created ABFAB working group (see http://datatracker.ietf.org/wg/abfab/).
* O&M area particularly regarding AAA in context to ABFAB.  
* I also believe it is useful to talk to the RAI area people since you will find the cellular operator community there. There is a lot of excitement for putting applications on mobile phones. Getting a better idea how those people think may be helpful. 

This list can easily grow if you are interested in work beyond OAuth (for example on work related to the recent real-time communication in the browser workshop).

It may be worth mentioning that there is always the chance to talk to lots of people who have a long history in the development of communication protocols.  

Ciao
Hannes

PS: You mentioned the Kerberos people showing up at an earlier meeting. I still think it is very useful to take a look at the design of Kerberos given the strong relationship between Kerberos and OAuth. I little while ago I made an interview with two MIT folks about the Kerberos design: http://www.tschofenig.priv.at/kerberos/Kerberos.mp3

On Oct 15, 2010, at 8:52 PM, David Recordon wrote:

> Hey Hannes, I'd like to at least explain my reasoning behind not planning to go to the China meeting because it really isn't restrictions around travel. This is likely inpolitic to say, but it's because of how much of a waste of my time the LA meeting was. The LA meeting contained numerous people who weren't – and still aren't – engaged in this working group who felt that they should argue with us repeatedly around how what we were doing was wrong and already solved by Kerberos. That trip was only two days, but China will easily be a week. So for me it is about what is the best use of my time, not just how much it costs.
> 
> I'd love to have another face to face meeting between people working actively on deploying OAuth 2.0. I hope that IIW in a few weeks will provide a venue for some of that. But if it's in Europe then I'll go to Europe. For me it is about who is (and isn't) going to be there rather than where the meeting is physically located.
> 
> --David
> 
> 
> On Fri, Oct 15, 2010 at 5:11 AM, Tschofenig, Hannes (NSN - FI/Espoo) <[email-masked]> wrote:
> Hi Torsten,
>