Subject: Re: [OAUTH-WG] OAuth 2.0 for Native Apps: open source client libraries for Android and iOS now available

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 11 Mar 2016 10:54:41 +0100

Hi William,

sorry for the late response but I just wanted to note that I really
appreciate your efforts around making code available for specifications
we are developing. The implementation efforts that take place currently
with specification writing have always provided a lot of valuable feedback.

I will take a look at your libraries in the near future since I am
interested in using those myself for the IoT environment.

Ciao
Hannes

On 02/26/2016 08:30 PM, William Denniss wrote:
> The Google Identity team this week open sourced AppAuth for Android and
> iOS. AppAuth is a client library for OAuth that enables native Android
> and iOS apps to perform authorization flows in a secure and usable way
> using in-app browser tabs (Custom Tabs on Android,
> SFSafariViewController on iOS), fully supporting the draft best practice
> <https://tools.ietf.org/html/draft-ietf-oauth-native-apps> for
> performing standards-based auth in native apps.
> 
> The libraries are opinionated and follow the draft best practice
> completely. Low-level protocol APIs are exposed allowing customizability
> including the ability to support OAuth extensions and custom parameters.
> Higher level convenience APIs are also provided to assist with auth
> state management, and encapsulate common requests like exchanging the
> authorization code and making API calls with fresh tokens.
> 
> You can grab the code here:
> https://openid.github.io/AppAuth-Android
> https://openid.github.io/AppAuth-iOS
> 
> The library should work with any Authorization Server that supports
> public clients with custom URI scheme and/or app-claimed HTTPS redirects
> (custom URI schemes are still required for full backwards compatibility
> support, though on newer systems app-claimed HTTPS links are viable –
> both are supported by the library). We have verified interop with the
> Google and PingFederate OAuth implementations.
> 
> Please give it a spin, and let me know how it works with your own
> implementations!
> 
> 
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

---

From: Eduardo Gueiros <[email-masked]>
Date: Thu, 31 Mar 2016 16:45:53 -0600

Any plan to bring the libraries to more “young” languages like Swift in iOS and Kotlin in Android?

> On Feb 26, 2016, at 12:30 PM, William Denniss <[email-masked]> wrote:
> 
>

---

From: Dominick Baier <[email-masked]>
Date: Fri, 1 Apr 2016 07:06:07 +0200

I am working on a xplat library for .net/xamarin iOS, Android, WinPhone, Windows written in C#.

https://github.com/IdentityModel/IdentityModel.OidcClient

We are making good progress, but the xplat crypto story is the hardest part here.

If anybody wants to contribute, contact me via github.

— 
cheers
Dominick Baier

On 1 April 2016 at 00:46:03, Eduardo Gueiros ([email-masked]) wrote: