Subject: [OAUTH-WG] Martin Duke's No Objection on draft-ietf-oauth-jwsreq-32: (with COMMENT)

From: Martin Duke via Datatracker <[email-masked]>
Date: Tue, 06 Apr 2021 12:12:45 -0700

Martin Duke has entered the following ballot position for
draft-ietf-oauth-jwsreq-32: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-oauth-jwsreq/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

After reading Sec 10.5, I was a little unclear how the client and auth server
necessarily achieve interoperability, but I think it's just an editorial fix.

If the server advertises that a signed object is required, then it cannot
communicate with a client that does not support the extension. But if the
object_required metadata is missing, then what is the metadata that tells the
client to use a signed object if it can?

IIUC the answer is that the server metadata includes the
request_object_signing_alg_values_supported and/or
request_object_encryption_alg_values_supported parameter in the metadata. It
might be helpful to spell that out here.

Is this correct?

---

From: Mike Jones <[email-masked]>
Date: Thu, 8 Apr 2021 04:44:43 +0000

Thanks for your review, Martin.  We've published https://tools.ietf.org/html/draft-ietf-oauth-jwsreq-33 to address your and other IESG comments.

Responses are inline below, prefixed by "Mike>".

-----Original Message-----
From: Martin Duke via Datatracker <[email-masked]> 
Sent: Tuesday, April 6, 2021 12:13 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Martin Duke's No Objection on draft-ietf-oauth-jwsreq-32: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

After reading Sec 10.5, I was a little unclear how the client and auth server necessarily achieve interoperability, but I think it's just an editorial fix.

If the server advertises that a signed object is required, then it cannot communicate with a client that does not support the extension. But if the object_required metadata is missing, then what is the metadata that tells the client to use a signed object if it can?

IIUC the answer is that the server metadata includes the request_object_signing_alg_values_supported and/or request_object_encryption_alg_values_supported parameter in the metadata. It might be helpful to spell that out here.

Is this correct?

Mike> Yes, correct.  I've added the clarifying point that you suggested by adding this paragraph to the end of Section 10.5:
	    Note that even if "require_signed_request_object"
	    metadata values are not present, the client MAY use signed request objects,
	    provided that there are signing algorithms mutually supported by the client and the server.
	    Use of signing algorithm metadata is described in Section 4.

				Thanks again,
				-- Mike