Subject: [today] New draft for IANA considerations change

From: Thomas Roessler <[email-masked]>
Date: Thu, 19 Jul 2001 11:29:12 +0200

I'll submit a version with the following IANA considerations section 
at 1900 GMT, today.  Please raise any objections NOW.

Changes:

- asc and sig are given as extensions for application/pgp-signature
- no Macintosh file type is given for application/pgp-keys

This version is based on a conversation with Werner Koch.  I have 
received no further feed-back from NAI.

>9.  IANA Considerations
>
>   This document defines three media types: "application/pgp-encrypted",
>   "application/pgp-signature" and "application/pgp-keys". The following
>   sections specify the IANA registrations for these types.
>
>9.1.  Registration of the application/pgp-encrypted media type
>
>   MIME media type name: application
>   MIME subtype name: pgp-encrypted
>   Required parameters: none
>   Optional parameters: none
>
>   Encoding considerations:
>
>      Currently this media type always consists of a single 7bit text
>      string.
>
>   Security considerations:
>
>      See Section 8 and RFC 2440 Section 13.
>
>   Interoperability considerations: none
>
>   Published specification:
>
>      This document.
>
>   Additional information:
>
>      Magic number(s): none
>      File extension(s): none
>      Macintosh File Type Code(s): none
>
>   Person & email address to contact for further information:
>
>      Michael Elkins
>      Email: [email-masked]
>
>   Intended usage: common
>
>   Author/Change controller:
>
>      Michael Elkins
>      Email: [email-masked]
>
>
>9.2.  Registration of the application/pgp-signature media type
>
>   MIME media type name: application
>   MIME subtype name: pgp-signature
>   Required parameters: none
>   Optional parameters: none
>
>   Encoding considerations:
>
>      The content of this media type always consists of 7bit text.
>
>   Security considerations:
>
>      See Section 8 and RFC 2440 Section 13.
>
>   Interoperability considerations: none
>
>   Published specification:
>
>      RFC 2440 and this document.
>
>   Additional information:
>
>      Magic number(s): none
>      File extension(s): asc, sig
>      Macintosh File Type Code(s): pgDS
>
>   Person & email address to contact for further information:
>
>      Michael Elkins
>      Email: [email-masked]
>
>   Intended usage: common
>
>   Author/Change controller:
>
>      Michael Elkins
>      Email: [email-masked]
>
>
>9.3.  Registration of the application/pgp-keys media type
>
>   MIME media type name: application
>   MIME subtype name: pgp-keys
>   Required parameters: none
>   Optional parameters: none
>
>   Encoding considerations:
>
>      The content of this media type always consists of 7bit text.
>
>   Security considerations:
>
>      See Section 8 and RFC 2440 Section 13.
>
>   Interoperability considerations: none
>
>   Published specification:
>
>      RFC 2440 and this document.
>
>   Additional information:
>
>      Magic number(s): none
>      File extension(s): asc
>      Macintosh File Type Code(s): none
>
>   Person & email address to contact for further information:
>
>      Michael Elkins
>      Email: [email-masked]
>
>   Intended usage: common
>
>   Author/Change controller:
>
>      Michael Elkins
>      Email: [email-masked]
>

-- 
Thomas Roessler                        http://log.does-not-exist.org/

---

From: John W Noerenberg II <[email-masked]>
Date: Thu, 19 Jul 2001 13:35:09 -0700

>received no further feed-back from NAI.

We'll let the Mac stuff go.  The files are self-describing.  Mac 
implementers are just going to have to figure it out from the content 
of the files.  The file types are parameters on the MIME labels.
But the file types are a local issue, not something for over the 
wire, anyway....

I compared -07 and -08.  Changes are fine.
- -- 

john noerenberg
[email-masked]
   --------------------------------------------------------------------------
   Peace of mind isn't at all superficial, really.  It's the whole thing.
   That which produces it is good maintenance; that which disturbs it
   is poor maintenance.
   -- Zen and the Art of Motorcycle Maintenance, Robert M. Pirsig, 1974
   --------------------------------------------------------------------------