Subject: test vectors for DSA

From: "Hari Hara Sudhan" <[email-masked]>
Date: Tue, 27 Mar 2007 18:41:07 +0530

Hello every one,

Iam looking for DSA test vectors for p (1024, 2048) and q (160, 224,256)
Does any one have test vectors for the above mentioned sizes.
Thanking you in advance

with regards,
R.Hari Hara Sudhan

---

From: David Shaw <[email-masked]>
Date: Tue, 27 Mar 2007 10:19:51 -0400

> Does any one have test vectors for the above mentioned sizes.

Sure, check out http://www.jabberwocky.com/openpgp/dsa2.tar.gz

There is a README file in there that gives the exact details, but
briefly, there are samples of:

 p=1024 q=160
 p=2048 q=224
 p=3072 q=256
 p=7680 q=385
 p=15360 q=512

David