Subject: [OFFTOPIC] Editor under GNU/Linux

From: "Arturo 'Buanzo' Busleiman" <[email-masked]>
Date: Thu, 15 Mar 2007 18:56:50 -0300

Sorry to bother: Any recommendation on a text editor to use that supports all formatting
requirements for an Internet Draft? My googling so far has only provided a MS Word template.

- --
Arturo "Buanzo" Busleiman - Consultor Independiente en Seguridad Informatica
Enigform for Firefox: A secure browsing experience: http://enigform.mozdev.org
Mail Hosting Seguro y Consultoria - http://www.buanzo.com.ar/pro/

---

From: "Arturo 'Buanzo' Busleiman" <[email-masked]>
Date: Thu, 15 Mar 2007 23:35:01 -0300

Simon Josefsson wrote:
> I recommend any text editor and the xml2rfc tool:
> http://xml.resource.org/
> See also RFC 2629.

Yes, I finished reading that! I'll try nroff with the ms module (and the fix.pl script) and xml2rfc,
too. XML with the DTD sounds far better, but all XML DTD modes are for things like "emacs". I'd
rather use joe :P

Thanks for your time. I'll do my best, publish the Draft in this list, and ask for feedback :)

- --

---

From: Simon Josefsson <[email-masked]>
Date: Fri, 16 Mar 2007 03:31:10 +0100

http://xml.resource.org/

See also RFC 2629.

/Simon

---

From: Simon Josefsson <[email-masked]>
Date: Fri, 16 Mar 2007 03:52:37 +0100

> too. XML with the DTD sounds far better, but all XML DTD modes are for things like "emacs". I'd

You don't need XML support in your editor, joe will be fine.  If you
want a XML file to start editing from, have a look at:

http://josefsson.org/openpgp-header/draft-josefsson-openpgp-mailnews-header.xml

Good luck!

/Simon

---

From: Jon Callas <[email-masked]>
Date: Sat, 17 Mar 2007 20:12:29 -0700

> I recommend any text editor and the xml2rfc tool:

Use xml2rfc. It's really the way to go these days.

The tool I'm using is a perl script that Tim Dierks created when he  
was doing the TLS spec. It's good enough that I've never moved to  
xml2rfc, but there are so many nice things about the XML one that you  
should use it. It will do all the right boilerplate and crap. That  
changes often and you'll tear your hair out doing it yourself. It  
took me ten days (!) to get bis19 changed to meet all the stupid crap  
that isn't documented anywhere.

	Jon

---

From: "Arturo 'Buanzo' Busleiman" <[email-masked]>
Date: Sun, 18 Mar 2007 09:16:14 -0300

> Use xml2rfc. It's really the way to go these days.

Yes, most definitely. Simon is already helping me out with some of the details. I hope to post the
beta Draft asap. Thanks for your time, Jon!

- --
Arturo "Buanzo" Busleiman - Consultor Independiente en Seguridad Informatica
Foros GNU/Buanzo: Respeto, Soluciones y Buena Onda: http://foros.buanzo.com.ar
Consulting and Secure Mail Hosting: http://www.buanzo.com.ar/pro/