Subject: [openpgp] I-D Action: draft-ietf-openpgp-crypto-refresh-00.txt

From: [email-masked]
Date: Fri, 29 Jan 2021 08:34:44 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Open Specification for Pretty Good Privacy WG of the IETF.

        Title           : OpenPGP Message Format
        Authors         : Werner Koch
                          Paul Wouters
	Filename        : draft-ietf-openpgp-crypto-refresh-00.txt
	Pages           : 94
	Date            : 2021-01-29

Abstract:
   This document is maintained in order to publish all necessary
   information needed to develop interoperable applications based on the
   OpenPGP format.  It is not a step-by-step cookbook for writing an
   application.  It describes only the format and methods needed to
   read, check, generate, and write conforming packets crossing any
   network.  It does not deal with storage and implementation questions.
   It does, however, discuss implementation issues necessary to avoid
   security flaws.

   OpenPGP software uses a combination of strong public-key and
   symmetric cryptography to provide security services for electronic
   communications and data storage.  These services include
   confidentiality, key management, authentication, and digital
   signatures.  This document specifies the message formats used in
   OpenPGP.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-openpgp-crypto-refresh/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-openpgp-crypto-refresh-00.html

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Paul Wouters <[email-masked]>
Date: Fri, 29 Jan 2021 11:59:31 -0500 (EST)

On Fri, 29 Jan 2021, [email-masked] wrote:

> Subject: [openpgp] I-D Action: draft-ietf-openpgp-crypto-refresh-00.txt

> https://www.ietf.org/archive/id/draft-ietf-openpgp-crypto-refresh-00.html

Hi,

We have uploaded the first document in the process described by the chairs
to fold in the changes of 4880bis into the crypto-refresh document.

The -00 document is just the re-generated version of RFC4880. The only
changes are the updated boilerplate and generating code differences of
the xml tools over the years, as well as the document author, role and
name/time of the draft.

You can see the diff with RFC4880 using this url:

https://tools.ietf.org//rfcdiff?url1=https://tools.ietf.org/rfc/rfc4880.txt&url2=https://www.ietf.org/archive/id/draft-ietf-openpgp-crypto-refresh-00.txt

Since this document is marked a succeeding the rfc4880bis-10 draft,
using the diff between the "last two versions" is not very helpful
in this case.

Please let us know if you see any issue of this document representing
the state of RFC4880. We will send out the -01 version in the next
couple of days.

Paul & Werner

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Fri, 29 Jan 2021 21:14:49 -0500

> the xml tools over the years, as well as the document author, role and

Thanks for this, Paul!

> https://tools.ietf.org//rfcdiff?url1=https://tools.ietf.org/rfc/rfc4880.txt&url2=https://www.ietf.org/archive/id/draft-ietf-openpgp-crypto-refresh-00.txt

I've reviewed this diff and I don't see any substantive changes from RFC
4880 -- just minor formatting differences.  I hope other folks on the
list will take a minute or two to confirm that they're also seeing the
same situation.

I've proposed some document editing workflow clarifications over on
https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/31, including
an ephemeral section (to be removed when we make it to an RFC) that
describes how to collaborate on the document.

The proposed ephemeral section merely echos what we've discussed here,
saying:

>> # Document Workflow
>> 
>> This document is built from markdown using [ruby-kramdown-rfc2629](https://rubygems.org/gems/kramdown-rfc2629), and tracked using [git](https://git-scm.com/).
>> The markdown source under development can be found in the file `crypto-refresh.md` in the `main` branch of the [git repository](https://gitlab.com/openpgp-wg/rfc4880bis).
>> Discussion of this document should take place on the [[email-masked] mailing list](https://www.ietf.org/mailman/listinfo/openpgp).
>> 
>> A non-substantive editorial nit can be submitted directly as a [merge request](https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/new).
>> A substantive proposed edit may also be submitted as a merge request, but should simultaneously be sent to the mailing list for discussion.
>> 
>> An open problem can be recorded and tracked as [an issue](https://gitlab.com/openpgp-wg/rfc4880bis/-/issues) in the gitlab issue tracker, but discussion of the issue should take place on the mailing list.
>> 
>> \[Note to RFC-Editor: Please remove this section on publication.\]

The merge request also includes a nice contribution to the Makefile from
Vincent Breitmoser for how someone comfortable with docker can build the
draft from source.  Thanks, Vincent!

If the editors are comfortable with this change, it'd be great to merge
it into the main branch before we release -01.

> We will send out the -01 version in the next couple of days.

Looking forward to it!

        --dkg