Subject: Re: Instance ID for virtual interface

From: "Joyal, Daniel R (Daniel)" <[email-masked]>
Date: Mon, 6 Jan 2003 14:57:56 -0500

Hi Toshiaki,

 I can add this.

-Dan

> -----Original Message-----
> From: Toshiaki Takada [mailto:[email-masked]]
> Sent: Friday, January 03, 2003 9:43 PM
> To: [email-masked]
> Subject: Instance ID for virtual interface
>
>
> Hi,
>
> I have one question.
>
> OSPFv3 packet header includes 1 octet "Instance ID" so that
> it allows running multiple instances on a single link.
>
> I thought "Instance ID" for Virtual interfaces could be
> configured as well.  I looked through OSPFv3 MIB draft,
> however "ospfv3VirtIfTable" table doesn't have Instance ID
> object in the entry.
>
> My question is, should we have "ospfv3VirtIfInstId" object
> like "ospfv3IfTable", or isn't it allowed to configure
> instance ID over virtual link?
>
> -- Toshiaki Takada
>

---

From: Toshiaki Takada <[email-masked]>
Date: Mon, 6 Jan 2003 17:06:33 -0800

Dan/Vishwas,

Thanks for clarification.

BTW, there is another question.  OSPFv3 supports handling
for unknown type of LSAs, but in the draft of OSPFv3 MIB,
ospfv3AsLsdbType, ospfv3AreaLsdbType and ospfv3LinkLsdbType
seems to accept only known type of LSAs.

Is my understanding wrong?

Thanks,

-- Toshiaki Takada

At Mon, 6 Jan 2003 14:57:56 -0500,

---

From: Acee Lindem <[email-masked]>
Date: Tue, 7 Jan 2003 01:45:42 -0500

> seems to accept only known type of LSAs.

Hello Takada-san,

This is a reflection of the fact that an LSA is maintained
at its respective flooding scope (AS, Area, or Link). For
example, ospfv3AsLsdbType is simply a MIB variable corresponding
to the LSA type for LSAs maintained in the AS level Link State
Database (LSDB).

Thanks,
Acee

--
Acee