Subject: Determining which LSA is newer

From: "Banerjee, Gargi" <[email-masked]>
Date: Thu, 16 Jan 2003 10:32:13 -0500

Hi,
I had a question regarding section 13.1 (Determining which lsa is newer) in
rfc 2328.
Bullet 3 in the above section says :

Else, if only one of the instances has its LS age field set
to MaxAge, the instance of age MaxAge is considered to be
more recent.

I was wondering why we are specific about exactly one of the lsas being of
maxage.
What if we receive a maxaged lsa and the current copy in the database
maxages at exactly
the same time.
According to section 13.1 these two lsas will be considered identical
(assuming sequence number etc. is the same).
However, what could be the possible disadvantage of
treating the received maxage lsa as the more current one, replacing the
database copy with this lsa and flooding it out to our neighbors.

Thanks in advance,
Gargi

---

From: Acee Lindem <[email-masked]>
Date: Thu, 16 Jan 2003 10:42:08 -0500

> database copy with this lsa and flooding it out to our neighbors.

Hello Gargi,

In either case, the LSA is purged from the OSPF routing domain.
Hence, I don't see any disadvantage to considering the two MAXAGE'ed LSA
instances identical.

Thanks,
Acee

--
Acee