Subject: [Fwd: Re: GR/NSF Terminology]

From: Acee Lindem <[email-masked]>
Date: Thu, 30 Jan 2003 14:19:41 -0500

I support changing "hitless" to "graceful" in the
OSPF draft to be consistent with the other protocol documents.
I'll leave the file name the same for continuity but it will be
"graceful restart" once it is published as an RFC. Any thoughts on
this? This change would be based on a discussion on the main
routing discussion list (see below).

-------- Original Message --------
Subject: Re: GR/NSF Terminology
Date: Thu, 30 Jan 2003 08:33:58 -0700
From: Danny McPherson <[email-masked]>
Reply-To: [email-masked]
To: [email-masked]

 > The OSPF document you cite defines various terms, but in an
 > OSPF-specific fashion.  Furthermore, the definitions are not
 > collected anywhere in the document but are peppered throughout it...
 > which is fine in context but doesn't lend itself to generic use of
 > the terms.

Agreed.

 > Seems like there are two things we could do:
 >
 > First, leave the documents as they are.  This is my preferred
 > alternative.  The docs are relatively well advanced in terms of
 > specification and even deployment, and doing what would be a
 > non-trivial update solely for the purpose of aligning terminology
 > strikes me a being work for work's sake.  This is doubly true because
 > a major terminology change creates the risk of introducing subtle
 > errors to the spec if one isn't careful.  Apart from aesthetics, what
 > need do you think is fulfilled by aligning the specs?
 >
 > Alternately, if we do want to go ahead and change the specs, then a
 > (generic) definitions document such as you have volunteered to write
 > seems a necessity.  I'm not a fan of "framework" documents and I hope
 > we could keep the scope of the proposed definitions document focused.

OK, so folks don't seem to be to keen on the idea at this point.
Given that I'm not attached to the idea of more work "for the
sake of work" then I'll drop it.  I believe there is room for
commonality but look where that's got me in PWE3 *8^/

 > By the way, I think "graceful restart" has historic precedence over
 > "hitless restart" if you want to align terms :-).

Agreed.

-danny

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

--
Acee

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Thu, 30 Jan 2003 11:25:27 -0800

I fully support "graceful restart"

Padma

---

From: Rahul Aggarwal <[email-masked]>
Date: Thu, 30 Jan 2003 11:27:13 -0800

Hi Acee,

> routing discussion list (see below).

I think that is a good idea. It will also help in making sure we don't
have another terminology document being written :)

thanks,
rahul