Subject: Timing of MaxAge LSAs

From: Rohit Gupta <[email-masked]>
Date: Sun, 23 Feb 2003 19:40:00 -0800

Hi,
Suppose i am advertising an LSA, say AS-External LSA.
Now that route goes off and i advertise the same LSA
with age set to MaxAge. Now it again comes up after
some time (with interval less than MinLSInterval). I
cannot originate a new LSA because of the
MinLSInterval gap for which i have to anyway wait.
Once this interval is over i will originate a copy of
this LSA. But what if it again goes down before my
MinLSInterval period expires.

Should an implementation
1> Originate a new LSA and then again flush it
OR
2> Should i not do anything because i know that the
route has anyway gone down.

Given the granularity of this timer (and maybe some
others too!) isnt it a little difficult to achieve
sub-second convergence?

Regards,
Rohit

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/

---

From: Acee Lindem <[email-masked]>
Date: Sun, 23 Feb 2003 23:00:03 -0500

> route has anyway gone down.

Externally, origination should appear as the latter.
However, keep in mind that the only time flooding
can be suppressed is if an LSA is MaxAged while
waiting MinLSInterval to expire AND the sequence
number is the initial sequence number (0x80000001).

> others too!) isnt it a little difficult to achieve

This OSPF constant can delay convergence but it
is more a factor with router LSAs. For external LSAs,
I think you want some holddown between originations
and I don't think 5 seconds is unreasonable.

--
Acee

---

From: Rohit Gupta <[email-masked]>
Date: Sun, 23 Feb 2003 20:26:31 -0800

Acee,
> number is the initial sequence number (0x80000001).

And what if its not ISN. In my particular case it wont
be!

Theoretically i understand that the latter is the
desired behaviour but do implementations actually do
that when sending a MaxAge LSA (scan thru the Rxmt
lists, etc and block the origination!)

> and I don't think 5 seconds is unreasonable.

But this timer is applied for all the LSAs ..
including the Router LSA. AS-External-LSA was just an
example which i was taking ..

Has anyone thought on these lines or is there some
work which has been done over this.

I for one would certainly be interested in knowing
more about it.

Regards,
Rohit

---

From: Yasuhiro Ohara <[email-masked]>
Date: Wed, 26 Feb 2003 04:41:55 +0900

We have studied the relationship between fixed-timer protocol feature
(MinLSInterval, MinLSArrival) and the route flaps.

The copy of our paper can be retrieved at:
http://www.sfc.wide.ad.jp/~yasu/saint2003.pdf
Manav and I submitted the paper to the workshop of Saint2003.

The paper is efficient in that the new correlation between OSPF protocol
and convergence property was found. I agree that we all knew the fact
that fixed-timer can affect adversely to convergence, but I guess
we did not know how bad the effect is, at least in the way that
we described in our paper.

The paper is short in that the situation is rare in reality.
The configuration of experiment is not like the real network.
And the assumption that our paper implicitly has, which is
"There should be multiple paths to the identical destination",
may be wrong.

regards,
yasu

From: Rohit Gupta <[email-masked]>
Subject: Re: Timing of MaxAge LSAs
Date: Sun, 23 Feb 2003 20:26:31 -0800