Subject: OSPF---out of band

From: alok <[email-masked]>
Date: Tue, 11 Feb 2003 14:03:06 +0530

Hi,

As far as I understand, the OSPF protocol always sends LSA on "the links
which it advertises and forms adjacencies"

there is something referred to as passive, but then one cant form
adjacencies over passive links..............

assuming there are 2 links between Node A and Node B one is 64kbps other is
100Mbps...

i need to use the 64kbps link to establish OSPF adjacencies and pass the LSA
information etc over it.

however i want the traffic to use the 100Mbps link...

so essentially, i want ospf to do the following:

for this 2 node network OSPF should have something like

for destination on node B , next-hop is via 100Mbps between node A and B
but, the interfaces themseleves are "passive" interfaces....

is there anyway this can be done?

in BGP this would be "destn network x.y.z.w" next-hop interface ip of B
which is directly connected...

so one could run BGP out-of-band over the 64Kbps but still put a next hop to
the other interface.....
so BGP doesnt even run on the 100Mbps link, it runs on the 64Kbps
link.....(signalling is segregated) but the forwarding is still over
100Mbps....
how does one do this in OSPF?

another this which is confusing is that if the interface doesnt have an
"IP"...(unnumbered P2P) the RFC 2328 says:

                     If the neighboring router is fully adjacent, add a
                    Type 1 link (point-to-point). The Link ID should be
                    set to the Router ID of the neighboring router. For
                    numbered point-to-point networks, the Link Data
                    should specify the IP interface address. For
                    unnumbered point-to-point networks, the Link Data
                    field should specify the interface's MIB-II [Ref8]
                    ifIndex value. The cost should be set to the output
                    cost of the point-to-point interface.

so essentially, all i know is that it will be router-id X is next hop over
so and so P2P link....or the 64k link??????

how does one segregate the link-ids? so that each link is uniquely
identified....
and even if there is a way to "segregate" it out, how does one put that
100Mbps in the forwarding table and not the 64kbps?

is there any draft/document i can refer to for the same?

-thanks and rgds
Alok

---

From: Acee Lindem <[email-masked]>
Date: Tue, 11 Feb 2003 08:48:25 -0800

Hi Alok,

> adjacencies over passive links..............

passive interfaces are not part of the base OSPF specification (although
they are handled similiar to OSPF hosts).

> i need to use the 64kbps link to establish OSPF adjacencies and pass the LSA

It is can't be done using the vanilla OSPF. There has never been a strong
requirement for OSPF to use links other than the ones over which adjacencies
are established.

--
Acee

---

From: Yasuhiro Ohara <[email-masked]>
Date: Wed, 12 Feb 2003 02:50:32 +0900

> requirement for OSPF to use links other than the ones over which adjacencies

Agree to Acee, and wondered what is the reason that you don't want
the OSPF to run on (or to form an adjacency over) the 100Mbps link ?
I guess the merit which is that any failures in L3 can be detected
is always prefered over the demerit of bandwidth consumption.

regards,
yasu

---

From: alok <[email-masked]>
Date: Wed, 12 Feb 2003 12:29:18 +0530

I could still detect link failures and pass them over the 64kbps link?

I dont think OSPF is needed to detect "link failures" ..the kernel itself
would do it...?..physical link being up/down is kernel's problem...

as far as L3 failure goes...can you give me a "specific" example? where you
say "L3 is down" but "L2 is up"...(assume unnumbered interfaces)...mismatch
in config?

fine, as i said that isnt a concern...i have 100Mbps unnumbered (P2P) link
and 64kbps P2P link.

OSPF hellos mainly would be used to detect "routing node" failures which
would anyway be passed over via the other link in this case..

---

From: Manav Bhatia <[email-masked]>
Date: Wed, 12 Feb 2003 12:31:23 +0530

Alok,
> would do it...?..physical link being up/down is kernel's problem...

Kernel will tell you if your own physical link went down. How do you think
you will come to know if the link at the other end of your adjaceny went
down?

--
Manav

> > > > i need to use the 64kbps link to establish OSPF adjacencies and
pass
> the LSA

---

From: alok <[email-masked]>
Date: Wed, 12 Feb 2003 12:41:08 +0530

> you will come to know if the link at the other end of your adjaceny went

"serial is up, line protocol is down"......

L2 is end to end i guess....or assumed so....mebbe there are cases where
this might not be true...cant think of one though (on P2P)

eitherways the other end could still signal "his own end is down' over the
64kbps link?

if that went down..well thats the only place im supposed to send hello
packets via..so OSPF will faill...but I am fine with that...

assume that 64k was a DCC channel on an SDH mux?

---

From: Manav Bhatia <[email-masked]>
Date: Wed, 12 Feb 2003 12:42:26 +0530

I think my previous mail was a little ambiguous .. expounding more on it ..

Imagine what will happen when your 64kbps link on one end goes down You
will be tearing the adjacency and no traffic will flow even though you have
your 100Mbps link alive!

----- Original Message -----
From: "alok" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, February 12, 2003 12:29 PM
Subject: Re: OSPF---out of band

pass

---

From: alok <[email-masked]>
Date: Wed, 12 Feb 2003 13:00:15 +0530

i have a box infront of node-a and node -b
its basically a mux....
it has a seperate signalling channel/timeslots...
the link is provisioned over the mux (okie ill make that 100Mbps to 155Mbps
so that you call it oc-3 or STM-1)
the link between boxatnodeA and boxatnodeB is STM-1+64k
in the link between boxatnodeA and boxatnodeB i want to use the 64k part
(muxed out) for signalling..i can tap it out from my mux using some serial
cable and put it onto an interface..

essentially, assume that if the 64k is down the link between the 2 boxes is
down

you might say the last mile on the 64kbps to my router is down
too...fine..very rare..its something one can live with...

if it flaps..well we had a whole lot of things on hitless restart (which now
seems to be called graceful restart)....and we had reduction in LSAs using
the "triggered updates" ..making LSA refresh timer as infiinty etc...

if I can ensure that
1. if 64k is up, 155Mbps may be up or down (that is possible in my scenario)
2.but if 64k is down 155Mbps is down guaranteed

how do i look at this?

---

From: ROBERT PATHFINDER <[email-masked]>
Date: Wed, 12 Feb 2003 11:53:34 -0800

> too...fine..very rare..its something one can live

You may want to look at the proposals of the
deleted draft "draft-ietf-ospf-ppp-flood-" which
defines parallel point-to-point links between two
OSPF routers as equivalent links if they are part
of the same OSPF area.

Only of the equivalent links is required to be fully
adjacent and the others can remain in 2-Way state,
thereby preventing database exchanges and LSA flooding
over the non-adjacent equivalent links.

Also it requires modification of the routing table
calculation as it stores any of the equivalent links
that have least cost as the interface to reach next
hop
which is the directly connected neighbor in this case.

So if the STM-1 link is assumed to have minimum cost
between 64K and STM-1 then SRM-1 link could appear as
the interface to reach the neighbor router in the
forwarding table and IP datagram traffic forwarding
would then happen over the STM-1 link and OSPF DBD,
LSA flooding would be restricted over the 64K link.

However this requires changing the OSPF protocol
operation slightly.

> > I think my previous mail was a little ambiguous ..
> expounding more on it
> ..
> >
> > will be tearing the adjacency and no traffic will
> flow even though you
> have
> > your 100Mbps link alive!
> >
> > > I dont think OSPF is needed to detect "link
> failures" ..the kernel
> itself
> > > as far as L3 failure goes...can you give me a
> "specific" example? where
> > you
> > > say "L3 is down" but "L2 is up"...(assume
> unnumbered
> > interfaces)...mismatch
> > > in config?
> > >
> > > fine, as i said that isnt a concern...i have
> 100Mbps unnumbered (P2P)
> > link
> > > and 64kbps P2P link.
> > >
> > > > > > assuming there are 2 links between Node A
> and Node B one is 64kbps
> > > other is
> > > > > > 100Mbps...
> > > > > >
> > > > > It is can't be done using the vanilla OSPF.
> There has never been a
> > > strong
> > > > > requirement for OSPF to use links other than
> the ones over which
> > > adjacencies
> > > > > are established.
> > > >

=====
Somen Bhattacharya
E-Mail : [email-masked]

__________________________________________________
Do you Yahoo!?
Yahoo! Shopping - Send Flowers for Valentine's Day
http://shopping.yahoo.com