Subject: different costs!

From: Rohit Gupta <[email-masked]>
Date: Thu, 20 Feb 2003 23:21:08 -0800

Hi,
I have a very basic doubt.

 -------       -------
 | R-A |       | R-B |
 -------       -------
    |             |
  __|_____________|
           |
           |
         ------
         |R-C |
         ------

In this setup i have 3 routers on an ethernet. From
Router C's perspective can i assign different costs to
reach R-A and R-B? (I know it can be done in p2p
links). For example, can i somehow assign a cost to
reach R-A as 3 and R-B as say, 10, thus making all my
traffic to choose R-A as long as its up?

Any answers please?

Regards,
Rohit

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/

---

From: alok <[email-masked]>
Date: Fri, 21 Feb 2003 13:30:13 +0530

am not too sure.....

but i think if cost for R-B is higher than R-A........

in this case traffic coming back towards R-C will be preferred via R-A (for
any router connected further) above R-A and R-B etc...

so u can control the downstream  towards R-C that way

same as P2P in a way actually.... if you give different costs on either side
in P2P the same would happen

---

From: Rohit Gupta <[email-masked]>
Date: Fri, 21 Feb 2003 00:38:20 -0800

Rite ALok .. but my question is HOW do i set the costs
for these routers when both of them are on the same
ethernet.

I know it can be done on p2p links .. but my doubt is
in case of ethernet media where theoretically all the
nodes should be reachable with the same cost!

Isnt it so?

Rohit.

---

From: alok <[email-masked]>
Date: Fri, 21 Feb 2003 14:39:02 +0530

well...
"ip ospf cost" should work on BMA....

and the path computation from one router sees "its cost" not the cost of the
other guy..
so u can give different costs manually...whats wrong with it?

---

From: Rohit Gupta <[email-masked]>
Date: Fri, 21 Feb 2003 01:18:04 -0800

thanks !

I got it!

--- alok <[email-masked]> wrote:
> > > in this case traffic coming back towards R-C
> will be
> > > preferred via R-A (for
> > > so u can control the downstream  towards R-C
> that
> > > way
> > >
> > > > links). For example, can i somehow assign a
> cost
> > > to
> > > > reach R-A as 3 and R-B as say, 10, thus making
> all
> > > my

---

From: alok <[email-masked]>
Date: Fri, 21 Feb 2003 15:51:45 +0530

havent tested it.......
has anyone?

---

From: Shankar Agarwal <[email-masked]>
Date: Fri, 21 Feb 2003 09:51:20 -0800

I am not sure if i understood you fully. But as far as i know When
Router C advertises its Router LSA it gives only one cost to the
interface that it connects to broadcast network. So i don't think it is
possible to control the traffic just from configuring Router C. We can
make it take router A by configuring it so that the routes that A
advertises happens to have a lower cost then same routes advertised by
B. So Router C will see Router A as the preferred path.

---

From: Sina Mirtorabi <[email-masked]>
Date: Fri, 21 Feb 2003 10:08:19 -0800

Rohit

It would depends how your LAN is represented in SPF, so if you use
network type broadcast or NBMA there is no way to achieve it ( from RC )
as you will have only one adjacency to the DR and DR's cost to all the
attached routers is always 0

If you configure as point-to-multipoint then you can have cost
differently set for each neighbor and influence the path on RC

Sina

> -----Original Message-----
> From: Mailing List [mailto:[email-masked]] On
> Behalf Of Rohit Gupta
> Sent: Thursday, February 20, 2003 11:21 PM
> To: [email-masked]
http://taxes.yahoo.com/

---

From: alok <[email-masked]>
Date: Mon, 24 Feb 2003 12:25:42 +0530

no, i meant the reverse path..the traffic coming back from any router above
A and B will take this path