Subject: Re: Opaque LSA Timers...

From: Vivek Dubey <[email-masked]>
Date: Sat, 19 Apr 2003 07:45:26 -0000

Hi Acee,
Your reasons for not supporting such variations
are agreeable but:
    "If Ospf is providing a service to application (by
    mean of Opaque LSA), there is every reason for
    an application to except some priority service
    in case of requirements."

Because flooding of application specific information
shouldn't be entirely retricted by base protocol
flooding algorithm.

Possibly there is scope to explore ways to handle
such requirments in a generalized way.

thanks,
vivek

On Fri, 18 Apr 2003 Acee Lindem wrote :
>[email-masked] wrote:
>>Hi all,
>>i excuse me for this and previous observation, but
>>i considered the administrative group information very
>>important,
>>because i think they can come from network administrator or
>> from
>>any administrative tool and perhaps the administrator doesn' t
>>want
>>to wait MinLSInterval seconds to send his update;
>>so i thought was reasonable to do a separate timer for this
>>particular and important opaque field. Do you agree?
>
>Giovanni,
>
>I don't agree for (at least) the following reasons:
>
>   1. This is just one variation of the "re-originate the LSA
>faster"
>      requirement. We can't afford to have a separate solution
>for
>      each variation.
>   2. Multiple timers LSA Interval timers (which I assume you
>use
>      to advertise if any interval is satisfied) would add
>undue
>      complexity and overhead.
>   3. While we have Not-So-Stubby Areas I don't think we want
>      Not-So-Opaque LSAs. If the contents of the LSAs are truly
>      opaque they should not have ramifications on the base
>      flooding algorithm.
>
>Thanks,
>Acee
>
>
>>
>>I read there was proposals in the past to reduce or ignore
>>MinLSInterval, but i agree with the important presence of
>>MinLSInterval;
>>i only think to a separate management.
>>
>>Was this proposals (or drafts ) specific to my consideration and
>>did they refer
>>to the only Opaque administrative field?
>>
>>Thanks in advance for your answers and kindness.
>>
>>Giovanni
>>Coritel - Rome
>>
>
>
>--
>Acee

---

From: Acee Lindem <[email-masked]>
Date: Sat, 19 Apr 2003 06:21:33 -0400

> such requirments in a generalized way.

Hi Vivek,

A generalized solution to decrease flooding latency
would be the only thing that makes any sense.

Personally, I don't buy the argument that MinLSInterval
is too large an upper bound for the delay on
administrative TE changes to be flooded. However, that
really isn't the most important issue here.

--
Acee