Subject: Re: Working Group Last Call for draft-ietf-ospf-mib-update-06.txt

From: Daniel Joyal <[email-masked]>
Date: Wed, 30 Apr 2003 11:09:30 -0400

> -----Original Message-----
> From: Acee Lindem [mailto:[email-masked]]
> Sent: Tuesday, April 29, 2003 6:20 PM
> To: [email-masked]
> Subject: Re: Working Group Last Call for
> draft-ietf-ospf-mib-update-06.txt
>
>
> Hi Don,
>
> Some questions below:
>
> Don Goodspeed wrote:
> > Dan and all,
> >
> > Couple of things from my second review that I don't know if
> we want to
> > address or not: 1. Configuration of a TE metric at the
> interface level
> > (like ISIS).
>
> Do we really want this? It seems that if this were added,
> other TE stuff should be added as well.

What other TE stuff would we need?

>
> > 2. Text regarding the issue that some SNMP agents may not
> be able to
> > query the largest size of the ospfLsdbAdvertisement attribute.

I'll add some text.

> 3.
> > Adding new error codes to ospfConfigErrorType:
> invalidLength (actual
> > packet size did not match)
>
> What does this mean? That the OSPF packet length didn't match
> the IP packet length? I don't think we want people to check
> this since there is at least one extension that requires them
> not to match.

Do you mean cryptographic authentication?

>
> > , duplicateRouterIdReceived.

I will add this. It was previously suggested.

> > 4. Is it permitted (I can't remember) to add a single var-bind to a
> > previously defined notification.  If it is, can I suggest
> adding new
> > attributes for ospfIfEventType and ospfNbrEventType to the
> > IfStateChange and NbrStateChange traps?

I will check and add if allowed.

-Dan
>
> Thanks,
> Acee
>
> >
> > Thanks in advance,
> > Don
> >
> >  --- On Tue 04/29, Daniel Joyal < [email-masked] > wrote:
> > From: Daniel Joyal [mailto: [email-masked]]
> > To: [email-masked]
> > Date: Tue, 29 Apr 2003 09:57:59 -0400
> > Subject: Re: Working Group Last Call for
> > draft-ietf-ospf-mib-update-06.txt
> >
> > Version -06 of the OSPFv2 MIB update includes:
> >
> > - Add General group object for configuring reference bandwidth
> > - Change General group object ospfOpaqueLsaSupport MAX-ACCESS from
> > read-write to read-only
> > - Deprecate ospfExtLsdbTable and add ospfAsLsdbTable
> > - Add external route tag object to ospfAreaAggregateTable
> for NSSA (RFC 3101)
> > - Change status of RFC 1850 compliance and conformance
> groups from "deprecated" to
> >   "current"
> > - Add support for Graceful Restart
> >
> > Pending updates for version -07
> >
> > - Configuration objects to support detection of inactive neighbors
> > - Resolution of issues raised by IESG's OAM expert reviewer
> on version
> > -05
> > - Remaining open issues on traps
> > - Add section on MIB support for multiple OSPF instances
> > - Fix smilint errors/warnings
> > - Fix ospfStubRouterAdvertisement Description clause per
> Don's comment
> > - Change "hitless restart" to "graceful restart" per Don's comment
> > - Any additional issues from WG
> >
> > -Dan
> >
> > _______________________________________________
> > Join Excite! - http://www.excite.com
> > The most personalized portal on the Web!
> >
>
>
> --
> Acee
>

---

From: Acee Lindem <[email-masked]>
Date: Wed, 30 Apr 2003 11:27:07 -0400

Hi Dan,

> What other TE stuff would we need?

 From a configuration standpoint, there is also TE color. From a
monitoring standpoint, there is all the bandwidth state. How did
ISIS handle this?

> Do you mean cryptographic authentication?

Nope - I mean link local signaling. Even though it is not a standard
I don't think we should add checking to make it more difficult to
deploy if we ever decide to standardise it.

--
Acee