Subject: Graceful restart vs max-metric graceful ...

From: Erblichs <[email-masked]>
Date: Mon, 14 Apr 2003 14:22:11 -0700

Group,

        Max-metric vs graceful restart
        -------------------------------

        There are a number of routers that currently support
        advertising max-metric LSAs for a period of time
        during router bootup and at shutdown.

        The reason behind this is due to the fact that we
        don't want to handle transit packets until we
        have basicly completed our SPF calculations and
        inserted the majority of the forwarding entries.

        After a period of time has passed (some companies
        call it announce-time), we then re-originate our
        LSAs with the normal metrics.

        I would like to know whether there is a
        belief that the max-metric functionality and
        graceful restart is compatible OR whether their
        is a belief that max-metric functionality is
        obsoleted by graceful restart???

                Also .... Blackhole event

        Upon restart, when a a topology
        change has occured on possibly just 1 interface.
        Then packets transiting from a valid helper interface
        segment to a now non-valid interface segment
        will be dropped for the duration that can
        approach 1 hr. Right???

        How does one helper on 1 interface know about
        other helpers (or non-helpers) on other interfaces/
        segments. If OSPF control functionality is inoperable,
        then we are unable to transmit LSAs to inform that
        an interface has gone down between the time that
        we transmitted our grace-LSAs and the time that
        are are now restarting.

        Thus, should a graceful restarting router
        transmit max-metric LSAs before shutdown
        to minimize transiting packets
        in case we loose a helper on one OR more
        of our interfaces?

        Mitchell Erblich
        Sr. Software Engineer
        -----------------------------

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Mon, 14 Apr 2003 15:37:17 -0700

Mitchell,

See inline comments

>        Max-metric vs graceful restart
The two problems are orthogonal .. In the case of overloading
a router - the router is avoided because it doesn't have the routes
in its routing table. In the graceful restart case we assume that the
router has its forwarding plane functioning and hence is able to
forward packets.

>        will be dropped for the duration that can
I suppose you mean that the change in topology is in the restarting
router itself or else graceful restart is aborted.
Now remember that  a graceful restart means that all is fine in the
router .. any change in topology should abort the restart.

>        we transmitted our grace-LSAs and the time that
Again, we are under the assumption that the forwarding capabilities
are intact .. if it isn't then we cannot magically get the packets across
graceful restart or not.

>        in case we loose a helper on one OR more

We will be avoiding the restart router .. which is not what we intend

Padma

---

From: Erblichs <[email-masked]>
Date: Mon, 14 Apr 2003 15:59:42 -0700

Inlin...

        Mitchell....

> are intact .. if it isn't then we cannot magically get the packets across

                Yes, our forwarding is intact.

                1) We Sucessfully "enter graceful-restart".

                2) We down our control section of the router.

                3) A helper on a segment/interface  dies ...
                   Our other helpers on different interfaces
                        are ok.

                4) We exit graceful restart. and fail it due to #3.

                At #3, due to the fact that a helper died, and
                we have no control section, traffic forwarded thru
                one interface transiting the down helper is lost..
                We cannot insert a new forward element in our
                forwarding table until we get back our control
                section sometime after #4.

                In effect, we have 1-way traffic.. that is lost..
                Right???

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Tue, 15 Apr 2003 22:39:09 -0700

<snip>
>                    Our other helpers on different interfaces
This helper could be having other neighbors that are fine and they will
detect it and cause a change in topology.

>                 In effect, we have 1-way traffic.. that is lost..
<snip>

The case that you are indicating above has multiple failures and
I do not think that any protocol will be able to sustain it
without packet loss even in the normal case.
In the graceful restart the max amount of time you will have
a packet loss eventually in case of multiple failures is the
grace-period which is configurable. Note that if you had
a large DeadRouterInterval you would have the same problem.

Padma

---

From: Erblichs <[email-masked]>
Date: Wed, 16 Apr 2003 01:40:30 -0700

> detect it and cause a change in topology.

                I agree somewhat. But please le me repeat, we have lost 1 helper
                on 1 segment/interface. The topology change will only help
                with the loss of pkts coming from the past-helper and will be
                correctly redirected. The problem is that the other interface
                helpers won't see the topology change because our flooding
                functionality is based on our control section with our router
                functioning. It isn't until sometime in #4 that we restore
                flooding.

                So, our other helpers on our other interfaces are still
                directing traffic accross our valid helper interfaces.

                --- IFF you are familiar with route reflector logic within
                    BGP, I am assuming that the helpers/clients are unaware
                    of each others status if they are on different interface
                    segments and require OSPF flooding.

                Only during sometime in #4 when we realize that we have
                lost only 1 helper, can we start to make corrective action
                with our forwarding tables. Of course, it is implimention
                dependent. ..

                So, should we max-metric our LSAs until we re-start if their
                are alternate paths? Doing so would force additional SPF
                computations as the tradeoff until we can have our control
                section back and can make corrective action to our forwarding
                table(s) if need be.

                With only a single path transiting our restarting router
                a max-LSA should still allow the flow, but the loss would
                have happened anyway if we had completely shutdown the
                router.