Subject: I-D ACTION:draft-ietf-ospf-scalability-03.txt

From: [email-masked]
Date: Wed, 2 Apr 2003 06:28:29 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Open Shortest Path First IGP Working Group of the IETF.

        Title           : Prioritized Treatment of Specific OSPF Packets and
                          Congestion Avoidance
        Author(s)       : G. Choudhury et al.
        Filename        : draft-ietf-ospf-scalability-03.txt
        Pages           : 16
        Date            : 2003-4-1

This document proposes methods that are intended to improve the
scalability and stability of large networks using OSPF protocol.
The methods include processing OSPF Hellos and LSA Acknowledgements
at a higher priority compared to other OSPF packets, and other
congestion avoidance procedures. Simulation results in support of
some of the proposals are given in the appendix sections.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ospf-scalability-03.txt

To remove yourself from the IETF Announcement list, send a message to
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
        "get draft-ietf-ospf-scalability-03.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
        [email-masked].
In the body type:
        "FILE /internet-drafts/draft-ietf-ospf-scalability-03.txt".

NOTE:   The mail server at ietf.org can return the document in
        MIME-encoded form by using the "mpack" utility.  To use this
        feature, insert the command "ENCODING mime" before the "FILE"
        command.  To decode the response(s), you will need "munpack" or
        a MIME-compliant mail reader.  Different MIME-compliant mail readers
        exhibit different behavior, especially when dealing with
        "multipart" MIME messages (i.e. documents which have been split
        up into multiple messages), so check your local documentation on
        how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Choudhury, Gagan L, ALABS" <[email-masked]>
Date: Wed, 2 Apr 2003 07:47:01 -0600

Hi All,
   Here is a highlight of changes on the attached draft:

1. The draft is in the BCP track.

2. The length of the title is significantly reduced.

3.  "Explicit Marking" of OSPF packets is not advocated in the main body of
     the draft.  A short discussion on that is included in Appendix C.  The title is
     also changed to reflect that fact.

4. Discussions on the simulation study and detailed discussion on the causes for
    generation of LSA storm and its impact are moved to the appendix.

5.  Now the main body of the draft is short and mainly concentrates on implementation. 
     Also, all proposals are made fairly explicit.
     Whenever a parameter is involved in a proposal, an example value is also given.

6.  Two proposals are included based on "implicit congestion detection", i.e.,
     without requiring any changes in protocol bits on the wire.  The first one  is
     an exponential backoff of the LSA retransmission interval based
     on the number of times a particular LSA has to be retransmitted.  The
     second one is throttling the rate of sending LSAs towards a node if the
     number of unacknowledged LSAs from that node exceeds a threshold.  Another
     proposal is also included on limiting the maximum number of adjacencies
     to be brought up simultaneously.

       Gagan Choudhury 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, April 02, 2003 6:28 AM
To: [email-masked]
Subject: I-D ACTION:draft-ietf-ospf-scalability-03.txt

Send a message to:
        [email-masked].
In the body type:

---

From: "Manral, Vishwas" <[email-masked]>
Date: Thu, 3 Apr 2003 12:36:07 -0500

Hi Srinivas,

We had added text in this regard in section 4.1.2.
http://www.ietf.org/internet-drafts/draft-ash-manral-ospf-congestion-control
-00.txt

If its agreed to by the working group, we can add similar text in the
scalability draft.

Thanks,
Vishwas

-----Original Message-----
From: Srinivas Goli [mailto:[email-masked]]
Sent: Thursday, April 03, 2003 10:30 PM
To: [email-masked]
Subject: Re: I-D ACTION:draft-ietf-ospf-scalability-03.txt

Perhaps you should address the authentication related issues with
prioritizing certain packets. For example if MD5 authentication is
enabled the received packet's sequence numbers may be out of order.

We should change this to expect different sequence numbers for high
priority packets and low priority packets.

Manral, Vishwas wrote:

>Hi Krishna,
>
>The draft aims at two things: -
>
>1. Increase scalability
>2. Prevent CPU overload
>
>The throttling adjacencies is done in case where the number of adjacencies
>comming up can actually cause a CPU overload. We have purposely left out
the
>criteria(which could be implementaion specific), based on comments got on
>the list.
>
>You could check out the congestion-control draft we had out some time back,
>where(m not sure) we may have given some example criterias.
>
>Thanks,
>Vishwas
>
>From: Krishna Rao [mailto:[email-masked]]
>Sent: Thursday, April 03, 2003 6:09 PM
>Subject: Re: I-D ACTION:draft-ietf-ospf-scalability-03.txt
>
>
>Hi,
>The proposal made to "throttle adjacencies" in the draft,
>won't affect convergence time ??
>What's the criteria to decide which adjacency are
>to be formed and which ones to defer??
>
>
>thanks,
>krishna
>
>
>
>On Wed, 02 Apr 2003 Choudhury, Gagan L, ALABS wrote :
>
>
>>Hi All,
>>        "FILE
>>/internet-drafts/draft-ietf-ospf-scalability-03.txt".
>>

--
--
Srinivas
Laurel Networks Inc.
[email-masked]
(412)809-4268