Subject: Re: Graceful Restart

From: Krishna Rao <[email-masked]>
Date: Mon, 7 Apr 2003 11:32:22 -0000

Hi,
1) Since the aim is to keep the restarting router
    in the network, so during graceful restart:

    If router analyses its own router/network lsa (if
    it was DR) and does necessary operation, that should
    be enough.
    Why to again elect itself as DR ?

2) So suppose, if it doesn't elect itself as DR and
    new DR(some other router) is elected.
    But if network topology hasn't changed, only change
    might be in terms of new DR/BDR and new adjacencies
    with those DR/BDR.
    But that does not in anyway change network topology in
    terms of reachability of routes.
    So graceful restart should not be aborted !!!!

    Though Network Lsa will change.
    But how does it makes "Router LSA" of restarting
    router inconsistent, in terms of reachability
    of "helpers", to restarting router???

3)Finally when it exits the graceful restart:
   It originates router Lsas, calculates SPF etc.

Or i am missing some point ???

krishna

On Fri, 04 Apr 2003 Acee Lindem wrote :
>John, Krishna,
>
>John has it pretty much right but there is one additional key
>point. If the restarting router doesn't succeed its role as
>DR on interfaces where it was previously DR the specification
>is broken. The restarting router uses his own pre-restart
>router and network LSAs to determine when graceful restart
>has converged. A DR election would change the topology and
>the restarting router would detect an LSA inconsistency and
>exit graceful restart prematurely.
>
>Thanks,
>Acee
>
>John Smith wrote:
>>Krishna,
>>my 2 euros (dollars are out !!!)
>>
>>
>>>draft-ietf-ospf-hitless-restart-07.txt:
>>>2.  Operation of restarting router:
>>>
>>>Point 2) If the restarting router determines that it was
>>>Designated
>>>          Router on a given segment immediately prior to the
>>>restart,
>>>          it elects itself as Designated Router again
>>>
>>>Q1)Why does this need to be done while restarting?
>>>    AND
>>>    How does it help ??
>>
>>
>>Its helps in maintaining sanity in the network. Others think
>>that this router is still up
>>and continue trusting him as DR. When he comes up he should not
>>break this trust and
>>should ideally start operating as a DR.
>>
>>The basic concept is that if he resigns from DRship then the BDR
>>will take over and they
>>will need to again re-elect the BDR .. which is a messy affair.
>>The whole point of
>>graceful restart is to avoid such events !!
>>
>>
>>>Q2)What if normal DR/BDR election takes place "on exiting
>>>    graceful restart"
>>
>>
>>Why do you want to land in this mess? You will again need to
>>re-issue your LSAs, etc.
>>Everybody will have to re-synch .. and the whole purpose of
>>graceful restart will be
>>defeated.
>>
>>Others more informed about this protocol can correct me whatever
>>i missed out!
>>
>>JS
>>
>>
>>
>>__________________________________________________
>>Yahoo! Plus
>>For a better Internet experience
>>http://www.yahoo.co.uk/btoffer
>>
>
>
>--
>Acee

_______________________________________________________________________
Odomos - the only  mosquito protection outside 4 walls -
Click here to know more!
http://r.rediff.com/r?http://clients.rediff.com/odomos/Odomos.htm&&odomos&&wn

---

From: Acee Lindem <[email-masked]>
Date: Mon, 7 Apr 2003 09:46:52 -0400

Hi Krishna,

> Or i am missing some point ???

With the current approach, the restarting router doesn't
re-originate any LSAs until it exits graceful restart. Rather,
the pre-restart LSAs are used. Hence, a change in DR will result
in a topology and an inconsistency with the pre-restart LSA.

Thanks,
Acee

--
Acee