Subject: Re: route insertion into Forwarding table..

From: alok <[email-masked]>
Date: Fri, 11 Apr 2003 19:38:24 +0530

or is it

update (update comes in)---ack----run SPF --- put into FT ?

Could a router not go down after the ack ?

but the neighbours would believe that the FT is accurate?

-rgds
Alok

----- Original Message -----
From: alok <[email-masked]>
To: <[email-masked]>
Sent: Friday, April 11, 2003 6:28 PM
Subject: route insertion into Forwarding table..

> Greetings,
>
> There is something which has been confusing me for quite a while now,
>
> If a router receives an update from a neighbour, informing it of some
change
> in topology,
>
> or if one assumes that there is a "router coming up with some existing
> entries in the forwarding table",
>
> "when" is this new route put into the forwarding table?
>
> in other words, when is the new route treated as "valid"?
>
> Is it as soon as SPF calculations are done or is it after an LSack is
sent?
>
> What is the exact sequence?
>
> update----SPF----ack---FT
>
> or
>
> update---SPF----FT---ack
>
>
> Thanking you for your help,
> Alok
>
>
>

---

From: Acee Lindem <[email-masked]>
Date: Fri, 11 Apr 2003 10:34:52 -0400

> but the neighbours would believe that the FT is accurate?

Alok,

The only thing the OSPF router should infer from the ack is
that the LSA has been received by its neighbor and need not
be retransmitted. The control plane and forwarding plane
should converge in due time.

Thanks,
Acee

--
Acee

---

From: Alok Dube <[email-masked]>
Date: Sat, 12 Apr 2003 01:21:43 +0530

> should converge in due time.

Acee,

2 more queries.. pertaining to "graceful restart"

1. Incase a router "acks" this LSA and then enters a "graceful restart"
without modifying the FT, what is the result?
2. If there is a way to "ensure this convergence" shouldnt this
methodology be "documented" as a part of the draft?... or shouldnt it be
mentioned that the "gracefully restarting router" should "ensure this
convergence" before entring the "graceful restart"?

-rgds
Alok

---

From: Jing Shen <[email-masked]>
Date: Sat, 12 Apr 2003 18:36:11 +0800

Maybe there will be transient loop during restart, but as routing daemon restarts routing table will be recomputed.

>convergence" before entring the "graceful restart"?

But the problem is how could these LSAs be kept in a safe place?

-rgds
Alok

Jing Shen

State Key Lab of CAD&CG
ZheJiang University(YuQuan)
HangZhou, ZheJiang Province 310027
P.R.China

---------------------------------
Do You Yahoo!?
"雅虎通网络KTV, 随时随地免费卡拉OK~~"

---

From: Alok Dube <[email-masked]>
Date: Sat, 12 Apr 2003 20:34:26 +0530

> Maybe there will be transient loop during restart, but as routing
> daemon restarts routing table will be recomputed.

but i could still enter a graceful restart or not? the draft says
something in point 1 in 2.1 but I wasnt sure if this is what it
meant...which is why the question.
>>methodology be "documented" as a part of the draft?... or shouldnt it
>>be mentioned that the "gracefully restarting router" should "ensure
>>this convergence" before entring the "graceful restart"?
>

There are LSAs which:
1. have been acked so the adjacent routers think everything is fine
2. have not been used to modify the FT (if required) or in other words, no
SPF computation has been run on them.3. at this point a router enters a graceful restart.

> "ÑÅ»¢Í¨ÍøÂçKTV, ËæÊ±ËæµØÃâ·Ñ¿¨ÀOK~~"