Subject: Re: Multiple un-numbered serial links between two routers

From: "Manral, Vishwas" <[email-masked]>
Date: Tue, 15 Apr 2003 00:38:47 -0400

Hi Jj,

I agree with Acee. I am not sure why we compulsarily need to have multiple
parallel links between two routers advertized in the LSA, for normal SPF.

I think if we advertize the minimum cost unnumbered parallel link, it would
serve the same purpose for SPF calculations. I think something similar is
done for "neighbor reachability"(something similar to a link in Router LSA)
in case of ISIS, in most implementations.

Thanks,
Vishwas

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Tuesday, April 15, 2003 9:55 AM
To: [email-masked]
Subject: Re: Multiple un-numbered serial links between two routers

j j wrote:
> Can OSPF support this? Seems like there isn't enough
> information in Router LSA to distinctly identify the
> interfaces for nexthop information.

JJ,

You are correct - a router link in a router LSA doesn't
provide you with enough information to distinctly identify
parallel unnumbered links. Note that an IP next hop
address is not necessary for a point-to-point link (see section
16.1.1 in RFC 2328).

>
> Or is this an invalid configuration on a router?

There are a number of implementation choices one could
make. One is to consider all the advertised parallel unnumbered
links valid as long there is bi-directional connectivity
via one of them. Another would be to consider the configuration
invalid.

> thanks

Hope this helps,
--
Acee

---

From: j j <[email-masked]>
Date: Tue, 15 Apr 2003 08:35:12 -0700

Hi Vishwas,

You ask why we need to have multiple links advertised.
How can we do equal cost multipath if there were
other vertices behind the second router? For e.g.
R1 and R2 has multiple unnumbered links. Behind R2
are other vertices.  R1 is the calculating router.

These vertices should have multiple nexthops. I agree
that nexthop IP address is not needed. But my dilemma
is that as SPF is going through the links in R2's rtr
LSA, there isn't enough information to map those link
id's to egress ifnum on R1.

thanks

> via one of them. Another would be to consider the

__________________________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo
http://search.yahoo.com