Subject: Regarding keeping multiple routes with unequal costs to ABR/ASBR

From: Yongjun Im <[email-masked]>
Date: Fri, 4 Apr 2003 22:14:47 +0900

Hello, 

I would like to ask if the OSPF behaviour described below complies with RFC 2328.
As a matter of fact, I believe it doesn't work appropriately even if it complies with the standard.

The problem was found in the following network topology in which we wanted to 
test primiary/secondary routes using different OSPF metrics 
(the Link1 and Link2 are set to 10 and 1, respectively).

                 OSPF
            <--Link1(10) -->              OSPF                 
LER_A                             LSR  <-------->  LER_B
            <--Link2(1)--->  (ABR)                                                    
                 OSPF        
    
<------ Area 0 ---------> <----- Area 100 ----->

In the picture above, we added OSPF route entries using Adtech analyzer which 
acted as a ABR/ASBR. What the OSPF routing table in LER_A contained, 
after all routes propagation through OSPF routing domain, was somewhat unexpected for us, 
because it kept all of the routes, including the route to LSR, injected from Analyzer 
as equal-cost multi-path through both Link1 and Link2, not only through Link2 with lower cost.

Regardless of whether a destination is ABR or ASBR, I believe the best route 
(with the least cost) to that router, should be kept. Therefore, in the topology above
I think that LER_A has to keep only the route over Link2, with the smaller metric, to LSR(ABR).

Any help in this regard will be greatly appreciated.

Regards,

Yongjun.

---

From: Acee Lindem <[email-masked]>
Date: Fri, 4 Apr 2003 09:49:44 -0500

Yongjun,

If I understand your topology you are correct. LER_A should
only install the lower cost routes over Link2.

Thanks,
Acee

--
Acee

---

From: 임용준 <[email-masked]>
Date: Sat, 5 Apr 2003 02:17:48 +0900

If LER_B is an ASBR, should LER_A install only the lower cost route
(over Link2) to ASBR(LER_B) ?

-------------
Yongjun,

Thanks,
Acee

Yongjun Im wrote:
> As a matter of fact, I believe it doesn't work appropriately even if it
complies
with the standard.
> because it kept all of the routes, including the route to LSR, injected
from
Analyzer
> as equal-cost multi-path through both Link1 and Link2, not only through
Link2
with lower cost.
> (with the least cost) to that router, should be kept. Therefore, in the
topology
above
> I think that LER_A has to keep only the route over Link2, with the
smaller
metric, to LSR(ABR).

--
Acee

---

From: Acee Lindem <[email-masked]>
Date: Fri, 4 Apr 2003 12:28:29 -0500

> (over Link2) to ASBR(LER_B) ?

Yes. What would lead you to think otherwise?

>>I would like to ask if the OSPF behaviour described below complies with
>
> RFC 2328.
>
>>The problem was found in the following network topology in which we
>
> wanted to
>
>>In the picture above, we added OSPF route entries using Adtech analyzer
>
> which
>
>>after all routes propagation through OSPF routing domain, was somewhat
>
> unexpected for us,
>
>>Regardless of whether a destination is ABR or ASBR, I believe the best
>
> route
>

--
Acee