Subject: Multiple Ethernet interfaces on same subnet

From: j j <[email-masked]>
Date: Sun, 20 Apr 2003 12:20:37 -0700

is this allowed on routers?

for e.g. can I configure router with eth0 10.1.1.1/24
and eth1 as 10.1.1.2/24?

thanks,

__________________________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo
http://search.yahoo.com

---

From: j j <[email-masked]>
Date: Sun, 20 Apr 2003 17:45:22 -0700

Well, the reason for me asking the question is this --

Rfc2328 section 16.1.1 says following:

"In the second case, the parent vertex is a network
that directly connects the calculating router to the
destination router.  The list of next hops is then
determined by examining the destination's router-LSA.
FOR EACH LINK IN THE ROUTER-LSA THAT POINTS BACK TO
THE PARENT NETWORK, the link's Link Data field
provides the IP address of a next hop router."

If I understand this properly, there can be multiple
links in the router lsa that can point back to parent
network only if the router has multiple interfaces on
the same subnet.

Am I missing something?

thanks,

---

From: Rikki Nguyen <[email-masked]>
Date: Mon, 21 Apr 2003 10:54:15 -0700

Not necessarily.  Two routers could have multiple P2P
interfaces between them.  That would force them to
have different subnets or none at all.

---

From: j j <[email-masked]>
Date: Tue, 22 Apr 2003 22:58:24 -0700

Why would P2P links point to network LSA? Please
read the question carefully.  The parent vertex
is a network (i.e. network LSA).

thanks