Subject: Normal to STUB/NSSSA

From: John Smith <[email-masked]>
Date: Fri, 4 Apr 2003 13:00:53 +0100

Hello,
What must a router do when its configured inside a normal area and then re-configured to
be a part of the stub network OR NSSA network.

Should it flush all the AS-External-LSAs it has in its database .. What exactly will
happen?

Thanks in advance,
JS

__________________________________________________
Yahoo! Plus
For a better Internet experience
http://www.yahoo.co.uk/btoffer

---

From: Vivek Dubey <[email-masked]>
Date: Fri, 4 Apr 2003 17:58:46 +0530

Hi,
When a router moves from being part
of normal ospf area to internal NSSA/STUB router:
1) Type 5 LSAs should be deleted/flushed.

2) Type 3 can be kept/removed based on
   whether import of Type 3 is allowed.

Cleaner way would be to re-initialize the
area itself and start afresh. This should take
care of most things.....

vivek

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of John
Smith
Sent: Friday, 4 April 2003 5:31 PM
To: [email-masked]
Subject: Normal to STUB/NSSSA

Hello,
What must a router do when its configured inside a normal area and then
re-configured to
be a part of the stub network OR NSSA network.

Should it flush all the AS-External-LSAs it has in its database .. What
exactly will
happen?

Thanks in advance,
JS

***************************************************************************
This message is proprietary to Future Software Limited (FSL)
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information
and should not be circulated or used for any purpose other than for
what it is intended.

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message.
FSL accepts no responsibility for loss or damage arising from
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

---

From: alok <[email-masked]>
Date: Fri, 4 Apr 2003 18:27:10 +0530

hi,

>    whether import of Type 3 is allowed.

i know there is a difference between what some people call "stub" versus
totally "stub"
....but is this a standard/draft.....?

i mean this makes sense if one puts BGP etc into IGP but do people do that
anywhere............?

-thanks and rgds
Alok

---

From: Acee Lindem <[email-masked]>
Date: Fri, 4 Apr 2003 09:54:14 -0500

Hi John,

> Should it flush all the AS-External-LSAs it has in its database .. What exactly will

To make things simple, let's consider this router to be internal
to the area (not an ABR). The router should flush its self-originated
AS external LSAs and discard all its AS external LSA. If it is an
NSSA, it should (dependent on policy), reoriginate its redistributed
routes as NSSA type 7 LSAs. If may or may not have reoriginate its
router LSA dependent on changes to the router bits. The ABR case
is much more complicated.

--
Acee

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Fri, 4 Apr 2003 08:34:58 -0800

Hi

I do not agree with the fact that it should necessarily
flush its external LSA.

Moving to a stub
~~~~~~~~~~~~~~~~
Whether or not it flushes the LSA doesn't matter as those
LSAs will not be taken into account by anyone as the
Advertising router router-lsa has the E-bit clear.
This will in turn flush the type-4 LSAs (rfc2328 pg 136).
The router will not be part of the router routing table
as an ASBR. Hence none of the external LSAs originated by
that router will be considered for SPF calculation.

So it is an implementation decision to do so. I think it
is more scalable not to do so .. it reduces traffic.

Moving into a NSSA
~~~~~~~~~~~~~~~~~~
You need to flush your type 5 and generated type 7 instead.
Type 3 kept/flushed - depends on config

Padma