Subject: Re: Multiple un-numbered serial links between two routers

From: "Manral, Vishwas" <[email-masked]>
Date: Tue, 15 Apr 2003 12:39:24 -0400

Hi JJ,

Let me explain
    L1
  ----------     L3
A    L2     B ----------C
  ----------

Assume a topology like the above, where A, S, C are routers and L1, L2 and
L3 are networks.

If L1 and L2 are equal costs at A.

In A's routing table the path to destination learnt from C would be thru
both L1 and L2, and as A knows the costs of the two interfaces is the same,
so it will create ECMP's.

Now in case of C there will be just one path to any destination learnt from
D that is thru L3. B will have the ECMP in this case.

Let me know if I am any clearer now.

Thanks,
Vishwas

-----Original Message-----
From: j j [mailto:[email-masked]]
Sent: Tuesday, April 15, 2003 9:05 PM
To: [email-masked]
Subject: Re: Multiple un-numbered serial links between two routers

Hi Vishwas,

You ask why we need to have multiple links advertised.
How can we do equal cost multipath if there were
other vertices behind the second router? For e.g.
R1 and R2 has multiple unnumbered links. Behind R2
are other vertices.  R1 is the calculating router.

These vertices should have multiple nexthops. I agree
that nexthop IP address is not needed. But my dilemma
is that as SPF is going through the links in R2's rtr
LSA, there isn't enough information to map those link
id's to egress ifnum on R1.

thanks

--- "Manral, Vishwas" <[email-masked]> wrote:
> Hi Jj,
>
> I agree with Acee. I am not sure why we compulsarily
> need to have multiple
> parallel links between two routers advertized in the
> LSA, for normal SPF.
>
> I think if we advertize the minimum cost unnumbered
> parallel link, it would
> serve the same purpose for SPF calculations. I think
> something similar is
> done for "neighbor reachability"(something similar
> to a link in Router LSA)
> in case of ISIS, in most implementations.
>
> Thanks,
> Vishwas
>
> -----Original Message-----
> From: Acee Lindem [mailto:[email-masked]]
> Sent: Tuesday, April 15, 2003 9:55 AM
> To: [email-masked]
> Subject: Re: Multiple un-numbered serial links
> between two routers
>
>
> j j wrote:
> > Can OSPF support this? Seems like there isn't
> enough
> > information in Router LSA to distinctly identify
> the
> > interfaces for nexthop information.
>
> JJ,
>
> You are correct - a router link in a router LSA
> doesn't
> provide you with enough information to distinctly
> identify
> parallel unnumbered links. Note that an IP next hop
> address is not necessary for a point-to-point link
> (see section
> 16.1.1 in RFC 2328).
>
> >
> > Or is this an invalid configuration on a router?
>
> There are a number of implementation choices one
> could
> make. One is to consider all the advertised parallel
> unnumbered
> links valid as long there is bi-directional
> connectivity
> via one of them. Another would be to consider the
> configuration
> invalid.
>
> >
> >
> > thanks
> >
>
> Hope this helps,
> --
> Acee

---

From: j j <[email-masked]>
Date: Tue, 15 Apr 2003 10:13:39 -0700

I was only pointing out the fact that if routers
advertised only one link, we would not be able to
do ecmp.

All I am saying is that If I took your example and
went through the steps as listed in rfc2328 for
nexthop calculations, I would not be able
to get correct results.

> A    L2     B ----------C

__________________________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo
http://search.yahoo.com

---

From: Naiming Shen <[email-masked]>
Date: Tue, 15 Apr 2003 11:50:45 -0700

] I was only pointing out the fact that if routers
 ] advertised only one link, we would not be able to
 ] do ecmp.

Just imagine the L1 and L2 belong to a link bundle between
A and B. From C's point of view, it does not need to know this
link bundle has only one link or 5 links. From B's point of
view, it knows exactly how many links it needs to do ecmp over
that link bundle. (my example is a little extreme, but it
should serve the purpose).

cheers.

 ]
 ] All I am saying is that If I took your example and
 ] went through the steps as listed in rfc2328 for
 ] nexthop calculations, I would not be able
 ] to get correct results.
 ]
 ]
 ]
 ] --- "Manral, Vishwas" <[email-masked]> wrote:
 ] > Hi JJ,
 ] >
 ] > Let me explain
 ] >     L1
 ] >   ----------     L3
 ] > A    L2     B ----------C
 ] >   ----------
 ] >
 ] > Assume a topology like the above, where A, S, C are
 ] > routers and L1, L2 and
 ] > L3 are networks.
 ] >
 ] > If L1 and L2 are equal costs at A.
 ] >
 ] > In A's routing table the path to destination learnt
 ] > from C would be thru
 ] > both L1 and L2, and as A knows the costs of the two
 ] > interfaces is the same,
 ] > so it will create ECMP's.
 ] >
 ] > Now in case of C there will be just one path to any
 ] > destination learnt from
 ] > D that is thru L3. B will have the ECMP in this
 ] > case.
 ] >
 ] > Let me know if I am any clearer now.
 ] >
 ] > Thanks,
 ] > Vishwas
 ] >
 ] > -----Original Message-----
 ] > From: j j [mailto:[email-masked]]
 ] > Sent: Tuesday, April 15, 2003 9:05 PM
 ] > To: [email-masked]
 ] > Subject: Re: Multiple un-numbered serial links
 ] > between two routers
 ] >
 ] >
 ] > Hi Vishwas,
 ] >
 ] > You ask why we need to have multiple links
 ] > advertised.
 ] > How can we do equal cost multipath if there were
 ] > other vertices behind the second router? For e.g.
 ] > R1 and R2 has multiple unnumbered links. Behind R2
 ] > are other vertices.  R1 is the calculating router.
 ] >
 ] > These vertices should have multiple nexthops. I
 ] > agree
 ] > that nexthop IP address is not needed. But my
 ] > dilemma
 ] > is that as SPF is going through the links in R2's
 ] > rtr
 ] > LSA, there isn't enough information to map those
 ] > link
 ] > id's to egress ifnum on R1.
 ] >
 ] >
 ] >
 ] > thanks
 ] >
 ] >
 ] >
 ] >
 ] >
 ] > --- "Manral, Vishwas" <[email-masked]> wrote:
 ] > > Hi Jj,
 ] > >
 ] > > I agree with Acee. I am not sure why we
 ] > compulsarily
 ] > > need to have multiple
 ] > > parallel links between two routers advertized in
 ] > the
 ] > > LSA, for normal SPF.
 ] > >
 ] > > I think if we advertize the minimum cost
 ] > unnumbered
 ] > > parallel link, it would
 ] > > serve the same purpose for SPF calculations. I
 ] > think
 ] > > something similar is
 ] > > done for "neighbor reachability"(something similar
 ] > > to a link in Router LSA)
 ] > > in case of ISIS, in most implementations.
 ] > >
 ] > > Thanks,
 ] > > Vishwas
 ] > >
 ] > > -----Original Message-----
 ] > > From: Acee Lindem [mailto:[email-masked]]
 ] > > Sent: Tuesday, April 15, 2003 9:55 AM
 ] > > To: [email-masked]
 ] > > Subject: Re: Multiple un-numbered serial links
 ] > > between two routers
 ] > >
 ] > >
 ] > > j j wrote:
 ] > > > Can OSPF support this? Seems like there isn't
 ] > > enough
 ] > > > information in Router LSA to distinctly identify
 ] > > the
 ] > > > interfaces for nexthop information.
 ] > >
 ] > > JJ,
 ] > >
 ] > > You are correct - a router link in a router LSA
 ] > > doesn't
 ] > > provide you with enough information to distinctly
 ] > > identify
 ] > > parallel unnumbered links. Note that an IP next
 ] > hop
 ] > > address is not necessary for a point-to-point link
 ] > > (see section
 ] > > 16.1.1 in RFC 2328).
 ] > >
 ] > > >
 ] > > > Or is this an invalid configuration on a router?
 ] > >
 ] > > There are a number of implementation choices one
 ] > > could
 ] > > make. One is to consider all the advertised
 ] > parallel
 ] > > unnumbered
 ] > > links valid as long there is bi-directional
 ] > > connectivity
 ] > > via one of them. Another would be to consider the
 ] > > configuration
 ] > > invalid.
 ] > >
 ] > > >
 ] > > >
 ] > > > thanks
 ] > > >
 ] > >
 ] > > Hope this helps,
 ] > > --
 ] > > Acee
 ]
 ]
 ] __________________________________________________
 ] Do you Yahoo!?
 ] The New Yahoo! Search - Faster. Easier. Bingo
 ] http://search.yahoo.com

- Naiming