Subject: Re: Zero as ospfIfRetransInterval

From: Jeff Parker <[email-masked]>
Date: Tue, 24 Jun 2003 09:25:29 -0400

You're not allowed to change the syntax unless
it's equivalent to the old syntax. So in this
case, we would need to deprecate/obsolete.
-Dan

Dan -
        You are such a wet blanket

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 24 Jun 2003 09:27:01 -0400

Jeff,
I don't think the whole list has to know that ;)

Gregory Mirsky             Axiowave Networks, Inc.
SW Engineer                200 Nickerson Road
Phone: (774)348-4664       Marlborough, MA 01752
E-mail: [email-masked]
--------------------------------------------
Adding manpower to a late SW project makes it later

-----Original Message-----
From: Jeff Parker [mailto:[email-masked]]
Sent: Tuesday, June 24, 2003 9:25 AM
To: [email-masked]
Subject: Re: Zero as ospfIfRetransInterval

Dan -

---

From: Schrodi Karl <[email-masked]>
Date: Thu, 26 Jun 2003 10:03:05 +0200

Hi Acee,

I fully understand that retransmission is mandatory - but does it really make sense to have a retransmission interval of zero? Wouldn´t it be like some kind of a DoS attack against yourself and your neighbour(s)?

Well, probably nobody reasonably will set this interval to zero - but ...

I would prefer something like the previous proposal of Vishwas, i.e. putting a limitation in the object description in the MIB.

Regards
Karl

-----Ursprüngliche Nachricht-----
Von: Acee Lindem [mailto:[email-masked]]
Gesendet: Mittwoch, 25. Juni 2003 19:03
An: [email-masked]
Betreff: Re: Zero as ospfIfRetransInterval

Eric Gray wrote:
> Acee,
>
>     Why would it be wrong to set a retransmit interval to zero?  Usually,
> setting a retransmit interval to zero would have the special meaning that
> retransmission does not occur (i.e. - the interval is infinite).  Is that not
> an intended meaning in this case?

Nope - not retransmitting would make the flooding unreliable and
would violate the base protocol specification (RFC 2328).

>
> Acee Lindem wrote:
>
>
>>Manral, Vishwas wrote:
>>
>>>Hi Acee,
>>>
>>>If we do not intend to define new variables, we may want to at least put the
>>>limitation of 0, in the object description in the MIB.
>>
>>Hi Vishwas,
>>
>>That sounds like a good idea since any implementation that allows
>>write access to set the variables to 0 is broken.
>>
>>Thanks,
>>Acee
>>
>>
>>>Thanks,
>>>Vishwas
>>>
>>>From: Acee Lindem [mailto:[email-masked]]
>>>Sent: Tuesday, June 24, 2003 18:16
>>>Hi Dan,
>>>Daniel Joyal wrote:
>>>>it's equivalent to the old syntax.
>>>
>>>
>>>Even if the old syntax doesn't match the protocol
>>>specification?
>>>
>>>
>>>
>>>
>>>>So in this
>>>Then I don't think it is worth defining
>>>new MIB variables given that ospfIfTransitDelay,
>>>ospfIfRetransInterval, ospfVirtIfTransitDelay, and
>>>ospfVirtIfRetransInterval have served us thus far.
>>>
>>>Other opinions are welcome.
>>>
>>>Thanks,
>>>Acee
>>>
>>>
>>>
>>>>-Dan
>>>>
>>>>
>>>>>From: Acee Lindem [mailto:[email-masked]]
>>>>>Sent: Monday, June 23, 2003 11:35 PM
>>>>>To: Mailing List; Joyal, Daniel [BL60:NP30:EXCH]
>>>>>Igor Miroshnik wrote:
>>>>>>All,
>>>>>>Can anybody clarify the physical sense of assigning
>>>>>>ospfIfRetransInterval to zero? RFC1850 allows such an assignment.
>>>>>
>>>>>I believe UpToMaxAge should range from 1..3600 rather than 0..3600.
>>>>>
>>>>>Dan - can we change this in the MIB update without
>>>>>deprecating variables?
>>>>>
>>>>>
>>>>>>Thanks
>>>>>>
>>>>>
>>>>>
>>>>>--
>>>>>Acee
>>>>>
>>>>>
>>>>
>>>
>>>--
>>>Acee
>>>
>>
>>--
>>Acee
>
>
>
>

--
Acee