Subject: Re: Clarification in size of Rtr and network LSA

From: Don Goodspeed <[email-masked]>
Date: Fri, 13 Jun 2003 14:13:04 -0400

Hmmm.  Would a scheme like ISIS has for extended LSPs
work for the router LSA?  If we could use a range of
router IDs that are not assigned, then maybe.  Or we
could use a non-backward compatible method using opaque
LSAs.  Any ideas?  -don

================================
Krishna,

I myself don't like fragmentation, if just due to the fact
that any fragment gets dropped, then the whole packet/frame
needs to be rexmit'ed.

Additionally, I would expect at least consistency counts for
each LSA type. This count should be retrieveable before
you start filling the LSA. With this count you can allocate
the proper memory size.

Mitchell Erblich
Sr Software Engineer
-------------

Krishna Rao wrote:
>
> Hi,
> This is w.r.to the size of the Router LSA to be generated. We can not predict the size of the router LSA initially in the process of forming the Router LSA. Usually we allocate (Max MTU size - (OSPF header size + IP header size + MD5 authentication size) --> 1500 - (28 + 20 + 16)= 1436) and start filling the LSA. For Point to point interface we add two links and need 24 bytes for each point to point interface. That results in supporting only 59 interfaces in a single area. Is this an acceptable argument? or Should we design such that OSPF sends a LSA more than MTU size and gets fragmented in IP.
> What is the scalabilty figure for Number of interfaces in a area for popular routers?
>
> Thanks in advance,
> Regards,
> Krishna

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

---

From: Acee Lindem <[email-masked]>
Date: Fri, 13 Jun 2003 14:24:08 -0400

> could use a non-backward compatible method using opaque

Don,

Let's not go there ;^). Every implementation should
support IP fragmentation and reassembly up to a certain
limit (if not the full 64K). This should more than exceed
anybody's requirement for the number of interfaces in a
single area. For example, if one supports IP fragmentation
and reassembly up to 16K (not an unreasonable number since
there are some DLCs that support MTUs this big) one can
support around 1350 numbered P2P interfaces or around
2700 numbered or transit interfaces. Does anyone have
a requirement to support more interfaces
in a single area?

Thanks,
Acee

--
Acee