Subject: MOSPF can't determine the receiving interface exactly - In John Moy's book OSPF Anatomy of a Routing Protocol

From: Ian Potts <[email-masked]>
Date: Thu, 5 Jun 2003 13:41:50 +0100

Hello,

In John Moy's excellent book, Anatomy of an Internet
Routing Protocol, on page 195 (section 10.3.1 The
Multicast Forwarding Cache), it states that a router
does the RPF check in MOSPF on the router's ID, and
not on the incoming interface, since MOSPF can't
determine the receiving interface exactly, since there
is insufficient information in the OSPF lsdb to match
the sending and receiving halves.

Can someone please explain this to me since I am
confused.  Looking at the router LSAs given below,
can't the router first work out the router-id, then
consult the routing table to find the interface?

Many Thanks
Ian

Router 1

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 144.141.252.254
     (Link Data) Router Interface address:
144.128.254.138
      Number of TOS metrics: 0
       TOS 0 Metrics: 1000

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 144.128.254.136
     (Link Data) Network Mask: 255.255.255.248
      Number of TOS metrics: 0
       TOS 0 Metrics: 1000

Router 2

Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 144.141.89.2
     (Link Data) Router Interface address:
144.128.254.137
      Number of TOS metrics: 0
       TOS 0 Metrics: 1000

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 144.128.254.136
     (Link Data) Network Mask: 255.255.255.248
      Number of TOS metrics: 0
       TOS 0 Metrics: 1000

__________________________________________________
Yahoo! Plus - For a better Internet experience
http://uk.promotions.yahoo.com/yplus/yoffer.html

---

From: Yasuhiro Ohara <[email-masked]>
Date: Wed, 11 Jun 2003 08:29:06 +0900

Hi, I try to explain.

Even in your example, actually you don't determine the receiving half
of the point-to-point link. You can only know the receiving interface
of the other router by *guessing*, and you can guess only because
they don't have any other links to the same router.

Let's suppose your example have two point-to-point links between
Router 1 and Router 2 as it will be easier to understand.
(The book also mentions that configuration, "when multiple
point-to-point links connect the router to the neighbor"
in the same section)

The Router-LSAs in the database will be like below.

Router 1

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 144.141.252.254
     (Link Data) Router Interface address: 144.128.254.138
      Number of TOS metrics: 0
       TOS 0 Metrics: 1000

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 144.141.252.254
     (Link Data) Router Interface address: 10.1.1.1 (or whatever)
      Number of TOS metrics: 0
       TOS 0 Metrics: 10000 (or whatever)

Router 2

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 144.141.89.2
     (Link Data) Router Interface address: 144.128.254.137
      Number of TOS metrics: 0
       TOS 0 Metrics: 1000

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 144.141.89.2
     (Link Data) Router Interface address: 192.168.0.1 (or whatever)
      Number of TOS metrics: 0
       TOS 0 Metrics: 10000 (or whatever)

Then, can you illustrate the network configuration, specifically
which interface of Router 1 is connected to the interface which is
described as Link-Description #1 in the Router 2's Router-LSA ?
Why ?

Note that point-to-point link can be configured not to share the
IP-subnet. So Router 1's interface having address 144.128.254.138
may not necessarily be connected to the Router 2's interface having
address 144.128.254.137.

For the multicast forwarding of direction from Router 1 to Router 2,
both router can calculate that Router 1 should send the datagrams
on the interface #1 (having address 144.128.254.138), because it has
lower cost. But neither router can determine which interface the
Router 2 will receive that datagram on.

This problem is resolved in OSPFv3 as each single Link Description in
Router-LSA describes both sending and receiving halves (by describing
both side of IfIndex). OSPFv2's Link Description only describes sending
half and the *Router-ID* of receiving router. It doesn't describe
receiving half (interface) of receiving router.

Hope this helps.

regards,
yasu

From: Ian Potts <[email-masked]>
Subject: MOSPF can't determine the receiving interface exactly - In John Moy's book OSPF Anatomy of a Routing Protocol
Date: Thu, 5 Jun 2003 13:41:50 +0100

>      (Link Data) Router Interface address: 144.128.254.138
>       Number of TOS metrics: 0
>        TOS 0 Metrics: 1000
>
>      (Link Data) Router Interface address: 144.128.254.137
>       Number of TOS metrics: 0
>        TOS 0 Metrics: 1000
>