Subject: Re: Clarification in size of Rtr and network LSA

From: Krishna Rao <[email-masked]>
Date: Tue, 17 Jun 2003 13:42:20 -0000

Hi,
      If Fragmentation is the way for this, why should we negotiate MTU in DDP
Regards,
Krishna.

On Sat, 14 Jun 2003 Don Goodspeed wrote :
>Ok, ok.  I admit I was just stirring the pot a little.
>
>I just wanted people to see that, like it or not,
>fragmentation is a way of life in OSPF if you have
>more than a 100+ links on a router.
>
>Cheers,
>Don
>
>Don Goodspeed wrote:
> > Hmmm. Would a scheme like ISIS has for extended LSPs
> > work for the router LSA? If we could use a range of
> > router IDs that are not assigned, then maybe. Or we
> > could use a non-backward compatible method using opaque
> > LSAs. Any ideas? -don
>
>Don,
>
>Let's not go there ;^). Every implementation should
>support IP fragmentation and reassembly up to a certain
>limit (if not the full 64K). This should more than exceed
>anybody's requirement for the number of interfaces in a
>single area. For example, if one supports IP fragmentation
>and reassembly up to 16K (not an unreasonable number since
>there are some DLCs that support MTUs this big) one can
>support around 1350 numbered P2P interfaces or around
>2700 numbered or transit interfaces. Does anyone have
>a requirement to support more interfaces
>in a single area?
>
>Thanks,
>Acee
>
> >
> > ================================
> > Krishna,
> >
> > I myself don't like fragmentation, if just due to the fact
> > that any fragment gets dropped, then the whole packet/frame
> > needs to be rexmit'ed.
> >
> > Additionally, I would expect at least consistency counts for
> > each LSA type. This count should be retrieveable before
> > you start filling the LSA. With this count you can allocate
> > the proper memory size.
> >
> > Mitchell Erblich
> > Sr Software Engineer
> > -------------
> >
> > Krishna Rao wrote:
> >
> >>Hi,
> >>This is w.r.to the size of the Router LSA to be generated. We can not predict the size of the router LSA initially in the process of forming the Router LSA. Usually we allocate (Max MTU size - (OSPF header size + IP header size + MD5 authentication size) --> 1500 - (28 + 20 + 16)= 1436) and start filling the LSA. For Point to point interface we add two links and need 24 bytes for each point to point interface. That results in supporting only 59 interfaces in a single area. Is this an acceptable argument? or Should we design such that OSPF sends a LSA more than MTU size and gets fragmented in IP.
> >>What is the scalabilty figure for Number of interfaces in a area for popular routers?
> >>
> >>Thanks in advance,
> >>Regards,
> >>Krishna
> >
> >
> > _______________________________________________
> > Join Excite! - http://www.excite.com
> > The most personalized portal on the Web!
> >
>
>
>--
>Acee
>
>_______________________________________________
>Join Excite! - http://www.excite.com
>The most personalized portal on the Web!

---

From: Acee Lindem <[email-masked]>
Date: Tue, 17 Jun 2003 11:01:33 -0400

Krishna,

I'm assuming you mean database exchange by DDP. If two boxes on the same
network do not agree on the MTU, fragmentation will not be done correctly
and the box with the smaller MTU may not be able to receive a maximum
size packet from the box with larger MTU.

Acee

>> ------------------------------------------------------------------------
>>
>> <http://www.herohonda.com/karizma>
>

--
Acee