Subject: Re: OSPF Capabilities Draft

From: "Manral, Vishwas" <[email-masked]>
Date: Thu, 5 Jun 2003 07:19:33 -0400

Hi Acee,

Are you talking of some sort of a translation mechanism where you have ABR's
send area-scope LSA's into stub/NSSA for each global scope LSA?

Thanks,
Vishwas

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Monday, June 02, 2003 19:51
To: [email-masked]
Subject: Re: OSPF Capabilities Draft

I received one comment from Peter Psenack on this draft. A router
with attached stub or NSSA areas should also originate an area scoped
capability LSAs for these area when the domain wide flooding
option is selected. I think this is a good idea.and will add it
as we more forward. Any more discussion?

Thanks,
Acee

Acee Lindem wrote:
> The draft draft-raggarwal-igp-cap-0x.txt has been discussed at the
> last three IETFs. At the last two IETFs, there was mild support and
> we agreed to take the discussion to the OSPF WG list. In order to remove
> one of the barriers to making this draft a WG document, I have split out
> the OSPF specific portion into a separate draft. Rahul has done the same
> for ISIS.
>
> <Speaking as a WG Member>
>
> I beleive the time has come to accept this as a WG document. The
> described mechanism is consistent with other OSPF features and is
> backward compatible. All the OSPF options been have been allocated and
> new proposal will be able to make use of this mechanism without
> solving the option bit problem. One example is
> draft-vasseur-mpls-ospf-te-cap-00.txt.
>
> </Speaking as a WG Member>
>
> Link to draft below:
>
> http://www.ietf.org/internet-drafts/draft-lindem-ospf-cap-00.txt
>
> Further discussion? Any opposition to accepting this draft as a WG
> document?
>
> Thanks,
> --
> Acee
>

--
Acee

---

From: Peter Psenak <[email-masked]>
Date: Thu, 5 Jun 2003 21:49:14 +0200

Vishwas,

>send area-scope LSA's into stub/NSSA for each global scope LSA?
no. We talked with Acee about a case where NSSA ABR  needs to generate
multiple Capability LSA  - one Type-11 plus one Type-10 per each
stub/NSSA area attached.
Similar to Type-5 plus Type-7 LSAs case on NSSA ABR/ASBR.

thanks,
Peter

---

From: Acee Lindem <[email-masked]>
Date: Fri, 6 Jun 2003 00:40:09 -0400

> Similar to Type-5 plus Type-7 LSAs case on NSSA ABR/ASBR.

This seemed reasonable to me for attached NSSA/stubs (even though unattached
NSSA/stubs would not get the advertisements).

--
Acee