Subject: Inconsistent view of routers over a LAN

From: Cheng-Yin Lee <[email-masked]>
Date: Tue, 10 Jun 2003 11:01:49 -0400

Hello,
What happens if for some reason Router A can't reach Router B, but
Router C can reach A & B (and vice-versa), when Router A,B,C are
connected over a broadcast network or LAN.

E.g. in the case for (OSPF and IS-IS) where:
i) C is the DR
ii) B is the DR

Thanks
Cheng-Yin

---

From: Cheng-Yin Lee <[email-masked]>
Date: Tue, 10 Jun 2003 11:52:19 -0400

Hello,
Just got some private responses, perhaps I should clarify.
This is in context of an emulated LAN, and I am not looking for a fix in
routing protocols.

Thanks
Cheng-Yin

---

From: Acee Lindem <[email-masked]>
Date: Tue, 10 Jun 2003 13:16:02 -0400

> This is in context of an emulated LAN, and I am not looking for a fix in

Hi Cheng-Yin,

What I've recommended in the past for these situations is to force
the routing protocol to view the underlying network as a P2MP
(Point-to-Multi-Point) network. Many vendors support this. For
example, in our implementation you'd simply configure:

   router ospf 1
    area 0
     interface backbone
      network-type point-to-multipoint
               o
               o
          < the rest of the OSPF config>
               o

Good Luck,
Acee

--
Acee