Subject: Clarification in size of Rtr and network LSA

From: Krishna Rao <[email-masked]>
Date: Fri, 13 Jun 2003 10:23:50 -0000

Hi,
      This is w.r.to the size of the Router LSA to be generated. We can not predict the size of the router LSA initially in the process of forming the Router LSA. Usually we allocate  (Max MTU size - (OSPF header size  + IP header size + MD5 authentication size) --> 1500 - (28 + 20 + 16)= 1436) and start filling the LSA. For Point to point interface we add two links and need 24 bytes for each point to point interface. That results in supporting only 59 interfaces in a single area. Is this an acceptable argument? or Should we design such that OSPF sends a LSA more than MTU size and gets fragmented in IP. 
What is the scalabilty figure for Number of interfaces in a area for popular routers?

Thanks in advance,
Regards,
Krishna

---

From: Erblichs <[email-masked]>
Date: Fri, 13 Jun 2003 09:54:25 -0700

Krishna,

        I myself don't like fragmentation, if just due to the fact
        that any fragment gets dropped, then the whole packet/frame
        needs to be rexmit'ed.

        Additionally, I would expect at least consistency counts for
        each LSA type. This count should be retrieveable before
        you start filling the LSA. With this count you can allocate
        the proper memory size.

        Mitchell Erblich
        Sr Software Engineer
        -------------

Krishna Rao wrote:
>   ------------------------------------------------------------------------