Subject: Re: Zero as ospfIfRetransInterval

From: "Manral, Vishwas" <[email-masked]>
Date: Tue, 24 Jun 2003 08:55:15 -0400

Hi Acee,

If we do not intend to define new variables, we may want to at least put the
limitation of 0, in the object description in the MIB.

Thanks,
Vishwas

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Tuesday, June 24, 2003 18:16
To: [email-masked]
Subject: Re: Zero as ospfIfRetransInterval

Hi Dan,

Daniel Joyal wrote:
> You're not allowed to change the syntax unless
> it's equivalent to the old syntax.

Even if the old syntax doesn't match the protocol
specification?

> So in this
> case, we would need to deprecate/obsolete.

Then I don't think it is worth defining
new MIB variables given that ospfIfTransitDelay,
ospfIfRetransInterval, ospfVirtIfTransitDelay, and
ospfVirtIfRetransInterval have served us thus far.

Other opinions are welcome.

Thanks,
Acee

>
> -Dan
>
>  > -----Original Message-----
>  > From: Acee Lindem [mailto:[email-masked]]
>  > Sent: Monday, June 23, 2003 11:35 PM
>  > To: Mailing List; Joyal, Daniel [BL60:NP30:EXCH]
>  > Subject: Re: Zero as ospfIfRetransInterval
>  >
>  >
>  >
>  >
>  > Igor Miroshnik wrote:
>  > > All,
>  > >
>  > > Can anybody clarify the physical sense of assigning
>  > > ospfIfRetransInterval to zero? RFC1850 allows such an assignment.
>  >
>  > I believe UpToMaxAge should range from 1..3600 rather than 0..3600.
>  >
>  > Dan - can we change this in the MIB update without
>  > deprecating variables?
>  >
>  > >
>  > > Thanks
>  > >
>  >
>  >
>  > --
>  > Acee
>  >
>  >
>

--
Acee

---

From: Acee Lindem <[email-masked]>
Date: Tue, 24 Jun 2003 09:01:29 -0400

> limitation of 0, in the object description in the MIB.

Hi Vishwas,

That sounds like a good idea since any implementation that allows
write access to set the variables to 0 is broken.

Thanks,
Acee

--
Acee

---

From: Eric Gray <[email-masked]>
Date: Wed, 25 Jun 2003 11:05:37 -0400

Acee,

    Why would it be wrong to set a retransmit interval to zero?  Usually,
setting a retransmit interval to zero would have the special meaning that
retransmission does not occur (i.e. - the interval is infinite).  Is that not
an intended meaning in this case?

---

From: Acee Lindem <[email-masked]>
Date: Wed, 25 Jun 2003 13:02:52 -0400

> an intended meaning in this case?

Nope - not retransmitting would make the flooding unreliable and
would violate the base protocol specification (RFC 2328).

--
Acee