Subject: [OSPF] Security Extension for OSPFv2 when using Manual Key Management - draft-bhatia-karp-ospf-ip-layer-protection-03

From: Acee Lindem <[email-masked]>
Date: Mon, 11 Apr 2011 13:18:08 -0400

There was general agreement that this should be a WG document at the meeting in Prague. Please indicate your position on making this draft a WG document with intended status Proposed Standard. 

Thanks,
Acee

---

From: Stan Ratliff <[email-masked]>
Date: Mon, 11 Apr 2011 14:16:48 -0400

Support.

Regards,
Stan

On Apr 11, 2011, at 1:18 PM, Acee Lindem wrote:

> There was general agreement that this should be a WG document at the  
> meeting in Prague. Please indicate your position on making this  
> draft a WG document with intended status Proposed Standard.
>
> Thanks,
> Acee
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Glen Kent <[email-masked]>
Date: Tue, 12 Apr 2011 05:10:16 +0530

Support

---

From: Jack Kohn <[email-masked]>
Date: Tue, 12 Apr 2011 05:30:14 +0530

+1

On Mon, Apr 11, 2011 at 11:46 PM, Stan Ratliff <[email-masked]> wrote:
>> meeting in Prague. Please indicate your position on making this draft a WG
>> document with intended status Proposed Standard.
>>
>> Thanks,
>> Acee

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 11 Apr 2011 22:58:16 -0400

In message <[email-masked]>
Acee Lindem writes:
> meeting in Prague. Please indicate your position on making this draft
> a WG document with intended status Proposed Standard.
>  
> Thanks,
> Acee

Yes I support making this a WG item.

One improvement and something pointed out in KARP is that
public/private key pairs are often used and have advantages over
shared keys.  One thing that can be done if a public/private key pair
is used is encrypt a session key for use during a session.  Instead of
a sequence number or session ID, the key itself is exchanged.  That is
somewhat similar to the way kerberos makes use of a session key to
encrypt as little information as possible using the shared secret that
is used to get a tgt from the KDC.  This has an advantage that with a
periodic change in the session key a snooper with access to a lot of
computing resource could still have trouble breaking the session key
before it changed.

For most applications of OSPF this won't matter.  For some it might.

Curtis

And always remember - just because you are paranoid doesn't mean they
are not out to get you.  :-)

---

From: Wenhu Lu <[email-masked]>
Date: Tue, 12 Apr 2011 14:25:30 -0400

Yes I support.

Regards,
-wenhu 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Acee Lindem
Sent: Monday, April 11, 2011 10:18 AM
To: OSPF WG List
Cc: Sam Hartman
Subject: [OSPF] Security Extension for OSPFv2 when using Manual Key Management - draft-bhatia-karp-ospf-ip-layer-protection-03

Thanks,
Acee

---

From: Russ White <[email-masked]>
Date: Tue, 12 Apr 2011 14:43:04 -0400

Support.

:-)

Russ

---

From: Abhay Roy <[email-masked]>
Date: Wed, 27 Apr 2011 08:47:34 -0700

There has been multiple support and no opposition for this draft. We 
will make this a WG draft..

Regards,
-Abhay