Subject: [OSPF] WG Last Call for Supporting Authentication Trailer for OSPFv3 - draft-ietf-ospf-auth-trailer-ospfv3-03.txt

From: Abhay Roy <[email-masked]>
Date: Mon, 11 Apr 2011 09:19:10 -0700

We are starting the Working Group Last Call of this revision of the 
subject draft.

This drafts is intended to be a Proposed Standard. The OSPF WG last call
will begin today and will end at 5pm PST,  April 25th, 2011.

Abhay/Acee

-------- Original Message --------
Subject: 	I-D Action:draft-ietf-ospf-auth-trailer-ospfv3-03.txt
Date: 	Sat, 19 Feb 2011 12:00:02 -0800
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]
CC: 	[email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Open Shortest Path First IGP Working Group of the IETF.

	Title           : Supporting Authentication Trailer for OSPFv3
	Author(s)       : M. Bhatia, et al.
	Filename        : draft-ietf-ospf-auth-trailer-ospfv3-03.txt
	Pages           : 20
	Date            : 2011-02-19

Currently OSPFv3 uses IPsec for authenticating protocol packets.
However, there are some environments, e.g., Mobile Ad-hoc Networks
(MANETs), where IPsec is difficult to configure and maintain, and
this mechanism cannot be used.  This draft proposes an alternative
mechanism that can be used so that OSPFv3 does not depend upon IPsec
for authentication.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ospf-auth-trailer-ospfv3-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 11 Apr 2011 13:01:54 -0400

Yes/Supported

Regards,
Jeff

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Abhay Roy
Sent: Monday, April 11, 2011 09:19
To: [email-masked]
Subject: [OSPF] WG Last Call for Supporting Authentication Trailer for OSPFv3 - draft-ietf-ospf-auth-trailer-ospfv3-03.txt

We are starting the Working Group Last Call of this revision of the subject draft.

Abhay/Acee

-------- Original Message --------
Subject:

I-D Action:draft-ietf-ospf-auth-trailer-ospfv3-03.txt

Date:

Sat, 19 Feb 2011 12:00:02 -0800

From:

[email-masked]<mailto:[email-masked]>

Reply-To:

[email-masked]<mailto:[email-masked]>

To:

[email-masked]<mailto:[email-masked]>

CC:

[email-masked]<mailto:[email-masked]>

        Pages           : 20

        Date            : 2011-02-19

for authentication.

Internet-Draft.

---

From: Glen Kent <[email-masked]>
Date: Tue, 12 Apr 2011 05:11:35 +0530

No comments!

On Mon, Apr 11, 2011 at 9:49 PM, Abhay Roy <[email-masked]> wrote:

> -------- Original Message --------  Subject: I-D
> Action:draft-ietf-ospf-auth-trailer-ospfv3-03.txt  Date: Sat, 19 Feb 2011
> 12:00:02 -0800  From: [email-masked]  Reply-To:
> [email-masked]  To: [email-masked]  CC: [email-masked]
>
> A URL for this Internet-Draft is:http://www.ietf.org/internet-drafts/draft-ietf-ospf-auth-trailer-ospfv3-03.txt
>
> Internet-Drafts are also available by anonymous FTP at:ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>
>

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 11 Apr 2011 22:42:52 -0400

In message <[email-masked]>
Abhay Roy writes:
> This drafts is intended to be a Proposed Standard. The OSPF WG last
> call will begin today and will end at 5pm PST, April 25th, 2011.
>  
> Abhay/Acee

It is weak with only the 32 bit sequence number.  That said, if there
is concensus for moving forward as-is I have no objection.  It is a
step in the right direction, though IMHO it is too small a step in the
right direction and would not have to be revisited quite as soon if
something more robust were proposed.

Bottom line.  Falls short of what I'd like to see but no objection.

Curtis

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Tue, 12 Apr 2011 08:38:47 +0530

Hi Curtis,

This draft aligns the OSPFv3 security mechanism with that of OSPFv2. Once this is done, any proposal or extension that works for OSPFv2 will work for OSPFv3 as well. 

If for example, we decide to go via the nonce and session ID mechanism or the KARP boot count, then that mechanism will work for OSPFv3 also.

So, this really is orthogonal to the work that's being carried out in KARP/OSPF WGs. Once that gets frozen it will be applicable to OSPFv3 as well. However, that can happen only once we have this piece in.

Cheers, Manav

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 11 Apr 2011 23:40:13 -0400

In message <[email-masked]>
"Bhatia, Manav (Manav)" writes:
>  
> Hi Curtis,
>  
> This draft aligns the OSPFv3 security mechanism with that of
> OSPFv2. Once this is done, any proposal or extension that works for
> OSPFv2 will work for OSPFv3 as well.
>  
> If for example, we decide to go via the nonce and session ID mechanism
> or the KARP boot count, then that mechanism will work for OSPFv3 also.
>  
> So, this really is orthogonal to the work that's being carried out in
> KARP/OSPF WGs. Once that gets frozen it will be applicable to OSPFv3
> as well. However, that can happen only once we have this piece in.
>  
> Cheers, Manav

Thanks.

Curtis

---

From: Russ White <[email-masked]>
Date: Tue, 12 Apr 2011 14:42:35 -0400

Support.

:-)

Russ

-- 
[email-masked] :: CCIE :: CCDE :: <>< Grace Alone

Now, we never can annihilate a penalty. We can only divert it from the
head of the man who has incurred it to the heads of others who have not
incurred it. A vast amount of "social reform" consists in just this
operation. -William Graham Sumner

---

From: Abhay Roy <[email-masked]>
Date: Wed, 27 Apr 2011 08:54:20 -0700

There has been much discussion on the list, and one significant change 
was made to -03 version. Cryptographic Sequence Number has changed from 
32 bit to 64 bits.

We would like to extend the Last Call till 5pm PST, May 9th 2011.

Please review the changes from 03 -> 04 version. Diff can be found here:

http://tools.ietf.org/rfcdiff?url2=draft-ietf-ospf-auth-trailer-ospfv3-04.txt

-Abhay/Acee

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 27 Apr 2011 12:08:14 -0400

Yes/support

Regards,
Jeff

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Abhay Roy
Sent: Wednesday, April 27, 2011 08:54
To: [email-masked]
Subject: [OSPF] WG Last Call (EXTENDED) for Supporting Authentication Trailer for OSPFv3 - draft-ietf-ospf-auth-trailer-ospfv3-04.txt

There has been much discussion on the list, and one significant change was made to -03 version. Cryptographic Sequence Number has changed from 32 bit to 64 bits.

-Abhay/Acee

Abhay/Acee

-------- Original Message --------
Subject:

Date:

From:

Reply-To:

To:

CC:

        Pages           : 20

        Date            : 2011-02-19

for authentication.

Internet-Draft.