Subject: [OSPF] Comments on OSPF Hybrid Broadcast and P2MP Interface Type - draft-ietf-ospf-hybrid-bcast-and-p2mp-00.txt

From: Acee Lindem <[email-masked]>
Date: Fri, 3 Feb 2012 12:45:29 -0500

I've reviewed the subject document and have a couple comments. 

    This document introduces some new dependencies since routers connected to the hybrid network are using the DRs Router-LSA to originate their own Router-LSA. Hence, if some goes wrong with the distributed DR election algorithm, connectivity will fail differently than before. Is anyone concerned about this? If so, we could add a requirement that the non-DR router and the DR agree on who is DR prior to the non-DR router using the DR-Router's Router-LSA to originate its own. 

    The document needs a "Management Considerations" section that addresses how the hybrid interface will be represented in the OSPF and OSPFv3 MIBs. This would include the ospfIfType and ospfv3IfType.

Thanks,
Acee

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 15 Feb 2012 10:23:51 -0500

Acee,

Thanks for your comments. Please see below.

> -----Original Message-----
> From: Acee Lindem [mailto:[email-masked]] 
> Sent: Friday, February 03, 2012 12:45 PM
> To: [email-masked] List
> Subject: [OSPF] Comments on OSPF Hybrid Broadcast and P2MP 
> Interface Type - draft-ietf-ospf-hybrid-bcast-and-p2mp-00.txt
> 
>     This document introduces some new dependencies since 
> routers connected to the hybrid network are using the DRs 
> Router-LSA to originate their own Router-LSA. Hence, if some 
> goes wrong with the distributed DR election algorithm, 
> connectivity will fail differently than before. Is anyone 
> concerned about this? If so, we could add a requirement that 
> the non-DR router and the DR agree on who is DR prior to the 
> non-DR router using the DR-Router's Router-LSA to originate its own. 

Makes sense. How about the following?

   o  If a router is not the DR and has a full adjacency to the DR,
-->   and both the DR and this router agree on the DR role, it
      MUST add a Type 1 link corresponding to each neighbor that is in
      state 2-Way or higher and to which the DR's router LSA includes
      a link.

> 
> 
>     The document needs a "Management Considerations" section 
> that addresses how the hybrid interface will be represented 
> in the OSPF and OSPFv3 MIBs. This would include the 
> ospfIfType and ospfv3IfType.

Sure we'll add that.

Should the neighbor entry be enhanced to include per-nbr metric as well? Current interface entry does include interface metrics, so it makes sense to include per-nbr metric in the nbr entry.

Thanks.
Jeffrey

---

From: Acee Lindem <[email-masked]>
Date: Wed, 15 Feb 2012 11:53:21 -0500

Hi Jeffrey,

>      state 2-Way or higher and to which the DR's router LSA includes

That's fine. Hope you guys agree with the additional verification. 

> Should the neighbor entry be enhanced to include per-nbr metric as well? Current interface entry does include interface metrics, so it makes sense to include per-nbr metric in the nbr entry.

I'd say yes. While this is not documented as a neighbor configuration parameter for P2MP networks, everyone has implemented it. 

Thanks,
Acee