Subject: [OSPF] question about Opaque LSA (RFC 5250)

From: Gaurav Agrawal <[email-masked]>
Date: Thu, 23 Aug 2012 12:20:05 -0700

Hi,
    I have couple of questions about reachability of originator of Type 11
Opaque LSA. According to RFC, When processing a received type-11 Opaque
LSA, the router MUST look up the routing table entries (potentially one per
attached area) for the ASBR that originated the LSA.  If no entries
exist for the ASBR (i.e., the ASBR is unreachable), the router MUST
do nothing with this LSA.

1. Should the LSA still be flooded if originator is not reachable?  In my
understanding the reachability check should be done while while processing
the data in LSA not while flooding the LSA. Can someone clarify?

2. Since, OSPF itself will not use the opaque data, does this imply that
OSPF needs to notify the application that originator of opaque data is
unreachable and opaque data is stale.

Thanks,
Gaurav

---

From: Acee Lindem <[email-masked]>
Date: Thu, 23 Aug 2012 15:32:58 -0400

Hi Gaurav, 

On Aug 23, 2012, at 3:20 PM, Gaurav Agrawal wrote:

> Hi,
>     I have couple of questions about reachability of originator of Type 11 Opaque LSA. According to RFC, When processing a received type-11 Opaque LSA, the router MUST look up the routing table entries (potentially one per attached area) for the ASBR that originated the LSA.  If no entries exist for the ASBR (i.e., the ASBR is unreachable), the router MUST do nothing with this LSA.
>  
> 1. Should the LSA still be flooded if originator is not reachable? 

Of course, there is no advertising router reachability checking prior to flooding. 

> In my understanding the reachability check should be done while while processing the data in LSA not while flooding the LSA.

Yes. Consider this in terms of the non-opaque LSAs, an OSPF router will not install routes corresponding to a Router-LSA or AS-External-LSA if the advertising router is not reachable. 

> Can someone clarify?
>  
> 2. Since, OSPF itself will not use the opaque data, does this imply that OSPF needs to notify the application that originator of opaque data is unreachable and opaque data is stale.

That is an implementation detail but an OSPF API to determine if the originator is essentially implied. The details of the API, e.g., notification or polling, are not part of the specification. 

Hope this helps, 
Acee