Subject: [OSPF] Mirja Kühlewind's No Objection on draft-ietf-ospf-ttz-05: (with COMMENT)

From: "Mirja Kuehlewind" <[email-masked]>
Date: Wed, 04 Jan 2017 09:34:46 -0800

Mirja Kühlewind has entered the following ballot position for
draft-ietf-ospf-ttz-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ospf-ttz/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Questions on IANA section (not an OSPF expert, so please excuse me if I
misunderstood something):
- Don't you have to register both LS types 9 and 10 somehow?
- And do the "Types for new TLVs in the new TTZ LSA" create a new
registry or is this an existing one?

Other minor comments:
- What's a DR? Please spell this out!
- There is only little normative language used in this doc. Potentially
some more normative language could make things clearer. However I don't
have concrete proposals what to change and I believe the most important
parts are in normative language. So there is no urgent need to change
anything but maybe another check would be good to make sure normative
language is used where needed.

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 5 Jan 2017 03:23:18 +0000

Hi Mirja,

    Thank you very much for your time and valuable comments.
    Your comments are addressed inline below with prefix [HC].

Best Regards,
Huaimo
-----Original Message-----
From: Mirja Kuehlewind [mailto:[email-masked]]
Sent: Wednesday, January 04, 2017 12:35 PM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Mirja Kühlewind's No Objection on draft-ietf-ospf-ttz-05: (with COMMENT)

Questions on IANA section (not an OSPF expert, so please excuse me if I
misunderstood something):
- Don't you have to register both LS types 9 and 10 somehow?
[HC]: LS types 9 and 10 are the existing types. No need to register them.

- And do the "Types for new TLVs in the new TTZ LSA" create a new
registry or is this an existing one?
[HC]: A new register needs to be created for "Types for new TLVs in the new TTZ LSA". In section “IANA Considerations”, the following changes have been proposed to and approved by IANA.

  IANA is to create and maintain a new registry:

  o OSPFv2 TTZ LSA TLVs

  Initial values for the registry are given below.

       Value         OSPFv2 TTZ LSA TLV Name    Definition
       -----         -----------------------    ----------
       0             Reserved
       1             TTZ ID TLV                 see section 6.2
       2             TTZ Router TLV             see section 6.3
       3             TTZ Options TLV            see section 6.4
       4-32767       Unassigned
       32768-65535   Reserved

  The future assignments are to be made through IETF Review.

Other minor comments:
- What's a DR? Please spell this out!
[HC]: DR is short for Designated Router. We will spell it out in the document.

[HC]: We will have another check for this and make sure normative language is used wherever needed.

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 5 Jan 2017 11:24:10 -0800

Hi Mirja, Authors, et. al,
I have question about allocating new LSA type number for TTZ LSA for
Experimental document from IETF Consensus/IETF Review, as suggested in
Section 14, rather than from the Private Use range.
Or, which may be the best route, partition the Private use range into
Experimental and Private and then allocate the new value out of the
Experimental range.

Regards,
Greg

On Wed, Jan 4, 2017 at 9:34 AM, Mirja Kuehlewind <[email-masked]>
wrote:

> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 5 Jan 2017 19:41:39 +0000

Hi Greg,

From: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 5, 2017 at 2:24 PM
To: Mirja Kuehlewind <[email-masked]<mailto:[email-masked]>>
Cc: The IESG <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] Mirja Kühlewind's No Objection on draft-ietf-ospf-ttz-05: (with COMMENT)
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Thursday, January 5, 2017 at 2:24 PM

Hi Mirja, Authors, et. al,
I have question about allocating new LSA type number for TTZ LSA for Experimental document from IETF Consensus/IETF Review, as suggested in Section 14, rather than from the Private Use range.

Irrespective of the experimental track, this is an OSPF WG document which has going through both IETF Consensus and Review so I see no issues with drawing from values from the general range.

Thanks,
Acee

Or, which may be the best route, partition the Private use range into Experimental and Private and then allocate the new value out of the Experimental range.

Regards,
Greg

On Wed, Jan 4, 2017 at 9:34 AM, Mirja Kuehlewind <[email-masked]<mailto:[email-masked]>> wrote:
Mirja Kühlewind has entered the following ballot position for
draft-ietf-ospf-ttz-05: No Objection

Other minor comments:

_______________________________________________
OSPF mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ospf