Subject: [OSPF] [OSPFv3-SR] Regarding Prefix SID Sub TLV advertisment for IPv6 data plane Segment routing

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Mon, 16 Jan 2017 13:46:16 +0000

Dear Authors,
I am requesting your clarification regarding prefix-SID sub TLV  advertisement for IPv6 data plane.

In case of data plane is IPV6 data plane,  while advertising IPv6 prefix (Node/Prefix SID) in E-intra/E-inter prefix TLV of extension LSAS, whether we need to include Prefix-SID sub TLV.
If need to include, we can encode  Ipv6 address prefix in SID/Label sub TLV. As per draft, if the length of this sub TLV must be 3 or 4.

For Adj-SID,  for SID filed it is clearly mention it may be ipv6 address, but it is not mentioned for Prefix- SID sub TLV.
It means for IPv6 prefix segment advertisement , Prefix-SID sub TLV  may not be required to advertise in extension LSAs.

Regards,
Veerendranath

---

From: Peter Psenak <[email-masked]>
Date: Mon, 16 Jan 2017 16:43:51 +0100

Veerendranath,

On 16/01/17 14:46 , Veerendranatha Reddy Vallem wrote:
> In case of data plane is IPV6 data plane,  while advertising IPv6 prefix
> (Node/Prefix SID) in E-intra/E-inter prefix TLV of extension LSAS,
> whether we need to include Prefix-SID sub TLV.

definitely not the Prefix-SID sub TLV as defined in the draft - that was 
defined for MPLS data plane.

The draft needs more work/changes for the IPv6 data plane. We are 
planning to update it accordingly.

thanks,
Petetr

>
> If need to include, we can encode  Ipv6 address prefix in SID/Label sub
> TLV. As per draft, if the length of this sub TLV must be 3 or 4.
>
> For Adj-SID,  for SID filed it is clearly mention it may be ipv6
> address, but it is not mentioned for Prefix- SID sub TLV.
>
> It means for IPv6 prefix segment advertisement , Prefix-SID sub TLV  may
> not be required to advertise in extension LSAs.
>
> Regards,
>
> Veerendranath
>