Subject: [OSPF] Quagga OSPF

From: sree ietf <[email-masked]>
Date: Tue, 3 Jan 2017 12:10:58 +0530

Hi All,

Does OSPF QUAGGA supports Segment Routing?

Thanks & Regards
Sreekanth

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 03 Jan 2017 07:43:56 +0000

To my knowledge it does not
On Mon, Jan 2, 2017 at 22:41 sree ietf <[email-masked]> wrote:

> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: Mathias HOUNGBO <[email-masked]>
Date: Tue, 3 Jan 2017 09:52:56 +0100

what's Segment Routing ?

Le 03/01/2017 à 08:43, Jeff Tantsura a écrit :
> On Mon, Jan 2, 2017 at 22:41 sree ietf <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi All,
>

Il n'y a pas de raccourci pour atteindre le développement.
Open source is not limited to software and it is not limited to english either! 
Mefies toi de la médiocrité, c'est la moisissure de l'esprit

-- 
My blog - http://mathias.houngbo.net

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 3 Jan 2017 11:30:56 +0000

Mathias - See https://www.ietf.org/id/draft-ietf-spring-segment-routing-10.txt

Hope this helps,
Acee

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of Mathias HOUNGBO <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 3, 2017 at 3:52 AM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] Quagga OSPF

what's Segment Routing ?

Le 03/01/2017 à 08:43, Jeff Tantsura a écrit :
To my knowledge it does not
On Mon, Jan 2, 2017 at 22:41 sree ietf <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

Thanks & Regards
Sreekanth

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 3 Jan 2017 07:43:58 -0800

There's definitely interest. Perhaps the best person to talk to would be David

Regards,
Jeff

> On Jan 3, 2017, at 03:30, Acee Lindem (acee) <[email-masked]> wrote:
> 
> Mathias - See https://www.ietf.org/id/draft-ietf-spring-segment-routing–10.txt
> 
> Hope this helps,
> Acee
> 
> From: OSPF <[email-masked]> on behalf of Mathias HOUNGBO <[email-masked]>
> To: OSPF WG List <[email-masked]>

---

From: Dinesh Dutt <[email-masked]>
Date: Tue, 3 Jan 2017 08:07:47 -0800

No it does not,

Dinesh

---

From: Paul Jakma <[email-masked]>
Date: Wed, 4 Jan 2017 11:23:56 +0000 (GMT)

> Does OSPF QUAGGA supports Segment Routing?

It doesn't, but it could be interesting.

It's worth noting that you can already somewhat create arbitrary paths 
between different source/dests, or different paths from shortest for 
arbitrary dests, from a central controller, using just standard OSPF. 
See the SIGCOMM "Central Control Over Distributed Routing" paper and 
http://fibbing.net. Really interesting work.

regards,
-- 
Paul Jakma | [email-masked] | @pjakma | Key ID: 0xD86BF79464A2FF6A
Fortune:
How long does it take a DEC field service engineer to change a lightbulb?

It depends on how many bad ones he brought with him.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 4 Jan 2017 11:58:10 +0000

Hi Paul, 

On 1/4/17, 6:23 AM, "OSPF on behalf of Paul Jakma" <[email-masked]

>http://fibbing.net. Really interesting work.

Interesting but certainly not a generalized solution offering the breadth
of functionality and flexibility as OSPF Segment Routing.

Thanks, 
Acee

---

From: Mathias HOUNGBO <[email-masked]>
Date: Wed, 4 Jan 2017 13:45:44 +0100

Thanks Acee

Le 03/01/2017 à 12:30, Acee Lindem (acee) a écrit :
> Mathias - See
> https://www.ietf.org/id/draft-ietf-spring-segment-routing–10.txt
> <https://www.ietf.org/id/draft-ietf-spring-segment-routing%9610.txt>
>
> Hope this helps,
> Acee
>
> From: OSPF <[email-masked] <mailto:[email-masked]>> on
> behalf of Mathias HOUNGBO <[email-masked]
> <mailto:[email-masked]>>
> To: OSPF WG List <[email-masked] <mailto:[email-masked]>>

---

From: Olivier Dugeon <[email-masked]>
Date: Tue, 10 Jan 2017 16:59:10 +0100

Hi Sreekanth, all

Sorry for the delay, but I just subscribe to the mailing list.

Here, at Orange, we have developed a Segment Routing implementation on top of Quagga for OSPF.

For the moment, the code is not ready to be published. I must solve a strange issue before releasing it: OSPF Opaque LSA to advertised Adjacency SID are emitted with a wrong checksum which cause some problem of course when received by neighbours routers.

The code has been tested against Cisco IOS-XRv version 6.0.1. and works well when there is no bad checksum. It is possible to configure several Node SID (one per loopback address), SRGB, and the code manage automatically Adjacency SID. MPLS FIB entries are automatically computed and installed in the Linux Kernel. There is also the possibility to build Segment Path for a given prefix, thus adding new entries in the MPLS FIB.

The code needs Linux Kernel version 4.5 minimum for MPLS data plane support and ldpd implementation for Quagga for interaction between Zebra layer and the kernel to fulfil MPLS FIB.. There is also a remaining bug in the Linux kernel: it is possible to push only 2 labels. We got a patch from Cumulus Network to correct it and we can stack up to 16 labels. We made success tests up to 8 labels stack. In addition, due to Linux Kernel MPLS behaviour, our implementation support only Penultimate Hop Popping.

So, I would correct all remaining bugs before releasing the code and make a public announcement. But, as the question has been raised on the mailing list, I start to exchange information in case of peoples on the list are interested to help us. I hope to have a release by February.

In our todo list, we plan to port the code to ISIS, add binding SID support, work without PHP and add the possibility to enforce Tactical TE path i.e. specify the label stack for a given prefix.

Regards

Olivier

> -------- Message transféré --------
> Date :     Tue, 3 Jan 2017 12:10:58 +0530
> De :     sree ietf <[email-masked]>
> Pour :     [email-masked]
>
> Hi All,
>