Subject: [OSPF] FW: [OSPFv3 IPv6 SR] Regarding prefixes identification for IPv6 Segment Routing

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Mon, 20 Feb 2017 09:34:09 +0000

Dear Authors,
Gentle remainder,

We are planning to implement the "identification of IPv6 prefix for segment routings  (SRH) by setting the flag in option field" as described in below mail.
Please provide your valuable opinion  whether it is ok as per Extension draft.

Regards,
Veerendranath

From: Veerendranatha Reddy Vallem
Sent: 14 February 2017 13:08
To: [email-masked]' <[email-masked]>
Cc: [email-masked]
Subject: [OSPFv3 IPv6 SR] Regarding prefixes identification for IPv6 Segment Routing

Dear Authors,
While adverting prefixes for IPv6 Segment Routing (SRH support), the IPv6 prefixes  may not require to carry additional sub TLVs related to SRH some times.
So to identify prefixes are using for IPv6 Segment Routing, it may be helpful we add one option bit in prefix options like 'N' bit added for Node identification.

Please provide your opinion for adding new bit for IPv6 segment routing  in prefix options.

                        0  1  2  3  4  5  6  7
                    +--+--+--+--+--+--+--+--+
                    |  |  | N|DN| P| x|LA|NU|
                    +--+--+--+--+--+--+--+--+

Regards,
Veerendranath

---

From: Peter Psenak <[email-masked]>
Date: Mon, 27 Feb 2017 16:01:52 +0100

Veerendranath,

can you please elaborate on the use case? I'm not sure I understand 
exactly what you are asking for.

thanks,
Peter

On 20/02/17 10:34 , Veerendranatha Reddy Vallem wrote:
> Dear Authors,
>
> Gentle remainder,
>
> We are planning to implement the “identification of IPv6 prefix for
> segment routings  (SRH) by setting the flag in option field” as
> described in below mail.
>
> *From:* Veerendranatha Reddy Vallem
> *Sent:* 14 February 2017 13:08
> *To:* [email-masked]'
> <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* [OSPFv3 IPv6 SR] Regarding prefixes identification for IPv6
> Segment Routing
>
> Dear Authors,
>
> While adverting prefixes for IPv6 Segment Routing (SRH support), the
> IPv6 prefixes  may not require to carry additional sub TLVs related to
> SRH some times.
>
> So to identify prefixes are using for IPv6 Segment Routing, it may be
> helpful we add one option bit in prefix options like ‘N’ bit added for
> Node identification.
>

---

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Tue, 28 Feb 2017 05:32:44 +0000

Dear Peter,

We used segment routing support flag (bit 6 or 7 in RI capability information) to notify the node support SR capability.
But there may be some legacy I/O boards which are not capable for SRH/MPLS processing, can be bound to OSPF process.

OSPFv3 extended LSAs can also be used to carry normal prefix information same as regular LSAs.

For MPLS, we have sub TLVs for SR prefix information, so that we can identify the prefixes not used for  segment routing.

But for IPv6, prefix information itself prefix SID, so mostly sub TLV information is not used to carry additional SR information.
So in this case, I feel, we may need a flag to identify the prefixes not supported segment routing or supporting segment routing.

Regards,
Veerendranath

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: 27 February 2017 20:32
To: Veerendranatha Reddy Vallem <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: FW: [OSPFv3 IPv6 SR] Regarding prefixes identification for IPv6 Segment Routing

Veerendranath,

can you please elaborate on the use case? I'm not sure I understand exactly what you are asking for.

thanks,
Peter

On 20/02/17 10:34 , Veerendranatha Reddy Vallem wrote:
> Dear Authors,
>
> Gentle remainder,
>
> We are planning to implement the "identification of IPv6 prefix for 
> segment routings  (SRH) by setting the flag in option field" as 
> described in below mail.
>
> helpful we add one option bit in prefix options like 'N' bit added for 
> Node identification.
>

---

From: Peter Psenak <[email-masked]>
Date: Tue, 28 Feb 2017 13:00:33 +0100

Veerendranath,

OSPFv3 SR extension would need a bigger changes for SRv6.

The point you are raising is valid, but I'm not sure the flag is the 
right approach. We may want to detach the SRv6 advertisements from the 
prefix reachability advertisements completely, because we do no want the 
SRv6 segments to contribute to the routing at all.

We are working on the ISIS extension for SRv6 and once that is done I 
will update the OSPFv3 draft accordingly.

thanks,
Peter

On 28/02/17 06:32 , Veerendranatha Reddy Vallem wrote:
> .