Subject: [OSPF] [Adj-SID Flags] Regarding newly added 'P' flag

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Thu, 2 Mar 2017 04:53:19 +0000

Dear Authors,
As per my understanding 'P' flag is used to avoid Adj-SID value  change in forwarding plane and during segment routing path calculation by controller  for interface flapping or switch over cases.
The Adj-SID value may change if adjacency gone down for longer period (say 10 min) and come up, even P flag is set in previous advertisement.
Please help me to know if any other use cases for setting P flag in Adj-SID

Regards,
Veerendranath

---

From: Peter Psenak <[email-masked]>
Date: Thu, 02 Mar 2017 10:26:09 +0100

Hi Veerendranath,

On 02/03/17 05:53 , Veerendranatha Reddy Vallem wrote:
> Dear Authors,
>
> As per my understanding ‘P’ flag is used to avoid Adj-SID value  change
> in forwarding plane and during segment routing path calculation by
> controller  for interface flapping or switch over cases.

for any case, even for router reload, etc.

>
> The Adj-SID value may change if adjacency gone down for longer period
> (say 10 min) and come up, even P flag is set in previous advertisement.

no. If the P flag is set, the Adj-SID should never change, unless 
specifically requested by the operator.

thanks,
Peter