Subject: [OSPF] OSPF RFC 2328

From: "Panetta, Chris" <[email-masked]>
Date: Fri, 28 Apr 2017 17:36:14 +0000

Hello,

I was referred over to this group from [email-masked]. I just have a general question in regards to RFC 2328 or more specifically devices within my network that are clearly not following procedure. I guess I am also trying to get more of an understanding of how a company would establish itself as being a provider of a routing device. I am currently in discussions with a company that has provided us with the ability to perform OSPF within our company. We are running into an issue though where it seems as if OSPF is NOT following the RFC 2328 procedure. What's happening is the device is believing itself to have higher router ID than the DR/ BDR when the DR / BDR is already established. The DR has a priority of 110 the BDR has priority 105 and the device in question has a priority of 1. For a company to even say that they can provide RIP / OSPF / BGP on their devices do they have to adhere to IETF RFCs? Is that checked at all by the IETF a product is performing per RFC?

Christopher Panetta
Network Administrator
Suffolk County Water Authority
4060 Sunrise Hwy
Oakdale, New York 11769
D   631-563-0332
M  631-338-6081
http://www.scwa.com<http://www.scwa.com/>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 28 Apr 2017 18:03:39 +0000

Hi Chris,

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of "Panetta, Chris" <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 28, 2017 at 1:36 PM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] OSPF RFC 2328

Hello,

I was referred over to this group from [email-masked]<mailto:[email-masked]>. I just have a general question in regards to RFC 2328 or more specifically devices within my network that are clearly not following procedure. I guess I am also trying to get more of an understanding of how a company would establish itself as being a provider of a routing device. I am currently in discussions with a company that has provided us with the ability to perform OSPF within our company. We are running into an issue though where it seems as if OSPF is NOT following the RFC 2328 procedure. What’s happening is the device is believing itself to have higher router ID than the DR/ BDR when the DR / BDR is already established. The DR has a priority of 110 the BDR has priority 105 and the device in question has a priority of 1. For a company to even say that they can provide RIP / OSPF / BGP on their devices do they have to adhere to IETF RFCs? Is that checked at all by the IETF a product is performing per RFC?

I can tell you that this is unequivocally not the charter of the IETF.

Thanks,
Acee (OSPF Co-Chair)

Christopher Panetta
Network Administrator