Subject: [OSPF] [ospf-sr] regarding Algorithm TLV and other TLVs in RI LSA

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Fri, 28 Apr 2017 07:12:36 +0000

Dear Authors,

1.      As per section 3.1 SR- Algorithm TLV ,

       "If the SR-Algorithm sub-TLV appears in multiple Router Information LSAs

          that have different flooding scopes, the SR-Algorithm sub-TLV in the Router Information LSA with

          the lowest flooding scope SHOULD be used."

      "The RI LSA can be advertised at any of the defined opaque flooding
       scopes (link, area, or Autonomous System (AS)).  For the purpose of
       SR-Algorithm TLV advertisement, area scope flooding is required."

      As per first  statement, we should use lowest scope (Ex: if the algorithm TLV is received in AS ,Area and link, then link SR algorithm is preferred)
       But second statement indicates we use area scope for algorithm TLV. These two statements may cause little confusion while implementation.
      As per my understanding,  Area scope will be preferred since Node visibility is at area scope.

2.      Even "SR Local Block Sub-TLV SRMS and Preference Sub-TLV" are top level TLVs in RI LSA like SR-Algorithm TLV and "SID/Label Range TLV", may be it is better to replace "Sub TLV" with TLV.

Thanks and Regards,
Veerendranath

---

From: Peter Psenak <[email-masked]>
Date: Fri, 28 Apr 2017 09:56:02 +0200

Veerendranatha,

On 28/04/17 09:12 , Veerendranatha Reddy Vallem wrote:
> Dear Authors,
>
> 1.As per section 3.1 SR- Algorithm TLV ,
>
>
>
>        “The RI LSA can be advertised at any of the defined opaque flooding
>
>         SR-Algorithm TLV advertisement, area scope flooding is required.”
>
>        As per first  statement, we should use lowest scope (Ex: if the
> algorithm TLV is received in AS ,Area and link, then link SR algorithm
> is preferred)

link scope is not valid per the paragraph above. The first sentence 
talks about RI LSA in general. Second one says what is required for 
SR-Alg. TLV.

>
>         But second statement indicates we use area scope for algorithm
> TLV. These two statements may cause little confusion while implementation.

not really.

First statement resolves the conflict in case the SR-Algorithm sub-TLV 
appears in multiple RI LSAs.

Second statement says that area scope is the minimum needed. AS scope 
works as well BTW.

> visibility is at area scope.

correct.

>
> 2.Even “SR Local Block Sub-TLV SRMS and Preference Sub-TLV” are top
> level TLVs in RI LSA like SR-Algorithm TLV and “SID/Label Range TLV”,
> may be it is better to replace “Sub TLV” with TLV.

ack.

regards,
Peter