Subject: [OSPF] Fwd: Last Call: <draft-ietf-isis-l2bundles-04.txt> (Advertising L2 Bundle Member Link Attributes in IS-IS) to Proposed Standard

From: Alia Atlas <[email-masked]>
Date: Wed, 3 May 2017 14:30:42 -0400

Dear RTGWG, OSPF WG & IDR WG,

I'd like to bring this IETF Last Call to your attention.  The method for
advertising
L2 bundle information via IS-IS described in this draft may be of interest
for other
protocols (OSPF,  BGP-LS) that may use it as precedent for how to advertise
such information if there is need in the future and consistency is desired
at that point.

Regards,
Alia

---------- Forwarded message ----------
From: The IESG <[email-masked]>
Date: Wed, May 3, 2017 at 1:52 PM
Subject: Last Call: <draft-ietf-isis-l2bundles-04.txt> (Advertising L2
Bundle Member Link Attributes in IS-IS) to Proposed Standard
To: IETF-Announce <[email-masked]>
Cc: [email-masked], [email-masked], [email-masked],
[email-masked], [email-masked]

The IESG has received a request from the IS-IS for IP Internets WG (isis)
to consider the following document:
- 'Advertising L2 Bundle Member Link Attributes in IS-IS'
  <draft-ietf-isis-l2bundles-04.txt> as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2017-05-17. Exceptionally, comments may be
sent to [email-masked] instead. In either case, please retain the
beginning of the Subject line to allow automated sorting.

Abstract

   There are deployments where the Layer 3 interface on which IS-IS
   operates is a Layer 2 interface bundle.  Existing IS-IS
   advertisements only support advertising link attributes of the Layer
   3 interface.  If entities external to IS-IS wish to control traffic
   flows on the individual physical links which comprise the Layer 2
   interface bundle link attribute information about the bundle members
   is required.

   This document introduces the ability for IS-IS to advertise the link
   attributes of layer 2 (L2) bundle members.

The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-isis-l2bundles/

IESG discussion can be tracked via
https://datatracker.ietf.org/doc/draft-ietf-isis-l2bundles/ballot/

The following IPR Declarations may be related to this I-D:

   https://datatracker.ietf.org/ipr/2793/

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 11 May 2017 18:58:28 +0000

Hi Alia,
I have reviewed the document and had several conversations with the authors. I believe the encodings are adaptable to the OSPF Segment Routing extensions. Of course, we’ll use a different identifier than System ID (Used to identify LAN-Adj-SID neighors). One comment I have is that it would be nice to have ASCII art graphically depicting the format of the new Sub-TLVs.

Thanks,
Acee

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, May 3, 2017 at 2:30 PM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] Fwd: Last Call: <draft-ietf-isis-l2bundles-04.txt> (Advertising L2 Bundle Member Link Attributes in IS-IS) to Proposed Standard

I'd like to bring this IETF Last Call to your attention.  The method for advertising
L2 bundle information via IS-IS described in this draft may be of interest for other
protocols (OSPF,  BGP-LS) that may use it as precedent for how to advertise
such information if there is need in the future and consistency is desired at that point.

Regards,
Alia

---------- Forwarded message ----------
From: The IESG <[email-masked]<mailto:[email-masked]>>
Date: Wed, May 3, 2017 at 1:52 PM
Subject: Last Call: <draft-ietf-isis-l2bundles-04.txt> (Advertising L2 Bundle Member Link Attributes in IS-IS) to Proposed Standard
To: IETF-Announce <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action. Please send substantive comments to the
[email-masked]<mailto:[email-masked]> mailing lists by 2017-05-17. Exceptionally, comments may be
sent to [email-masked]<mailto:[email-masked]> instead. In either case, please retain the
beginning of the Subject line to allow automated sorting.

Abstract

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 11 May 2017 20:35:10 +0000

Acee –

Did you look at the Appendix – which has ASCII art for some example encodings?

   Les

From: rtgwg [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Thursday, May 11, 2017 11:58 AM
To: Alia Atlas; OSPF List; [email-masked]; idr@ietf. org
Subject: Re: [OSPF] Fwd: Last Call: <draft-ietf-isis-l2bundles-04.txt> (Advertising L2 Bundle Member Link Attributes in IS-IS) to Proposed Standard

Hi Alia,

Thanks,
Acee

Regards,
Alia

---------- Forwarded message ----------
From: The IESG <[email-masked]<mailto:[email-masked]>>
Date: Wed, May 3, 2017 at 1:52 PM
Subject: Last Call: <draft-ietf-isis-l2bundles-04.txt> (Advertising L2 Bundle Member Link Attributes in IS-IS) to Proposed Standard
To: IETF-Announce <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Abstract

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 11 May 2017 20:48:38 +0000

Hi Les,

From: "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 11, 2017 at 4:35 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Alia Atlas <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>
Subject: RE: [OSPF] Fwd: Last Call: <draft-ietf-isis-l2bundles-04.txt> (Advertising L2 Bundle Member Link Attributes in IS-IS) to Proposed Standard

Acee –

No  - I missed these. I was looking more for the format in body rather than just field descriptions. However, the examples are also helpful.

Thanks,
Acee

   Les

From: rtgwg [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Thursday, May 11, 2017 11:58 AM
To: Alia Atlas; OSPF List; [email-masked]<mailto:[email-masked]>; idr@ietf. org
Subject: Re: [OSPF] Fwd: Last Call: <draft-ietf-isis-l2bundles-04.txt> (Advertising L2 Bundle Member Link Attributes in IS-IS) to Proposed Standard

Hi Alia,

Thanks,
Acee

Regards,
Alia

---------- Forwarded message ----------
From: The IESG <[email-masked]<mailto:[email-masked]>>
Date: Wed, May 3, 2017 at 1:52 PM
Subject: Last Call: <draft-ietf-isis-l2bundles-04.txt> (Advertising L2 Bundle Member Link Attributes in IS-IS) to Proposed Standard
To: IETF-Announce <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Abstract