Subject: Re: [OSPF] [OSPF-SR] Regarding graceful restart behavior with change in SR informaiotn carrying LSA

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 29 May 2017 19:44:46 +0000

Hi Veeru,

I think that changes to Prefix/Link Attribute LSAs must be considered as a topology change for purposes of  RestartHelperStrictLSAChecking. If this were to be covered, it should have been in RFC 7684. Although RFC 3623 doesn’t really specify what constitutes a topology change.

However, perhaps we could add a note in this draft.

Thanks,
Acee

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of Veerendranatha Reddy Vallem <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 29, 2017 at 5:41 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] [OSPF-SR] Regarding graceful restart behavior with change in SR informaiotn carrying LSAs

Dear Authors,

In OSPFv2:
I am requesting for your clarification regarding  change in Opaque Type 7 and Opaque Type 8 LSAs (LSA origination/flush or modify)  need to consider for OSPFv2 GR exit case or not.
As per my understanding these LSAs will not be topology LSAs for OSPF, so it may not require to consider these LSAs for GR case.
I am requesting for your confirmation.

Also in OSPFv3:
SR information is carried in new extension LSAs, which can carry both topology and attribute information.
In this case, whether we need to consider LSA change for Graceful restart or not.
I am requesting for your confirmation.

Regards,
Veerendranath

---

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Tue, 30 May 2017 05:46:33 +0000

Dear Acee,
Thanks for the confirmation.

I am little bit confused about Strict LSA checking behavior. Please help me to understand the behavior in following case.

RestartHelperStrictLSAChecking:  Whether it will be applicable to only Prefix/Link attribute Opaque LSAs or it will be applicable for other opaque LSAs like RI and TE LSAs also. (All LSAs in DB)
Some of existing implementations will not consider opaque LSA changes as topology change by default. So whether we need to consider opaque Type (7 or 8) change only as topology change by default.

Regards,
Veerendranath

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: 30 May 2017 01:15
To: Veerendranatha Reddy Vallem <[email-masked]>; [email-masked]
Cc: OSPF WG List <[email-masked]>
Subject: Re: [OSPF] [OSPF-SR] Regarding graceful restart behavior with change in SR informaiotn carrying LSA

Hi Veeru,

Thanks,
Acee

Dear Authors,

In OSPFv2:

Also in OSPFv3:

Regards,
Veerendranath

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 30 May 2017 14:55:41 +0000

Hi Veeru,

From: Veerendranatha Reddy Vallem <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, May 30, 2017 at 1:46 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: RE: [OSPF] [OSPF-SR] Regarding graceful restart behavior with change in SR informaiotn carrying LSA

Dear Acee,

Any change that impacts the data plane should be considered a topology change. Note that, in practice, most implementations default RestartHelperStrictLSAChecking to false and do not put a lot of emphasis on granular determination of whether or not an LSA change could impact the data plane. In the case of Prefx/Link attribute LSAs, most attributes do impact the data plane.

Thanks,
Acee

Regards,
Veerendranath

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: 30 May 2017 01:15
To: Veerendranatha Reddy Vallem <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] [OSPF-SR] Regarding graceful restart behavior with change in SR informaiotn carrying LSA

Hi Veeru,

Thanks,
Acee

Dear Authors,

In OSPFv2:

Also in OSPFv3:

Regards,
Veerendranath

---

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Wed, 31 May 2017 06:52:09 +0000

Thanks Acee for the clarification.

Regards,
Veerendranath

Sent: 30 May 2017 20:26

Hi Veeru,

Dear Acee,

Thanks,
Acee

Regards,
Veerendranath

Hi Veeru,

Thanks,
Acee

Dear Authors,

In OSPFv2:

Also in OSPFv3:

Regards,
Veerendranath