Subject: [OSPF] IETF OSPF YANG and BFD Configuration

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 18 May 2017 19:27:39 +0000

Hi Jeff,

At the OSPF WG Meeting in Chicago, you suggested that we may want to provide configuration of BFD parameters within the OSPF model (ietf-ospf.yang). We originally did have this configuration. However, after much discussion and coordination with the BFD YANG design team, we agreed to leave the BFD session parameters in BFD and only enable BFD within the OSPF and IS-IS models.

We did discuss the fact that vendors (notably Cisco IOS-XR and Juniper JUNOS) do allow configuration within the IGPs. However, the consensus was to leave the BFD configuration in the BFD model. The heuristics to determine what parameters to use when the same BFD endpoint was configured with different parameters in different protocols were proprietary and somewhat of a hack.

I may have not remembered all the details so I’d encourage others to chime in.

Thanks,
Acee

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 18 May 2017 14:33:07 -0700

Agree with Acee’s assessment. After much debate, we decided that we should leave BFD parameter configuration in the BFD model itself, and have any IGP protocol reference the BFD instance in BFD itself. This makes sense specially if multiple protocols fate-share the BFD session.

Cheers.

> On May 18, 2017, at 12:27 PM, Acee Lindem (acee) <[email-masked]> wrote:
> 
> Hi Jeff, 
> 

Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 18 May 2017 14:34:20 -0700

Resending with correct BFD WG address.

> On May 18, 2017, at 2:33 PM, Mahesh Jethanandani <[email-masked]> wrote:
> 
>> On May 18, 2017, at 12:27 PM, Acee Lindem (acee) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Jeff, 
>> 
> [email-masked] <mailto:[email-masked]>
> 
> 
> 

Mahesh Jethanandani
[email-masked]

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 19 May 2017 02:31:38 +0000

We started off with the intent of having BFD parameters in the applications/protocols which make use of BFD. For timer/multiplier this is pretty straight-forward, although the discussion of what to do when not all applications have the same BFD parameters for the same session (e.g. Go with most aggressive etc). Then we started looking at authentication parameters and having BFD authentication parms in OSPF/ISIS etc is not intuitive. And what do we do if applications have different BFD authentication parms. We concluded that the BFD authentication parms were better off in BFD. And once we did that, the timer/multiplier followed....

I may not recall all the details/discussons, but I do recall that we went back and forth on this and it took some time to make the decision.

Regards,
Reshad (as individual contributor).

From: Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 18, 2017 at 5:34 PM
To: "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>
Cc: Jeffrey Haas <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: IETF OSPF YANG and BFD Configuration
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, Reshad <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Thursday, May 18, 2017 at 5:40 PM

On May 18, 2017, at 2:33 PM, Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>> wrote:

Agree with Acee's assessment. After much debate, we decided that we should leave BFD parameter configuration in the BFD model itself, and have any IGP protocol reference the BFD instance in BFD itself. This makes sense specially if multiple protocols fate-share the BFD session.

Cheers.

On May 18, 2017, at 12:27 PM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jeff,

I may have not remembered all the details so I'd encourage others to chime in.

Thanks,
Acee

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>