Subject: Re: [OSPF] Advertising Tunneling Capability in OSPF (draft-ietf-ospf-encapsulation-cap-02)

From: Jeff Tantsura <[email-masked]>
Date: Mon, 08 May 2017 13:51:36 -0700

Acee,

support, the draft is ready.

Thanks!

Cheers,

Jeff

From: OSPF <[email-masked]> on behalf of "Acee Lindem (acee)" <[email-masked]>
Date: Thursday, April 27, 2017 at 07:45
To: "[email-masked]" <[email-masked]>
Subject: [OSPF] Advertising Tunneling Capability in OSPF (draft-ietf-ospf-encapsulation-cap-02)

This begins the WG last call for the subject draft. Please send your  support and/or 

comments to this list prior to 12:00 AM GMT, May 12th, 2017. 

For your convenience, here is the URL for the subject document. 

https://www.ietf.org/id/draft-ietf-ospf-encapsulation-cap-02.txt

Thanks,

Acee 

_______________________________________________ OSPF mailing list [email-masked] https://www.ietf.org/mailman/listinfo/ospf

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 8 May 2017 14:49:11 -0700

Dear All,
yes/support (readability needs some work)

Couple nits:

   - Introduction.
      - Perhaps "Some networks use tunnels for a variety of reasons, such
      as:" may be re-worded as "There my be number of reasons why
different types
      of tunneling technique has been used in networks, among these are:"
      - "The ingress needs to select a type of tunnel which is supported by
      the egress." I think that the idea is to find match between set
of tunnels
      supported by the ingress and the egress.
   - Section 3
      - s/Routers advertises/Routers advertise/
      - It is stated that "The Encapsulation Capability TLV SHOULD NOT
      appear more than once within a given OSPF Router Information (RI) Opaque
      LSA." What happens when it does appear more than once? Discard LSA? TLV?

Regards,
Greg

>
> *From: *OSPF <[email-masked]> on behalf of "Acee Lindem (acee)" <
> [email-masked]>
> *Date: *Thursday, April 27, 2017 at 07:45
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[OSPF] Advertising Tunneling Capability in OSPF
> (draft-ietf-ospf-encapsulation-cap-02)
>
>
>
> _______________________________________________ OSPF mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/ospf
>
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>
>

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 9 May 2017 02:19:07 +0000

Hi Greg,

Thanks for your support and your comments. Please see my response inline.

发件人: OSPF [mailto:[email-masked]] 代表 Greg Mirsky
发送时间: 2017年5月9日 5:49
收件人: Acee Lindem (acee)
抄送: OSPF WG List
主题: Re: [OSPF] Advertising Tunneling Capability in OSPF (draft-ietf-ospf-encapsulation-cap-02)

Dear All,

Couple nits:

  *   Introduction.

     *   Perhaps "Some networks use tunnels for a variety of reasons, such as:" may be re-worded as "There my be number of reasons why different types of tunneling technique has been used in networks, among these are:"
[Xiaohu] Will update it.

     *   "The ingress needs to select a type of tunnel which is supported by the egress." I think that the idea is to find match between set of tunnels supported by the ingress and the egress.
[Xiaohu] Yes. Will add more words to clarify it.

  *   Section 3

     *   s/Routers advertises/Routers advertise/
     *   It is stated that "The Encapsulation Capability TLV SHOULD NOT appear more than once within a given OSPF Router Information (RI) Opaque LSA." What happens when it does appear more than once? Discard LSA? TLV?

[Xiaohu] Thanks for pointing out this. How about adding the following text for clarification “If the Encapsulation Capability TLV appears more than once in an OSPF Router Information LSA, only the first occurrence SHOULD be processed and others MUST be ignored.”
Best regards,
Xiaohu
Regards,
Greg

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, April 27, 2017 at 07:45
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] Advertising Tunneling Capability in OSPF (draft-ietf-ospf-encapsulation-cap-02)

Thanks,
Acee

_______________________________________________ OSPF mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/ospf

_______________________________________________
OSPF mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ospf

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 8 May 2017 19:53:43 -0700

Hi Xiaohu,
thank you for your most expedient response and kind consideration of my
comments.
I've just noticed typo in my own proposal s/There my/There may/.
And just one more question, why you propose to use SHOULD in "... the first
occurrence SHOULD be processed ..." Would MUST be more appropriate here? Or
you envision that in some circumstances this policy may be changed?

Regards,
Greg

On Mon, May 8, 2017 at 7:19 PM, Xuxiaohu <[email-masked]> wrote:

> *发件人:* OSPF [mailto:[email-masked]] *代表 *Greg Mirsky
> *发送时间:* 2017年5月9日 5:49
> *收件人:* Acee Lindem (acee)
> *抄送:* OSPF WG List
> *主题:* Re: [OSPF] Advertising Tunneling Capability in OSPF
>       as:" may be re-worded as "There my be number of reasons why different types
>       the egress." I think that the idea is to find match between set of tunnels

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 9 May 2017 02:56:36 +0000

OK, I will replace “SHOULD ” with “MUST”. Thanks again Greg.

Best regards,
Xiaohu

发件人: Greg Mirsky [mailto:[email-masked]]
发送时间: 2017年5月9日 10:54
收件人: Xuxiaohu
抄送: Acee Lindem (acee); OSPF WG List
主题: Re: 答复: [OSPF] Advertising Tunneling Capability in OSPF (draft-ietf-ospf-encapsulation-cap-02)

Hi Xiaohu,
thank you for your most expedient response and kind consideration of my comments.
I've just noticed typo in my own proposal s/There my/There may/.
And just one more question, why you propose to use SHOULD in "... the first occurrence SHOULD be processed ..." Would MUST be more appropriate here? Or you envision that in some circumstances this policy may be changed?

Regards,
Greg

On Mon, May 8, 2017 at 7:19 PM, Xuxiaohu <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

发件人: OSPF [mailto:[email-masked]<mailto:[email-masked]>] 代表 Greg Mirsky
发送时间: 2017年5月9日 5:49
收件人: Acee Lindem (acee)
抄送: OSPF WG List
主题: Re: [OSPF] Advertising Tunneling Capability in OSPF (draft-ietf-ospf-encapsulation-cap-02)

Dear All,

Couple nits:

  *   Introduction.

  *   Section 3

Thanks,
Acee