Subject: [OSPF] I-D Action: draft-ietf-ospf-segment-routing-extensions-15.txt

From: [email-masked]
Date: Mon, 22 May 2017 10:51:16 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Open Shortest Path First IGP of the IETF.

        Title           : OSPF Extensions for Segment Routing
        Authors         : Peter Psenak
                          Stefano Previdi
                          Clarence Filsfils
                          Hannes Gredler
                          Rob Shakir
                          Wim Henderickx
                          Jeff Tantsura
	Filename        : draft-ietf-ospf-segment-routing-extensions-15.txt
	Pages           : 35
	Date            : 2017-05-22

Abstract:
   Segment Routing (SR) allows a flexible definition of end-to-end paths
   within IGP topologies by encoding paths as sequences of topological
   sub-paths, called "segments".  These segments are advertised by the
   link-state routing protocols (IS-IS and OSPF).

   This draft describes the OSPF extensions required for Segment
   Routing.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ospf-segment-routing-extensions/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ospf-segment-routing-extensions-15
https://datatracker.ietf.org/doc/html/draft-ietf-ospf-segment-routing-extensions-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ospf-segment-routing-extensions-15

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chao Fu <[email-masked]>
Date: Tue, 23 May 2017 02:51:01 +0000

Hi all,

Some typos in https://datatracker.ietf.org/doc/draft-ietf-ospf-segment-routing-extensions/

Section 5 [Page 14]:

   The NP-Flag (No-PHP) MUST be be set and the E-flag MUST be clear for
                                                     ----------  Should delete one "be"  
   Prefix-SIDs allocated to redistributed prefixes, unless the
   redistributed prefix is directly attached to the ASBR.

Section 6 [Page 16] :
6.  SID/Label Binding Sub-TLV

   The SID/Label Binding Sub-TLV is used to advertise a SID/Label
   mapping for a path to the a prefix.
                                          --------  Should delete "a"

Section 6.2 [Page 18]
6.2.  ERO Sub-TLVs

   All ERO information represents an ordered set which describes the
   segments of a path.  The first ERO Sub-TLV describes the first
   segment of a path.  Similiarly, the last ERO Sub-TLV describes the
                                     --------------- Should be "Similarly" (one more 'i' in the document)
   segment closest to the egress point.  If a router extends or stitches
   a path, it MUST prepend the new segment's path information to the ERO
   list.  This applies equally to advertised backup EROs.

Regards,
Chao Fu

-----Original Message-----
From: OSPF [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, May 23, 2017 01:51
To: [email-masked]
Cc: [email-masked]
Subject: [OSPF] I-D Action: draft-ietf-ospf-segment-routing-extensions-15.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf