Subject: [OSPF] RFC 3101 NSSA/External Route preference clarification

From: "Balaji Ganesh (balagane)" <[email-masked]>
Date: Tue, 13 Jun 2017 08:13:23 +0000

Hi all,

When the metrics are same, RFC 3101 specifies the preference for NSSA/External routes as follows.
In the section 2.5<https://tools.ietf.org/html/rfc3101#section-2.5> Calculating Type-7 AS External Routes - 2.5.6.(e), it says..

          (e) If the current LSA is functionally the same as an
              installed LSA (i.e., same destination, cost and non-zero
              forwarding address) then apply the following priorities in
              deciding which LSA is preferred:

                 1. A Type-7 LSA with the P-bit set.

                 2. A Type-5 LSA.

                 3. The LSA with the higher router ID.

Points 1 and 2 are clear..

However Point 3 specifies preference of an LSA with a higher router ID. Why is it so?

-          Should we not install ECMP paths in this case?

-          Is point 3 actually intended for NSSA translators to prefer a Type 7 LSA which needs to be used for translation to Type 5?

Considering the above 2 points, I guess point 3 needs to be modified in the RFC to probably say..

                    3. Preference is same, install ECMP paths.
                       Additionally if the router is an NSSA translator, prefer the LSA with higher router ID for Type 7-Type 5 translation.

Please let know any views/comments on the same.

Regards,
Balaji

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sun, 18 Jun 2017 18:37:46 +0000

Hi –  I encouraged Balaji to post to the list is that I think many implementations have ignored #3. I know that I changed the IBM implementation to compute ECMP routes to multiple ASBRs and had the Redback implementation do this from the start. Consequently, we’d like to solicit input as to what other implementations do. If we can reach consensus on this, we could issue an Errata to make this optional.

Thanks,
Acee

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of "Balaji Ganesh (balagane)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, June 13, 2017 at 4:13 AM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] RFC 3101 NSSA/External Route preference clarification

Hi all,

                 2. A Type-5 LSA.

Regards,
Balaji