Subject: Re: [OSPF] OSPFv2 Segment Routing Extensions ERO Extensions (would also effect OSPFv3 and IS-IS) - REPLY TO THIS ONE

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 9 Jun 2017 14:45:53 +0000

Corrected IS-IS WG alias – Please reply to this one.
Thanks,
Acee

From: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Date: Friday, June 9, 2017 at 10:42 AM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: OSPFv2 Segment Routing Extensions ERO Extensions (would also effect OSPFv3 and IS-IS)

Hi OSPF, ISIS, and SPRING WGs,

As part of the Alia’s AD review, she uncovered the fact that the ERO extensions in 6.1 and 6.2 are specified as far as encoding but are not specified as far as usage in any IGP or SPRING document. As document shepherd,  my proposal is that they simply be removed since they were incorporated as part of a draft merge and it appears that no one has implemented them (other than parsing). We could also deprecate types (4-8) in the OSPFv2 Extended Prefix LSA Sub-TLV registry to delay usage of these code points for some time (or indefinitely ;^).

Thanks,
Acee

---

From: Peter Psenak <[email-masked]>
Date: Fri, 09 Jun 2017 19:04:53 +0200

Acee,

my question is whether we need the whole section 6 and the SID/Label 
Binding Sub-TLV that it specifies. In OSPF Binding SID is not used for 
SRMS advertisement like in ISIS.

thanks,
Peter

On 09/06/17 16:45 , Acee Lindem (acee) wrote:
> From: Acee Lindem <[email-masked] <mailto:[email-masked]>>
> To: OSPF WG List <[email-masked] <mailto:[email-masked]>>,
> "[email-masked] <mailto:[email-masked]>" <[email-masked]
> <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>"
> <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked]
> <mailto:[email-masked]>"
> <[email-masked]
> <mailto:[email-masked]>>
>     As part of the Alia’s AD review, she uncovered the fact that the ERO
>     extensions in 6.1 and 6.2 are specified as far as encoding but are
>     not specified as far as usage in any IGP or SPRING document. As
>     document shepherd,  my proposal is that they simply be removed since
>     they were incorporated as part of a draft merge and it appears that
>     no one has implemented them (other than parsing). We could also
>     deprecate types (4-8) in the OSPFv2 Extended Prefix LSA Sub-TLV
>     registry to delay usage of these code points for some time (or
>     indefinitely ;^).
>
>     Thanks,
>     Acee
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 9 Jun 2017 17:07:28 +0000

Hi Peter, 

I’d say that if none of the implementations are using it, we should remove
it. 

Thanks,
Acee

---

From: Peter Psenak <[email-masked]>
Date: Mon, 12 Jun 2017 10:18:05 +0200

Hi,

I would like to get some feedback on the usage of the SID/Label Binding TLV.

Is there any implementation that uses SID/Label Binding TLV for 
advertising the SID/Label binding to a FEC as specified in section 6 of 
the draft-ietf-ospf-segment-routing-extensions-16 or section 2.4 of 
draft-ietf-isis-segment-routing-extensions-12?

If not, do we see this as something we want to preserve in the IGP SR 
drafts?

ISIS uses The SID/Label Binding TLV to advertise
prefixes to SID/Label mappings, which is known to be supported by 
several implementations and that piece needs to be preserved.

thanks,
Peter

On 09/06/17 19:04 , Peter Psenak wrote:
> .

---

From: <[email-masked]>
Date: Mon, 12 Jun 2017 12:50:05 +0000

Hello SPRING WG,

I'd like to encourage discussion on this thread.

The related questions seem to be:
- Binding SIDs:
	-  Is there any implementation?
	- Is it useful?
	- Does it need to be specified?

- Binding SIDs advertised in IGP:
	-  Is there any implementation?
	 - Is it useful?
	- Does it need to be specified?

As of today, there seem to be multiple SPRING (related) document that make reference (define/use) to the Binding SIDs. e.g.
- architecture https://tools.ietf.org/html/draft-ietf-spring-segment-routing-11#section-3.5.2
- MPLS instantiation https://tools.ietf.org/html/draft-ietf-spring-segment-routing-mpls-08#section-2
- non-protected paths https://tools.ietf.org/html/draft-litkowski-spring-non-protected-paths-01#section-3.3
- SR policies: https://tools.ietf.org/html/draft-filsfils-spring-segment-routing-policy-00#section-7

However, it also seems a priori possible to define Binding SIDs and not advertised them in the IGP. (e.g. by keeping them local to the PCE)

On a side note, if the Binding SIDs are removed from the IGP, do they need to be removed from the BGP-LS extensions? [+IDR chairs]

Thanks,
Regards,
--Bruno

> From: OSPF [mailto:[email-masked]] On Behalf Of Peter Psenak
> Sent: Monday, June 12, 2017 10:18 AM
 > To: OSPF WG List; [email-masked]; [email-masked]
 > Cc: [email-masked]
 > Subject: Re: [OSPF] OSPFv2 Segment Routing Extensions ERO Extensions (would also effect
 > OSPFv3 and IS-IS) - REPLY TO THIS ONE
 > 
 > Hi,
 > 
 > _______________________________________________
 > OSPF mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/ospf

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Rob Shakir <[email-masked]>
Date: Mon, 12 Jun 2017 13:08:14 +0000

Bruno, SPRING,

I am aware of at least one implementation that makes heavy use of Binding
SIDs, so I do not think that this is something that we can remove from the
protocol specification. It seems to me that we have a number of cases that
continue to exist that make it useful to have them specified, particularly:

   - Binding of a SID to a deeper label stack to prevent there being large
   label stacks required on ingress. This is required due to limited push
   depth, and limited readable label depths for hashing.
   - Re-use of some other protocol's or network's forwarding path by a
   device that is imposing an SR label stack.

There is not an alternative construct that can be used for this purpose, so
we should not remove it.

In both of these cases there seems, to me, to be a use case for having the
information in the IGP in the case that an implementation computes TE paths
using cSPF, having binding SID information available to it (along with the
ERO) enables it to reduce the label stack depth by finding binding SIDs
that follow the same path as the computed ERO. Without the ERO (which might
not be an RSVP-TE ERO, but I believe that it how it was first envisaged)
how can the head-end of an TE path know what path the advertised Binding
SID takes? It's fine to punt this and say "the PCE in the sky will know" -
however, I believe SPRING's charter doesn't limit the technology to only
centralised computation of paths.

I don't believe current demand for this is a good reason to remove it from
the protocol specification - it is still somewhat early days for folks
deploying TE based on SR - where I think the Binding SID concept is most
important.

r.

On Mon, 12 Jun 2017 at 05:50 <[email-masked]> wrote:

> As of today, there seem to be multiple SPRING (related) document that make
> reference (define/use) to the Binding SIDs. e.g.
> - architecture
> https://tools.ietf.org/html/draft-ietf-spring-segment-routing-11#section-3.5.2
> - MPLS instantiation
> https://tools.ietf.org/html/draft-ietf-spring-segment-routing-mpls-08#section-2
> - non-protected paths
> https://tools.ietf.org/html/draft-litkowski-spring-non-protected-paths-01#section-3.3
> - SR policies:
> https://tools.ietf.org/html/draft-filsfils-spring-segment-routing-policy-00#section-7
>
>
> However, it also seems a priori possible to define Binding SIDs and not
> advertised them in the IGP. (e.g. by keeping them local to the PCE)
>
> On a side note, if the Binding SIDs are removed from the IGP, do they need
> to be removed from the BGP-LS extensions? [+IDR chairs]
>
> Thanks,
> Regards,
> --Bruno
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: <[email-masked]>
Date: Mon, 12 Jun 2017 13:37:46 +0000

Hi Acee, authors

2 clarification questions inline [Bruno]

From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Friday, June 09, 2017 4:46 PM
To: OSPF WG List; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [OSPF] OSPFv2 Segment Routing Extensions ERO Extensions (would also effect OSPFv3 and IS-IS) - REPLY TO THIS ONE

As part of the Alia’s AD review, she uncovered the fact that the ERO extensions in 6.1 and 6.2 are specified as far as encoding but are not specified as far as usage in any IGP or SPRING document. As document shepherd,  my proposal is that they simply be removed since they were incorporated as part of a draft merge and it appears that no one has implemented them (other than parsing).
[Bruno] Is the option to move those Binding SID IGP extensions in a different (WG) document opened/considered? Any opinion on this?

We could also deprecate types (4-8) in the OSPFv2 Extended Prefix LSA Sub-TLV registry to delay usage of these code points for some time (or indefinitely ;^).
[Bruno] Are there reasons to make actions to delay/against such usage?

Thanks
Regards,
--Bruno

Thanks,
Acee

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Mon, 12 Jun 2017 13:52:19 +0000

Hi Rob,

sorry for the mess. I’m afraid, the problem has been poorly described.

We’re obviously NOT questioning the use of the Binding SID and we’re NOT proposing the removal of it.

What we’re talking about is the set of RSVP-like/ERO-like subTLVs that have been defined in both isis and ospf protocols and for which, apparently, nobody has found yet any use.

Can we try to shutdown the unnecessary noise and confusion ?

Thanks.
s.

> On Jun 12, 2017, at 3:08 PM, Rob Shakir <[email-masked]> wrote:
> 
> Bruno, SPRING,
> 
> I am aware of at least one implementation that makes heavy use of Binding SIDs, so I do not think that this is something that we can remove from the protocol specification.
> It seems to me that we have a number of cases that continue to exist that make it useful to have them specified, particularly:
> 	• Binding of a SID to a deeper label stack to prevent there being large label stacks required on ingress. This is required due to limited push depth, and limited readable label depths for hashing.
> 	• Re-use of some other protocol's or network's forwarding path by a device that is imposing an SR label stack.
> There is not an alternative construct that can be used for this purpose, so we should not remove it.
> 
> In both of these cases there seems, to me, to be a use case for having the information in the IGP in the case that an implementation computes TE paths using cSPF, having binding SID information available to it (along with the ERO) enables it to reduce the label stack depth by finding binding SIDs that follow the same path as the computed ERO. Without the ERO (which might not be an RSVP-TE ERO, but I believe that it how it was first envisaged) how can the head-end of an TE path know what path the advertised Binding SID takes? It's fine to punt this and say "the PCE in the sky will know" - however, I believe SPRING's charter doesn't limit the technology to only centralised computation of paths.
> 
> I don't believe current demand for this is a good reason to remove it from the protocol specification - it is still somewhat early days for folks deploying TE based on SR - where I think the Binding SID concept is most important.
> 
> r.
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 12 Jun 2017 13:59:03 +0000

Hi Bruno,

From: Bruno Decraene <[email-masked]<mailto:[email-masked]>>
Date: Monday, June 12, 2017 at 9:37 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: RE: [OSPF] OSPFv2 Segment Routing Extensions ERO Extensions (would also effect OSPFv3 and IS-IS) - REPLY TO THIS ONE

Hi Acee, authors

From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Friday, June 09, 2017 4:46 PM
To: OSPF WG List; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [OSPF] OSPFv2 Segment Routing Extensions ERO Extensions (would also effect OSPFv3 and IS-IS) - REPLY TO THIS ONE

As part of the Alia’s AD review, she uncovered the fact that the ERO extensions in 6.1 and 6.2 are specified as far as encoding but are not specified as far as usage in any IGP or SPRING document. As document shepherd,  my proposal is that they simply be removed since they were incorporated as part of a draft merge and it appears that no one has implemented them (other than parsing).
[Bruno] Is the option to move those Binding SID IGP extensions in a different (WG) document opened/considered? Any opinion on this?
If there is the energy to fully specify usage, than a separate document would make sense. I think there is a enough description of the binding SID in existing SPRING documents. However, it the ERO that is not specified.

We could also deprecate types (4-8) in the OSPFv2 Extended Prefix LSA Sub-TLV registry to delay usage of these code points for some time (or indefinitely ;^).
[Bruno] Are there reasons to make actions to delay/against such usage?
Since these are fully specified in the IGP Extensions, there are probably implementations that parse and validate the sub-TLVs.

Thanks,
Acee

Thanks
Regards,
--Bruno

Thanks,
Acee

---

From: <[email-masked]>
Date: Mon, 12 Jun 2017 14:05:44 +0000

Hi Stefano,

> From: Stefano Previdi (sprevidi) [mailto:[email-masked]]  > Sent: Monday, June 12, 2017 3:52 PM
> 
 > Hi Rob,
 > 
 > What we’re talking about is the set of RSVP-like/ERO-like subTLVs that have been defined in
 > both isis and ospf protocols and for which, apparently, nobody has found yet any use.

In order to clarify, could you provide the precise list/set of those subTLVs which are proposed to be removed? for both IS-IS and OSPF.

Thanks
--Bruno
 
 > > I am aware of at least one implementation that makes heavy use of Binding SIDs, so I do
 > not think that this is something that we can remove from the protocol specification.
 > > 	• Binding of a SID to a deeper label stack to prevent there being large label stacks
 > required on ingress. This is required due to limited push depth, and limited readable label
 > depths for hashing.
 > > In both of these cases there seems, to me, to be a use case for having the information in
 > the IGP in the case that an implementation computes TE paths using cSPF, having binding SID
 > information available to it (along with the ERO) enables it to reduce the label stack depth by
 > finding binding SIDs that follow the same path as the computed ERO. Without the ERO
 > (which might not be an RSVP-TE ERO, but I believe that it how it was first envisaged) how can
 > the head-end of an TE path know what path the advertised Binding SID takes? It's fine to
 > punt this and say "the PCE in the sky will know" - however, I believe SPRING's charter
 > doesn't limit the technology to only centralised computation of paths.
 > >
 > > I don't believe current demand for this is a good reason to remove it from the protocol
 > specification - it is still somewhat early days for folks deploying TE based on SR - where I
 > think the Binding SID concept is most important.
 > >
 > > r.
 > >
 > > However, it also seems a priori possible to define Binding SIDs and not advertised them in
 > the IGP. (e.g. by keeping them local to the PCE)
 > >
 > > On a side note, if the Binding SIDs are removed from the IGP, do they need to be removed
 > from the BGP-LS extensions? [+IDR chairs]
 > >
 > > Thanks,
 > > Regards,
 > > --Bruno
 > >
 > ______________________________________________________________________
 > ___________________________________________________
 > >

---

From: Peter Psenak <[email-masked]>
Date: Mon, 12 Jun 2017 16:10:15 +0200

Stefano, Rob,

the question is about the "usage of the SID/Label Binding TLV", not 
about the Binding SID concept. I don't know how to better describe the 
problem.

In ISIS SR draft SID/Label Binding TLV has two functions:

1. Advertise the SID/Label binding to a FEC
2. SRMS advertisements

In OSPF SID/Label Binding TLV has only one function:

1. Advertise the SID/Label binding to a FEC

The question is whether we need the function (1) at all in IGP SR drafts.

thanks,
Peter

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Mon, 12 Jun 2017 14:16:36 +0000

> On Jun 12, 2017, at 4:05 PM, [email-masked] wrote:
> 
> Hi Stefano,
> 

I’d expect anyone to make the effort to go read the isis and ospf specs. Nevertheless, here are the set of subTLVs in ISIS in the form of <section in the draft, subTLV name>

2.4.7.  ERO Metric sub-TLV
2.4.8.  IPv4 ERO subTLV
2.4.9.  IPv6 ERO subTLV
2.4.10. Unnumbered Interface ID ERO subTLV
2.4.11. IPv4 Backup ERO subTLV
2.4.12. IPv6 Backup ERO subTLV
2.4.13. Unnumbered Interface ID Backup ERO subTLV

You’ll find the same subTLVs in ospf and ospfv3 drafts.

Note also that you have the equivalent TLVs defined in bgp-ls by draft-ietf-idr-bgp-ls-segment-routing-ext.

s.