Subject: [OSPF] [Editorial Errata Reported] RFC2328 (5041)

From: RFC Errata System <[email-masked]>
Date: Tue, 13 Jun 2017 13:22:44 -0700 (PDT)

The following errata report has been submitted for RFC2328,
"OSPF Version 2".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5041

--------------------------------------
Type: Editorial
Reported by: Adam Augustyn <[email-masked]>

Section: 10.2

Original Text
-------------
1-Way
    An Hello packet has been received from the neighbor, in
    which the router is not mentioned.  This indicates that
    communication with the neighbor is not bidirectional.

Corrected Text
--------------
1-WayReceived
    An Hello packet has been received from the neighbor, in
    which the router is not mentioned.  This indicates that
    communication with the neighbor is not bidirectional.

Notes
-----
RFC2328 defines The Neighbor state machine and it's states. One of the states is defined/named as 1-WayReceived ([Page 95] 10.3.).
1-WayReceived is also mentioned on page 84 and 98.

Pages 85 and 88 use event 1Way which should be renamed to 1-WayReceived for consistency with definition of the state.

[Page 85]
Event 1-Way forces Init state,

[Page 88]
10.2.  Events causing neighbor state changes 
1-Way
    An Hello packet has been received from the neighbor, in
    which the router is not mentioned.  This indicates that
    communication with the neighbor is not bidirectional.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2328 (no draft string recorded)
--------------------------------------
Title               : OSPF Version 2
Publication Date    : April 1998
Author(s)           : J. Moy
Category            : INTERNET STANDARD
Source              : Open Shortest Path First IGP
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 13 Jun 2017 20:38:25 +0000

This editorial errata is correct. Please update it to also correct
instance of “1-Way” to “1-WayReceived” in the text immediately below
figure 13. 
Thanks,
Acee 

On 6/13/17, 4:22 PM, "RFC Errata System" <[email-masked]> wrote:

>RFC2328 defines The Neighbor state machine and it's states. One of the
>states is defined/named as 1-WayReceived ([Page 95] 10.3.).
>Pages 85 and 88 use event 1Way which should be renamed to 1-WayReceived
>for consistency with definition of the state.
>
>[Page 85]