Subject: [OSPF] Implementation Survey for OSPFv3 Extended LSAs

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 28 Jul 2017 19:20:42 +0000

Hi Dirk, Veeru,

Please respond to the implementation survey questions below.

  1. Does your implementation support for all 9 OSPFv3 Extended LSAs?

  2. Does your implementation support for N-Bit Prefix Option?

  3. Does your implementation support OSPFv3 Extended LSAs across the entire routing domain?

  4. Does your implementation support per-area deployment of OSPF Extended LSAs (AS-External LSAs are legacy)?

  5. Does your implementation support full deployment of OSPFv3 Extended LSAs?

  6. Does your implementation support sparse mode deployment of OSPFv3 Extended LSAs?

  7. Does your implementation support any applications that make use of OSPFv3 Extended LSAs (e.g., Segment Routing)?

  8. Have you done any interoperability testing with other implementations?

Thanks,
Acee

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 28 Jul 2017 19:27:52 +0000

If anyone else has an implementation, please respond to the survey as well. I know there have been implementation specific queries.

Thanks,
Acee

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of Acee Lindem <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 28, 2017 at 3:20 PM
To: "Goethals, Dirk (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>, Veerendranatha Reddy Vallem <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] Implementation Survey for OSPFv3 Extended LSAs

Hi Dirk, Veeru,

Thanks,
Acee

---

From: Dirk Goethals <[email-masked]>
Date: Mon, 31 Jul 2017 14:51:50 +0200

Hi Acee,

I received questions w.r.t. the difference between 3 and 5, I guess
you meant:

- 3 and 4 are about AS <> area wide

- 5 and 6 are about full<>sparse mode

See answers inline.

Dirk

Op 28/07/2017 om 21:20 schreef Acee
Lindem (acee):

Hi Dirk, Veeru,

1. Does your implementation support for all 9 OSPFv3
Extended LSAs?

DG> Yes

2. Does your implementation support for N-Bit Prefix
Option?

DG> Yes

3. Does your implementation support OSPFv3 Extended LSAs
across the entire routing domain?

DG> Yes

4. Does your implementation support per-area deployment of
OSPF Extended LSAs (AS-External LSAs are legacy)?

DG> OSPFv3 in legacy
mode can enable extended LSA per area, but OSPFv3 in extended
mode, cannot support legacy per area.

5. Does your implementation support full deployment of
OSPFv3 Extended LSAs?

DG> Yes

6. Does your implementation support sparse mode deployment
of OSPFv3 Extended LSAs?

DG> Yes, by
default

7. Does your implementation support any applications that
make use of OSPFv3 Extended LSAs (e.g., Segment Routing)?

DG> Not yet,
segment routing is in the pipe.

8. Have you done any interoperability testing with other
implementations?

DG> No, only
some limited tests were done with Spirtent/Ixia

Thanks,

Acee

---

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Mon, 31 Jul 2017 16:02:18 +0000

Dear Acee,
Please find the answers inline for Huawei implementation.

1. Does your implementation support for all 9 OSPFv3 Extended LSAs?
[Veeru] Supports E-Router
               E-intra and E-Inter area LSAs to carry  Loopback prefixes

  2. Does your implementation support for N-Bit Prefix Option?
   [Veeru]   Supports N bit set  for Loopback prefixes,

    [Veeru] No

  [Veeru]     No

 [Veeru]    No

   [Veeru]  No

  7. Does your implementation support any applications that make use of OSPFv3 Extended LSAs (e.g., Segment Routing)?
  [Veeru]    Support for Segment routing

    [Veeru]  No

Regards,
Veerendranath

From: Dirk Goethals [mailto:[email-masked]]
Sent: 31 July 2017 18:22
To: Acee Lindem (acee) <[email-masked]>; Veerendranatha Reddy Vallem <[email-masked]>
Cc: OSPF WG List <[email-masked]>
Subject: Re: Implementation Survey for OSPFv3 Extended LSAs

Hi Acee,

I received questions w.r.t. the difference between 3 and 5, I guess you meant:
- 3 and 4 are about AS <> area wide
- 5 and 6 are about full<>sparse mode
See answers inline.
Dirk
Op 28/07/2017 om 21:20 schreef Acee Lindem (acee):
Hi Dirk, Veeru,

  2. Does your implementation support for N-Bit Prefix Option?
DG> Yes
  3. Does your implementation support OSPFv3 Extended LSAs across the entire routing domain?
DG> Yes
  4. Does your implementation support per-area deployment of OSPF Extended LSAs (AS-External LSAs are legacy)?
DG> OSPFv3 in legacy mode can enable extended LSA per area, but OSPFv3 in extended mode, cannot support legacy per area.
  5. Does your implementation support full deployment of OSPFv3 Extended LSAs?
DG> Yes
  6. Does your implementation support sparse mode deployment of OSPFv3 Extended LSAs?
DG> Yes, by default
  7. Does your implementation support any applications that make use of OSPFv3 Extended LSAs (e.g., Segment Routing)?
DG> Not yet, segment routing is in the pipe.
  8. Have you done any interoperability testing with other implementations?
DG> No, only some limited tests were done with Spirtent/Ixia

Thanks,
Acee