Subject: Re: [OSPF] draft-ietf-ospf-ospfv3-segment-routing-extensions

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 2 Oct 2017 18:45:41 +0000

Hi Dirk, 

I agree we should use the same term but we have finished WG last call and
AD review for the OSPFv2 Segment Routing extensions. Additionally,
everyone is familiar with the term link-group. A link-set would be new
terminology. Let’s fix the IS-IS draft.

Thanks,
Acee  
>
>
>
>-------- Original Message --------
>Subject: 	draft-ietf-ospf-ospfv3-segment-routing-extensions
>Resent-Date: 	Wed, 13 Sep 2017 06:26:45 -0700
>Resent-From: 	<[email-masked]>
>Resent-To: 	<[email-masked]>, <[email-masked]>,
><[email-masked]>, <[email-masked]>, <[email-masked]>,
><[email-masked]>, <[email-masked]>
>Date: 	Wed, 13 Sep 2017 15:26:47 +0200
>From: 	Dirk Goethals <[email-masked]>
>To: 	<[email-masked]>,
><[email-masked]>,
>"[email-masked]"
><[email-masked]>
>
>
>
>Hi authors,
>
>OSPF's G-flag and ISIS's S-flag are both representing adjacency sets,
>see snip below,
>can we align these definitions and simply call it S-Flag in both IGPs.
>
>Thx,
>Dirk
>
>OSPFv2 and OSPFv3:
>
>           The G-Flag.  Group Flag.  When set, the G-Flag indicates that
>           the Adj-SID refers to a set of adjacencies (and therefore MAY
>           be assigned to other adjacencies as well).
>
>
>
>ISIS:
>
>           S-Flag.  Set flag.  When set, the S-Flag indicates that the
>           Adj-SID refers to a set of adjacencies (and therefore MAY be
>           assigned to other adjacencies as well).
>
>.
>
>

---

From: "Goethals, Dirk (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 2 Oct 2017 19:58:56 +0000

Ok.
Thx,
Dirk
________________________________
From: Acee Lindem (acee) <[email-masked]>
Sent: Monday, October 2, 2017 8:45:41 PM
To: Goethals, Dirk (Nokia - BE/Antwerp)
Cc: OSPF WG List
Subject: Re: draft-ietf-ospf-ospfv3-segment-routing-extensions

Hi Dirk,

Thanks,
Acee

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 2 Oct 2017 20:16:25 +0000

Acee -

OSPF draft currently says:

"The G-Flag: Group Flag.  When set, the G-Flag indicates that
         the Adj-SID refers to a group of adjacencies (and therefore MAY
         be assigned to other adjacencies as well)."

IS-IS draft currently says:

"S-Flag.  Set flag.  When set, the S-Flag indicates that the
         Adj-SID refers to a set of adjacencies (and therefore MAY be
         assigned to other adjacencies as well)."

I do not see the terms "link-group" or "link-set" in either draft and I don’t see how they would apply to "adjacencies".
So exactly what is the issue and what is the proposed change?

If the concern is about the name "G-flag" vs "S-flag"  - I find this much ado about very little. (Sorry...)

    Les

> -----Original Message-----
> From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem
> (acee)
> Sent: Monday, October 02, 2017 11:46 AM
> To: Goethals, Dirk (Nokia - BE/Antwerp) <[email-masked]>
> Cc: OSPF WG List <[email-masked]>
> Subject: Re: [OSPF] draft-ietf-ospf-ospfv3-segment-routing-extensions
> 
> Hi Dirk,
> 
> >see snip below, can we align these definitions and simply call it
> >S-Flag in both IGPs.
> >
> >Thx,
> >Dirk
> >
> >OSPFv2 and OSPFv3:
> >
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 2 Oct 2017 20:40:51 +0000

Hi Les, 

I was talking in terms of general IETF terminology as opposed to specific
terminology in this draft. For example, we have various groups of links,
e.g., SRLGs and LAGs. It is more consistent to use “group” for adjacencies
as well. 
Thanks,
Acee

On 10/2/17, 4:16 PM, "Les Ginsberg (ginsberg)" <[email-masked]> wrote:

>I do not see the terms "link-group" or "link-set" in either draft and I
>don’t see how they would apply to "adjacencies".