Subject: [OSPF] Publication has been requested for draft-ietf-ospf-link-overload-10

From: Acee Lindem <[email-masked]>
Date: Wed, 13 Dec 2017 11:57:37 -0800

Acee Lindem has requested publication of draft-ietf-ospf-link-overload-10 as Proposed Standard on behalf of the OSPF working group.

Please verify the document's state at https://datatracker.ietf.org/doc/draft-ietf-ospf-link-overload/

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 14 Dec 2017 00:39:58 +0000

Please provide allocations for the code points in
draft-ietf-ospf-link-overload-10.txt:

 OSPF Extended Link TLVs Registry

   i) Link-Overload sub-TLV - Suggested value 5

   ii) Remote IPv4 address sub-TLV - Suggested value 4

   iii) Local/Remote Interface ID sub-TLV - Suggested Value 11

   OSPFV3 Router Link TLV Registry

   i) Link-Overload sub-TLV - suggested value 4

   BGP-LS Link NLRI Registry [RFC7752]

i)Link-Overload TLV - Suggested 1101

Thanks,

Acee 

On 12/13/17, 2:57 PM, "Acee Lindem (acee)" <[email-masked]> wrote:

>Acee Lindem has requested publication of draft-ietf-ospf-link-overload-10
>as Proposed Standard on behalf of the OSPF working group.
>
>Please verify the document's state at
>https://datatracker.ietf.org/doc/draft-ietf-ospf-link-overload/
>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 13 Dec 2017 19:42:21 -0500

approved

On Wed, Dec 13, 2017 at 7:39 PM, Acee Lindem (acee) <[email-masked]> wrote:

> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: Peter Psenak <[email-masked]>
Date: Thu, 14 Dec 2017 09:52:22 +0100

Hi Acee,

>   OSPF Extended Link TLVs Registry

more precisely, these should be allocated from "OSPFv2 Extended Link TLV 
Sub-TLVs" registry. The text in the draft should be updated as well to 
reflect the correct registry name. At this point it says "OSPF Extended 
Link TLVs Registry", which would suggest it is from a different, top 
level TLV registry.

Also I see that value 5 has been taken by RFC8169 already.

thanks,
Peter

> .

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 14 Dec 2017 12:39:19 +0000

Thanks Peter - Agree the registry needs to be updated.
Acee

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Fri, 15 Dec 2017 00:55:08 +0000

Hi all,

As Peter pointed out, there appear to be issues with these registrations. 

Is the first registry, "OSPF Extended Link TLVs Registry," meant to refer to  "OSPFv2 Extended Link Opaque LSA TLVs" or "OSPFv2 Extended Link TLV Sub-TLVs"? In the first of those, values 4, 5, and 11 are available. In the second, values 4 and 5 are not available. Please see

https://www.iana.org/assignments/ospfv2-parameters

For the second registry in the document, if "OSPFV3 Router Link TLV Registry" refers to "OSPFv3 Router LSA Link Types," value 4 is not available. Please see

https://www.iana.org/assignments/ospfv3-parameters

For the third registry in the document, if "BGP-LS Link NLRI Registry" refers to "BGP-LS NLRI-Types," value 1101 is available, but because this is a Specification Required registry, we'll have to ask the designated experts to confirm that this is OK. Can you confirm that this is the correct registry?

https://www.iana.org/assignments/bgp-ls-parameters

You can see a list of registries here:

https://www.iana.org/protocols

thanks,

Amanda Baber
Lead IANA Services Specialist

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 14 Dec 2017 17:34:45 -0800

Hi Amanda,

Please note, in the draft-ietf-ospf-segment-routing-msd regretfully, the authors have requested an allocation from OSPFv2 Extended Link Opaque LSA TLVs while it should have been from OSPFv2 Extended Link TLV Sub-TLVs registry.

Updated draft has been published (draft-ietf-ospf-segment-routing-msd-08) and email to update the allocation (value of 6 from OSPFv2 Extended Link TLV Sub-TLVs registry) has been sent to [email-masked]  (so 6 is unavailable)

Back to draft-ietf-ospf-link-overload OSPFv3 allocations-  it is quite complicated and requires resolution.
I believe, the registry in question would be “OSPFv3 Extend-LSA Sub-TLV”, please note - draft-ietf-ospf-ospfv3-segment-routing-extensions has already suggested values 3(used already by the base draft for route-tag) to 14 for their use.

Hopefully I haven’t caused even more confusion than before, we just need to sort out who is getting what ;-)

Many thanks!

Cheers,
Jeff

-----Original Message-----
From: OSPF <[email-masked]> on behalf of Amanda Baber via RT <[email-masked]>
Reply-To: <[email-masked]>
Date: Thursday, December 14, 2017 at 16:55
Cc: <[email-masked]>, <[email-masked]>, <[email-masked]>
Subject: [OSPF] [IANA #992646] FW: Publication has been requested for draft-ietf-ospf-link-overload-10

    Hi all,

    

    

    
    
    thanks,
    
    Amanda Baber

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Fri, 15 Dec 2017 01:39:23 +0000

Hi Jeff, 

I just sent a separate note about draft-ietf-ospf-segment-routing-msd from ticket [IANA #992766] to the people on the draft-string-all list. Thanks!

Amanda

On Fri Dec 15 01:35:11 2017, [email-masked] wrote:
> Hi Amanda,
> 
> Please note, in the draft-ietf-ospf-segment-routing-msd regretfully,
> the authors have requested an allocation from OSPFv2 Extended Link
> Opaque LSA TLVs while it should have been from OSPFv2 Extended Link
> TLV Sub-TLVs registry.
> 
> Updated draft has been published (draft-ietf-ospf-segment-routing-msd-
> 08) and email to update the allocation (value of 6 from OSPFv2
> Extended Link TLV Sub-TLVs registry) has been sent to iana-issues-
> [email-masked]  (so 6 is unavailable)
> 
> 
> I believe, the registry in question would be “OSPFv3 Extend-LSA Sub-
> TLV”, please note - draft-ietf-ospf-ospfv3-segment-routing-extensions
> has already suggested values 3(used already by the base draft for
> route-tag) to 14 for their use.
> 
> Is the first registry, "OSPF Extended Link TLVs Registry," meant to
> refer to  "OSPFv2 Extended Link Opaque LSA TLVs" or "OSPFv2 Extended
> Link TLV Sub-TLVs"? In the first of those, values 4, 5, and 11 are
> available. In the second, values 4 and 5 are not available. Please see
> 
> For the second registry in the document, if "OSPFV3 Router Link TLV
> Registry" refers to "OSPFv3 Router LSA Link Types," value 4 is not
> available. Please see
> 
> For the third registry in the document, if "BGP-LS Link NLRI Registry"
> refers to "BGP-LS NLRI-Types," value 1101 is available, but because
> this is a Specification Required registry, we'll have to ask the
> designated experts to confirm that this is OK. Can you confirm that
> this is the correct registry?
>

---

From: Peter Psenak <[email-masked]>
Date: Fri, 15 Dec 2017 10:48:31 +0100

Hi Amanda, Jeff,

> I believe, the registry in question would be “OSPFv3 Extend-LSA Sub-TLV”, please note - draft-ietf-ospf-ospfv3-segment-routing-extensions has already suggested values 3(used already by the base dra…

right, the correct registry should be OSPFv3 Extended-LSA sub-TLV. 
Unfortunately, this registry has not yet been created as it comes from 
draft-ietf-ospf-ospfv3-lsa-extend, which has not yet been published as RFC.

Now, draft-ietf-ospf-ospfv3-segment-routing-extensions have origially 
defined values 3-14 out of "OSPFv3 Extended-LSA sub-TLV" registry, but 
only values 3 to 6 would be needed. We should make early IANA allocation 
for these values (3,4,5,6) immediately as the "OSPFv3 Extended-LSA 
sub-TLV" becomes available - the reason is that there are implementation 
of OSPFv3 SR out there.

Then draft-ietf-ospf-link-overload can take the next value, e.g. 7 from 
"OSPFv3 Extended-LSA sub-TLV" registry.

thanks,
Peter

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 15 Dec 2017 17:10:53 +0000

Hi Amanda, 

On 12/14/17, 7:55 PM, "Amanda Baber via RT"
<[email-masked]> wrote:

>Is the first registry, "OSPF Extended Link TLVs Registry," meant to refer
>to  "OSPFv2 Extended Link Opaque LSA TLVs" or "OSPFv2 Extended Link TLV
>Sub-TLVs"? In the first of those, values 4, 5, and 11 are available. In
>the second, values 4 and 5 are not available. Please see
>

Sounds good to me.

>https://www.iana.org/assignments/ospfv3-parameters

Let’s defer this for now. We don’t even have early allocation for the
registries yet and this would be requested for “OSPFv3 Extended LSAs”.
Sorry for not seeing this in my initial E-mail. We recently reinstated the
OSPFv3 specification since OSPFv3 Extended LSAs is being progressed.

>refers to "BGP-LS NLRI-Types," value 1101 is available, but because this
>is a Specification Required registry, we'll have to ask the designated
>experts to confirm that this is OK. Can you confirm that this is the
>correct registry?
>

Sounds good, I’ve copied Hannes and Adrian.

Thanks,
Acee

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Fri, 15 Dec 2017 19:15:07 +0000

Hi Acee, Peter,

> >https://www.iana.org/assignments/ospfv2-parameters

Are we making the assignments in OSPF Extended Link TLVs Registry, which does have the values available? It looks like Peter wrote below that these should instead be allocated from the second option, the OSPFv2 Extended Link TLV Sub-TLVs registry, where values 4 and 5 have already been assigned.

thanks,
Amanda

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 16 Dec 2017 18:11:09 +0000

Hi Amanda, 

Right - assignments for the Remote IPv4 address Sub-TLV, Local/Remote
Interface ID Sub-TLV, and Link-Overload Sub-TLV should be taken from the
unassigned values (7-32767). The values in the draft were suggested since
they were unassigned when the draft was first authored. However, to the
best of my knowledge, there are no implementations using these values.

Thanks,
Acee 

On 12/15/17, 2:15 PM, "OSPF on behalf of Amanda Baber via RT"
<[email-masked] on behalf of [email-masked]>
wrote:

>>refer
>Are we making the assignments in OSPF Extended Link TLVs Registry, which
>does have the values available? It looks like Peter wrote below that
>these should instead be allocated from the second option, the OSPFv2
>Extended Link TLV Sub-TLVs registry, where values 4 and 5 have already
>been assigned.
>
>thanks,
>Amanda
>

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 20 Dec 2017 19:43:53 +0000

Hi all,

We've made the following early allocation in the BGP-LS NLRI-Types registry:

1101    Link-Overload TLV (TEMPORARY - registered 2017-12-20, expires 2018-12-20)    [draft-ietf-ospf-link-overload]

Please see

Since this allocation and the OSPFv2 Extended Prefix TLV Sub-TLV early allocations are complete, this ticket will be closed.

thanks,
Amanda