Subject: [payload] AAC_LC mime type and RTP/SDP binding

From: Daniel Petrie <[email-masked]>
Date: Mon, 18 Jul 2011 17:52:01 -0700 (PDT)

Hi:
Sorry for the broadcast on this.

I am looking for the RFC for RTP streaming of audio/AAC_LC.

Normally I can pretty easily find the codec profile with RTP and SDP binding for a mime type.  However I am having difficulty finding the RFC or draft for this.  Iana has no registration for the audio/AAC_LC MIME type, yet I know of several vendors who are advertising this MIME type in their SDP.  I have scanned through RFC 3016 & 3640, but less I am being dense, these do not define it either.

I would appreciate a pointer.

Cheers,
Dan

---

From: "Bont, Frans de" <[email-masked]>
Date: Tue, 19 Jul 2011 09:10:31 +0200

Hi Dan,

RFC 3016 & 3640 define two different payload formats for MPEG-4 AAC LC.

RFC 3016 defines the MIME subtype audio/MP4A-LATM, and support all MPEG-4 Audio coders, so also MPEG-4 AAC LC. The payload format is based on MPEG-4 LATM (Low-overhead MPEG-4 Audio Transport Multiplex), a format which is also used by DVB services using MPEG-2 TS.
An example of deployment of RFC 3016 is the 3GPP Transparent end-to-end Packet-switched Streaming Service (PSS) (3GPP TS 26.234).

RFC 3640 defines the MIME subtype mpeg4-generic, which has defined audio modes for MPEG-4 AAC and MPEG-4 CELP. The AAC modes are AAC-lbr and AAC-hbr and the payload carries elementary AAC frames. RFC 3640 is referenced in ETSI TS 102 005 (DVB services delivered directly over IP protocols) and the ATSC Mobile DTV Standard (ATSC A/153 Part 8).

I am not aware of a audio/AAC_LC MIME type.

Best regards,
Frans

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Daniel Petrie
> Sent: Tuesday 19 July 2011 2:52
> To: [email-masked]
> Subject: [payload] AAC_LC mime type and RTP/SDP binding
>
> Hi:
> Normally I can pretty easily find the codec profile with RTP and SDP
> binding for a mime type.  However I am having difficulty finding the
> RFC or draft for this.  Iana has no registration for the audio/AAC_LC
> MIME type, yet I know of several vendors who are advertising this MIME
> type in their SDP.  I have scanned through RFC 3016 & 3640, but less I
> am being dense, these do not define it either.
>
> _______________________________________________
> payload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/payload

The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Daniel Petrie <[email-masked]>
Date: Tue, 19 Jul 2011 01:04:44 -0700 (PDT)

Hi Frans:
Thank you for the response and references to AAC LC.  I am definitely seeing mime type audio/AAC_LC from several vendors.  See the following rtpmap from the SDP:

a=rtpmap:116 AAC_LC/32000

Can anyone provide a pointer to a spec. which defines what AAC profile and parameters are implied by this?

Cheers,
Dan

--- On Tue, 7/19/11, Bont, Frans de <[email-masked]> wrote:

> From: Bont, Frans de <[email-masked]>
> Subject: RE: [payload] AAC_LC mime type and RTP/SDP binding
> To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> Date: Tuesday, July 19, 2011, 3:10 AM
> Hi Dan,
> 
> RFC 3016 defines the MIME subtype audio/MP4A-LATM, and
> support all MPEG-4 Audio coders, so also MPEG-4 AAC LC. The
> payload format is based on MPEG-4 LATM (Low-overhead MPEG-4
> Audio Transport Multiplex), a format which is also used by
> DVB services using MPEG-2 TS.
> An example of deployment of RFC 3016 is the 3GPP
> Transparent end-to-end Packet-switched Streaming Service
> (PSS) (3GPP TS 26.234).
> 
> RFC 3640 defines the MIME subtype mpeg4-generic, which has
> defined audio modes for MPEG-4 AAC and MPEG-4 CELP. The AAC
> modes are AAC-lbr and AAC-hbr and the payload carries
> elementary AAC frames. RFC 3640 is referenced in ETSI TS 102
> 005 (DVB services delivered directly over IP protocols) and
> the ATSC Mobile DTV Standard (ATSC A/153 Part 8).
> 
> > From: [email-masked]
> [mailto:[email-masked]]
> On
> > Behalf Of Daniel Petrie
> The information contained in this message may be
> confidential and legally protected under applicable law. The
> message is intended solely for the addressee(s). If you are
> not the intended recipient, you are hereby notified that any
> use, forwarding, dissemination, or reproduction of this
> message is strictly prohibited and may be unlawful. If you
> are not the intended recipient, please contact the sender by
> return e-mail and destroy all copies of the original
> message.
> 
>