Subject: [payload] RTP Payload Format and File Storage Format for Opus Speech and Audio Codec - draft-spittka-payload-rtp-opus-00

From: "Julian Spittka" <[email-masked]>
Date: Tue, 5 Jul 2011 02:10:48 +0200

All,

Please find a first draft "draft-spittka-payload-rtp-opus-00" for the "RTP
Payload Format and File Storage Format for Opus Speech and Audio Codec"
uploaded at
https://datatracker.ietf.org/doc/draft-spittka-payload-rtp-opus/. 

Any feedback, questions, or comments are highly welcome.

Best Regards,

Julian.

---
Julian Spittka
Skype

see & chat: julian_spittka
write: [email-masked]

---

From: Colin Perkins <[email-masked]>
Date: Tue, 12 Jul 2011 15:56:24 +0100

On 5 Jul 2011, at 01:10, Julian Spittka wrote:
> Please find a first draft "draft-spittka-payload-rtp-opus-00" for the "RTP Payload Format and File Storage Format for Opus Speech and Audio Codec" uploaded at https://datatracker.ietf.org/doc/draft-spittka-payload-rtp-opus/. 
> 

A few quick comments:

- The codec supports a VBR mode, so it would be useful to reference the discussion in draft-ietf-avtcore-srtp-vbr-audio in the Security Considerations

- Section 4.1 states that the Marker bit in the RTP header is not used. Any reason why the standard audio usage of setting the M bit to one on the first packet on a talk-spurt isn't appropriate? 

- The media type registration defines a "stereo" parameter. Rather than define something codec-specific, can't this use the encoding parameter in the SDP "a=rtpmap:" line, line other stereo codecs?

Cheers,
Colin

-- 
Colin Perkins
http://csperkins.org/