Subject: [payload] draft-rea-payload-rtp-aptx-01

From: [email-masked]
Date: Thu, 2 Feb 2012 20:51:07 +0200

> Lähettäjä: "Kari Mäenpää" <[email-masked]>
> Päiväys: 1. helmikuuta 2012 10.37.41 UTC+2.00
> Vastaanottaja: [email-masked]
> Aihe: [payload] draft-rea-payload-rtp-aptx-01
> 
> Page 11 on txt - version;
> 
> Should LSB be different from MSB ?
> 
> 
> bw
> Kari
> Kari Mäenpää
> Production Systems Architect
> Production Platforms
> +358 - (0)9 - 1480 2567
> +358 - (0)40 - 869 1121
> 
> 
> Yleisradio Oy
> Finnish Broadcasting Company
> P.O Box 66
> 00024 Yleisradio
> Helsinki, Finland.

---

From: Ross Finlayson <[email-masked]>
Date: Fri, 3 Feb 2012 01:46:31 -0800

IMHO, the "aux=out-of-bound-aux" and "aux-port: <port-number>" mechanism - for specifying a separate port number on which an "auxiliary data stream" should be sent - needs closer scrutiny.  I don't know of another RTP payload format that uses a separate port number that's specified in a SDP "a=" parameter line, rather than on the "m=" line.

This raises lots of questions - for example, do packets on the "auxiliary data stream" share the same RTP sequence number and timestamp space as the 'main stream'?  And what about RTCP?

Does anyone actually implement sending the "auxiliary data stream" on a separate port number?  If not, then perhaps this feature should be removed from the specification...

	Ross.