Subject: Re: [payload] [ietf-types] Video media-types insufficient?

From: "Roni Even" <[email-masked]>
Date: Sat, 26 May 2012 12:53:14 +0300

Hi,
I think this should be discussed in payload WG
Roni Even

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Paul Libbrecht
> Sent: Saturday, May 26, 2012 11:28 AM
> To: IANA Media types
> Subject: [ietf-types] Video media-types insufficient?
> 
> 
> hello dear Media-types' expert,
> 
> the other day, I played with the nifty new video element of HTML5 which
> seems to be fairly well implemented. This element allows a list of
> sources together with their media-type so that the browser can find the
> "video format" that it can play.
> This element is perfectly following the idea of a media-type's
> characterization of an exploitable format.
> 
> However, this characterization is insufficient: the same media-type for
> videos can be encode data in multiple codecs and these are not encoded
> in media-types:
> 
> I met this while using the video/mp4 media-type and realized that our
> default encoding, the mpeg4 codec, did not play in iPad.
> So I used the same video element, with a src of media-type pointing to
> an mp4 file that uses the h264 codec. This one plays on iPad.
> 
> To me, this is a clear failure of the media-type video/mp4: it does not
> express sufficiently the playability on a device.
> 
> Is this something well known?
> Are there maybe media-type parameters that could help?
> Are newer video media-types better on this respect?
> 
> thanks in advance
> 
> Paul
> _______________________________________________
> ietf-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-types

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 28 May 2012 08:43:19 +0200

Hi,

Roni, if I understand correctly this is about the ISO based mp4 file
format and not the RTP payload format. Thus not really a question for
the Payload WG.

My question to Paul, does you and the browser use the codecs and
profiles parameter that are defined for this type. Please see
http://www.rfc-editor.org/rfc/rfc6381.txt

That is intended to more detailed express which profiles and codecs that
are included in the media type.

Cheers

Magnus

On 2012-05-26 11:53, Roni Even wrote:
> payload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/payload
> 
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------