Subject: [payload] Errata report on RFC6184 - H.264 payload

From: "Roni Even" <[email-masked]>
Date: Fri, 19 Apr 2013 10:41:12 +0300

Hi,

An errata report was filed on RFC6184
http://www.rfc-editor.org/errata_search.php?eid=3318  it is given bellow.

I would like to get some feedback about this errata, is it correct?

"Section 8.1 says:

On page 46 start from line 7: 

"When max-dpb is signaled, the receiver MUST be able to decode

NAL unit streams that conform to the signaled highest level,

with the exception that the MaxDpbMbs value in Table A-1 of [1]

for the signaled highest level is replaced with the value of

max-dpb * 3 / 8. Consequently, a receiver that signals max-dpb

          ^^^^^

MUST be capable of storing the following number of decoded

frames, complementary field pairs, and non-paired fields in its

decoded picture buffer:

Min(max-dpb * 3 / 8 / ( PicWidthInMbs * FrameHeightInMbs),

              ^^^^^

16)"

It should say:

When max-dpb is signaled, the receiver MUST be able to decode

NAL unit streams that conform to the signaled highest level,

with the exception that the MaxDpbMbs value in Table A-1 of [1]

for the signaled highest level is replaced with the value of

max-dpb * 8 / 3. Consequently, a receiver that signals max-dpb

          ^^^^^

MUST be capable of storing the following number of decoded

frames, complementary field pairs, and non-paired fields in its

decoded picture buffer:

Min(max-dpb * 8 / 3 / ( PicWidthInMbs * FrameHeightInMbs),

              ^^^^^

16)

"

My personal view is that  since MaxDpbMbs= max-dpb * 8 / 3 the errata is
correct.

Roni Even

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Fri, 19 Apr 2013 16:35:00 +0000

The errata looks correct. For further clarity, it may also help to add parenthesis
around (max-dpb*8/3).

NEW:
When max-dpb is signaled, the receiver MUST be able to decode
NAL unit streams that conform to the signaled highest level,
with the exception that the MaxDpbMbs value in Table A-1 of [1]
for the signaled highest level is replaced with the value of
max-dpb * 8/3. Consequently, a receiver that signals max-dpb
MUST be capable of storing the following number of decoded
frames, complementary field pairs, and non-paired fields in its
decoded picture buffer:
Min((max-dpb * 8/3) / (PicWidthInMbs * FrameHeightInMbs),16)

Mo

From: Roni Even [mailto:[email-masked]]
Sent: Friday, April 19, 2013 3:41 AM
To: [email-masked]
Cc: 'Botzko, Stephen'; Mo Zanaty (mzanaty); Wang, Ye-Kui; Tom Kristensen (tomkrist)
Subject: Errata report on RFC6184 - H.264 payload

Hi,
An errata report was filed on RFC6184 http://www.rfc-editor.org/errata_search.php?eid=3318  it is given bellow.

My personal view is that  since MaxDpbMbs= max-dpb * 8 / 3 the errata is correct.

Roni Even