Subject: Re: [payload] [AVTCORE] [Technical Errata Reported] RFC4733 (3489)

From: Magnus Westerlund <[email-masked]>
Date: Wed, 3 Apr 2013 16:55:25 +0200

AVTCORE and Payload WG,

There appear to exist an interoperability issue around the the need to
use the same timestamp rate for the DTMF and the audio. Thus, I think we
should serioulsy consider to approve this erratum. And if the text is
not correct, propose a better text.

I personally believe the proposal is significantly clearer than the old
text and also reflect what must have been intended.

This issues a 2-week last call on input on this erratum. After the 17th
of April I will issue a final recommendation on this erratum.

For previous discussion that resulted in this updated erratum proposal
see this AVTCORE mailing list discussion:
http://www.ietf.org/mail-archive/web/avt/current/msg15669.html

Cheers

Magnus Westerlund
AVTCORE WG chair

On 2013-02-19 08:42, RFC Errata System wrote:
> 
> The following errata report has been submitted for RFC4733,
> "RTP Payload for DTMF Digits, Telephony Tones, and Telephony Signals".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=4733&eid=3489
> 
> --------------------------------------
> Type: Technical
> Reported by: Xavier Marjou <[email-masked]>
> 
> Section: 2.1
> 
> Original Text
> -------------
> Named telephone events are carried as part of the audio stream and MUST use the same sequence number and timestamp base as the regular audio channel to simplify the generation of audio waveforms at a gateway.
> 
> Corrected Text
> --------------
> Named telephone events are carried as part of the audio stream and if they use the same SSRC (therefore the same timing and sequence number space), they MUST use the same timestamp clock rate as the regular audio channel.
> 
> Notes
> -----
> RFC4733 was written in a way to avoid the multiple clock-rate problem by mandating the use of the same SSRC for DTMF and audio. However it's not explicitly written, which brings an ambiguity. It was commented that RFC4733 needs to be updated. (c.f. http://tools.ietf.org/wg/avtext/minutes?item=minutes-85-avtext.html). This errata obsoletes the previous proposed errata (ID: 3451).
> 
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC4733 (draft-ietf-avt-rfc2833bis-15)
> --------------------------------------
> Title               : RTP Payload for DTMF Digits, Telephony Tones, and Telephony Signals
> Publication Date    : December 2006
> Author(s)           : H. Schulzrinne, T. Taylor
> Category            : PROPOSED STANDARD
> Source              : Audio/Video Transport
> Area                : Real-time Applications and Infrastructure
> Stream              : IETF
> Verifying Party     : IESG
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
> 
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 03 Apr 2013 11:23:38 -0700

On 04/03/2013 07:55 AM, Magnus Westerlund wrote:
> AVTCORE and Payload WG,
> 
> There appear to exist an interoperability issue around the the need to use
> the same timestamp rate for the DTMF and the audio. Thus, I think we should
> serioulsy consider to approve this erratum. And if the text is not correct,
> propose a better text.
> 
> This issues a 2-week last call on input on this erratum. After the 17th of
> April I will issue a final recommendation on this erratum.
> 

I support this text.

BTW I would like to applaud the way this erratum was handled. i.e. discussed
and refined first in the WG, as it should be[1].

Thanks.

[1] http://www.rfc-editor.org/pipermail/rfc-interest/2012-August/004839.html

> 
> For previous discussion that resulted in this updated erratum proposal see
> this AVTCORE mailing list discussion: 
> Magnus Westerlund AVTCORE WG chair
> 
>> The following errata report has been submitted for RFC4733, "RTP Payload
>> for DTMF Digits, Telephony Tones, and Telephony Signals".
>> 
>> -------------------------------------- You may review the report below
>> and at: http://www.rfc-editor.org/errata_search.php?rfc=4733&eid=3489
>> 
>> -------------------------------------- Type: Technical Reported by:
>> Xavier Marjou <[email-masked]>
>> 
>> Section: 2.1
>> 
>> Original Text ------------- Named telephone events are carried as part of
>> the audio stream and MUST use the same sequence number and timestamp base
>> as the regular audio channel to simplify the generation of audio
>> waveforms at a gateway.
>> 
>> Corrected Text -------------- Named telephone events are carried as part
>> of the audio stream and if they use the same SSRC (therefore the same
>> timing and sequence number space), they MUST use the same timestamp clock
>> rate as the regular audio channel.
>> 
>> Notes ----- RFC4733 was written in a way to avoid the multiple clock-rate
>> problem by mandating the use of the same SSRC for DTMF and audio. However
>> it's not explicitly written, which brings an ambiguity. It was commented
>> that RFC4733 needs to be updated. (c.f.
>> http://tools.ietf.org/wg/avtext/minutes?item=minutes-85-avtext.html).
>> This errata obsoletes the previous proposed errata (ID: 3451).
>> 
>> Instructions: ------------- This errata is currently posted as
>> "Reported". If necessary, please use "Reply All" to discuss whether it
>> should be verified or rejected. When a decision is reached, the verifying
>> party (IESG) can log in to change the status and edit the report, if
>> necessary.
>> 
>> -------------------------------------- RFC4733
>> (draft-ietf-avt-rfc2833bis-15) -------------------------------------- 
>> Title               : RTP Payload for DTMF Digits, Telephony Tones, and
>> Telephony Signals Publication Date    : December 2006 Author(s)
>> : H. Schulzrinne, T. Taylor Category            : PROPOSED STANDARD 
>> Source              : Audio/Video Transport Area                :
>> Real-time Applications and Infrastructure Stream              : IETF 
>> Verifying Party     : IESG

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 18 Apr 2013 09:50:02 +0200

AD,

I recommend that you verify this errata as there has been no objection
during this last call period and the text was developed in the context
of the AVTCORE WG.

Cheers

Magnus Westerlund
as WG chair of AVTCORE WG

-- 

Magnus Westerlund

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 18 Apr 2013 11:09:41 +0300

Hi,

I have just verified it.

Thanks,

Gonzalo