Subject: [payload] FW: Request for G.711 RTP Payload Format to be adopted as a PAYLOAD work item

From: Paul Coverdale <[email-masked]>
Date: Mon, 1 Apr 2013 14:20:00 -0400

I also support this as a new work item the Payload WG.

Paul Coverdale

From: Michael Ramalho (mramalho) 
Sent: Thursday, March 28, 2013 2:04 PM
To: [email-masked]
Subject: Request for G.711 RTP Payload Format to be adopted as a PAYLOAD
work item

Ali Begen, Roni Even (PAYLOAD WG Chairs) and Payload WG,

This email requests that the RTP payload format for ITU-T Rec. G.711.0 be a
formal work item for the PAYLOAD WG.

The G.711.0 RTP payload draft (draft-ramalho-payload-g7110) has been
discussed at past IETFs and is listed as a "related document" for the
PAYLOAD working group (see: http://datatracker.ietf.org/wg/payload/).

The history/chronology of G.711.0 work in the IETF Payload Working Group
follows after my signature for those interested.

If adopted, a milestone submit date of December 2013 is suggested.

Regards,

Michael Ramalho

>>Chronology of G.711.0 Work in the IETF PAYLOAD WG<<

>> IETF 81 Quebec, Canada, July 24-29, 2011

I presented the G.711.0 "Compression Segments" draft at the PAYLOAD meeting
held within the AVTEXT timeslot. This draft was a combination of a
"G.711-like" RTP payload specification and text describing how G.711.0 could
be used as a lossless compression mechanism for "G.711.0 segments" of an
end-to-end G.711 session.

In discussion that ensued at that meeting it was decided that this draft
should be split into two drafts:

Draft 1: "G.711.0 RTP Payload Format" draft (targeted as standards track
RFC), and

Draft 2: "G.711.0 Use Cases" draft (targeted as informational RFC).

Soon after IETF 81 this was accomplished by the following drafts:
draft-ramalho-payload-g7110-01.txt (G.711.0 RTP payload format) and
draft-ramalho-g7110-segments-00.txt (G.711.0 "use cases").

As the G.711.0 payload draft is nearly identical to the G.711 RTP payload
specification, there was little debate on the mailing lists about it outside
of the storage mode definition (the G.711 RTP payload specification did not
have a storage mode defined).

>>IETF 83 Paris, France, March 27, 2012

I presented: draft-ramalho-g7110-segments-00 during the PAYLOAD segment
inside of the AVTEXT meeting slot
(http://www.ietf.org/proceedings/83/slides/slides-83-avtext-6.pdf ).

I did not present on the G.711.0 payload format draft, as the only issue
being debated on the list for this draft was the storage mode - and the
storage mode agreements were converging to a solution on the mailing list.

I renewed the G.711.0 RTP payload specification with a new version
(draft-ramalho-payload-g7110-02.txt) which captured the email discussions on
the storage mode issues.

I let the use case draft (draft-ramalho-g7110-segments-00) expire due to
lack of interest on the mailing list. I believe interest will revive when
the payload specification is complete.

>>Summary: This email requests the G.711.0 RTP Payload Format be a formal
working group item with an associated milestone (December 2013 suggested).

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 1 Apr 2013 18:28:51 +0000

We have already seen quite a number of supporting emails for this draft. Please speak up till this Friday if you have any objections for adoption of this draft.

-acbegen, co-chair

From: "Michael Ramalho (mramalho)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 28, 2013 9:04 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [payload] Request for G.711 RTP Payload Format to be adopted as a PAYLOAD work item

This email requests that the RTP payload format for ITU-T Rec. G.711.0 be a formal work item for the PAYLOAD WG.

The G.711.0 RTP payload draft (draft-ramalho-payload-g7110) has been discussed at past IETFs and is listed as a “related document” for the PAYLOAD working group (see: http://datatracker.ietf.org/wg/payload/).

The history/chronology of G.711.0 work in the IETF Payload Working Group follows after my signature for those interested.

Regards,

Michael Ramalho

>> IETF 81 Quebec, Canada, July 24-29, 2011

I presented the G.711.0 “Compression Segments” draft at the PAYLOAD meeting held within the AVTEXT timeslot. This draft was a combination of a “G.711-like” RTP payload specification and text describing how G.711.0 could be used as a lossless compression mechanism for “G.711.0 segments” of an end-to-end G.711 session.

In discussion that ensued at that meeting it was decided that this draft should be split into two drafts:

Draft 1: “G.711.0 RTP Payload Format” draft (targeted as standards track RFC), and
Draft 2: “G.711.0 Use Cases” draft (targeted as informational RFC).

Soon after IETF 81 this was accomplished by the following drafts: draft-ramalho-payload-g7110-01.txt (G.711.0 RTP payload format) and draft-ramalho-g7110-segments-00.txt (G.711.0 “use cases”).

As the G.711.0 payload draft is nearly identical to the G.711 RTP payload specification, there was little debate on the mailing lists about it outside of the storage mode definition (the G.711 RTP payload specification did not have a storage mode defined).

>>IETF 83 Paris, France, March 27, 2012

I presented: draft-ramalho-g7110-segments-00 during the PAYLOAD segment inside of the AVTEXT meeting slot (http://www.ietf.org/proceedings/83/slides/slides-83-avtext-6.pdf ).

I did not present on the G.711.0 payload format draft, as the only issue being debated on the list for this draft was the storage mode – and the storage mode agreements were converging to a solution on the mailing list.

I renewed the G.711.0 RTP payload specification with a new version (draft-ramalho-payload-g7110-02.txt) which captured the email discussions on the storage mode issues.

I let the use case draft (draft-ramalho-g7110-segments-00) expire due to lack of interest on the mailing list. I believe interest will revive when the payload specification is complete.

>>Summary: This email requests the G.711.0 RTP Payload Format be a formal working group item with an associated milestone (December 2013 suggested).