Subject: Re: [payload] draft-ietf-payload-rtp-ancillary-08 info

From: Kjetil Oftedal <[email-masked]>
Date: Sat, 1 Apr 2017 11:46:23 +0200

Hi,

I missed that when looking through. Sorry about that.

But there might still be need for clarification here on the definition of field.
With 3G-level B DL(dual link)/HD DL the SDI transport format is basically a
interlaced format. But the video format is likely to be 50-60Hz progressive.
(Two concurrent interlaced fields is merged to one progressive frame)

Since this draft is uses link/SDI raster level line numbers, it should
be specified
that it is the link level video format that defines whether or not this
is interlaced transport.

Best regards,
Kjetil Oftedal

On 29/03/2017, Thomas Edwards <[email-masked]> wrote:
> Since draft-ietf-payload-rtp-ancillary- 00 the requirement has been:
>
> “RTP packets MUST NOT include ANC data from multiple fields, and all RTP
> packets belonging to the same field MUST have the same timestamp.”
>
> -Thomas
>
> --
> Thomas Edwards
> VP Engineering & Development
> FOX Networks Engineering and Operations
> [email-masked]
> Phone: +1.310.369.6696
> 10201 West Pico Blvd.
> Los Angeles, CA 90035
>
> On 3/28/17, 11:05 PM, "Kjetil Oftedal" <[email-masked]> wrote:
>
>     On 29/03/2017, Thomas Edwards <[email-masked]> wrote:
>     > ,..
>     > But there is one I’d call a “substantial” change.  This an addition of
> two
>     > field bits (F) carved out of former reserved bits to optionally
> identify the
>     > field in interlaced signal interfaces.  This is done in a backwards
>     > compatible way with -07. If a -07 sender properly filled in those (F)
> bits
>     > with ‘00’, the field bits are not considered to carry additional
>     > information.  Only if the first bit is a ‘1’ would the second bit
> indicate
>     > the first or second interlaced field.
>     > ...
>
>     This change, due to the placement of the field bits, indirectly adds a
>     requirement
>     that all ANC packets within a RTP frame is from the same video field,
>     as it is not possible to specify the field bits per ANC packet.
>
>     This was not a requirement earlier, and for interlaced the field
>     polarity could be
>     discovered from the Line_Number field.
>
>     I believe this should at least be clarified in the RFC that it is now
> required
>     that all ANC packets in a RTP frame are from the same video field.
>
>     Best regards,
>     Kjetil Oftedal
>
>
>

---

From: Thomas Edwards <[email-masked]>
Date: Thu, 20 Apr 2017 02:53:34 +0000

I have to admit that I am no expert in SMPTE multi-link SDI, but I do believe that you may be correct that some multi-link SDI solutions for progressive images may use interlaced links for transport.

How about appending the “F” (field) description with:

“Note that some multi-link SDI interfaces may use multiple interlaced signals to transmit progressive images, in which case ‘field’ would refer to the link field.”

-Thomas 

On 4/1/17, 2:46 AM, "Kjetil Oftedal" <[email-masked]> wrote:

    Hi,

    
    
    Best regards,
    Kjetil Oftedal