Subject: [PCN] Two conclusions from discussion of "discusses"

From: Tom Taylor <[email-masked]>
Date: Fri, 20 Jan 2012 09:09:35 -0500

1) I have been convinced by mail received off-line that flow termination 
is also potentially applicable to non-IP transports. So no changes to 
existing requirements in that respect.

2) Second point is a new one, and I need the agreement of the WG and AD 
to make this change. The edge behaviour documents currently say that if 
report suppression is being used, the CLE calculated by the egress node 
is included in the report sent to the Decision Point. If report 
suppression is not being used, the egress node does not calculate CLE 
and does not include it in the report. My reason for doing things this 
way in the first place was to save one end from having to redo a 
calculation already done at the other end. Effectively, the Decision 
Point has to be aware that report suppression is in use (unavoidable, so 
no problem), and decides to take CLE from incoming reports or calculate 
it depending on whether that condition holds or does not.

It would be cleaner to always require the Decision Point to calculate 
the CLE, in that it simplifies CLE logic and reduces the amount of 
information being carried in signalling. Would this change be acceptable 
aat this late point in the process, or should we keep what is there now?

Tom Taylor

---

From: <[email-masked]>
Date: Fri, 20 Jan 2012 15:34:10 +0000

Hi Tom,

Regarding your point 2) I agree to change the edge behaviour drafts 
and draft-ietf-pcn-signaling-requirements to address this point.
In particular, CLE will not be sent by the PCN-egress-node to the Decision Point.

Best regards,
Georgios

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Tom Taylor
> Sent: vrijdag 20 januari 2012 15:10
> To: pcn; David Harrington
> Subject: [PCN] Two conclusions from discussion of "discusses"
> 
> 1) I have been convinced by mail received off-line that flow termination is
> also potentially applicable to non-IP transports. So no changes to existing
> requirements in that respect.
> 
> 2) Second point is a new one, and I need the agreement of the WG and AD to
> make this change. The edge behaviour documents currently say that if report
> suppression is being used, the CLE calculated by the egress node is included
> in the report sent to the Decision Point. If report suppression is not being
> used, the egress node does not calculate CLE and does not include it in the
> report. My reason for doing things this way in the first place was to save one
> end from having to redo a calculation already done at the other end.
> Effectively, the Decision Point has to be aware that report suppression is in
> use (unavoidable, so no problem), and decides to take CLE from incoming
> reports or calculate it depending on whether that condition holds or does
> not.
> 
> It would be cleaner to always require the Decision Point to calculate the CLE,
> in that it simplifies CLE logic and reduces the amount of information being
> carried in signalling. Would this change be acceptable aat this late point in the
> process, or should we keep what is there now?
> 
> Tom Taylor
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Fri, 20 Jan 2012 17:16:49 +0000

Tom,
So i can answer 2) - please can you remind me why in the normal case the egress node doesn't calculate CLE? This seems the obvious place to do it to me, i have forgotten the discussion about this.
Thanks
phil

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom Taylor
Sent: 20 January 2012 14:10
To: pcn; David Harrington
Subject: [PCN] Two conclusions from discussion of "discusses"

Tom Taylor

---

From: Tom Taylor <[email-masked]>
Date: Fri, 20 Jan 2012 12:47:49 -0500

The egress node has no use for CLE in the normal case, so why should it 
bother to calculate it?

---

From: <[email-masked]>
Date: Fri, 20 Jan 2012 18:19:44 +0000

Is it really any hassle? If the egress doesnt calculate it, then it gets calculated when gets to the ingress node, and all egress nodes are ingress nodes.

Also, if admission control is on the basis of a pkt (or several pkts) being marked, ie the egress detects this and signals 'dont admit' - then if the egress node is reporting CLE it can simply set cle to 100%.

---

From: Tom Taylor <[email-masked]>
Date: Fri, 20 Jan 2012 18:57:55 -0500

Technically, it's the Decision Point that needs the value. The egress 
node does not indicate "don't admit" in either of the edge behaviours 
I've documented -- or did you have another edge behaviour proposal in mind?

---

From: <[email-masked]>
Date: Mon, 23 Jan 2012 09:17:26 +0000

<< The egress 
I've documented 
I wasn't saying it did. Reporting CLE leaves the decision point to decide whether to admit or block.

<<-- or did you have another edge behaviour proposal in mind?
My 2nd para referred to an edge behaviour we once talked about, sorry for bringing that up.

I dont see much advantage or disadvantage in the change - I dont mind either way.

---

From: Michael Menth <[email-masked]>
Date: Mon, 23 Jan 2012 10:24:22 +0100

The problem is that the descriptions in the document sets are not 
consistent regarding whether CLE is explicitly reported or not.  The CLE 
value is calculated by CLE=marked traffic / overall traffic. As these 
quantities are reported in signalling messages, and the calculation is 
very simple, I am in favor of dropping the CLE to avoid reporting 
redundant data.

Regards

Michael

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de