Subject: [PCN] IESG feedback from 3-in-1 encoding/ encoding comparison

From: Toby Moncaster <[email-masked]>
Date: Fri, 2 Mar 2012 09:45:17 +0000

Adrian Farrel is keen to find out what the WG intentions are regarding the "other" WG encoding drafts. Just to remind everyone, the original idea was to have the baseline encoding and a set of 3 experimental encodings that built on it. Then Bob got RFC6040 published and we decided to push 3-in-1 encoding as the main standard. This left the other experimental encodings in limbo. They are:

draft-ietf-pcn-psdm-encoding-01 <http://tools.ietf.org/html/draft-ietf-pcn-psdm-encoding-01>

draft-ietf-pcn-3-state-encoding-01 <http://tools.ietf.org/html/draft-ietf-pcn-3-state-encoding-01>

These are both cited in the encoding comparison draft which poses some potential problems. Firstly we are not meant to refer to IDs in RFCs, secondly these have both long expired so will eventually disappear from any archives, thirdly I believe Michael may still want to use PSDM experimentally?

There would seem to be 3 possible courses of action:

1) We ask for these to be published as historical RFCs so they can be referenced from encoding comparison
2) we ask for these to be published as experimental schemes so they can be referenced and can be used
3) we remove all reference from the encoding comparison

OPtion 1 is probably the easiest as (hopefully) they would not need too much updating. Option 2 requires more work on the drafts (in light of the fact we are obsolete RFC5696 which they both depend on), but would at least hold the door open to future work. Option 3 partially defeats the point of the encoding comparison document. 

I have a very slight preference for option 1, but what do other people think? 

Toby

---

From: Michael Menth <[email-masked]>
Date: Fri, 02 Mar 2012 10:51:00 +0100

Hi Toby,

I am also in favor of option 1.

Kind regards,

     Michael

Am 02.03.2012 10:45, schrieb Toby Moncaster:
> draft-ietf-pcn-psdm-encoding-01<http://tools.ietf.org/html/draft-ietf-pcn-psdm-encoding-01>
>
> draft-ietf-pcn-3-state-encoding-01<http://tools.ietf.org/html/draft-ietf-pcn-3-state-encoding-01>
>
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcn

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---

From: <[email-masked]>
Date: Fri, 2 Mar 2012 10:30:12 +0000

Hi,

I agree with Toby that Option 1 is probably the best one to choose!

Best regards,
Georgios

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Toby Moncaster
> Sent: vrijdag 2 maart 2012 10:45
> To: pcn
> Subject: [PCN] IESG feedback from 3-in-1 encoding/ encoding comparison
> 
> Adrian Farrel is keen to find out what the WG intentions are regarding the
> "other" WG encoding drafts. Just to remind everyone, the original idea was
> to have the baseline encoding and a set of 3 experimental encodings that
> built on it. Then Bob got RFC6040 published and we decided to push 3-in-1
> encoding as the main standard. This left the other experimental encodings in
> limbo. They are:
> 
> These are both cited in the encoding comparison draft which poses some
> potential problems. Firstly we are not meant to refer to IDs in RFCs, secondly
> these have both long expired so will eventually disappear from any archives,
> thirdly I believe Michael may still want to use PSDM experimentally?
> 
> OPtion 1 is probably the easiest as (hopefully) they would not need too much
> updating. Option 2 requires more work on the drafts (in light of the fact we
> are obsolete RFC5696 which they both depend on), but would at least hold
> the door open to future work. Option 3 partially defeats the point of the
> encoding comparison document.
>

---

From: <[email-masked]>
Date: Fri, 2 Mar 2012 11:05:53 +0000

Just a correction, lots of RFCs refer to internet drafts.

I don't think Adrian's comment was one about the mechanics of references, but what the status is of these other encodings.
So the solution is simple, the comparison doc spells out (more) clearly that they were ones we thought about, recorded here for posterity, but are now no longer being pursued - in favour of 3-in-1

<< It appears that there are a number of alternative encoding being 
proposed as documented in this I-D, draft-ietf-pcn-3-state-encoding, 
draft-ietf-pcn-psdm-encoding, etc., and as discussed in 
draft-ietf-pcn-encoding-comparison. It isn't clear to me whether these
encodings are being proposed to co-exist, to be used by different 
operators depending on specific environments, or whether they are being
floated to see which one gets more market-place support.>>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 02 March 2012 10:30
To: [email-masked]; [email-masked]
Subject: Re: [PCN] IESG feedback from 3-in-1 encoding/ encoding comparison

Hi,

Best regards,
Georgios

---

From: Bob Briscoe <[email-masked]>
Date: Fri, 2 Mar 2012 19:51:49 +0000

+1

At 10:30 02/03/2012, [email-masked] wrote:
> > draft-ietf-pcn-psdm-encoding-01 
> <http://tools.ietf.org/html/draft-ietf-pcn-> psdm-encoding-01>
> >
> > draft-ietf-pcn-3-state-encoding-01 
> <http://tools.ietf.org/html/draft-ietf-> pcn-3-state-encoding-01>
> >

________________________________________________________________
Bob Briscoe,                                BT Innovate & Design

---

From: Steven Blake <[email-masked]>
Date: Fri, 02 Mar 2012 15:27:29 -0500

On Fri, 2012-03-02 at 11:05 +0000, [email-masked] wrote:

> I don't think Adrian's comment was one about the mechanics of
> references, but what the status is of these other encodings.
> So the solution is simple, the comparison doc spells out (more)
> clearly that they were ones we thought about, recorded here for
> posterity, but are now no longer being pursued - in favour of 3-in-1
> 
> operators depending on specific environments, or whether they are
> being floated to see which one gets more market-place support.>>

+1

I think publishing the abandoned encoding drafts as RFCs would just
confuse a situation that is going to be confusing enough with RFC5696
and 3-in-1 both extant.  Plus, it's extra load on the IESG and the
gen-art folks.

Regards,

// Steve

---

From: "Scott O. Bradner" <[email-masked]>
Date: Sat, 3 Mar 2012 18:16:50 -0500

+1 - having the formal historical record seems like a good idea

Scott

On Mar 2, 2012, at 2:51 PM, Bob Briscoe wrote:

>> > draft-ietf-pcn-psdm-encoding-01 <http://tools.ietf.org/html/draft-ietf-pcn-> psdm-encoding-01>
>> >
>> > draft-ietf-pcn-3-state-encoding-01 <http://tools.ietf.org/html/draft-ietf-> pcn-3-state-encoding-01>
>> >