Subject: Re: [PCN] IESG feedback from 3-in-1 encoding/ encoding comparison

From: <[email-masked]>
Date: Mon, 5 Mar 2012 10:46:23 +0000

Hi Phil,

Do you mean that you are rather against publishing the other encodings drafts as historical RFCs.

In a previous email I have mentioned that Option 1 (publish encodings drafts as historical RFCs) proposed by Toby is probably the best choice.

However, I will not strongly insist on this option. I am also fine if we will not publish these encodings drafts as historical RFCs. The encoding comparison draft provides then the historical record of what these other encodings are (with the reference to the current I-Ds) like and the reasons pro/anti them.

Best regards,
Georgios

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: vrijdag 2 maart 2012 12:06
> To: Karagiannis, G. (Georgios); [email-masked]; [email-masked]
> Subject: RE: [PCN] IESG feedback from 3-in-1 encoding/ encoding
> comparison
> 
> Just a correction, lots of RFCs refer to internet drafts.
> 
> I don't think Adrian's comment was one about the mechanics of references,
> but what the status is of these other encodings.
> So the solution is simple, the comparison doc spells out (more) clearly that
> they were ones we thought about, recorded here for posterity, but are now
> no longer being pursued - in favour of 3-in-1
> 
> << It appears that there are a number of alternative encoding being
> proposed as documented in this I-D, draft-ietf-pcn-3-state-encoding, draft-
> ietf-pcn-psdm-encoding, etc., and as discussed in draft-ietf-pcn-encoding-
> comparison. It isn't clear to me whether these encodings are being proposed
> to co-exist, to be used by different operators depending on specific
> environments, or whether they are being floated to see which one gets
> more market-place support.>>
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: 02 March 2012 10:30
> To: [email-masked]; [email-masked]
> Subject: Re: [PCN] IESG feedback from 3-in-1 encoding/ encoding
> comparison
> 
> Hi,
> 
> I agree with Toby that Option 1 is probably the best one to choose!
> 
> Best regards,
> Georgios
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of
> > Toby Moncaster
> > Sent: vrijdag 2 maart 2012 10:45
> > To: pcn
> > Subject: [PCN] IESG feedback from 3-in-1 encoding/ encoding comparison
> >
> > Adrian Farrel is keen to find out what the WG intentions are regarding
> > the "other" WG encoding drafts. Just to remind everyone, the original
> > idea was to have the baseline encoding and a set of 3 experimental
> > encodings that built on it. Then Bob got RFC6040 published and we
> > decided to push 3-in-1 encoding as the main standard. This left the
> > other experimental encodings in limbo. They are:
> >
> > draft-ietf-pcn-psdm-encoding-01
> > <http://tools.ietf.org/html/draft-ietf-pcn-
> > psdm-encoding-01>
> >
> > draft-ietf-pcn-3-state-encoding-01
> > <http://tools.ietf.org/html/draft-ietf-
> > pcn-3-state-encoding-01>
> >
> > These are both cited in the encoding comparison draft which poses some
> > potential problems. Firstly we are not meant to refer to IDs in RFCs,
> > secondly these have both long expired so will eventually disappear
> > from any archives, thirdly I believe Michael may still want to use PSDM
> experimentally?
> >
> > There would seem to be 3 possible courses of action:
> >
> > 1) We ask for these to be published as historical RFCs so they can be
> > referenced from encoding comparison
> > 2) we ask for these to be published as experimental schemes so they
> > can be referenced and can be used
> > 3) we remove all reference from the encoding comparison
> >
> > OPtion 1 is probably the easiest as (hopefully) they would not need
> > too much updating. Option 2 requires more work on the drafts (in light
> > of the fact we are obsolete RFC5696 which they both depend on), but
> > would at least hold the door open to future work. Option 3 partially
> > defeats the point of the encoding comparison document.
> >
> > I have a very slight preference for option 1, but what do other people
> think?
> >
> > Toby
> > _______________________________________________
> > PCN mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/pcn
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Mon, 5 Mar 2012 11:22:29 +0000

Yes - I think the encoding comparison draft provides a good historical record of the various encodings that we thought of and their pros/cons.
Publishing the encodings as historical RFCs doesn't seem to me to add much value, and creates extra work for WG /iesg /ietf reviewers

phil

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 05 March 2012 10:46
To: Eardley,PL,Philip,DUB8 R; [email-masked]; [email-masked]
Subject: RE: [PCN] IESG feedback from 3-in-1 encoding/ encoding comparison 

Hi Phil,

Best regards,
Georgios

---

From: David Harrington <[email-masked]>
Date: Tue, 06 Mar 2012 13:23:38 -0500

Hi,

It appears to me the drafts have already expired.
You can refer to expired drafts in an Informational document, using an
approach similar to this:

   The XYZ encoding was proposed in a draft document submitted to the PCN
WG in <October
   2006>. The PCN WG chose to not advance this draft.

This way there is no reference to the expired draft, and the intentions to
not carry the drafts forward is easy to see.

Now, as to whether publishing them as historical is the right way:
How much more detail is in the drafts that will be lost if we just let
them expire?
Is it important to the industry to keep a record of that historical
detail, or just a summary of the ideas in those drafts and why they didn't
work.
I can understand that academically, it might be nice to have these
published as historical records, but I tend to agree that having them
published as RFCs could confuse people who are not really knowledgeable
about IETF practice and the difference in types of RFCs.
If the summary seems adequate, then I recommend letting the drafts
disappear.
You should make sure all your documents do not contain any references to
those drafts.

--
David Harrington
Director, Transport Area
Internet Engineering Task Force (IETF)
[email-masked]
+1-603-828-1401

On 3/5/12 6:22 AM, "[email-masked]" <[email-masked]> wrote:

>Yes - I think the encoding comparison draft provides a good historical
>record of the various encodings that we thought of and their pros/cons.
>Publishing the encodings as historical RFCs doesn't seem to me to add
>much value, and creates extra work for WG /iesg /ietf reviewers
>
>phil
>
>In a previous email I have mentioned that Option 1 (publish encodings
>drafts as historical RFCs) proposed by Toby is probably the best choice.
>
>However, I will not strongly insist on this option. I am also fine if we
>will not publish these encodings drafts as historical RFCs. The encoding
>comparison draft provides then the historical record of what these other
>encodings are (with the reference to the current I-Ds) like and the
>reasons pro/anti them.
>
>Best regards,
>Georgios
>
>

---

From: Steven Blake <[email-masked]>
Date: Thu, 08 Mar 2012 00:01:13 -0500

> You should make sure all your documents do not contain any references to

I think this last bit of advice applies even if the WG chooses to
publish the expired drafts.

Now, are there any volunteers to revise these drafts and get them in
shape for WG last call?

Regards,

// Steve

---

From: "Bradner, Scott" <[email-masked]>
Date: Thu, 8 Mar 2012 17:14:41 +0000

Dave - 

just to be sure - you are not suggesting to not have a reference to an expired ID (by document name, not by filename) are you?

Scott

---

From: Bob Briscoe <[email-masked]>
Date: Sun, 11 Mar 2012 14:39:28 +0000

Steve,

I got the impression most people (including you) were converging on 
not publishing psdm & 3-state as historical RFCs (unnec hassle for 
authors, IESG, GEN-ART etc). But then your latest message below seems 
to imply it is decided that we will.

We can publish as historical if people want (personally I've already 
said I don't see the need). However, it would be useful to have a 
decision whether to go ahead by early tomorrow to give us a fighting chance.

Bob

>Now, are there any volunteers to revise these drafts and get them in

________________________________________________________________
Bob Briscoe,                                BT Innovate & Design

---

From: Toby Moncaster <[email-masked]>
Date: 11 Mar 2012 17:09:00 +0000

Although it did seem like the balance was towards non-publication I think 
this should be explicitly decided by the WG. I have a marginal preference 
for publication because I think it wouldn't take all that much work.

I did wonder at one stage whether the two could be combined into a single 
historical RFC, but that didn't seem workable. I also wondered if there 
could be more about them in the encoding comparison, but that would make it 
a less balanced document.

However we do seem to be getting fundamentally contradictory guidance 
regarding how to reference these drafts (and not to reference them would be 
wrong/dishonest in my opinion).

Toby

On Mar 11 2012, Bob Briscoe wrote:

> We can publish as historical if people want (personally I've already said 
> I don't see the need). However, it would be useful to have a decision 
> whether to go ahead by early tomorrow to give us a fighting chance.
>
>
>
>Bob
>
>> >    The XYZ encoding was proposed in a draft document submitted to the 
>> > PCN WG in <October
>> > This way there is no reference to the expired draft, and the 
>> > intentions to not carry the drafts forward is easy to see.
>> >
>> > them expire? Is it important to the industry to keep a record of that 
>> > historical detail, or just a summary of the ideas in those drafts and 
>> > why they didn't work. I can understand that academically, it might be 
>> > nice to have these published as historical records, but I tend to 
>> > agree that having them published as RFCs could confuse people who are 
>> > not really knowledgeable about IETF practice and the difference in 
>> > types of RFCs. If the summary seems adequate, then I recommend letting 
>> > the drafts disappear. You should make sure all your documents do not 
>> > contain any references to those drafts.
>>

---

From: Steven Blake <[email-masked]>
Date: Sun, 11 Mar 2012 15:01:14 -0400

> decision whether to go ahead by early tomorrow to give us a fighting chance.

It's a WG decision, not the chairs, but it is pointless to discuss it if
no-one will volunteer to do the work.

Given the looming deadline, I suggest that if anyone wants to see them
published and is willing to do the work, they go ahead and refresh the
drafts.  The WG can finalize the decision this week.  I have to say
that, by my reading of the list, there is no rough consensus in either
direction.

Regards,

// Steve

---

From: David Harrington <[email-masked]>
Date: Mon, 12 Mar 2012 20:10:39 -0400

Hi,

I hope I parsed your  double negatives appropriately.
I was suggesting that having a normative reference to an expired draft
could be problematic.

I see that one of the drafts was revised as Historic .
Is the WG decision to publish these as Historic or let them disappear?
The IESG needs to know.

On 3/8/12 12:14 PM, "Bradner, Scott" <[email-masked]> wrote:

>Dave - 
>
>just to be sure - you are not suggesting to not have a reference to an
>expired ID (by document name, not by filename) are you?
>
>Scott
>
>>>> So the solution is simple, the comparison doc spells out (more)
>>>>clearly
>>>> that

---

From: Steven Blake <[email-masked]>
Date: Tue, 13 Mar 2012 00:38:26 -0400

> Is the WG decision to publish these as Historic or let them disappear?

I thought RFCs were re-categorized as Historic?  I didn't realize that
an RFC could be published as Historic right off the bat.

I'm initiating a 3-day WGLC to determine whether to publish
draft-ietf-pcn-psdm-encoding-02.txt and
draft-ietf-pcn-3-state-encoding-02.txt
as Informational/Historic RFCs (terminating EOB Thursday 3/15).
  
Please send comments to the list ASAP.

Regards,

// Steve

---

From: <[email-masked]>
Date: Tue, 13 Mar 2012 08:32:51 +0100

While I clearly prefer egress node based pcn policy decisions, not
requiring any signaled feedback to policy decision points, I don't
object to have both drafts as historic RFCs. But I don't want to
work on them.

Regards,

Ruediger

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steven Blake
Sent: Tuesday, March 13, 2012 5:38 AM
To: David Harrington
Cc: <[email-masked]>; <[email-masked]>
Subject: Re: [PCN] IESG feedback from 3-in-1 encoding/ encoding comparison

Regards,

// Steve

---

From: Toby Moncaster <[email-masked]>
Date: Tue, 13 Mar 2012 10:23:46 +0000

I guess I have to stop equivocating on this…

I am actually in favour of publishing these as historical (with the caveat that they are only worth expending a few man-hours effort on).

Like Steve I hadn't realised that could be done, but as it seems fairly normal procedure it seems like the right option for these drafts. I am also prepared to put a small amount of effort into the process. My hope would be that historical documents need a good deal less scrutiny and hence these can be published more or less as they are in the new -02 versions I posted last night.

Toby

---

From: <[email-masked]>
Date: Wed, 14 Mar 2012 12:41:11 +0000

I think that the encoding-comparison draft is sufficient and that they don't need to be published as historical rfcs. Mainly because of the extra effort involved with no benefit in my view. 

If it is decided there is consensus and effort to progress these 2 docs as historical, I suggest:

- waiting for 3-in-1 to get to RFC status or at least into rfc editor, in case issues emerge during that approval which need to be reflected back into these two docs. (For instance, Bob recently sent an email - not sure if that would imply changes to these two docs as well.) 
- please make sure key parts (abstract, intro, conclusion) make it clear that this is a document for archive purposes and the actual encoding to use is in rfcxxxx potential confusion

> I was suggesting that having a normative reference to an expired draft
I think this can be skirted round. In the encoding comparison, say something like "PSDN encoding was proposed in [ref]"
Then it can be an Informational reference - since it's informing the reader where it was proposed, whereas the actual definition is in the encoding comparison doc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steven Blake
Sent: 13 March 2012 04:38
To: David Harrington
Cc: <[email-masked]>; <[email-masked]>
Subject: Re: [PCN] IESG feedback from 3-in-1 encoding/ encoding comparison

  

Regards,

// Steve

---

From: David Harrington <[email-masked]>
Date: Wed, 14 Mar 2012 11:50:44 -0400

Hi,

We've had a number of things go Historic since I've been on IESG.
IIRC, and I may not, we decided docs could be published directly to
Historic.
But I am not a process geek; I hate discussions of whether a doc must go
to Informational and then be declared historic, or simply gets published
as historic right off the bat.
If you say it is historic, then the IESG process geeks can decide whether
it must be published as informational first.
The thing is, the IESG can make that change - without another IETF LC -
and then declare it historic, so it doesn't matter much in my eyes.
However, putting historic into the document header seriously addresses
Adrian's concern that the future of these alternate docs is unclear.

As a contributor, I'm good with a WG decision to go Historic.

Chairs, is that the WG consensus?
We need an answer to this so we can clear Adrian's discuss and get
encoding-comparison into the RFC Editor's Q.
Having an answer before ietf83 is definitely desirable, and earlier is
preferable.

Thanks,

---

From: <[email-masked]>
Date: Thu, 15 Mar 2012 04:51:09 +0000

Hi Steve,

I do not object to have both drafts as historic RFCs!

Best regards,
Georgios 

________________________________________
Van: [email-masked] [[email-masked]] namens Steven Blake [[email-masked]]
Verzonden: dinsdag 13 maart 2012 5:38
Aan: David Harrington
CC: <[email-masked]>; <[email-masked]>
Onderwerp: Re: [PCN] IESG feedback from 3-in-1 encoding/ encoding comparison

Regards,

// Steve

---

From: Steven Blake <[email-masked]>
Date: Sun, 18 Mar 2012 23:11:09 -0400

Greetings,

I've tallyed up the comments on the WGLC to publish

as Historical RFCs.  By my count (excluding the chairs):

- one comment for publishing
- one comment against publishing
- three comments that are essentially "no objection".

That is not enough input to determine WG consensus either way.  Given
the non-zero effort required of the IESG and RFC Editor to get these
published, and the lack of consensus to publish, my determination is
that pcn *will not* request that these drafts be published.

Regards,

// Steve