Subject: [perpass] perpass list email not sent encrypted...

From: John-Mark Gurney <[email-masked]>
Date: Wed, 23 Oct 2013 11:28:04 -0700

Is it just me, or is it funny that we are talking about securing the
inet, yet the ietf apparently doesn't do STARTTLS when sending email?
and hence the perpass email list is sent out unencrypted...

Guess I'll drop a note to [email-masked].

-- 
  John-Mark Gurney				Voice: +1 415 225 5579

     "All that I will do, has been done, All that I have, has not."

---

From: Jim Fenton <[email-masked]>
Date: Wed, 23 Oct 2013 12:09:42 -0700

> Guess I'll drop a note to [email-masked].
It's not just you.  IETF SHOULD be using STARTTLS for email, not
particularly for this or other mailing lists (where attackers could just
read the archives, anyway) but because it's the Right Thing To Do.

-Jim

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 23 Oct 2013 20:35:48 +0100

> read the archives, anyway) but because it's the Right Thing To Do.

That was discussed in the DANE meeting in Berlin and
there's a plan for eating our own dogfood, but I'm
not sure where its at. Will check.

S.

> 
> -Jim
> _______________________________________________
> perpass mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/perpass
>

---

From: [email-masked]
Date: Wed, 23 Oct 2013 15:19:52 -0700 (PDT)

> not sure where its at. Will check.

If by "for email" you mean "for outgoing SMTP relay", this this is *not*
as easy as turning on opportunistic use of STARTTLS in SMTP.

The main problem is dealing with SSL/TLS negotiation failures, either because
you don't share a ciphersuite or because the server says it supports STARTTLS
but doesn't actally have a certificate installed. (The latter is distressingly
common.) When this happens you have to close the connection and try again. Some
SMTP clients support this, others do not.

As for DANE or other DNS announcements, it's far too new to be of much use.

				Ned

---

From: Warren Kumari <[email-masked]>
Date: Wed, 23 Oct 2013 18:44:24 -0400

> not sure where its at. Will check.

Yup.

We reached out to the folk who run the mail servers for the IETF (AMS).

The servers that are currently handling mail are (or, were when I chatted with them) older boxes, running older versions of Linux (and, presumably older MTA).
AMS was in the process of deploying shiny new boxes, with new OS, etc. I'm suspecting that the plans might have gotten delayed a bit.

Once the newer boxes are up the plan (from what I understand) was to migrate over to them, and then enable STARTTLS. After that we were planning on doing DANE.

W

--
What our ancestors would really be thinking, if they were alive today, is: "Why is it so dark in here?"

    -- (Terry Pratchett, Pyramids)

---

From: Richard Barnes <[email-masked]>
Date: Wed, 23 Oct 2013 20:47:50 -0400

> not sure where its at. Will check.

I can sort of see the dogfood / Right Thing To Do argument.  But it seems
kind of silly to waste the bits / cycles encrypting things whose entire
point is to be public.

--Richard

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 24 Oct 2013 01:53:23 +0100

> kind of silly to waste the bits / cycles encrypting things whose entire

Not everything that goes in or out of ietf.org via
SMTP is public. See ombudspersonage discussion for
example. Or nomcom. For most lists, yes, this isn't
much of a deal over and above dogfood consumption.

S

---

From: Richard Barnes <[email-masked]>
Date: Wed, 23 Oct 2013 21:54:10 -0400

> much of a deal over and above dogfood consumption.

Ok, fair enough.  Those instances had slipped my mind.  Perhaps this a good
illustration of why turning on TLS is the Right Thing To Do -- even if you
think everything transiting your mail server is public, there's probably
something you've forgotten.  :)

--Richard

---

From: Richard Guy Briggs <[email-masked]>
Date: Thu, 24 Oct 2013 09:35:50 -0400

> much of a deal over and above dogfood consumption.

But the whole point of Opportunistic Encryption, which is essentially
what STARTTLS is about, is to encrypt as much of the traffic as possible
to discourage targetting any particular traffic for analysis.

This is why you might run a newsfeed through an IPsec link carrying more
sensitive traffic, so that the sheer volume makes it impractical to
decode or suspect it all.

> >>> -Jim

	slainte mhath, RGB

--
Richard Guy Briggs               --  ~\    -- ~\            <hpv.tricolour.net>
<www.TriColour.net>                --  \___   o \@       @       Ride yer bike!
Ottawa, ON, CANADA                  --  Lo_>__M__\\/\%__\\/\%
Vote! -- <greenparty.ca>_____GTVS6#790__(*)__(*)________(*)(*)_________________