Subject: [perpass] A reminder, the Network is the Enemy...

From: Nicholas Weaver <[email-masked]>
Date: Wed, 20 Nov 2013 12:42:53 -0800

As a reminder, the network is the enemy.

http://www.wired.com/opinion/2013/11/this-is-how-the-internet-backbone-has-been-turned-into-a-weapon/

We need to consider the network transporting our data as an active attacker, not just one which can observer/wiretap, but one that is both outside our control and willing to serve as a vehicle for attacking the end systems.  Its always been this way, but the recent behavior of the NSA/GCHQ has ensured that the pleasant fiction of the network's lack of hostility is no longer acceptable.

--
Nicholas Weaver                  it is a tale, told by an idiot,
[email-masked]                full of sound and fury,
510-666-2903                                 .signifying nothing
PGP: http://www1.icsi.berkeley.edu/~nweaver/data/nweaver_pub.asc

---

From: Ted Lemon <[email-masked]>
Date: Wed, 20 Nov 2013 15:57:43 -0500

> We need to consider the network transporting our data as an active attacker, not just one which can observer/wiretap, but one that is both outside our control and willing to serve as a vehicle for…

The thing that hit me from this article that I really just hadn't fully understood previously is that any web site that displays personalized information per user that can be easily parsed now serves as a way to do a targeted attack on an individual or on individuals who work for an organization.

So if you read slashdot or tumblr, for example, both of which display personally identifying information on their home pages if you are logged in, then an MiTM attacker can listen on the link the server is connected to and trigger on HTTP responses to you, and then attack you specifically, without revealing the attack to anyone else.

So this starts as a pervasive passive attack, essentially, and then turns into an active attack only for the targeted user or users.

This can be mitigated in several ways—obviously https-everywhere will address the problem, but also if the web site simply doesn't display personally identifying information in their outgoing traffic, then the passive attack isn't possible.

Of course, if the attacker knows your IP address, then they don't need to scrape the HTTP response, but attackers don't necessarily have that information, particularly if what they are doing is illegal in the country you live in.   So there's real value in being aware of this threat model and trying to mitigate it.

Specifically, maybe the IETF (or someone) should be recommending that web sites not display personally identifying information about logged-in users except over TLS connections.   Certainly we should document this threat model and try to raise awareness about it.

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Wed, 20 Nov 2013 23:43:36 +0100

* Ted Lemon wrote:
>The thing that hit me from this article that I really just hadn't fully 
>understood previously is that any web site that displays personalized 
>information per user that can be easily parsed now serves as a way to do 
>a targeted attack on an individual or on individuals who work for an 
>organization.
>
>So if you read slashdot or tumblr, for example, both of which display 
>personally identifying information on their home pages if you are logged 
>in, then an MiTM attacker can listen on the link the server is connected 
>to and trigger on HTTP responses to you, and then attack you 
>specifically, without revealing the attack to anyone else.

>This can be mitigated in several ways—obviously https-everywhere will 
>address the problem, but also if the web site simply doesn't display 
>personally identifying information in their outgoing traffic, then the 
>passive attack isn't possible.

Online advertisers are happy to help you identify your targets and put
code on their computers, <http://en.wikipedia.org/wiki/Malvertising>.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Ted Lemon <[email-masked]>
Date: Wed, 20 Nov 2013 18:13:46 -0500

> code on their computers, <http://en.wikipedia.org/wiki/Malvertising>.

Malvertising is a scattershot approach, not a targeted approach.   If you have access to a lot of demographic data, you may with some difficulty be able to target an attack to an individual, but scraping the HTTP at the server is a _lot_ easier.   Making that impossible increases the cost of this type of attack significantly.

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 21 Nov 2013 05:00:12 +0100

* Ted Lemon wrote:
>Malvertising is a scattershot approach, not a targeted approach.   If
>you have access to a lot of demographic data, you may with some
>difficulty be able to target an attack to an individual, but scraping
>the HTTP at the server is a _lot_ easier.   Making that impossible
>increases the cost of this type of attack significantly.

Modern ads are complex computer programs running on your computer with
access to information the ad network associates with "you", information
associated with the page the ad is on, and the ability to probe your
computer for more information. Instead of scanning through the network
traffic the attacker would use these data sources to identify you and
attack once identified.

Silly example: let's say the ad can know which page it is loaded on and
it can persist information that is available when the ad is loaded from
the page by the user again. Now that page is https://example.com/~user
and the ad is shown to all who visit that page. After some time the ad
knows (perhaps through a synchronising server) which user has visited
that page most frequently and can infer that's the actual user "user".

If an attacker wanted to target someone attending the most recent IETF
meeting they might start with booking ads for "People who normally
reside in X but are on visit in Vancouver" during the first week of
November 2013. Someone with an interest in internationalisation, Uni-
code and all that stuff? Probe the system for unusual fonts.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Ted Lemon <[email-masked]>
Date: Wed, 20 Nov 2013 23:10:44 -0500

Bjoern, please don't take my reassertion of the problem I wanted to talk about as an indication that I consider the problem you want to talk about unimportant.   I agree that online ads present an attack surface, and that we should think about that.   I'm quite aware that my computer is running programs at the behest of ad networks (well, actually it's not, because I don't allow Flash in my web browser, but I certainly agree with you in principle).

The point of what I said previously was to talk about another attack surface with different characteristics.   The problem you are describing is one that's already on the radar of most of us tin-foil-hat wearers.   I just wanted to get an additional problem which is similar but really meaningfully different on the radar as well.

What's interesting about the http-with-identifying-info attack is that it can be easily prevented by not including identifying info or by using https.   Unfortunately the targeted-ad attack can't be addressed in this way, but that doesn't mean that the http-with-identifying-info attack isn't worth addressing.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 27 Nov 2013 16:05:48 +0100

On Wed, Nov 20, 2013 at 12:42:53PM -0800,
 Nicholas Weaver <[email-masked]> wrote 

> http://www.wired.com/opinion/2013/11/this-is-how-the-internet-backbone-has-been-turned-into-a-weapon/

You mention DNSSEC twice, as a solution against some man-on-the-side
attacks (injecting false DNS answers).

The Schneier paper
<https://www.schneier.com/blog/archives/2013/10/how_the_nsa_att.html>
about QUANTUM mentions packet injection but not the DNS. We don't know
if the NSA does DNS poisoning (but we may assume they - and other
actors - do it).

However, if the attacker is the NSA, we have to take into account the
possibility that they can sign data with the root's private key, which
is under US management. Therefore, is DNSSEC still useful?

May be, in these cases:

* the attacker may consider that DNSSEC validation is so uncommon
today that it is not worth the work to inject spoofed RRSIG

* some people may have trust anchors located at lower levels (some
registries do publish them for instance
<http://www.afnic.fr/fr/certificats/>).  Do you think it is
technically sound? Many people decided not to publish these trust
anchors, because of the management costs and risks, but it was before
Snowden. May be we should actively recommend the publication of such
"lower" trust anchors now?