Subject: [perpass] orphan thread on gmt_unix_time - any takers to work this with the TLS wg?

From: Stephen Farrell <[email-masked]>
Date: Tue, 12 Nov 2013 12:11:17 +0000

Hiya,

Way back in the mists of September there was a thread [1]
on this that seemed to have broad agreement that this was
a useful and quite doable change to TLS but I don't think
we currently have a clear owner to push it along in the
TLS WG. If everyone thinks someone else will get around to
doing this, it won't happen.

Any takers?

Thanks,
S.

[1] https://www.ietf.org/mail-archive/web/perpass/current/msg00168.html

---

From: "Andreas Kuckartz" <[email-masked]>
Date: 12 Nov 2013 15:15:51 +0100

> doing this, it won't happen.

Does the IETF have an issue tracking system for such issues (besides
mailing lists) ?

Cheers,
Andreas

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 12 Nov 2013 14:21:17 +0000

> Does the IETF have an issue tracking system for such issues (besides

Individual working groups manage that themselves so YMMV.
For this activity I've been keeping track via a file:-)
That's at [1] but I'm in the process of updating it based
on all last week's events so the current version is out
of date. I'll have it updated in the next few days with
what I think is the current state of play when I'm done
going over the meeting notes etc.

Meanwhile, feel free to volunteer to take this one on if
you're up for pushing the work along in the TLS WG.

Cheers.
S.

[1] http://down.dsg.cs.tcd.ie/misc/perpass.txt

> 
> Cheers,
> Andreas
> _______________________________________________
> perpass mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/perpass
> 
>

---

From: Nick Mathewson <[email-masked]>
Date: Tue, 12 Nov 2013 09:55:09 -0500

> doing this, it won't happen.

I'd be glad to lend my enthusiasm, time, and modest sticktoitiveness,
but I'd need somebody with more experience working in WGs to help me
with the process stuff.

(An update on the topic: OpenSSL has merged my patches to randomize
gmt_unix_time by default.  I also wrote a patch to allow tlsdate, the
one known user of gmt_unix_time that people mentioned, to support
reading the time from HTTPS headers. That patch has also been merged.)

yrs,
-- 
Nick Mathewson

---

From: Ben Laurie <[email-masked]>
Date: Tue, 12 Nov 2013 15:12:30 +0000

> but I'd need somebody with more experience working in WGs to help me

I can help with process stuff.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 12 Nov 2013 16:26:27 +0000

Nick, Ben,

Great thanks - consider yourselves volunteered:-)

I'd say whack out a draft-laurie-tls-notgmt or whatever and
see if the TLS WG like that as an update to 5246. If they
don't dislike it but don't wanna care/process it we can ask
if they don't mind if its AD sponsored and take it that
route.

Thanks,
S.

---

From: Dean Willis <[email-masked]>
Date: Wed, 13 Nov 2013 12:24:05 -0600

I believe the tools team has made a web-based issue tracker available to
each WG. Are we going to keep perpass going long enough to justify using an
issue tracker?